sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

Space Kadet    157
3 minutes ago, Salvator said:

Oh goddamit i totally forgot i have KJR installed! Sorry for the bother.

We all make these mistakes, hence the forums :P

Share this post


Link to post
Share on other sites
Saberdo    2

i can do what i want i still have partdrift... 

Share this post


Link to post
Share on other sites
Knacky    14
Posted (edited)

Well... I tried everything you mentionned, guys. But I still can't make it work.
- I uninstalled IR and KJR and reinstalled it according to the process described on the previous page.
- I checked the autostruts. The door I want to open is not strutted at all, neither the hinge. (see screenshot below)
- I tried with original and reworked parts. Same result.
- I removed all the landing legs and wheels.

What am I missing ??? That annoys me A LOT because I can't build anything cool without that mod ! :/

When I spawn on the runway, the door falls like it's not even attached. The part of the door that is in contact with the hinge move erratically and explodes. (see 2nd screenshot)

qHKWFAz.jpg
MrUxx2w.jpg

I also modified the parts of the door so their masses are all set to 0.01. So the door shouldn't be very heavy. I use procedural wings so I can't change the mass of the wings, though.

Could "rigid attachment" change anything to it ? I didn't set it on. I'm running out of ideas... :(

EDIT : I identified a part that contained LFO so the door was not quite light, now it is. I also removed the front wings, they make it wobble terribly. The door parts seemed no to be attached between them, so I added a stock strucural part between the hinge and the door, and now the door parts act normally. But it still seems too heavy for that hinge... even if I set BreakingForce and BreakingTorque to 1000000 on the hinge. Now the door opens a bit, but as you can see, it can't reach 90° at all...

lN8oM8l.jpg

Edited by Knacky

Share this post


Link to post
Share on other sites
V8jester    1099

@Knacky From what I can tell. You are attempting to lift a multi ton door with a single hinge. (The B9 HX parts you are using are, I believe full of fuel. Which is extremely heavy) To lift something that heavy is a more advanced procedure which can be very difficult to explain (but I will do my best)

 

You will need multiple hinges / IR components to move such a large door.

You will also need a way to secure the door when it is open or closed

Quantum struts are a great tool for both of these problems.

You cannot actually "attach" two IR components to a moving segment at the same time. But you can attach additional IR components to a moving segment using struts or a stronger connection is using a quantum strut. so simple example is attach 3 IR Pivitrons to a surface in a row. Set all 3 up to move in the same direction and alignment. Attach a beam or something to the center Pivitron. Then using Quantum struts / regular struts attach the outside Pivitrons to the beam, which is already attached to the center Pivitron. You now have a beam that moves as well as has additional support from additional outside 2 IR Pivitrons. You can also use this same technique with just about any other IR component. I was able to use this kind of design on my tower crane capable of lifting 40+ tons. I used 4 Rotatrons to support the heavy load of the boom it's 200 ton counterweights and a 40 ton payload.

 

In this picture is the Tower crane rotation bearing I designed using 3 uncontrolled IR Rotatrons and a single Controlled IR Bearing. All the uncontrolled Rotatrons are attached back to the structure of the support with 4 CMES struts each

screenshot19_zpsktpmwlv6.png~original

 

And here is a video to show it actually works :)

 

Share this post


Link to post
Share on other sites
Cratzz    5
Posted (edited)

Hello, using the dev-version (v2.0.10) with reworked parts and no parts work as intended. I made a short video showing the problem. Im also using the fixed KJR version.

Infernal Robotics

Im going to try try without KJR and the Legacy parts, to see if that makes a difference.

EDIT: It was KJR that caused the issue, thx for nothing :wink:

Edited by Cratzz

Share this post


Link to post
Share on other sites
Calvin_Maclure    201
14 minutes ago, Messeno said:

Hi, how do I work infernal robotics in 1.2.2?

What exactly do you mean by ''work''? How do you use it in-game or how do you install it?

Share this post


Link to post
Share on other sites
Knacky    14

@V8jester Thank you for your help ! I've been wondering why it didn't work for days, I was convinced it was a KJR issue, but finally the problem came from the door weight. Some B9 HX parts kept their original mass (the HX1-UH Hollow Module, exactly) even if I modify it in the cfg file. So I took the tank part that looks the same and I could change it. I first tried to change the mass of the door parts to 0.0 but THIS IS NOT A THING TO DO : it made the door wobble a lot and explode every time. So I set the mass of each door part to 0.06. Now it's pretty stable and very light. Then I used your advice, Jester, and combined the power of 3 Pivotrons, without needing a beam. Finally, I used a Rotatron for the lower part of the nose that becomes a ramp.

Looking cool, isn't ? :D

K6i2Ct6.jpg

QvjEW6X.jpg

cuMh0i1.jpg

Thanks again for your help !

Share this post


Link to post
Share on other sites
Messeno    0
16 hours ago, Calvin_Maclure said:

What exactly do you mean by ''work''? How do you use it in-game or how do you install it?

I installed the mod correctly but  in game the parts did not work

Share this post


Link to post
Share on other sites
V8jester    1099
Posted (edited)
49 minutes ago, Space Kadet said:

@V8jester need some help, and you seem to be the expert

 

That sure does look "familiar" :wink:

So the way I stabilized it and fueled it was a cheat. I enabled infinit electricity and fuel (but it will indeed achieve orbit the way I showed in my video without cheats)

So your three best friends from this point on are going to be.

Tweakscale, Tweakable Everything and B9 Aerospace.

Grab a B9 HX reaction wheel and scale it down to what you need. Then alt+click a copy of the scaled reaction wheel. This copy will give you a small scale reaction wheel with full scale torque. (Something like 1700 torque) I used two of them tweaked down to what I needed to fly the Protolift as smoothly as possible just took some tweaking with tweakable everything to get the values right. Otherwise you will have way too much torque and it will look really funny trying to fly.

If you have any more questions jump over to my Advanced aircraft thread linked in my signature.

 

edit

Would have helped to watch the whole video.....

So the axis of one of the rotations became inverted after a time warp? Did you use everything in my post?

Edited by V8jester

Share this post


Link to post
Share on other sites
Space Kadet    157

Yeah i installed everthing just as said, and still it seems to slip! It also happens in the sph, it took ages to get thows rotatrons balenced!

Thanks for the rest of that thow itll help with other things, but my version just has one 2.5reaction wheel and doubled up rcs, and it lands on duna fine with althow not completly vertically, fuel is fine too, it can get to 100k orbit on kerbin, then once i jump it to duna, it can land and return to orbit. I love that wee ship!

Thanks for the drsign, ive never made a little opt craft before :P

Share this post


Link to post
Share on other sites
InfiniteAtom    11

Does this mod work for the latest version of KSP?

Share this post


Link to post
Share on other sites
1 hour ago, InfiniteAtom said:

Does this mod work for the latest version of KSP?

It does if you install it correctly.

Share this post


Link to post
Share on other sites
Space Kadet    157
Posted (edited)
20 hours ago, V8jester said:

So the axis of one of the rotations became inverted after a time warp? Did you use everything in my post?

so i just pulled out everything and reinstalled direct from the linke (it just incase ive changed something since the last install) but no change

heres the video, i loaded on the runway, undid the strut, rotated teh engines up and back, flew to orbit and did the same, then hyper edited to duna. and thats where this starts with me undoing the struts and trying to move the engines.

 

so in the paused bit of the video i was just trying to realign then engines with the new orientation they had, and again as you see as soon as i timewarped, they did the same thing again

Edited by Space Kadet
forgot the video

Share this post


Link to post
Share on other sites
V8jester    1099
Posted (edited)

@Space Kadet When you installed the rotations onto the ship. Are they installed via radial, or mirror? The need to be mirror. And then are you setting up limits on them? Ir leaving them able to spin 360 on the craft in flight, with preset stops?

I built mine with a 90 degree limit in rotation and then had 2 presets 0 and 90 degrees. I also used hyper edit in my video and I didn't experience that issue. I am really curious what could be causing this..... what version of hyper edit are you using?

So you are sure you are using IR 2.0.10 correct?

And are you using the legacy docking washers? Or the Rework Rotatrons? You need the rework stuff as the legacy parts often have issues with symmetry.

 

edit

I forgot to mention my last trick with the nacelles. I used a Rotatron to rotate the nacelles but I also used a sliding rail to extend the engine up in the air. This allowed me to push the nacelles back farther in forward flight yet high enough to land / open the rear hatch. Also to clean up the front of the ship / place the exhaust under the wings.

Edited by V8jester

Share this post


Link to post
Share on other sites
Space Kadet    157
6 minutes ago, V8jester said:

@Space Kadet When you installed the rotations onto the ship. Are they installed via radial, or mirror? The need to be mirror. And then are you setting up limits on them? Ir leaving them able to spin 360 on the craft in flight, with preset stops?

I built mine with a 90 degree limit in rotation and then had 2 presets 0 and 90 degrees. I also used hyper edit in my video and I didn't experience that issue. I am really curious what could be causing this..... what version of hyper edit are you using?

So you are sure you are using IR 2.0.10 correct?

And are you using the legacy docking washers? Or the Rework Rotatrons? You need the rework stuff as the legacy parts often have issues with symmetry.

 

edit

I forgot to mention my last trick with the nacelles. I used a Rotatron to rotate the nacelles but I also used a sliding rail to extend the engine up in the air. This allowed me to push the nacelles back farther in forward flight yet high enough to land / open the rear hatch. Also to clean up the front of the ship / place the exhaust under the wings.

yeah im using that version, and i had them on mirror, and i used locks at 0 and 90, and my hyperedit is the latest, i refreshed my mods a week back, but also its happened without hyperediting now. just after using time warp. and my recent try using the smaller rotatrons, it went fine after many hyper edits and all that jaz, and when i unlocked after landing they snapped round and launched my ship into the air!

Im also having a problem in the editor which i think is related. when i goto set a limit on one side, and i invert the other so i can use it, it seems to rotate so i have to set the locks at -180 and -90 (the first craft didnt have that issue) but i duno what to do. i tried using hindges but i cant get them to toggle they same way on either side of the ship.

Share this post


Link to post
Share on other sites
InfiniteAtom    11
20 hours ago, TheRagingIrishman said:

It does if you install it correctly.

How would one not install it correctly? How do you install this mod specifically?

Share this post


Link to post
Share on other sites
14 minutes ago, InfiniteAtom said:

How would one not install it correctly? How do you install this mod specifically?

Go to the post that I linked in my last post, it has full install directions. It's a little complicated because the mod has been updated to 1.2.2 but not by the original author so it's not just 1 folder you have to download. 

Share this post


Link to post
Share on other sites

Infernal Robotics is a great mod! It makes creating VTOL's extremely easy, and the preset function really helps. I recently used the mod to create a massive folding wing cargo craft, and for normal travel the wings go into the 'normal' position using the rotatron and power hinges, and I fire the RAPIERS and use the rotatron again to switch to VTOL mode if need be. For prolonged space travel or if I'm needing to get to somewhere quickly, the wings fold up again to save space and I use a telescopic piston to push out a set of the Kerbodyne 'Mammoth' engines for maximum speed. It's such a great mod! :cool::0.0:

 

Share this post


Link to post
Share on other sites
On 13-4-2017 at 8:49 PM, V8jester said:

Did you use all the links found in this post?

 

I did, but I noticed it wasn't nessicerely the weapons. It's something else that isn't making it work but I don't know what. One clip here is with it working normally and one with it being glitched

 

Working

https://youtu.be/IAOwsmT527Y

 

Not Working

https://youtu.be/Ic300GKec5M

Share this post


Link to post
Share on other sites
Jame's    0
On 7/12/2016 at 3:25 AM, LatiMacciato said:

i know docks will make my like miserable, as is very first post lol .. but im yet unsure if thats a known bug

when i link parts that are docked it unlinks the KIS/KAS linked part (i thaught of docking it at the tail will stenghen them give the load a stability .. at least that was the idea of this rocket)

IRlinkingfca76.png

 

What landing mod are you using???

Plus where can i get "Infernal Robotics" Parts, not the legacy parts but foldertron and Etc???

Share this post


Link to post
Share on other sites
p14082003    24

Still waiting for 1.2 update!! i love this mod

Share this post


Link to post
Share on other sites
Olympic1    372
1 hour ago, p14082003 said:

Still waiting for 1.2 update!! i love this mod

Patience is a virtue

Share this post


Link to post
Share on other sites
10 hours ago, p14082003 said:

Still waiting for 1.2 update!! i love this mod

This mod was updated ages ago, I'm pretty sure it was in one of jester's posts but you'll have to go back a few pages.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now