NecroBones

[1.4] SpaceY Expanded, v1.5 (2018-04-02)

Recommended Posts

Actually is listed as compatible with 1.3, so you are fine

  • Like 1

Share this post


Link to post
Share on other sites

I'm not seeing any compatibility problems, but there seems to be something wonky going on with the textures. Example:

https://imgur.com/MvxgIzO

It's nothing -super- major, and might be something weird interacting with another addon.

Share this post


Link to post
Share on other sites
2 hours ago, etmoonshade said:

I'm not seeing any compatibility problems, but there seems to be something wonky going on with the textures. Example:

https://imgur.com/MvxgIzO

It's nothing -super- major, and might be something weird interacting with another addon.

My guess: you don't have the associated part switcher (B9 part switch, or maybe firespitter, or something) installed.

Share this post


Link to post
Share on other sites
4 hours ago, AccidentalDisassembly said:

My guess: you don't have the associated part switcher (B9 part switch, or maybe firespitter, or something) installed.

Hm, interesting. Neither one is listed as a dependency, but I notice I don't have Firespitter in my mod folder anymore (I rearrange mods every time I fire up KSP after an absence, and there's some mod I've used in the past that needed Firespitter that I must not use anymore.) I'll slap it in there and update this post with more info.

Edit: Nope. I now have B9 Part Switch AND Firespitter installed and they're still doing that. I'll dig around in logs at some point and figure out what went wrong (or submit a proper bug report.)

Edited by etmoonshade

Share this post


Link to post
Share on other sites
2 hours ago, etmoonshade said:

Hm, interesting. Neither one is listed as a dependency, but I notice I don't have Firespitter in my mod folder anymore (I rearrange mods every time I fire up KSP after an absence, and there's some mod I've used in the past that needed Firespitter that I must not use anymore.) I'll slap it in there and update this post with more info.

Edit: Nope. I now have B9 Part Switch AND Firespitter installed and they're still doing that. I'll dig around in logs at some point and figure out what went wrong (or submit a proper bug report.)

Hmmm... Interstellar Fuel Switch maybe? All I can think up is that there are two models/textures fighting because of the absence of a switching mod, or some related problem, sorry.

Share this post


Link to post
Share on other sites

Will you add gimbal for Penguin engines?

Edited by krone12

Share this post


Link to post
Share on other sites
On 3/18/2018 at 9:23 AM, krone12 said:

Will you add gimbal for Penguin engines?

 

Right now my thinking is probably not. I had made a design choice to make them more reminiscent of the Apollo SM's main engine, in that it's a large vacuum engine that is completely static. This puts emphasis back onto using RCS thrusters, like a real spacecraft. :) (or reaction wheels, also somewhat like some real spacecraft).

 

  • Like 1

Share this post


Link to post
Share on other sites

 

OK,  this is switched over to the stock mesh switcher in KSP 1.4. This should resolve magenta texture problems introduced in KSP 1.4. Let me know if there are still problems.

 

1.4 (2018-04-02) - KSP 1.4 update.
 - Reworked color-changing to use KSP 1.4's mesh switcher.
 - Flag decals disabled for now, since the stock mesh switcher doesn't play nicely with them.
 - Disabled auto-caps on tanks, due to KSP bugs over several versions.
 - Added some missing definitions for Modular Fuel Tanks.
 - Changed ModularFuelTanks config to use consolidated wildcard patch.

 

 

  • Like 2

Share this post


Link to post
Share on other sites

Is this going to be updated for 1.4.2? I have problems using the spacey engines and RCS thrusters giving off a long white flame longer than the ship. Also have this issue in 1.4.2 trying to use FASA RCS thrusters and some of their rocket engines.

Edited by MikeO89

Share this post


Link to post
Share on other sites

Both this mod and its base (SpaceY Heavy Lifters) are 1.4.4

But both are part mods and typically part mods are not broken by incremental changes. 

You should be able to run both "SpaceY Heavy Lifters" and SpaceY Expanded" in a 1.4.5 game.

I am currently using "SpaceY Heavy Lifters" in my 1.4.5 game and have not noticed any issues so far. ;)

Share this post


Link to post
Share on other sites

There is an issue 

with the Vernier.  It's using the old ModuleRCS, which is why the plume is backwards and very large.  I've written a patch to fix it.  The patch is good for 1.4 and 1.5

 Just drop the following into the GameData directory, call the file MM_SYvernier1.cfg, or download it from this link:

https://www.dropbox.com/s/jajttxynlhlf1je/SpaceYVernierPatch.zip?dl=0

License for the patch is the Unlicense

Spoiler

@PART[SYvernier1]
{
	!MODULE[ModuleRCS] {}

	MODULE
	{
		name = ModuleRCSFX
		stagingEnabled = False
		thrusterTransformName = RCSthruster
		thrusterPower = 100
		resourceName = LiquidFuel
		resourceFlowMode = STAGE_PRIORITY_FLOW
		runningEffectName = running
		PROPELLANT
		{
			name = LiquidFuel
			ratio = 0.9
			DrawGauge = True
			resourceFlowMode = STAGE_PRIORITY_FLOW
		}
		PROPELLANT
		{
			name = Oxidizer
			ratio = 1.1
			resourceFlowMode = STAGE_PRIORITY_FLOW
		}
		atmosphereCurve
		{
			key = 0 260
			key = 1 180
			key = 9 0.001
		}
	}

	EFFECTS
	{
		running
		{
			AUDIO_MULTI_POOL
			{
				channel = Ship
				transformName = RCSthruster
				clip = sound_rocket_mini
				volume = 0.0 0.0
				volume = 0.1 0.0
				volume = 0.5 0.025
				volume = 1.0 0.15
				pitch = 0.0 0.75
				pitch = 1.0 1.0
				loop = true
			}
			MODEL_MULTI_PARTICLE
			{
				modelName = Squad/FX/Monoprop_small
				transformName = RCSthruster
				emission = 0.0 0.0
				emission = 0.1 0.0
				emission = 1.0 2.0
				speed = 0.0 0.8
				speed = 1.0 1.0
				localRotation = -90, 0, 0
			}
		}		
	}

}

 

 

Edited by linuxgurugamer
  • Like 2

Share this post


Link to post
Share on other sites

This is cool. Thank you. I wish this could be done for the FASA Apollo RCS thrusters as they all do the same thing.

Share this post


Link to post
Share on other sites

Works in 1.5.1, and if you use the MM patch LinuxGuruGamer posted a few posts back, the large Vernier thruster will have the correct effects on it (the RCS plume won't point backwards anymore).

Share this post


Link to post
Share on other sites

I know I already asked this on Fuel tanks plus, but could we get this, Fuel Tanks Plus and Color Coded Canisters map the stock textures to the list of selectable textures?

BTW, I love this mod!

Share this post


Link to post
Share on other sites
2 hours ago, Ruedii said:

I know I already asked this on Fuel tanks plus, but could we get this, Fuel Tanks Plus and Color Coded Canisters map the stock textures to the list of selectable textures?

BTW, I love this mod!

You do know that @NecroBones hasn't been around since June?

Share this post


Link to post
Share on other sites

Anyone know of a similar mod to this one, one that's been (or will be) updated for 1.6? I love this mod but it doesn't appear as it will be updated anymore. TIA.

Share this post


Link to post
Share on other sites

Im staying at 1.5.1 specifically for mods like this - I love having the heavy lifters, and Necrobones fuel tanks, and especially all the ladders and landing legs in the Lithobraking. 

We need to clone @linuxgurugamer.  Better yet, more of us need to learn to code just enough so we can do upkeep.

The "point" releases so far seem more like marketing gimmicks given the regressions and absence of bug fixes - 1.6 makes no difference at all to those of us players who have been running KER and BetterBurnTime for years.  Why build that into the game, why not work on bug fixes and content instead of duplicating addon functionality? 

Edited by Murdabenne

Share this post


Link to post
Share on other sites

Well, there were a lot of bug fixes, and people have been screaming for a dV indicator ever since the game came out.

and no offense, but you arent their target market, since you already own the game.  They need to keep improving the game in order to generate new sales, otherwise there will be zero updates 

On 1/5/2019 at 5:39 PM, OldLost said:

Anyone know of a similar mod to this one, one that's been (or will be) updated for 1.6? I love this mod but it doesn't appear as it will be updated anymore. TIA.

This works fine in 1.6, whats your problem with it?

Share this post


Link to post
Share on other sites
On 1/12/2019 at 12:20 PM, linuxgurugamer said:

This works fine in 1.6, whats your problem with it?

That's good news. No problem; I'm still trying to make sure all the mods I like will work with 1.6 before moving on from 1.4.5. Hearing from you it works fine with 1.6 is good enough for me. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now