Jump to content

[1.9.x] Editor Extensions Redux released (with SelectRoot merge. StripSymmetry & NoOffsetLimits)


Recommended Posts

8 minutes ago, IMLL1 said:

Hey, I'm just wondering if/when this will be updated. It's an amazing mod, but combined with MM it seems to produce a couple bugs.

Need more details to help here.  See the red labelled link in my signature.

However, there were issues with Module Manager 4.0.0 and 4.0.1.  Try either downgrading to 3.1.3 or upgrading to 4.0.2 and see if that fixes things.

Link to post
Share on other sites
Just now, Jacke said:

Need more details to help here.  See the red labelled link in my signature.

However, there were issues with Module Manager 4.0.0 and 4.0.1.  Try either downgrading to 3.1.3 or upgrading to 4.0.2 and see if that fixes things.

Got it. Thanks. I had a bug where if I opened the advanced filters (not the filterextension ones, the stock ones), then it would freeze me in the category (engine, pods, tanks, etc) that I was in until I extended and reentered the VAB. I think that this was traced to EER, and not one of the other mods I had installed. The bugs weren't the main issue, I just want to see this outstanding mod updated.

Link to post
Share on other sites
9 minutes ago, IMLL1 said:

Got it. Thanks. I had a bug where if I opened the advanced filters (not the filterextension ones, the stock ones), then it would freeze me in the category (engine, pods, tanks, etc) that I was in until I extended and reentered the VAB. I think that this was traced to EER, and not one of the other mods I had installed. The bugs weren't the main issue, I just want to see this outstanding mod updated.

That's not a bug of EEX but of KSP 1.6 and related to missing bulkheadprofiles:

I've posted a tiny MM patch in the linked thread as a workaround.
EEX actually works perfectly fine on 1.6 :)

Edited by 4x4cheesecake
Link to post
Share on other sites
2 hours ago, 4x4cheesecake said:

That's not a bug of EEX but of KSP 1.6 and related to missing bulkheadprofiles:

I've posted a tiny MM patch in the linked thread as a workaround.
 EEX actually works perfectly fine on 1.6 :)

Ah! Thanks! It also has a small glitch where I couldn't place or remove parts at one point, no matter what I tried. New craft, open craft and try to edit, nada. Glad to know that EEX isn't responsable!

Link to post
Share on other sites

Hey there!

I was using the mod without issue with 1.6.1 until an issue came up that I can't seem to resolve, even after multiple installs of the mod and validations of the game files. Although the UI is accurate, the mod has suddenly stopped allowing me to swap between any settings using the mod's hotkeys. Additionally, the only available symmetries are the ones available in the base game and the only angle snap that's allowed is 15 degrees. Not certain if there's some setting I've inadvertently triggered or if this is an actual bug, but either way I wanted to ask around to see if anyone had solutions. My install is heavily modded, but it seemed to be running without issue until very recently. Let me know what you all think, thanks for the assistance!

Link to post
Share on other sites
24 minutes ago, Arcanejack said:

Hey there!

I was using the mod without issue with 1.6.1 until an issue came up that I can't seem to resolve, even after multiple installs of the mod and validations of the game files. Although the UI is accurate, the mod has suddenly stopped allowing me to swap between any settings using the mod's hotkeys. Additionally, the only available symmetries are the ones available in the base game and the only angle snap that's allowed is 15 degrees. Not certain if there's some setting I've inadvertently triggered or if this is an actual bug, but either way I wanted to ask around to see if anyone had solutions. My install is heavily modded, but it seemed to be running without issue until very recently. Let me know what you all think, thanks for the assistance!

It is a known issue and the reason for the 'restore keybindings' (or similar) button in the mod settings. For some reason, the keybindings are deleted but you can also restore themvia the button or in the game settings but the button is more convenient ;)

edit: Oh, the exact name of the button is "Reset Symmetry Mode & Angle Snap keys", regarding the OP:

Quote

Added button to Settings page 2 to "Reset Symmetry Mode & Angle Snap keys

:)

Edited by 4x4cheesecake
Link to post
Share on other sites
  • 4 weeks later...

As far as I know, the latest version works fine with 1.6.1, but in CKAN the Max KSP Version is set at 1.6.0. Is there a reason why the CKAN setting is set like that?

I can force CKAN to install mods by changing the Compatible KSP Versions setting, so it is not a problem for me. I am just curious. 

Link to post
Share on other sites
1 hour ago, MaltYebisu said:

As far as I know, the latest version works fine with 1.6.1, but in CKAN the Max KSP Version is set at 1.6.0. Is there a reason why the CKAN setting is set like that?

I can force CKAN to install mods by changing the Compatible KSP Versions setting, so it is not a problem for me. I am just curious. 

That comes from the metadata that CKAN has, usually from the KSP AVC .version file for the mod, created by the mod author.

Normally, most mods compiled for any 1.6.x will work in any 1.6.y where y is greater than or equal to x.  But that has to be explicitly put into the .version file for a mod.

Link to post
Share on other sites
9 hours ago, MaltYebisu said:

As far as I know, the latest version works fine with 1.6.1, but in CKAN the Max KSP Version is set at 1.6.0. Is there a reason why the CKAN setting is set like that?

I can force CKAN to install mods by changing the Compatible KSP Versions setting, so it is not a problem for me. I am just curious. 

CKAN gets it's data from the .version file (if it exists and was configured to).  I haven't rebuilt this for a while, so it's not going to get updated until I do.

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

New release, 3.3.20

  • Added new feature activated by default letter B:  Centers the vessel horizontally in the editor, and lowers it to 5m high

Note:  Alt-C is relatively unknown and toggles the snap on and off

Link to post
Share on other sites
13 hours ago, linuxgurugamer said:

New release, 3.3.20

  • Added new feature activated by default letter B:  Centers the vessel horizontally in the editor, and lowers it to 5m high

Note:  Alt-C is relatively unknown and toggles the snap on and off

Very nice !!! ty for you

Link to post
Share on other sites
  • 2 weeks later...
21 hours ago, linuxgurugamer said:

What isn't working?

Please provide a log file

Yes, here's the log. https://drive.google.com/file/d/1nFDz3LdeqIkxG5Akeg8PURALTz_g1TiT/view?usp=sharing

 

Apart from the dependencies and Editor extensions, I only have Mechjeb installed. The KSP installation is new (plus the making history expansion). KSP is is the portable version installed on my D: Drive. (As I don't install games on my boot drive).

 

Edited by Levelord
Link to post
Share on other sites
17 minutes ago, Levelord said:

Apart from the dependencies and Editor extensions, I only have Mechjeb installed.

Actually, you don't have editor extensions installed ;)

From your log:

Quote
Mod DLLs found:
Stock assembly: Assembly-CSharp v0.0.0.0
MiniAVC v1.2.0.6
ClickThroughBlocker v0.1.7.1 / v1.0.0.0
MiniAVC v1.2.0.6
ToolbarControl v0.1.6.20 / v1.0.0.0
MechJeb2 v2.5.1.0 / v / v2.8.3.0

Folders and files in GameData:
000_ClickThroughBlocker
001_ToolbarControl
MechJeb2
Stock folder: Squad

Stock folder: SquadExpansion

No editor extensions to find there ;)

Link to post
Share on other sites
7 minutes ago, 4x4cheesecake said:

Actually, you don't have editor extensions installed ;)

From your log:

No editor extensions to find there ;)

Now I feel extra Kerbal today. Managed to install all the dependencies except for the mod itself. :blush:

Link to post
Share on other sites
On 4/18/2019 at 7:32 PM, linuxgurugamer said:

What isn't working?

Please provide a log file

It appears to be an issue with ClickThroughBlocker. It seems to say it can't find its assembly, but I definitely have it installed.  As a result, EditorExtensions doesn't work, its button in the VAB does nothing and the symmetry buttons don't get replaced. Here's the log file: 

[LOG 12:53:28.565] ------------------- initializing editor mode... ------------------
[LOG 12:53:28.565] editor started
[LOG 12:53:28.583] [FlightGlobals]: Vessel persistentId changed from 4025730174 to 2985591112.
[LOG 12:53:28.586] Loading Depletion Nodes
[LOG 12:53:28.586] DepNodeCount:  0
[LOG 12:53:28.586] Loading Biome Nodes
[LOG 12:53:28.586] BiomeNodeCount:  0
[LOG 12:53:28.586] Loading Planet Nodes
[LOG 12:53:28.586] PlanetNodeCount:  0
[LOG 12:53:28.597] [ScenarioDestructibles]: Loading... 0 objects registered
[LOG 12:53:28.597] [ScenarioUpgradeableFacilities]: Loading... 0 objects registered
[LOG 12:53:28.745] ScaleModList: listSize 41 maxListSize 1713
[WRN 12:53:29.062] HighlightingSystem : Framebuffer depth data is not available and can't be used to occlude highlighting. Highlighting occluders enabled.
[WRN 12:53:29.143] ADDON BINDER: Ingoring binding redirect due to incompatible versions: ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null => ClickThroughBlocker, Version=0.1.6.10, Culture=neutral, PublicKeyToken=null
[EXC 12:53:29.146] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.147] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.147] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.148] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.148] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.148] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.149] [UiApp] Awake: EngineersReport
[LOG 12:53:29.149] [UiApp] Awake: Contracts
[LOG 12:53:29.149] [UiApp] Awake: KSPedia
[LOG 12:53:29.149] [UiApp] Awake: Missions App
[LOG 12:53:29.150] [UiApp] Awake: DeltaVApp
[LOG 12:53:29.150] [ApplicationLauncher] OnSceneLoadedGUIReady: scene EDITOR ShouldBeVisible() True ShouldBeOnTop() False iIsPositionedAtTop False
[LOG 12:53:29.150] ScaleModList: listSize 82 maxListSize 1526
[EXC 12:53:29.172] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.172] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.192] [MessageSystem] Reposition 0.02 5216
[LOG 12:53:29.193] [GenericAppFrame] Reposition 0.02 5216
[LOG 12:53:29.193] [GenericAppFrame] Reposition 0.02 5216
[EXC 12:53:29.234] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.234] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.252] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.252] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.264] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.264] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.280] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.281] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.297] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.297] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.298] [UIApp] Adding Missions App to Application Launcher
[LOG 12:53:29.299] ScaleModList: listSize 82 maxListSize 1485
[LOG 12:53:29.299] [UIApp] Adding Contracts to Application Launcher
[LOG 12:53:29.300] ScaleModList: listSize 82 maxListSize 1444
[LOG 12:53:29.300] [UIApp] Adding EngineersReport to Application Launcher
[LOG 12:53:29.300] ScaleModList: listSize 82 maxListSize 1403
[EXC 12:53:29.315] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.315] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.316] [UIApp] Adding DeltaVApp to Application Launcher
[LOG 12:53:29.317] ScaleModList: listSize 82 maxListSize 1362
[LOG 12:53:29.317] [MissionsApp] OnAppStarted(): id: -317608
[LOG 12:53:29.317] MissionsApp does not execute in this game mode, destroying this instance
[LOG 12:53:29.317] [UIApp] OnDestroy: Missions App
[LOG 12:53:29.317] ScaleModList: listSize 82 maxListSize 1362
[LOG 12:53:29.318] [GenericAppFrame] Reposition 0.1408404 5222
[LOG 12:53:29.319] [GenericAppFrame] Reposition 0.1408404 5222
[EXC 12:53:29.350] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.350] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.352] [GenericAppFrame] Reposition 0.1762324 5223
[EXC 12:53:29.367] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.368] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.369] [UIApp] Adding KSPedia to Application Launcher
[LOG 12:53:29.369] ScaleModList: listSize 82 maxListSize 1362
[EXC 12:53:29.385] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.385] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.396] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.396] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.407] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.408] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.420] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.420] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.430] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.431] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[LOG 12:53:29.431] [UIMasterController]: ShowUI
[EXC 12:53:29.446] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.447] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.463] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.463] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.480] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.480] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.497] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.497] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.514] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.514] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.530] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.530] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.546] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

[EXC 12:53:29.547] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

 

Edited by PhaserArray
Formatting
Link to post
Share on other sites
8 hours ago, PhaserArray said:

It appears to be an issue with ClickThroughBlocker. It seems to say it can't find its assembly, but I definitely have it installed.  As a result, EditorExtensions doesn't work, its button in the VAB does nothing and the symmetry buttons don't get replaced. Here's the log file: 

Please provide a link to the complete log file. Snippits aren't useful in cases like this

5 hours ago, xZephy said:

Yup same here, i use your RCSBuild aid and Hangar extender, but EEX doesn't appear at all :/

The same, please provide a link to the complete log file

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...