Jump to content

[1.12.X] Kerbal Planetary Base Systems v1.6.15 [28. April 2022]


Nils277
 Share

Recommended Posts

@vladimirthebest This is a well known issue. Unfortunately this is something that cannot be fixed from my side. It is an error in KSP itself that it sometimes does not register when a part has been detached from a node again. I suspect that this is prone to happen more often when there are multiple nodes on one part. I really hope that this will be fixed in 1.1.

Edited by Nils277
Link to comment
Share on other sites

In response to my bug submission regarding KPBS stopping KIS showing it's extra menus.

It appears to be a little more complicated

I created a vanilla install cleaned all mods out. Put in KIS, KAS and KPBS. And the menus appear...

I do run a number of mods, but weirdly it appears that KPBS triggers whatever is going on. Anyone got any starters other than trying a combination of 20 different mods?

Link to comment
Share on other sites

I'm having fun with my new Mun base.  ;)  One request: Could the 'Garage adapter' get a crew hatch?  (And associated CLS config.)  The idea being that you can walk directly out into the garage from the rest of the base, and vice-versa.

(I was also going to report the big water container issue, but I see that's been fixed in the Github master.)

Link to comment
Share on other sites

So it is update time! :)

Changes:

Quote

v1.0.4

Enhancements:

  • Removed duplicate flag and added a new one.
  • The Airlock-End and the End-Cap now have mounts for landing legs

Bug-Fixes:

  • The windows of the deployable parts stay lit when returning to a vessel
  • The deprecated/unavailable parts are not shown in the techtree anymore
  • The big water container now have water (thanks to cdp1337)

Downloads:

MRispXN.pngcNJI52O.png rMKWvsX.png

Have fun and fell free to report any bugs.

 

17 hours ago, DStaal said:

I'm having fun with my new Mun base.  ;)  One request: Could the 'Garage adapter' get a crew hatch?  (And associated CLS config.)  The idea being that you can walk directly out into the garage from the rest of the base, and vice-versa.

(I was also going to report the big water container issue, but I see that's been fixed in the Github master.)

I will consider this. Might be a good idea to directly get into the garage :wink:

Edited by Nils277
Link to comment
Share on other sites

First off: I *super love* your mod! Makes for such nice looking bases :)

 

However bit of a problem: I'm using it with TACLS and it seems the water drill is hardcoded to only find water in some bodies, why ?? Why doesnt it just check for concentration like any other drill?

(Seems to be the same problem with the air filter).

 

My direct problem with that being that I'm using some kopernicus planets and while I can see some of them having water, I cant put bases there because it wont extract.

Now that I found the problem I altered the cfg file to include Asclepius (the planett I'm targetting now) but it sounds a bit weird :/

Link to comment
Share on other sites

50 minutes ago, DarkGod said:

First off: I *super love* your mod! Makes for such nice looking bases :)

 

However bit of a problem: I'm using it with TACLS and it seems the water drill is hardcoded to only find water in some bodies, why ?? Why doesnt it just check for concentration like any other drill?

(Seems to be the same problem with the air filter).

 

My direct problem with that being that I'm using some kopernicus planets and while I can see some of them having water, I cant put bases there because it wont extract.

Now that I found the problem I altered the cfg file to include Asclepius (the planett I'm targetting now) but it sounds a bit weird :/

The intention for this was to only allow water on planets/moons when which are likely to have water. And i do not see that water should be e.g. on Dres. When water would be available on all celestial bodies, there wouldn't be a need for many of the recyclers to create a permanent base.
Unfortunately the definition for water used in the community resource pack defines water to be available on all celestial bodies. The same applies to the other resources.

I did not consider the kopernicus planets, this is indeed a major problem.

So there are two solutions....either i break with the compliance of the community resource pack, which i would rather not want to. Or enable all resources on all planets, wich is also not the best solution from my point of view :( 

Are there any other ideas to how to solve this?

Edited by Nils277
Link to comment
Share on other sites

Oh I see. This makes sense I agree.

Perhaps a "kind of fix" would be to detect some of the most popular planet packs and add support for them? Like Asclepius has rivers so water is logical there and I'm sure a few more cases can be found

Link to comment
Share on other sites

:DGreat mod! Now I can build beautiful and functional bases without doing many jobs aligning the docking ports!

I often use the LV25 "Meerkat" Landing Assist engine with the Throttle Controlled Avionics mod so it would work fine even if the CoM is not centered. However I found it difficult to rotate the module with TCA enabled. It is possible to make each nozzle as a single part so that TCA can tweak the thrust and make rotations more sensitive?

Link to comment
Share on other sites

1 hour ago, Nils277 said:

I have never really paid attention to the planet packs. Can you name a few that are most popular? :D

Well, I use the Outer Planets Mod, Arkas, Ascleius, Mios, Moons of Eeloo, and Trans Keptunian. Oh, and Kerbol Origins. Now, to aboid confusion, Amarius1s mod also has another branch called Kerbol Plus Remade. Another new one is ExtraSolar, but that being said, water is a sirprisingly common material. The moon, Venus, water is litterally dirt around pluto. There just isn't enough heat for liquid water.

Link to comment
Share on other sites

Litte update: (lets hope there won't be confusion with this release version and the ksp version :rolleyes:)

Quote

v1.0.5
General Changes:

  • The Airfilter and the Water-Drill for TAC/USI-LS now use the stock harvester module
  • Removed settings config for USI-LS to prevent confusion
  • Additional resources are only added when a mod needing this resource is installed
  • Small tweak on the new Flag

Bug Fixes:

  • Fixed error when loading the editor icons

Download:

MRispXN.pngcNJI52O.png rMKWvsX.png

 

@DarkGod I just changed the harvester to use the normal harvester and use the CRP definitions for the resources. I looked again at the def for water and the other resources and water is not that high concentrated on the most planets so it would fit. Does you mod support CRP? Of so, it should add a config for water for its plants. I no, i will look at the most popular ones and add theses definitions eventually.

 

58 minutes ago, Fat_Bird said:

:DGreat mod! Now I can build beautiful and functional bases without doing many jobs aligning the docking ports!

I often use the LV25 "Meerkat" Landing Assist engine with the Throttle Controlled Avionics mod so it would work fine even if the CoM is not centered. However I found it difficult to rotate the module with TCA enabled. It is possible to make each nozzle as a single part so that TCA can tweak the thrust and make rotations more sensitive?

That would unfortunately be more difficult than it seems. KSP has some strange issues when more than one thrust transform is in a single part. Or at least there were some serious issues when i last checked.

12 minutes ago, Andem said:

Well, I use the Outer Planets Mod, Arkas, Ascleius, Mios, Moons of Eeloo, and Trans Keptunian. Oh, and Kerbol Origins. Now, to aboid confusion, Amarius1s mod also has another branch called Kerbol Plus Remade. Another new one is ExtraSolar, but that being said, water is a sirprisingly common material. The moon, Venus, water is litterally dirt around pluto. There just isn't enough heat for liquid water.

Hmm that are a lot. Do you know if these mods do support CRP? If so they would add water/other resources to the planets. As you can see above, the drill now uses the CRP definitions instead of a custom one :wink:

Edited by Nils277
Link to comment
Share on other sites

10 minutes ago, Nils277 said:

KSP has some strange issues when more than one thrust transform is in a single part.

:PSo I'm actually asking to seperate the engine in half and make each half a single part! IMO LV25 can be seperated into 3 parts: the passage, the left nozzle and the right nozzle, with the last two attached to the first.

Edited by Fat_Bird
Link to comment
Share on other sites

21 minutes ago, Nils277 said:

Litte update: (lets hope there won't be confusion with this release version and the ksp version :rolleyes:)

Download:

MRispXN.pngcNJI52O.png rMKWvsX.png

 

@DarkGod I just changed the harvester to use the normal harvester and use the CRP definitions for the resources. I looked again at the def for water and the other resources and water is not that high concentrated on the most planets so it would fit. Does you mod support CRP? Of so, it should add a config for water for its plants. I no, i will look at the most popular ones and add theses definitions eventually.

 

That would unfortunately be more difficult than it seems. KSP has some strange issues when more than one thrust transform is in a single part. Or at least there were some serious issues when i last checked.

Hmm that are a lot. Do you know if these mods do support CRP? If so they would add water/other resources to the planets. As you can see above, the drill now uses the CRP definitions instead of a custom one :wink:

OPM definitely does, but I would have to check the individual threads later.

Link to comment
Share on other sites

USI-LS makes it hard.  It should be possible with inputs of fertilizer - which means mining gypsum or ore with this mod.  (The alge tanks can work with ore.)  Careful though - they dump excess, so you can lose material that way as well.  I haven't checked if they are completely balanced in the end, but the idea should be there.

Link to comment
Share on other sites

You can make a closed loop base with the Algae Container and the Greenhouse. It should all in all produce slightly more supplies than it needs mulch. 

Or if this is not the case, i have to rebalance it ;-)

Edited by Nils277
Link to comment
Share on other sites

Gotta say, I do love this mod. While I havent been doing much base building as of late (VTOL design work is way more engaging than it should be), I do look forward to finally getting back to base building with all the new parts.

Speaking of parts, I think congratulations are in order Nils. I just checked on curse, and currently your mod is the number one most downloaded parts pack for ksp. Very impressive. Time to update my own install.

Link to comment
Share on other sites

This mod is GREAT! Thanks! 

I have a question, though: I use IFI-LS. I tried the small greenhouse (actually, more like a green module) and it works fine, but I could not make the large greenhouse work, even after deploying it...

Link to comment
Share on other sites

4 hours ago, jlcarneiro said:

This mod is GREAT! Thanks! 

I have a question, though: I use IFI-LS. I tried the small greenhouse (actually, more like a green module) and it works fine, but I could not make the large greenhouse work, even after deploying it...

The large greenhouse needs Kerbals inside of it to operate ;-) When you have one Kerbal inside, it produces at max 50% speed. With two Kerbals inside it works at full capacity.

11 hours ago, daltonater said:

Gotta say, I do love this mod. While I havent been doing much base building as of late (VTOL design work is way more engaging than it should be), I do look forward to finally getting back to base building with all the new parts.

Speaking of parts, I think congratulations are in order Nils. I just checked on curse, and currently your mod is the number one most downloaded parts pack for ksp. Very impressive. Time to update my own install.

Thanks. :-)

Whoa, haven't expected that it would become that popular. 

Link to comment
Share on other sites

I just encountered, that i have made a huge mistake during the last updates of KPBS.

While playing around with the adapters for the landing legs to get symmetry attachement working, i foolishly renamed these attachment nodes (multiple times).
Unfortunately KSP encounters a critical error when it tries to load a save/craft which has the old names of the nodes saved.

When you want to fix that, open the saves and craft files in an text edior and search for the parts that start with:

PART
{
	part = KKAOSS.engine.g

and

PART
{
	part = KKAOSS.adapter.g

and for these parts change any occurance of  

attN = node_leg_1

or 

attN = node_stack_side0

to: 

attN = node_stack_leg1

and any occurance

attN = node_leg_2

or 

attN = node_stack_side1

to: 

attN = node_stack_leg2

Do only change these names in the mentioned parts. Any other part having these names is correct.

 

I have to apologize to everyone who has invalid saves because of this foolishness. :(

Edited by Nils277
Link to comment
Share on other sites

4 hours ago, Nils277 said:

The large greenhouse needs Kerbals inside of it to operate ;-) When you have one Kerbal inside, it produces at max 50% speed. With two Kerbals inside it works at full capacity.

Thanks!

Like the small one, it converts ore (and electricity) into lifesupport, right? I looked into it's cfg and it hás no converter modules...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...