Kernowden Kerbin

[1.8] Nice MKseries Body [NMB] [V3.4beta] [2020.2.1]

Recommended Posts

I check the part compiler and see a few errors in loading props, but it show that it is compiled the cockpit correctly.

***Update***

I have to download CollisionFX but it still doesn't not load the part. The game keeps saying it is missing the part

Game Image

Edited by commanderbunbun
Update

Share this post


Link to post
Share on other sites
2 hours ago, commanderbunbun said:

Where is that patch located and also, how do you install it?

 

Share this post


Link to post
Share on other sites
16 hours ago, Stone Blue said:

Oh, kewl!... I didnt know Tegmil's patch was good fo *mirrors*, too... :P

Actually mirrors are RPM displays and this cockpit has a rear view camera.

Share this post


Link to post
Share on other sites

So, I installed the mod again and again, and the F-18 cockpit still does not show up, even the game says that the part does not exist, however, I have gone into the files of the mod and the F-18 cockpit is there! I went back to version 1.7.3 with the exact same mods that are still in 1.8.1 and the F-18 cockpit showed up. I think that this is a matter of the version of KSP I am using. I am still unsure of the cause for this, but it works in 1.7.3

 

I have asked for help earlier to no conclusion, I am also wondering if the mod will be updated in the near future to work with the latest version of KSP, since some features do not work.

 

Thanks for your attention,

RThwX1lkZ.jpg 

^ v1.8.1

ivdCGw8.png Bruh

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

O2w5b64.jpg

^v1.7.3 

 

Works like a dime, not the rest of my mods tho :c

Share this post


Link to post
Share on other sites

Hi!  I'm the new maintainer of RPM and I'm doing an audit of mods that use it.  Is this mod still being maintained?  There are a number of issues with its use of RPM.  I could provide a MM patch to fix them but it'd be best if they were just fixed in the actual package.

  • space\f-18c.cfg contains a RasterPropMonitorComputer module.  This is incorrect - RasterPropMonitorComputer is a PartModule and needs to go in the part config, not an InternalModule
  • props\nmb_hud4.cfg also contains a RasterPropMonitorComputer and it shouldn't

  • None of the command parts themselves contain a RasterPropMonitorComputer module and they should.  Many things will appear to work without this, but some things don't.

Edited by JonnyOThan

Share this post


Link to post
Share on other sites
On 1/16/2020 at 12:35 PM, JonnyOThan said:

Hi!  I'm the new maintainer of RPM and I'm doing an audit of mods that use it.  Is this mod still being maintained?  There are a number of issues with its use of RPM.  I could provide a MM patch to fix them but it'd be best if they were just fixed in the actual package.

  • space\f-18c.cfg contains a RasterPropMonitorComputer module.  This is incorrect - RasterPropMonitorComputer is a PartModule and needs to go in the part config, not an InternalModule
  • props\nmb_hud4.cfg also contains a RasterPropMonitorComputer and it shouldn't

  • None of the command parts themselves contain a RasterPropMonitorComputer module and they should.  Many things will appear to work without this, but some things don't.

I will fix it,thnaks

Share this post


Link to post
Share on other sites
22 minutes ago, Kernowden Kerbin said:

I will fix it,thnaks

Cool!  I included a compatibility patch for NMB in my last release but if you fix it then it will be ideal for anyone not on 1.8 yet.

Share this post


Link to post
Share on other sites

Why did I download the latest version of nmbmod and the game jumped out

Edited by Kelvint

Share this post


Link to post
Share on other sites
1 hour ago, Kelvint said:

Why did I download the latest version of nmbmod and the game jumped out

same here the game crashed 4 times before i went back to the 1.7.3 version i think it has something to do with missing handail props

 

Share this post


Link to post
Share on other sites
1 hour ago, callsignblaze said:

same here the game crashed 4 times before i went back to the 1.7.3 version i think it has something to do with missing handail props

 

But I installed all the necessary props

Edited by Kelvint

Share this post


Link to post
Share on other sites
3 hours ago, Kelvint said:

Why did I download the latest version of nmbmod and the game jumped out

Find your KSP.log file next to the game executable, zip it up, upload it somewhere, and post the link here.

Share this post


Link to post
Share on other sites
1 hour ago, JonnyOThan said:

Find your KSP.log file next to the game executable, zip it up, upload it somewhere, and post the link here.

Hey,

This is my journal:

file?_download_id=5073668303234482648126

Are they a problem?

My Logs:https://dl-web.dropbox.com/cd/0/get/AxTcYYW81ZqFwu7cL9-i7bnXEvTE2gLJ4pLdAyk1yAyvnEu0eWVVrdHUHvJyc15OwBCsXWMnt-L3Nj9GCDC3GKrHGjjPOP7OUzdjekPEhO9wc-XK2rDt-t5VbYZ80wi7VS0/file?_download_id=2080986537136140250355521512829546518593222487523953026687354&_notify_domain=www.dropbox.com

Do you need more information?

Share this post


Link to post
Share on other sites
6 hours ago, Kelvint said:

Do you need more information?

I don't seem to have access to the dropbox link.

Share this post


Link to post
Share on other sites

I looks like it has to do with the handrail's textures. The textures used was in a DXT3. KSP 1.8.1 doesn't support it anymore. It switch to DXT5

Share this post


Link to post
Share on other sites
35 minutes ago, commanderbunbun said:

I looks like it has to do with the handrail's textures. The textures used was in a DXT3. KSP 1.8.1 doesn't support it anymore. It switch to DXT5

Sorry, I don't know how to switch those textures to DT5

Share this post


Link to post
Share on other sites

Has anyone have the same error with the RPM? 

[LOG 22:22:09.122] Load(Texture): JSI/RasterPropMonitor/Library/Components/NavBall/HDG
[WRN 22:22:09.134] Texture resolution is not valid for compression: 'E:\Steam\steamapps\common\Kerbal Space Program\GameData\JSI\RasterPropMonitor\Library\Components\NavBall\HDG.png' - consider changing the image's width and height to enable compression

Share this post


Link to post
Share on other sites
1 hour ago, commanderbunbun said:

Has anyone have the same error with the RPM? 

There is also a bunch of warnings with stock textures. It's not an error.

Share this post


Link to post
Share on other sites
3 hours ago, commanderbunbun said:

Has anyone have the same error with the RPM? 

[LOG 22:22:09.122] Load(Texture): JSI/RasterPropMonitor/Library/Components/NavBall/HDG
[WRN 22:22:09.134] Texture resolution is not valid for compression: 'E:\Steam\steamapps\common\Kerbal Space Program\GameData\JSI\RasterPropMonitor\Library\Components\NavBall\HDG.png' - consider changing the image's width and height to enable compression

This is just a warning, it still works correctly. Textures in DXT3 format can’t be loaded at all.  It shouldn’t prevent the part from working, it’ll just be untextured.

Share this post


Link to post
Share on other sites

Hello guys, I have a problem using cargo bays of this mod with BDA. When I put missiles inside and set them to In cargo bay: True, BDA still doesn't open the bay and thus cannot fire any of the missiles inside, any tips?

Share this post


Link to post
Share on other sites

NMB was working before, but I can't get my KSP starting when I installed the new one

[ERR 21:56:25.820] Texture 'NMB/Parts/Type20/Launcher' not found!

[ERR 21:56:25.820] Texture 'NMB/Parts/Type20/LauncherE' not found!

[LOG 21:56:25.823] Load(Model): NMB/Parts/Type20/model
[ERR 21:56:25.851] Texture 'NMB/Parts/Type20/_IVA2_Base_Color' not found!

[ERR 21:56:25.851] Texture 'NMB/Parts/Type20/03___Default_Base_Color' not found!

[ERR 21:56:25.852] Texture 'NMB/Parts/Type20/_IVA2_Base_Color 1' not found!

and

[ERR 21:56:26.118] Texture 'NMB/Props/Handrail/Handrail' not found!

[LOG 21:56:26.121] Load(Model): NMB/Props/Handrail2/model
[ERR 21:56:26.130] Texture 'NMB/Props/Handrail2/Handrail' not found!

[LOG 21:56:26.133] Load(Model): NMB/Props/Handrail3/model
[ERR 21:56:26.141] Texture 'NMB/Props/Handrail3/Handrail' not found!

[LOG 21:56:26.144] Load(Model): NMB/Props/Handrail4/model
[ERR 21:56:26.146] Texture 'NMB/Props/Handrail4/H4' not found!

[LOG 21:56:26.149] Load(Model): NMB/Props/HUD/model
[ERR 21:56:26.199] Texture 'NMB/Props/HUD/HB' not found!

[LOG 21:56:26.202] Load(Model): NMB/Props/HUD/model2
[ERR 21:56:26.243] Texture 'NMB/Props/HUD/HB' not found!
 

When I uninstall NMB I can get KSP to start

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.