Jump to content

[1.x.x] No Crew Requirement Continued 1.0.5


Recommended Posts

Note: this mod is a continuation of the mod by the same name by @RealGecko, found here.

No Crew Requirement Continued
A simple ModuleManager patch that eliminates crew requirements for manned vessels and/or the need to attach an unmanned probe to your spacecraft. Useful for automatic launches and docking of space station modules, rescue missions, etc. Requires ModuleManager.

BXWl53Y.png

Initial author
Initially created by Orbinaut, then continued by RealGecko, and finally myself, under GPL-3.0 license. Apparently, the old site gets replaced with an asterisk in posting, so I can't tell you where.

New Feature
Every command pod also receives level 0 SAS.

Download

http://spacedock.info/mod/715/No%20Crew%20Requirement%20Continued

Installation
Merge GameData content with your KSP installation's GameData.
Requires Module Manager.

Source

This mod is the source, it's a config file.

Delete any previous versions before installing the current one.

Notes:

In KSP 1.2+ unmanned command modules will be treated as probes and will have Remote Pilot Assistance available.

However, as it is still a mannable command pod, it will not have Hibernate feature and will still consume electric charge as usual.

i9ZJfJV.png

Changelog

Spoiler

1.0.5

* Fixed an issue that prevented the mod working properly without Tac Life Support

* No longer adds SAS to pods that already have it

 

Edited by Mrcarrot
Link to post
Share on other sites
  • 3 weeks later...
On 2/8/2018 at 11:17 PM, LitaAlto said:

Realizing this was RealGecko's work originally -- if this is basically a MM patch, might I suggest adding it to the Community Database of Module Manager Patches for Stock KSP?

I have suggested it there.

In other news, I'm working on adding a PartUpgrade to disable this until basic probe cores have been unlocked.

Link to post
Share on other sites
  • 1 month later...
On 2/12/2018 at 12:05 AM, Mrcarrot said:

I have suggested it there.

In other news, I'm working on adding a PartUpgrade to disable this until basic probe cores have been unlocked.

Hi

any plan on any update soon or should we just go with current version in 1.4 ? no pressure though just wanting to see what should i start my game with

Link to post
Share on other sites
7 hours ago, Jiraiyah said:

Hi

any plan on any update soon or should we just go with current version in 1.4 ? no pressure though just wanting to see what should i start my game with

It will probably work with the latest version of MM, tell me if it doesn't.

I will most likely release an update by the end of the week, now that it has been brought to my attention.

Link to post
Share on other sites
  • 4 weeks later...

It works for me on 1.4.3.

There is an issue though with TAC-LS, it relies on minimumCrew > 0 to add lifesupport resources to command pods. I think if you would add :AFTER[TacLifeSupport] to your cfg it will be solved.

Link to post
Share on other sites
  • 1 month later...
On 5/4/2018 at 5:21 AM, boribori said:

It works for me on 1.4.3.

There is an issue though with TAC-LS, it relies on minimumCrew > 0 to add lifesupport resources to command pods. I think if you would add :AFTER[TacLifeSupport] to your cfg it will be solved.

I'll look into this.

Link to post
Share on other sites
  • 1 year later...
5 hours ago, HebaruSan said:

The mod folder disappeared in the latest version; the files are now directly in GameData. Is this intentional?

No, it was not. Looks like I should be more careful with these things. :P

I've now published a much smaller update that fixes that and brings the .version file up-to-date.

Edited by Mrcarrot
Link to post
Share on other sites

So there is a small issue from the latest patch.

If you don't have TacLifesupport the AFTER[TacLifeSupport] condition cause the patch to be removed.

So now the patch only works for users of TacLifeSupport.

My fix was :FOR[TacZLifeSupportAfter] which means you still execute when TacLifeSupport is not in the install, but you are after TacLifeSupport due to the name ordering.  (But still before all the zzz mods that really want to go last).

Link to post
Share on other sites
1 hour ago, Covert said:

So there is a small issue from the latest patch.

If you don't have TacLifesupport the AFTER[TacLifeSupport] condition cause the patch to be removed.

So now the patch only works for users of TacLifeSupport.

My fix was :FOR[TacZLifeSupportAfter] which means you still execute when TacLifeSupport is not in the install, but you are after TacLifeSupport due to the name ordering.  (But still before all the zzz mods that really want to go last).

I think I know which line you are refering to and this is in teh config (.cfg) folder..

it's this line:

],#CrewCapacity[>0]],AFTER[TacLifeSupport]

so You change it so it reads

#CrewCapacity[>0]]FOR[TacZLifeSupportAfter]

if I am reading you correctly on this.


Space_Coyote

 

 

 

 

Link to post
Share on other sites

My current proposal for a fix.  This uses the same directory name as the mod for the timing clauses, moves the command crew clearing to after TacLifeSupport and avoids adding any extra SAS module node to the Near Future and expansion command pods that already have more advanced SAS included.  After a quick check run the right result shows up in the Module.ConfigCache.

@PART[*]:HAS[@MODULE[ModuleCommand],#CrewCapacity[>0],!MODULE[ModuleSAS]]:FOR[NCRC]
{
	MODULE
	{
		name = ModuleSAS
		SASServiceLevel = 0
	}
}

@PART[*]:HAS[@MODULE[ModuleCommand],#CrewCapacity[>0]]:LAST[NCRC]
{
	@MODULE[ModuleCommand]
	{
		@minimumCrew = 0
	}
}

 

Edited by Covert
Grammar fail.
Link to post
Share on other sites
On 12/1/2019 at 11:46 AM, Covert said:

My current proposal for a fix.  This uses the same directory name as the mod for the timing clauses, moves the command crew clearing to after TacLifeSupport and avoids adding any extra SAS module node to the Near Future and expansion command pods that already have more advanced SAS included.  After a quick check run the right result shows up in the Module.ConfigCache.

-snip-

Thanks!

I have now released 1.0.5... I appear to have done as I have all too often in the past, and released something without properly testing it. Hopefully all the bugs are fixed now. :P

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...