Nertea

[1.7.x] Stockalike Station Parts Redux (May 21st)

Recommended Posts

17 hours ago, Norcalplanner said:

Yep! I'm using Kerbal Health in my current career, and these parts help on multiple fronts. For example, the centrifuges reduce the microgravity penalty, while the Hostel habitat is so large that it reduces the penalty from being on a mission away from home.

And kerbal health adds some functions to the larger crewed parts,  like "med bays" and "comforts" which,  when turned on, increase kerbal endurance (at the expense of a lot of EC). Its a thing of genius.

Share this post


Link to post
Share on other sites
On 8/14/2018 at 2:15 AM, CorporalRutland said:

The 1.25m and 2.5m hubs and adapaters!

Well, these should be in some of the mid-late construction nodes - nothing too late. For example, the short 1.25m tube is in Advanced Construction and the 2.5m hub is in Meta Materials.

I am unaware of anyone else having any problems here but tech tree stuff can sometimes be weird if added to a game in progress.

Share this post


Link to post
Share on other sites
On 8/15/2018 at 11:34 PM, Nertea said:

Well, these should be in some of the mid-late construction nodes - nothing too late. For example, the short 1.25m tube is in Advanced Construction and the 2.5m hub is in Meta Materials.

I am unaware of anyone else having any problems here but tech tree stuff can sometimes be weird if added to a game in progress.

I'm starting a new game so I'll let you know how I get on!

Share this post


Link to post
Share on other sites
On 8/20/2018 at 1:25 PM, CorporalRutland said:

I'm starting a new game so I'll let you know how I get on!

Still no dice I'm afraid - not only can I not find the adapters, I can't find the Vista module either - and strangely, a search through the game files isn't locating it either.

I've re-downloaded and compared my extant files against those included in the download. They're the same.

Share this post


Link to post
Share on other sites
9 minutes ago, CorporalRutland said:

Still no dice I'm afraid - not only can I not find the adapters, I can't find the Vista module either - and strangely, a search through the game files isn't locating it either.

I've re-downloaded and compared my extant files against those included in the download. They're the same.

Logfiles then.

Share this post


Link to post
Share on other sites

Oh dear god I am catastrophically dumb, I've just noticed that the 6-point hub has a subselection menu and sure enough, there are all the connectors I've been looking for *biggest forehead smack ever*

I am so sorry to have wasted your time with this.

Share this post


Link to post
Share on other sites
43 minutes ago, 0something0 said:

Can we get support for Kerbalism?

Kerbalism provides some support for SSPX I believe?  It is certainly being tweaked on currently.

Peace.

Share this post


Link to post
Share on other sites
1 minute ago, theJesuit said:

Kerbalism provides some support for SSPX I believe?  It is certainly being tweaked on currently.

Peace.

So should I go talk to the Kerbalism folks?

Share this post


Link to post
Share on other sites
1 minute ago, 0something0 said:

So should I go talk to the Kerbalism folks?

Yup.  There is a discord server where you can chat directly with those who are working on it.  

Peace.

Share this post


Link to post
Share on other sites

1st time I saw the images of the parts, the detail blew me away.

I just downloaded version 1.0.5 of SSPXr. I see that the collider mesh for  B-EX-1 Extensible Crew Tube has been fixed (I used to have 1.0-A3 installed). Can you also fix the B-EX-2? No biggie. I'd even say the issue is cosmetic since the B-EX-1 has been fixed.

Many thanks!

Share this post


Link to post
Share on other sites
18 hours ago, bcqJC said:

1st time I saw the images of the parts, the detail blew me away.

I just downloaded version 1.0.5 of SSPXr. I see that the collider mesh for  B-EX-1 Extensible Crew Tube has been fixed (I used to have 1.0-A3 installed). Can you also fix the B-EX-2? No biggie. I'd even say the issue is cosmetic since the B-EX-1 has been fixed.

Many thanks!

What does 'fix' mean here? I had a 1-minute look and didn't see any issue.

Edited by Nertea

Share this post


Link to post
Share on other sites

Sorry for the delay...

I uninstalled all mods; then added back the ones packaged with SSPXr 1.0.5. Below are images I took of the issue. The images are out of order - sorry about that.

The last 2 were taken before I installed the Collide-o-scope mod to show the meshes.

You can see there that when retracted, the B-EX-2 port behaves as if it's still extended - it's propping up the airframe in the pictures.

I then installed Collide-o-scope to show the collision meshes. The rest of the pics show that the collision mesh for the B-EX-2 are the same when retracted or extended. The mesh for the B-EX-1 retracts and extends as intended.

Album a/q6JIpMz will appear when post is submitted
Edited by bcqJC
fixed the imgur link

Share this post


Link to post
Share on other sites

@Nertea I saw on Reddit that a while ago you started working on a redo of the stock 3.75m parts. It doesn't look like it was ever released, but would you be willing to bring the drone core, battery, and docking port to this mod? The 3.75m parts are beautiful, but I always need to adapt down to 2.5 when connecting two modules.

Even if you had only gotten around to modeling and texturing them I would be totally fine with making the part config by myself.

Edited by TronX33

Share this post


Link to post
Share on other sites

I'm having a weird issue where my EVA kerbals destroy the parts of this mod when they bump into them. Couldn't find the problem in this thread but wondering if anyone knows about this issue.

Share this post


Link to post
Share on other sites
3 hours ago, reducing said:

I'm having a weird issue where my EVA kerbals destroy the parts of this mod when they bump into them. Couldn't find the problem in this thread but wondering if anyone knows about this issue.

I haven't seen any problem like that myself but I guess if you got them going fast enough they could destroy something. How fast are they going when they hit?

Or maybe some other mod altered the part's crashTolerance or the Kerbal's mass... (not sure if increased mass of one object has any meaning as far as the code responsible for determining the outcome of crashing one part into another...)

Share this post


Link to post
Share on other sites
22 hours ago, TronX33 said:

@Nertea I saw on Reddit that a while ago you started working on a redo of the stock 3.75m parts. It doesn't look like it was ever released, but would you be willing to bring the drone core, battery, and docking port to this mod? The 3.75m parts are beautiful, but I always need to adapt down to 2.5 when connecting two modules.

Even if you had only gotten around to modeling and texturing them I would be totally fine with making the part config by myself.

Check the addon dev forum at the end of the month. 

20 hours ago, reducing said:

I'm having a weird issue where my EVA kerbals destroy the parts of this mod when they bump into them. Couldn't find the problem in this thread but wondering if anyone knows about this issue.

Glad you resolved it!

On 9/5/2018 at 9:41 AM, bcqJC said:

Sorry for the delay...

I uninstalled all mods; then added back the ones packaged with SSPXr 1.0.5. Below are images I took of the issue. The images are out of order - sorry about that.

The last 2 were taken before I installed the Collide-o-scope mod to show the meshes.

You can see there that when retracted, the B-EX-2 port behaves as if it's still extended - it's propping up the airframe in the pictures.

I then installed Collide-o-scope to show the collision meshes. The rest of the pics show that the collision mesh for the B-EX-2 are the same when retracted or extended. The mesh for the B-EX-1 retracts and extends as intended.

Album a/q6JIpMz will appear when post is submitted

Thanks for the images, I'll look into it. 

Share this post


Link to post
Share on other sites

Had a brief opportunity to fire up KSP and continue a longstanding tradition of building rovers out of station parts...

They don't actually drive of course (0/10 immersion ruined unplayable lol :D), I don't know what I expected but I had to try!

w4djE1Z.png

wR8hjPG.png

Edited by Starbuckminsterfullerton

Share this post


Link to post
Share on other sites
1 hour ago, Starbuckminsterfullerton said:

They don't actually drive of course

FWIW, DockRotate could change that.  :wink:

Share this post


Link to post
Share on other sites

Hey, I'm having a weird problem with SSPX, I'm making an interplanetary transport vehicle, centrifuge, nuclear engines, the works. It's made to aerobrake, but the centrifuge keeps burning up while nothing else (except a few protruding things at the top) heats up at all. After some testing, I found that if I put on a enormous procedural heat shield a bit bigger then the inflated centrifuge, it would protect it, but the thing is, when it's deflated it has the same problem. It's like it deflates visually, but the thing is still inflated, because the inflatable heat shield doesn't protect it. Any ideas on fixing this?

Share this post


Link to post
Share on other sites
6 hours ago, Dnarbnellih2 said:

Hey, I'm having a weird problem with SSPX, I'm making an interplanetary transport vehicle, centrifuge, nuclear engines, the works. It's made to aerobrake, but the centrifuge keeps burning up while nothing else (except a few protruding things at the top) heats up at all. After some testing, I found that if I put on a enormous procedural heat shield a bit bigger then the inflated centrifuge, it would protect it, but the thing is, when it's deflated it has the same problem. It's like it deflates visually, but the thing is still inflated, because the inflatable heat shield doesn't protect it. Any ideas on fixing this?

Sounds like its drag cubes aren't being properly calculated for both the inflated and deflated states

... a short investigation later and...

The problem is that SSPX uses a proprietary animator which does NOT implement  IMultipleDragCube

The solution is either use the stock animator class as a base for ModuleDeployableHabitat  or implement  IMultipleDragCube in the ModuleDeployableHabitat class. Either way involves a rewrite to one extent or another... Hard to say which would involve more work. Could be a case of being six of one and half a dozen of the other.

Edited by Starwaster

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.