Jump to content
  • 0

KSP black screen crash at random times


Question

So I sometimes when I play KSP it crashes to a black screen. It basically forcefully shuts down my laptop like when you hold down the power button for a long time ( I get that peewww sound). It tends to happen at the start of the game. For example when I enter the VAB or when I launch a rocket. I also got it one time while the game was still starting up. It can also happen like 3 times in a row (after starting up again). If it doesn't happen I can play the game just fine.

I have no mods installed, I only have the breaking ground expansion. I play the game from steam. 

 

Here I have my player log uploaded to dropbox:

https://www.dropbox.com/s/465m7hagdxxp5b9/Player.log?dl=0

This is my task manager when I just loaded up the game (the screen where you see all the buildings):

9DgCCR2.png

 

And here are my graphics settings. I already tried lowering some (like texture quality) because I suspected it had to with RAM or GPU limitations but to no avail.

5Eb4Tmq.png

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1
13 hours ago, FruitGoose said:

I would suggest NOT playing through steam as you’ll be stuck at the 32-bit version.

Huh? Where did you get that from? @thegozer100 actually runs the 64 bit executable, as you can see in the screenshot of the task manager and inside the log. And in my experience, steam always uses the 64bit executable.

On 4/2/2021 at 8:59 PM, thegozer100 said:

Here I have my player log uploaded to dropbox:

https://www.dropbox.com/s/465m7hagdxxp5b9/Player.log?dl=0

Is this a log after the game crashed? The last entry in your log shows an unsupported shader but not crash and I kinda doubt the shader is the issue here since the same warning shows up in my own logs and the game runs just fine.
Also, the log doesn't show the breaking ground expansion even though you mentioned that you got it. Did you remove it or left out? Just want to be sure this is the correct log here ;)

I've also noticed you're running the game in borderless window mode by using the "-popupwindow" startup parameter. Have you tried the regular windowed or fullscreen mode already?

 

On 4/2/2021 at 8:59 PM, thegozer100 said:

It basically forcefully shuts down my laptop like when you hold down the power button for a long time ( I get that peewww sound)

This actually sounds like a heat issue (your gpu or cpu gets too hot and your laptop shutsdown to protect the hardware) but that should happen everytime and not just sometimes.  Anyway, to rule that out: have you noticed this behavior in other games as well or is it just KSP?

Another question: did this happen in earlier game versions as well or is it new since the last update?

Link to post
Share on other sites
  • 0

@thegozer100 Your task manager suggests it’s a graphics/memory issue.

I would suggest NOT playing through steam as you’ll be stuck at the 32-bit version. If you go to the KSP folder (program files/steam/steamapps/common/kerbal space program usually)  (or right click on KSP icon on desktop and select open file location) there’s a 64 bit executable (has same icon as desktop one but has 64 in the name) in there. Send shortcut to desktop and run game from that (or just run it from there to try if you prefer).

not only will you get to play in 64-bit (so not limited to 4gb ram) but you get to bypass steam so they can’t  spy on you/slow your game down. I would give that a go and see if it’s still doing it but I think it might solve it regardless of the actual cause.

Edited by FruitGoose
Link to post
Share on other sites
  • 0
7 hours ago, 4x4cheesecake said:

Huh? Where did you get that from? @thegozer100 actually runs the 64 bit executable, as you can see in the screenshot of the task manager and inside the log. And in my experience, steam always uses the 64bit executable.

Well spotted. I saw he had steam running so assumed he’d launched it through that. But no he’s got steam running and playing 64-bit at the same time as you point out...

the steam version has always been 32-bit unless they’ve changed it recently. Originally everyone got crashes with too many mods so it was advised to play 64-bit (although it was unreliable originally). If you launch through the 64-bit exe and check the log, it’ll say “steam api failed to initialise” thus regardless it launches without involving steam so I stick by my claim.

If running it without steam doesn’t solve it then I agree about the overheating being the likely cause.

Edited by FruitGoose
Link to post
Share on other sites
  • 0

@4x4cheesecake Thanks for your response!

On 4/4/2021 at 12:31 PM, 4x4cheesecake said:

Is this a log after the game crashed? The last entry in your log shows an unsupported shader but not crash and I kinda doubt the shader is the issue here since the same warning shows up in my own logs and the game runs just fine.

I think this is the log after a crash. It has been some days so I can't quite remember if I started up the game before the log was created but I think I posted the log right after a crash. Maybe the crash wasn't logged if it is a heating issue? If it is a heating issue I would suspect it wouldn't appear in the logs.

 

On 4/4/2021 at 12:31 PM, 4x4cheesecake said:

I've also noticed you're running the game in borderless window mode by using the "-popupwindow" startup parameter. Have you tried the regular windowed or fullscreen mode already?

I can't find a full screen mode. So this is the hack I found after searching online. The regular windowed mode is rather small and is my opinion unplayable.

 

On 4/4/2021 at 12:31 PM, 4x4cheesecake said:

Also, the log doesn't show the breaking ground expansion even though you mentioned that you got it. Did you remove it or left out? Just want to be sure this is the correct log here ;)

Ok so apparently I don't have breaking ground installed. I remember buying them together because they were both on sale. I hadn't unlocked in the tech tree yet to notice it was missing.

 

On 4/4/2021 at 12:31 PM, 4x4cheesecake said:

This actually sounds like a heat issue (your gpu or cpu gets too hot and your laptop shutsdown to protect the hardware) but that should happen everytime and not just sometimes.  Anyway, to rule that out: have you noticed this behavior in other games as well or is it just KSP?

This might be the issue. I opened speedfan and after a couple minutes in the VAB I got the following results which sound quite high to me. At the moment I only play KSP (I don't game a lot because of time) but minecraft runs fine on this laptop. Do you (or anyone else) have recommendations for settings to lower the temperature?

76OBOVh.png

Link to post
Share on other sites
  • 0

@4x4cheesecake Ok I might have fixed the issue. I set render quality -> fast, frame limit ->  60 fps and I lowered some other settings. My GPU usage is still high but is considerably better. The temperature gauges on speedfan are also slightly better.

It's weird but it appears my GPU usage is a lot higher in the VAB compared to in-flight.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...