frizzank

[1.0.5] FASA 5.44

Recommended Posts

Unfortunately the LEM is part of Denny's stuff and while I do have the model files and textures I do not have the unity source and would have to re-create them in unity and re-export them. What is SPS?

Share this post


Link to post
Share on other sites

Ah, gotcha. Then I'd guess it's the same for SPS (as Darth Vader says, the Apollo CSM engine).

Share this post


Link to post
Share on other sites

The SPS should gimbal (it used an electric motor), but there is no gimbal code in the config file.

Share this post


Link to post
Share on other sites

I ran into a problem where, when flying a full Saturn stack, it wants to tilt to the left, regardless of your center of mass and stabilization. I have to manually thrust to the right until first staging.

Share this post


Link to post
Share on other sites

Any significantly tall rocket wants to tilt to the left on launch, it seems to be a stock bug or maybe the Coriolis effect with the new physics and atmospheric system.

The Saturn V is exaggerated by the fact that the parts are so much larger than stock ones. I recommend Kerbal Joint Reinforcement http://forum.kerbalspaceprogram.com/threads/55657-1-0-2-Kerbal-Joint-Reinforcement-v3-1-3-4-27-15

It fixes a bunch of stuff associated with large rockets like the Saturn V

Share this post


Link to post
Share on other sites

VASMIR asked about soviet packs not being updated. I noticed there is nothing on Soyuz, Salyut, Skylab, or any of those historical packs (except the FASA pack), and all threads on them are closed. The threads say 1.0.2... and yet the downloads are broken links and the threads are (as stated before) closed. ... am I missing something here?

Share this post


Link to post
Share on other sites
Any significantly tall rocket wants to tilt to the left on launch, it seems to be a stock bug or maybe the Coriolis effect with the new physics and atmospheric system.

The Saturn V is exaggerated by the fact that the parts are so much larger than stock ones. I recommend Kerbal Joint Reinforcement http://forum.kerbalspaceprogram.com/threads/55657-1-0-2-Kerbal-Joint-Reinforcement-v3-1-3-4-27-15

It fixes a bunch of stuff associated with large rockets like the Saturn V

I burn the main engines on the pad for 5-7 seconds before releasing the launch clamps, and rarely have a deviation of more than 2 degrees from true at liftoff. Immediate release of the clamps usually results in significant slew of roughly 10 degrees or more. It could well be a lag in physics stabilisation, even though I'm using KJR. I should think the more likely culprit is the gimbal algorithm. Release too soon, and the gimbals haven't caught up to full control authority. Hold the bird on the pad a few seconds, and the gimbals have a better idea of what's going on.

Edited by Jack Wolfe

Share this post


Link to post
Share on other sites

Yep, both SAS freaking out at near-zero velocity (slewing gimbals desperately) and clamps imparting a torque, would contribute.

Share this post


Link to post
Share on other sites

Can anyone point me to a Remote Tech MM file to make the antenna's work right? The Pioneer Ant doesn't seem to work with RT (haven't tried the others yet)

Share this post


Link to post
Share on other sites

Oh yeah, also. There's seems to be a bug with the launch clamps.

When ever I launch a rocket with the clamps, they would re-appear every 6 km as I climb. Sometimes even appearing inside the rocket, therefore destroying it :\

Examples. http://steamcommunity.com/sharedfiles/filedetails/?id=464887020 and http://steamcommunity.com/id/ILM126/screenshot/538524212986611904

Share this post


Link to post
Share on other sites

Its a known bug, happens with stock clamps as well just not as often for a some reason...

The workaround is to save after launch and do a quick load...

mPbk5wq.jpg

Share this post


Link to post
Share on other sites

I'm trying to determine if this is just a mod conflict bug or a FASA bug: The large launch tower automatically stages all by itself right after loading up at the launch pad. This is with RSS/RO, 64-bit KSP under Linux.

Share this post


Link to post
Share on other sites

Repeating the question, only because having the parts is kinda important for some productions I am working on.

VASMIR asked about soviet packs not being updated. I noticed there is nothing on Soyuz, Salyut, Skylab, or any of those historical packs (except the FASA pack), and all threads on them are closed. The threads say 1.0.2... and yet the downloads are broken links and the threads are (as stated before) closed. ... am I missing something here?

Share this post


Link to post
Share on other sites

On Agena Probe Core, two drawn RCS ports that are meant to be used for roll, are actually not functional. Please fix.

Also, correct stats for Agena rocket motor would be:

@PART[FASAAgena_Engine] {  // FASA Agena Rocket Engine
@mass = 0.132
@MODULE[ModuleEngines] {
@maxThrust = 71.2
!PROPELLANT[LiquidFuel] {}
!PROPELLANT[Oxidizer] {}
%PROPELLANT[MonoPropellant] {
%ratio = 1.0
%DrawGauge = True
}
!atmosphereCurve {}
%atmosphereCurve {
%key = 0 293
%key = 1 210
}
}
}

@PART[FASAAgena_Engine_FP,FASAAgenaProbe] { // FASA Agena Flight Pack, Agena Probe Core
@RESOURCE[MonoPropellant] {
@amount *= 1.63
@maxAmount *= 1.63
}
}

src: Encyclopedia Astronautica

I went MP cause of UDMH+RFNA, besides, RFNA is almost 2 times denser then UDMH! Resulting mix is 1.63 times denser for given engine.

Unfortunately I do not have more stats, for example total stage dry weight, power capabilities, and - oh woe - available Delta-V :-(

Edit: okay, here's what I've been able to find, but for Arena A (while I think I need lightened Agena D): Weight: 8,400 lbs. (6,400 lbs. propellant) - that gives 3.81 for entire Agena stack, of which 2.9 tons is propellant.

Other source is this, but it's more about engines... (note Bell Model 8096C Growth Agena Engine with self-actuatingby exhaust pressure (!!!) extending nozzle)

If someone knows stats for Agena D, please post.

agena04.jpg

Guess Agena Flight Pack should be rescaled also, and its top RCS ports moved to other part (Docking collar?)

Edit 2: found this info on Agena D. FASA parts are horrendously overweight... So I also used this:

@PART[proceduralTankRCS] {
@MODULE[TankContentSwitcher] {
@TANK_TYPE_OPTION[RCS] {
@dryDensity = 0.12 // was 0.22 - how much 1L of tankage weights
@RESOURCE[MonoPropellant] { @unitsPerT = 1994 } // Stochiometric N2H4/UDMH is 2.61:1, its density is ~957.3
}
}
}

So I guess that another part could be made - more advanced Agena engine with one-time extendable (but not retractable) nozzle, thrusting 53.38 kN with Isp of 336, weighting 0.084, eating MP. Needs to be one tech node up as it is more "advanced".

- - - Updated - - -

I burn the main engines on the pad for 5-7 seconds before releasing the launch clamps, and rarely have a deviation of more than 2 degrees from true at liftoff. Immediate release of the clamps usually results in significant slew of roughly 10 degrees or more. It could well be a lag in physics stabilisation, even though I'm using KJR. I should think the more likely culprit is the gimbal algorithm. Release too soon, and the gimbals haven't caught up to full control authority. Hold the bird on the pad a few seconds, and the gimbals have a better idea of what's going on.
I counter it by using SmartParts altimeter to free previously locked gimbals from AG. TweakableEverything helps a lot. Edited by cipherpunks

Share this post


Link to post
Share on other sites
I burn the main engines on the pad for 5-7 seconds before releasing the launch clamps, and rarely have a deviation of more than 2 degrees from true at liftoff. Immediate release of the clamps usually results in significant slew of roughly 10 degrees or more. It could well be a lag in physics stabilisation, even though I'm using KJR. I should think the more likely culprit is the gimbal algorithm. Release too soon, and the gimbals haven't caught up to full control authority. Hold the bird on the pad a few seconds, and the gimbals have a better idea of what's going on.

I counter it by using SmartParts altimeter to free previously locked gimbals from AG. TweakableEverything helps a lot.

That's as may be, but I prefer factoring in a tad extra fuel and skipping two additional mods. To each their own.

Share this post


Link to post
Share on other sites
On Agena Probe Core, two drawn RCS ports that are meant to be used for roll, are actually not functional. Please fix.

Also, correct stats for Agena rocket motor would be:src: Encyclopedia Astronautica

I went MP cause of UDMH+RFNA, besides, RFNA is almost 2 times denser then UDMH! Resulting mix is 1.63 times denser for given engine.

Unfortunately I do not have more stats, for example total stage dry weight, power capabilities, and - oh woe - available Delta-V :-(

Edit: okay, here's what I've been able to find, but for Arena A (while I think I need lightened Agena D): Weight: 8,400 lbs. (6,400 lbs. propellant) - that gives 3.81 for entire Agena stack, of which 2.9 tons is propellant.

Other source is this, but it's more about engines... (note Bell Model 8096C Growth Agena Engine with self-actuatingby exhaust pressure (!!!) extending nozzle)

If someone knows stats for Agena D, please post.

http://www.astronautix.com/graphics/a/agena04.jpg

Guess Agena Flight Pack should be rescaled also, and its top RCS ports moved to other part (Docking collar?)

Edit 2: found this info on Agena D. FASA parts are horrendously overweight... So I also used this:

So I guess that another part could be made - more advanced Agena engine with one-time extendable (but not retractable) nozzle, thrusting 53.38 kN with Isp of 336, weighting 0.084, eating MP. Needs to be one tech node up as it is more "advanced".

- - - Updated - - -

I counter it by using SmartParts altimeter to free previously locked gimbals from AG. TweakableEverything helps a lot.

That's the real Agena? I thought it was a coffee can filled with Mentos and Cola with holes punched in the back for thurst. At least that's how I did my weight and thrust calculations.

Sarcasm aside my pack is meant to go with stock stuff and since Kerbin is no where near real life everything in my pack is way out of whack for game play and balancing reasons to make it more fun/challenging. If you want the real world configs go here instead http://forum.kerbalspaceprogram.com/threads/99966-1-0-x-Realism-Overhaul-v10-0-2015-167.

I did a lot of research and made some hard choices about what to do. I left out a ton of stuff that was on the real Agena, I just didn't have time to do a 100% accurate one. In hind sight I should have left off all the RCS but the fact that I went with no reaction control gyros for pods and probes meant that if you forgot them you were screwed...

gatv_diagram_labelled.jpg

Share this post


Link to post
Share on other sites

hi guys! first of all, many thanks to frizzank for this unbelievable mod!!!

sadly my PC is not handling it anymore and I would like to keep only the engines provided by the mod. I tried going through the folders (red the How to delete parts.txt) and figuring out what to delete and what to keep but honestly I couldn't do it.

would anyone here be so kind as to guide me through the process of deleting parts from FASA in views of only keeping the engines? is this even possible?

let me know if you have any ideas!!! :D:D many thanks in advance!

Edited by pvnkb1tch

Share this post


Link to post
Share on other sites

Many textures are shared so your not going to get much in the way of memory or performance by deleting everything but the engines.

Have you tried removing the ReflectionPlugin.dll first? That helps some people with low end machines. It's in the FASA/Plugins folder.

Beyond that the ones with "LFE" are Liquid Fuel Engines, "SRB" are the Solid Rocket Boosters. Most have similar named textures (.dds) files as the models (.mu) and (.cfg). LFT is Liquid Fuel Tank. So most of those can go. In the Apollo folder you could delete everything but the FASA_Apollo_Eng folder.

Also FASA/ Agencies, Flags, ICBM, Misc, Props, Resources, Spaces, can all go if you just want the engines.

Share this post


Link to post
Share on other sites

@pvnkb1tch are you using ATM that helps alot also switching to opengl mode if your graphics card supports it also helps alot

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.