Jump to content

[0.22] UbioZur Welding Ltd. 2.0 Dev STOPPED


Recommended Posts

Just get into the config.xml and change 0 to 1

The Path: GameData\UbioWeldingLtd\PluginData\UbioWeldingLtd\config.xml

And in case that he uses any other mods that work with ModuleManager, or he uses Loading On Demand, it won't help him, as it would break the running gamedatabase.

Link to post
Share on other sites
Guys, I was trying to be smart, but results I am not.

My apologies

Just happend!!!

Don't worry, Restarting the game is the safest way.

I will look into Sarbians ModuleManager, his last official version contained a reload of the database with the mod configs, maybe it is accessable.

But the problem with Lod On Demand would not be fixed by that.

Link to post
Share on other sites

I will look into Sarbians ModuleManager, his last official version contained a reload of the database with the mod configs, maybe it is accessable.

But the problem with Lod On Demand would not be fixed by that.

Yes, using of ModuleManager helps, as well as using Alt-F12 -> database -> overview -> reload all (but to use ModuleManager is easier).

However, if you use PartCatalog, it anyway will not show the parts that did not exist at the start of the game.

Link to post
Share on other sites

I've used this before in earlier versions of KSP with no problems. I'm now using KSP 0.24.2 Linux 64-bit and when I put Ubio in my game data folder, the game won't load. I get a small piece of progress bar but it doesn't move and there's no text in the bar. Above the bar is "Untangling Space Tape..." etc and that keeps changing to other things so it's not completely frozen...

Any idea what's going on?

Link to post
Share on other sites
I've used this before in earlier versions of KSP with no problems. I'm now using KSP 0.24.2 Linux 64-bit and when I put Ubio in my game data folder, the game won't load. I get a small piece of progress bar but it doesn't move and there's no text in the bar. Above the bar is "Untangling Space Tape..." etc and that keeps changing to other things so it's not completely frozen...

Any idea what's going on?

Logfiles please, then we can say something.

Link to post
Share on other sites

I've gotten the fix for 0.24.2, and I've welded parts fine, but when I weld together multiple Tweakscale parts, and try to scale the welded part up, it reverts back to its original size on launch. Such as, welding 2 girders together, rescaling them to 200%, then when launching, they are at 100%.

I want to be able to make things like

Link to post
Share on other sites
I've gotten the fix for 0.24.2, and I've welded parts fine, but when I weld together multiple Tweakscale parts, and try to scale the welded part up, it reverts back to its original size on launch. Such as, welding 2 girders together, rescaling them to 200%, then when launching, they are at 100%.

I want to be able to make things like

Tweakscale interacts with the current model in the Hangar, while welding reads the things from the configs. I'm already looking into this, but was currently not able to find any help.

Link to post
Share on other sites
I've gotten the fix for 0.24.2, and I've welded parts fine, but when I weld together multiple Tweakscale parts, and try to scale the welded part up, it reverts back to its original size on launch. Such as, welding 2 girders together, rescaling them to 200%, then when launching, they are at 100%.

I want to be able to make things like

You cannot weld parts you have tweakscaled before. In the welding process they get their original size back. Always weld the original sized parts. Then go to the partfile.cfg and remove all multipe tweakscale modules and just leave one in the file. After that you can use tweaksclae and change the size.

So when i try to weld things my game freezes in the SPH/VAB but i can still move my mouse but i can't push anything any fixes?

Just wait and do nothing. It depends on how many parts you weld. Welding up to 100 parts gets done very quickly. But if you weld over 1000 parts it takes more than 5 minutes to finish it. Also the game is really crashing sometimes, but only if you have many parts and the RAM is full, then you get a crash report on the desktop.

Link to post
Share on other sites
Indeed, impact tolerance is calculated in some strange way, it would be nice to fix it.

As for the drag... First question: do you use FAR? If not, then drag depends only on the mass. If yes - hmmm... Have you tried to fly on craft with unwelded parts, then on same craft with welded parts, and then compare the readings from FAR? In first place is there any difference between values of "Reference area"? And second - in values of "Q" on same speed and altitude?

And as for mass, I believe, now (massless parts fix description, link to lates tfix version) it calculates correctly. If you noticed back - won't you please upload an example .craft file you trying to weld?

No NEAR or FAR in use. The drag issue is just the parts come out with odd values that are incongruous with the original values. Since as I see them, most parts are either drag of 0.1 or 0.2. But the ones comming out of the welder for me tend to be more like 0.154 or some other value.

Link to post
Share on other sites
So I'm curious, is there any way to adjust the amount you can re-scale in the Tweakscale mod? I have a base ship model, and want to say, rescale it up 6000% than it's original, but it locks me at 400% anyone know how to increase that limit?!

It's simple to increase the level. Just edit the DefaultScales.cfg of the tweakscale mod and save it. I have done it myself, maybe you saw it in my video.

Here the part to edit:

I changed the maxScale from 100 to 6000

SCALETYPE

{

name = free

freeScale = true

minScale = 25

maxScale = 6000

defaultScale = 100

suffix = %

}

24.2?? Please? Anyone?

It's already working, just read the last pages of this thread and you will find the solutions.

Link to post
Share on other sites
No NEAR or FAR in use. The drag issue is just the parts come out with odd values that are incongruous with the original values. Since as I see them, most parts are either drag of 0.1 or 0.2. But the ones comming out of the welder for me tend to be more like 0.154 or some other value.

Just looked at the UbioZur's code. It seems that the drag is calculated as the arithmetic average of the drags of parts. Isn't it good? Or not?..

In fact, it seems to me that it would be better to calculate the weighted average by mass.

Something like TotalDrag = DragOfPart1*MassOfPart1 + DragOfPart2*MassOfPart2 + ... + DragOfPartN*MassOfPartN ? It is easy to realize.

What are your opinions?

Anyway, I'm using FAR and don't fly in atmosphere on welded crafts :)

Link to post
Share on other sites

Pertaining to re-scaling the already welded crafts, how would someone, like myself, re-size a craft and keep it? Sounds weird at first, but when I re-scale a welded part in the SPH or VAB, it doesn't hold it's scale when I launch it, and resets the welded part to it's original size at the time of welding...

I suppose it's something I am currently overlooking, although it is postponing my mega-ship project. :/

Link to post
Share on other sites
Pertaining to re-scaling the already welded crafts, how would someone, like myself, re-size a craft and keep it? Sounds weird at first, but when I re-scale a welded part in the SPH or VAB, it doesn't hold it's scale when I launch it, and resets the welded part to it's original size at the time of welding...

I suppose it's something I am currently overlooking, although it is postponing my mega-ship project. :/

I will probably make a How-to video and upload it on my youtube channel, could be ready this weekend. Many people ask how to do this, so I think it's a good idea.

Btw, 1000th comment!

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...