Kickasskyle

[1.02] KW Rocketry v2.7 Available - 1.02 Compatibility! - 16/05/2015

Recommended Posts

Hi, I have noticed that Service Propulsion System engine doesn't show amount of fuel in staging window when activated. I have to open resource panel to monitor how much monopropelant I have left. Is this a bug or feature?

EDIT: Nevermind, I did a clean install of KW and it works now :)

Edited by Palec

Share this post


Link to post
Share on other sites

I've got an odd problem where this modpack, for no apparent reason, causes a CTD when creating a new world. Any idea what might be behind this?

Share this post


Link to post
Share on other sites

I may just borrow the Griffon Century starting sound for my windows startup.

Share this post


Link to post
Share on other sites
I think I'll pass on that one, I have no visibility of how KER works, and what stats it picks up on so I wouldn't know where to start, though I have heard other people mention this in relation to other mods so you might want to see if anyone has already asked on the KER side of things.

Ok, I'll ask in the KER forum, thank you.

In order to avoid issues with KER, build top-down. You get the best results if the root part is in the highest possible stage (S0) and all other stages are physically below the root part. (I suspect that has something to do with building in the other direction opening a new, different part tree internally or something.)

I always build top bottom, I guess I'll ask in the KER forum, thanks.

Share this post


Link to post
Share on other sites

For some reason, none of the KW engines have fairing shrouds when I use them. I didn't install the no auto fairings thing, and when I right click the engine, it says the fairing is enabled (using Tweakable Everything). I'm using the 32 bit version of KSP. Any idea why this is happening?

Share this post


Link to post
Share on other sites
For some reason, none of the KW engines have fairing shrouds when I use them. I didn't install the no auto fairings thing, and when I right click the engine, it says the fairing is enabled (using Tweakable Everything). I'm using the 32 bit version of KSP. Any idea why this is happening?

Did you delete the interstage shrouds? (I clean out mods a lot; no need for 4 sets of fuel tanks and 3 different sets of fairings.)

Share this post


Link to post
Share on other sites

The KW booster power doesn't seem to respond properly to tweaking its thrust (I think using TweakableEverything) in the VAB before launch. Here's the behaviour of the Globe X SRB:

  • When it's set to 100% thrust, it gives 614 kN of thrust
  • When it's tweaked down to 50.5% thrust, it gives 464.5 kN of thrust
  • When it's tweaked down to 5.5% thrust, it gives 328.6 kN of thrust

It's following the equation AcualThrust = 3.02 * ThrustSetting + 312

And other KW SRBs show similar behaviour. By contrast, the stock boosters seem to scale their thrust directly. At 100% setting, the Rockomax BACC Solid Fuel Booster gives 315 kN, at 50.5% it gives 50.5% of that (159.1 kN), and at 5.5% it gives 5.5% (17.3 kN).

So the KW boosters aren't behaving like the stock ones. Is this intended behaviour, or a bug? This is running KW Rocketry 2.6c and TweakableEverything 1.3.1 (latest versions as of 2014-08-02).

Share this post


Link to post
Share on other sites
The KW booster power doesn't seem to respond properly to tweaking its thrust (I think using TweakableEverything) in the VAB before launch. Here's the behaviour of the Globe X SRB:

  • When it's set to 100% thrust, it gives 614 kN of thrust
  • When it's tweaked down to 50.5% thrust, it gives 464.5 kN of thrust
  • When it's tweaked down to 5.5% thrust, it gives 328.6 kN of thrust

It's following the equation AcualThrust = 3.02 * ThrustSetting + 312

And other KW SRBs show similar behaviour. By contrast, the stock boosters seem to scale their thrust directly. At 100% setting, the Rockomax BACC Solid Fuel Booster gives 315 kN, at 50.5% it gives 50.5% of that (159.1 kN), and at 5.5% it gives 5.5% (17.3 kN).

So the KW boosters aren't behaving like the stock ones. Is this intended behaviour, or a bug? This is running KW Rocketry 2.6c and TweakableEverything 1.3.1 (latest versions as of 2014-08-02).

Its the intended behaviour, when you set it to 0%, the actual thrust is 50% of max.

Share this post


Link to post
Share on other sites

What you're tweaking is a multiplier to *throttle.* Final thrust = minThrust + (maxThrust - minThrust) * throttle.

"Thrust Limiter" should have been called "Throttle Limiter"

Share this post


Link to post
Share on other sites
Its the intended behaviour, when you set it to 0%, the actual thrust is 50% of max.

That's... unfortunate... but it does explain why the probe I just tried to launch with an all-SRB launch vehicle shot off the pad at I don't even know how many Gs and shredded itself in FAR, even though MJ said my TWR was dialed back to 1.2:1.

I guess MJ doesn't know that KWR SRBs follow different rules than the stock ones. Which means I'll need to stick to the stock SRBs when I need to tweak the thrust.

Edited by RoboRay

Share this post


Link to post
Share on other sites

Just downloaded KWR today. Finally decided to give the mod world a chance, and Spaceplane Plus and KWR were the ones I wanted most. I do have two questions, if you guys wouldn't mind helping me out.

1: I presume it is recommended I download either NEAR or FAR? I mean, let's face it, what's the point of having fairings if they actually slow your vehicle down?

2: Like many people, when I first downloaded KWR, I looked at all my shiny new toys that would make Jim Lovell jealous and thought "well, must be time to replicate Apollo 11". However, I'm running in to a slight problem. When using the 3.75-2.5m petal adapter, I run in to a tight spot. The fairing doesn't have enough for a minimal size lander and an engine nozzle. If I attach the petal fairing's top to the point where the engine and fuel tank connect, a clipping issue arises as soon as I go to decouple, with the clipping between my engine nozzle and lander causing my command module to go shooting off from the rest of the craft. However, if I attach the node at the very bottom/end of the nozzle to the node at the very top of the petal adapter, this, of course, auto-generates a fairing around the engine, same as any decoupler would. Will this second fairing's existence cause errors with the petal fairing's operation?

Thanks, all!

Share this post


Link to post
Share on other sites
That's... unfortunate... but it does explain why the probe I just tried to launch with an all-SRB launch vehicle shot off the pad at I don't even know how many Gs and shredded itself in FAR, even though MJ said my TWR was dialed back to 1.2:1.

I guess MJ doesn't know that KWR SRBs follow different rules than the stock ones. Which means I'll need to stick to the stock SRBs when I need to tweak the thrust.

From what I understand, KER handles KW boosters correctly (since rather recently though, check the thread). So either head over to the MJ thread and ask them to handle them correctly (I'm sure these are not the only ones using non-zero-minthrust), or just come over to KER :D

1: I presume it is recommended I download either NEAR or FAR? I mean, let's face it, what's the point of having fairings if they actually slow your vehicle down?

Well, I don't know if it's recommended as such, I've also used the fairings just for pretty lookin' rockets before I've ever used either, but they do work correctly with both if that's what you're asking. FAR and NEAR detect objects as shielded when inside a KW-fairing and act accordingly.

Edited by Creat

Share this post


Link to post
Share on other sites
or just come over to KER :D

No customizable minimalist window options, unfortunately, and lacking a few really nice bits of information that MJ provides. At least, the last time I checked... and it's been a while...

Share this post


Link to post
Share on other sites
No customizable minimalist window options, unfortunately, and lacking a few really nice bits of information that MJ provides. At least, the last time I checked... and it's been a while...

There's a new update with a UI refresh -- including configurable windows -- and more info. Check it out.

Share this post


Link to post
Share on other sites

Nice update but i have one Major Problem. If i use the new tanks it keep "crashing". And with "crashing" i mean that if i build up my Rocket with the new Tanks and Engines attached to another the Display keeps Black or well my Rockets "burns" and i can not Launch it from the Launch Pad.

Share this post


Link to post
Share on other sites

With the no auto-shroud installed, are shrouds disabled entirely for those parts? I.e., is there no optional way of installing a shroud on an engine in a tweakable fashion?

Thanks!

Share this post


Link to post
Share on other sites

What's the proper way to build the interstage fairing off the Titan V? I'm seeing a gap between the top body of the Titan engine and the top of the 5m fairing. I'm using manual shrouds.

Also, the shrouds don't separate when staged?

E0F6ECA974A4D9CBDAC4E60B4B7A3C545ECDCE81

Edited by mrBlaQ

Share this post


Link to post
Share on other sites
With the no auto-shroud installed, are shrouds disabled entirely for those parts? I.e., is there no optional way of installing a shroud on an engine in a tweakable fashion?

There are decouplers with shrouds built in. Use those when you want a shrouded engine.

Share this post


Link to post
Share on other sites
texture reduction anyone?

Why? Since this pack has been reworked it requires very little memory (~250 MB or something?) compared to it's size, part count and even previous versions. Whatever other mods/packs you are using that cumulatively put you over the memory limit for 32 bit, you're much more likely to get more mileage out of texture-reducing the others as they are probably bigger (or you wouldn't be over the limit). You could also just use the 64 bit version (if you have enough physical RAM), it works reasonably well with few exceptions (there are some, but very few, plugins that won't work with it).

Share this post


Link to post
Share on other sites

Is it just me or is the 'Griffon Century' over powered, with the largest tank it makes it pretty easy to get a orange tank or even more into space.

Share this post


Link to post
Share on other sites
However, if I attach the node at the very bottom/end of the nozzle to the node at the very top of the petal adapter, this, of course, auto-generates a fairing around the engine, same as any decoupler would. Will this second fairing's existence cause errors with the petal fairing's operation?

This is what I tried the other night - connecting the top of the petal adapter to the bottom of the SM engine which auto generates the fairing. The problem I have is that the auto generated fairing won't disappear. Whether I use the decouple command on the petal adapter or try to manually "jettison" the fairing before decoupling, the fairing stays in place. So when I open the petal fairing the auto generated fairing remains fixed in place, attached to nothing. I can clip right through it so I can still turn the SM around and extract my lander, but it looks pretty silly.

Share this post


Link to post
Share on other sites
This is what I tried the other night - connecting the top of the petal adapter to the bottom of the SM engine which auto generates the fairing. The problem I have is that the auto generated fairing won't disappear. Whether I use the decouple command on the petal adapter or try to manually "jettison" the fairing before decoupling, the fairing stays in place. So when I open the petal fairing the auto generated fairing remains fixed in place, attached to nothing. I can clip right through it so I can still turn the SM around and extract my lander, but it looks pretty silly.

The majority of the engines now have a cloned top node for this very reason, you can place shrouds/etc on them without triggering the automatic shroud. This was the design intent for the petal adapter.

Is it just me or is the 'Griffon Century' over powered, with the largest tank it makes it pretty easy to get a orange tank or even more into space.

Bigger rockets enabling you to lift heavier cargo into orbit isn't anything I wouldn't expect, if that weren't the case I'd question what their use.

Generally speaking the way we've setup the balance for KW rocketry at the moment relies on the thrust to weight ratio of the engines increasing relative to their size/role. To counter this they have a drop off in their ISP.

If you wanted to point at overpowered engines, the stock KR-2L actually has a higher thrust/weight ratio than the griffon century and a higher ISP to boot. But stocks in my opinion, dubious balance direction is a subject for another day.

Share this post


Link to post
Share on other sites
The majority of the engines now have a cloned top node for this very reason, you can place shrouds/etc on them without triggering the automatic shroud. This was the design intent for the petal adapter.

Bigger rockets enabling you to lift heavier cargo into orbit isn't anything I wouldn't expect, if that weren't the case I'd question what their use.

Generally speaking the way we've setup the balance for KW rocketry at the moment relies on the thrust to weight ratio of the engines increasing relative to their size/role. To counter this they have a drop off in their ISP.

If you wanted to point at overpowered engines, the stock KR-2L actually has a higher thrust/weight ratio than the griffon century and a higher ISP to boot. But stocks in my opinion, dubious balance direction is a subject for another day.

Can I request just one more engine to the large array of wonderful engines that come with KW. I think one more 5m engine is needed. An upper stage 5m if you will? I have been doing some heavy lifting over the last few days and it seems that an upper stage 5m is exactly whats missing. Obviously I know another part update is way in the future but maybe its something to add to the list in the future?

Share this post


Link to post
Share on other sites
Can I request just one more engine to the large array of wonderful engines that come with KW. I think one more 5m engine is needed. An upper stage 5m if you will? I have been doing some heavy lifting over the last few days and it seems that an upper stage 5m is exactly whats missing. Obviously I know another part update is way in the future but maybe its something to add to the list in the future?

There is one, it's right next to the Griffon called the Titan V. Why would you need another 5m upper stage rocket? Do your payloads never slim out to under 5m? If you were desperate for more 5m engines just use Tweakscale on other engines. I think the selection is fine, I'd welcome more of course, as I would more tanks and/or paint schemes (current and new), but the mod doesn't NEED anything. It's pretty much perfect.

EDIT: To those who believe the Griffon is overpowered, you do realise it's based on the Rocketdyne F-1 cluster that launched the Saturn V, right? One of the largest rockets ever created? With 60s technology? If your launch vehicle doesn't require it's full power it does have a thrust limiter, or just swap it out entirely.

Edited by Lei07
Minor rant

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.