Jump to content
  • 0

Re-target my own vessel?


Question

I hope this is a quick and easy one, but how do I re-center my view on my own ship. Whenever you are ANYWHERE near a celestial body, it ONLY wants to select that. You'd think there would be a priority for ships considering they are so much smaller, but nope. Always target the body first. Sometimes you can trick it by moving the camera, but is there a button somewhere for this?

Edited by Hyomoto
Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
Backspace. :)

Yep, that'll do it! Also in map view you can hit TAB and SHIFT+TAB to cycle through the celestials (Note that unless you want your ship flying off in a random direction make sure your navball is closed when using SHIFT + TAB)

Link to post
Share on other sites
  • 0

Hmm, I was able to TAB my way back. Shift-tab interferes with Steam, though you'd think I would've picked up on that sooner. Backspace ... didn't do anything. I'll fiddle with the buttons some more, then. Thanks!

Link to post
Share on other sites
  • 0

Backspace should focus on your ship in flight. Unless you're in the tracking station, then backspace recenters the view onto Kerbin.

Also, if you're trying to "Switch To" a craft and can't click on it (because of the same problem), you can simply double-click on it and the game will switch-to.

Link to post
Share on other sites
  • 0

I have finally relocated a few keys:

stage from space to insert

abort from backspace to clear

throttle from shift+ctrl to page up+down

cut throttle to also end

Takes a bit to retrain your brain and makes one handed flying while rotating and clicking mods with the other a bit more difficult, but saves you from one or two headaches a week.

Link to post
Share on other sites
  • 0
(Note that unless you want your ship flying off in a random direction make sure your navball is closed when using SHIFT + TAB)

I'm in the habit of setting an action group to toggle my engines off between manoeuvres after pressing shift way too many times when I didn't want to ^^

Link to post
Share on other sites
  • 0

Color me surprised, but I get to necro my own thread because it seems nearly ... seven years later I have the same question.  Tab now doesn't select anything but celesital bodies, backspace still does nothing and clicking anywhere near a planet still focuses on that planet.  Look, if it's a mod that fixes this behavior (despite being a tad shocked this problem is still a problem) then that's fine, but my brain won't let me believe there isn't a better option than reloading the scene to get the map to refocus on your vessel.  So, for the second time: is there a simple, vanilla, built-in way to focus on YOUR ship in map mode other than reloading the scene, and if not could you point me in the direction of the most current mod the cool kids are using?  I feel like there used to be a mod for this, it helped you set your nodes as well.  Precision Node?  Something like that.

As an aside, Googling this issue brought me back to my own thread so maybe I'm literally the only person with this issue?

Edited by Hyomoto
Link to post
Share on other sites
  • 0

Well, @Hyomoto, I have good news for you, I think.   The ~ key will return focus to your craft after using tab to view various bodies.  (I'm using a modded install, but I believe that's a stock command).

EDIT:   Ehh... I'm only 80% sure it's stock, if it's not it might be Kerbal Alarm Clock that does it?

Edited by Gargamel
Link to post
Share on other sites
  • 0
Just now, Gargamel said:

Well, @Hyomoto, I have good news for you, I think.   The ~ key will return focus to your craft after using tab to view various bodies.  (I'm using a modded install, but I believe that's a stock command).

Oh, you are a dear sir indeed.  Yes, that worked quite fine!  Good news indeed.  I will gladly share my snacks in thanks!

Link to post
Share on other sites
  • 0
2 hours ago, Gargamel said:

The ~ key

Well, nitpicking...

Is probably "backquote" and the tilde(~) happens to be in the same key for both of you. Also, it can be changed in the settings.

Link to post
Share on other sites
  • 0
3 minutes ago, Spricigo said:

Well, nitpicking...

Is probably "backquote" and the tilde(~) happens to be in the same key for both of you. Also, it can be changed in the settings.

I always refer to it as the tilde key, as it's the only key with anything resembling a ~, and there a couple keys with ` like things on them.   

 

Especially after I sneeze on the keyboard.  :D

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...