DMagic

[1.10.0] SCANsat [v20.2] -- Real Scanning, Real Science, at Warp Speed! [July 7, 2020]

Recommended Posts

37 minutes ago, Sᴄɪɴᴛɪʟʟᴀᴛá´ÂÊ€ said:

I am using SCANsat with SSRSS and everything was working fine until I tried to do a resource scan of Deimos with the M700 Survey Scanner. I am getting the message "You must be in a stable polar orbit between 25km and 3km to perform an orbital survey" which makes no sense with the larger number being first. I tried anyway and have been unable to find any polar orbit between the surface and escape that will match whatever constraints are needed to do the scan and am at a loss for how to complete it. I looked through all the cfg's I could find related to orbital scanning in my install but can't find anything sticking out that would cause this and could use some help in figuring it out. Thanks in advance to anyone that responds.

I didn't manage to update SD to work with 1.1.3 yet, so that might be a factor. But there could also be some configs in SSRSS that changes scansat, not sure.

It's probably an issue with one of those two mods anyways, not scansat itself

Share this post


Link to post
Share on other sites
47 minutes ago, Sigma88 said:

I didn't manage to update SD to work with 1.1.3 yet, so that might be a factor. But there could also be some configs in SSRSS that changes scansat, not sure.

It's probably an issue with one of those two mods anyways, not scansat itself

I haven't updated the game or any mods to 1.1.3 yet so that isn't it. I tried turning off the default scan setting and now scanning fully works for Phobos and Deimos so I'll just leave it like that. This issue is something to do with the default scanning system.

Share this post


Link to post
Share on other sites
On 30/6/2016 at 8:34 PM, DMagic said:

I don't know of anything that keeps track of your path on a map. It sounds like an interesting idea, though it might be complicated to actually implement.

I think the path-tracking is an accidental feature of how BTDT works.

Let me explain.

When I activate a BTDT scanner, and I have the SCANsat small map open, I can see the small map changes to a darker colour - except on those areas where BTDT has been activated before. You can see this by yourself, by activating a BTDT on any vessel while having the small map open.

On my mun circumnavigation, I activated BTDT at an anomaly and kept it activated, and for some reason the small map was "lighting up" wherever my rover went.

My guess is that SCANsat keeps a grid of scanned/unscanned bits for every body and type of scanner (radar, biome, SAR and BTDT), but the BTDT map is now really visible in the big map and cannot be exported.

@DMagic Is there any chance the "BTDT layer" could be exported, or viewed in the big map?

Share this post


Link to post
Share on other sites

Hi all,

 

My zoom map seems stuck in altimetry mode, when what I really want is biome.  It was working that way, but when I restarted the game and loaded a save, I don't see any way or controls to get the zoom map back to biome.  The large and small maps show biome data just fine.


What am I missing?

 

Cheers,

-BS

Share this post


Link to post
Share on other sites

@IvanSanchez That is sort-of a by product of the weird shading system used on the small map. It highlights areas of the map that have been scanned with your currently active scanners. So if only the BTDT is active you can end up with that kind of image. Something similar might be possible for the big map (and it would be east to export, since it directly alters the map's colors), I'll just have to see if there is a good way of adding that option.

@barfing_skull The zoom map can be re-synced to the settings of the big map by clicking on the zoom level indicator in the top-center of the window. Doing that will allow for using the biome or slope view, or using polar projection, it will also reset the planet to the one displayed on the big map. The KSPedia entry could probably use some info on how the zoom map works.

Share this post


Link to post
Share on other sites

Does anyone know if the M700 stock scanner is still bugged.  In past versions I couldn't get the resource data into the ScanSat system after running the survey with the stock scanner.  It would lose the data when I went back to the KSC, and wouldn't allow a rescan.

I'm about to send out a fleet of scanners and hope I have the ScanSat options set up correctly to get the data even if the M700 is still bugged.  I think it is instascan on, biome lock off, requires narrow band scanner off, and disable stock scanning.  Is that correct?

Thanks in advance.

Share this post


Link to post
Share on other sites

@Aethon I'm not sure about any stock scanner bugs, they shouldn't have anything to do with SCANsat.

There are descriptions of the resource scanning settings in the KSPedia entry, the settings window help tips, and the SCANsat wiki. If you don't want to interact with the stock scanning system just make sure that it is disabled (which will automatically disable the instant scan option, too). The biome lock and narrow band scanner requirement settings will adjust how much beyond simple orbital scans is required for fully accurate resource data.

Share this post


Link to post
Share on other sites

Heads up: Contract Configurator has just had a major overhaul, and all CP's need work to put them right. (It will basically work, but it's going to look strange).

I've just gone through the process on my other packs, but completely forgot about SSO - do you want me to work on it, or are you on top of it?

Share this post


Link to post
Share on other sites

Hi all,

While with an active vessel I can no longer get the big map.  The mini-map and zoom map are fine, and I can get the big map at the KSC, just not while with a vessel.  I've tried from different vessels around different parent bodies.  I've tried deleting and re-installing and am using the most recent version of SCANSat.  I've also tried opening the big map from Blitzy's Toolbar with the same result.  This started while in game.  I clicked on the big map and it disappeared, never to be seen again.

Any ideas?  Thanks.

Share this post


Link to post
Share on other sites

@LessrOf2Weevils Did the big map get dragged off screen? Try the Reset Window Position button in the settings window.

@severedsolo I haven't had a chance to look at what needs fixing. Is it just the way the names display because they don't have a target planet assigned that is a problem? If you could take a quick look that would be great, and I'll probably update soon with a few other fixes included.

Share this post


Link to post
Share on other sites
22 hours ago, DMagic said:

@LessrOf2Weevils Did the big map get dragged off screen? Try the Reset Window Position button in the settings window.

@severedsolo I haven't had a chance to look at what needs fixing. Is it just the way the names display because they don't have a target planet assigned that is a problem? If you could take a quick look that would be great, and I'll probably update soon with a few other fixes included.

That got it.  Thanks.  I must have missed that button.

Share this post


Link to post
Share on other sites

I've got a mystery but I don't know whose bug it is:

Mechjeb no longer gets the landing position from the ScanSat map.  This is very useful when you're trying to land on a flat spot in hilly terrain--you can't pause the game while picking the coordinate so it keeps moving due to the rotation of the body.  The ScanSat maps don't move, though, so you can carefully pick out a point without it's changing in a second.

Share this post


Link to post
Share on other sites
23 hours ago, DMagic said:

@severedsolo I haven't had a chance to look at what needs fixing. Is it just the way the names display because they don't have a target planet assigned that is a problem? If you could take a quick look that would be great, and I'll probably update soon with a few other fixes included.

I've sent you a PR, but basically - it was mostly a case of adding generic titles and specifying what to display when the player needs to see why the contract wasn't generating.

Share this post


Link to post
Share on other sites

Contract problem, I don't know if it's ScanSat or Contract Configurator or something else at fault:

Contract--do a biome scan of Minmus.  I've already done it, the bird is still in orbit, a piece of cake.  Fine.

Every time I hop to a bird and trigger the scanner it completes and a new contract takes it's place--for a biome scan of a body I have already visited.  The scanners are still in orbit.  Sometimes they're 1 star contracts, sometimes they are 3 star but they're all just grab the right bird, transmit data from the multispectral scanner and collect generally over 100k.

Share this post


Link to post
Share on other sites

i tried to search but could not find anything on the subject: Is there a way to alway use the full color spectrum of the RPM altimetry map, like it is done on the zoom map? I drive long trips in IVA view, and when I zoom in to a useful scale, the map is mostly just one color.

Share this post


Link to post
Share on other sites

@Freshmeat No, but that is something that should be relatively simple to add.

@severedsolo Thanks, I'll include those changes in the next update.

@Loren Pechtel Which version of MechJeb do you have? And is the option to use MechJeb integration available and selected in the Settings window? I'll have to look into contract issues, but duplicates may be a CC problem.

Share this post


Link to post
Share on other sites

Guys, minor question. When using the Big Map, I get resource concentrations in full percents. When using the Small Map, I don't get info at all. However, when displaying the map via the M700, I get a Small Map with data down to 0.01%.

Share this post


Link to post
Share on other sites

@DDE What are your SCANsat resource scanning options set to? Have you checked the KSPedia entry, or the SCANsat wiki? They both have lots of info about resource scanning.

Share this post


Link to post
Share on other sites
27 minutes ago, DMagic said:

@DDE What are your SCANsat resource scanning options set to? Have you checked the KSPedia entry, or the SCANsat wiki? They both have lots of info about resource scanning.

Biome lock yes, Instant resource scan no, Requires narrow band scanner yes, Disable stock scanning yes, Stock scan threshold yes 90%.

Share this post


Link to post
Share on other sites

Your wiki appears to have become significantly easier to understand since I last checked it.

Slap me.

However, why did you unlink the resource selection on the Big Map and the Small Map?

 

Share this post


Link to post
Share on other sites

@DDE Not sure what you mean by unlinking the two maps. Both have resource selection menus.

The different rules are there because the small map has a more accurate representation of the resource distribution and allows for essentially unlimited zoom in.

Share this post


Link to post
Share on other sites

Hey,

I was wondering how long is it supposed to take for the entire map to load, and is there a way to change it.  It takes a long time to draw the entire map every time I want to look at one thing, and in videos that I watched, it seems to load much faster sometimes.

Thanks.

Share this post


Link to post
Share on other sites

I always use SCANSat, but I am too lazy to set up sattelite networks and to map every planet. Is it possible to download planetary maps and data so that you can start out with the full maps loaded?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.