pingopete

[WIP][1.0.5]* RSS Visual Enhancements (RVE)

Realistically what would you prefer in RVE? -- choose one from each letter  

1,982 members have voted

  1. 1. Realistically what would you prefer in RVE? -- choose one from each letter

    • A) 1 main cloud layer, 1 cirrus layer (Medium/Compromise)
    • A) Low, Medium, High cloud layers (Heavy/Realistic)
    • B) Detail bias towards Land/Atmosphere visuals
    • B) Detail bias towards Orbit/Space visuals
    • C) Realism
    • C) Detail
    • C) CPU accessibility


Recommended Posts

On May 8, 2016 at 7:28 PM, Blacks said:

 

Download this & see if it will fix your problem, from picture what you post it look like you try to use last new Eve release what is not anymore compatible with any old visual pack because new system what it use = new cubemap texture

https://github.com/rbray89/EnvironmentalVisualEnhancements/blob/cbceb3b052ae73f9f9bb1dd12e045d814ac10188/AnyCPU-EVE.zip

Enjoy

I did what you did, it worked. Great.

Problem: my game has really crappy FPS. With 16GB RAM and 5.0GHz. Aaaand everything on lowest graphic settings.

Help?

Share this post


Link to post
Share on other sites
6 hours ago, Belerafon said:

I did what you did, it worked. Great.

Problem: my game has really crappy FPS. With 16GB RAM and 5.0GHz. Aaaand everything on lowest graphic settings.

Help?

How many mods you got running? They slowly bring down the fps, especially large part mods 

Share this post


Link to post
Share on other sites

I followed the instructions posted by @Blacks, But after loading the game the clouds are only on the top half of kerbin. I cant show a screenshot but It looked like my planet was in half and only the top half was with nice clouds and the way it should be on the whole planet. 

 

I am running ksp 1.1.2 on win10 x64 with 16gb of ram. 

Share this post


Link to post
Share on other sites
38 minutes ago, moepkid said:

I followed the instructions posted by @Blacks, But after loading the game the clouds are only on the top half of kerbin. I cant show a screenshot but It looked like my planet was in half and only the top half was with nice clouds and the way it should be on the whole planet. 

 

I am running ksp 1.1.2 on win10 x64 with 16gb of ram. 

Do you mean on the startup menu? That always happens, it should be fine in-game.

Share this post


Link to post
Share on other sites
55 minutes ago, moepkid said:

I followed the instructions posted by @Blacks, But after loading the game the clouds are only on the top half of kerbin. I cant show a screenshot but It looked like my planet was in half and only the top half was with nice clouds and the way it should be on the whole planet. 

 

I am running ksp 1.1.2 on win10 x64 with 16gb of ram. 

If you're speaking about the Opening Menu Screen, don't worry. Happens sometimes, it's working in flight.

Share this post


Link to post
Share on other sites

Thanks people! I just wasnt looking good enough. I restarted the game and now ingame it also works :D

Share this post


Link to post
Share on other sites
5 hours ago, StallionHurdler said:

I got it working on win 64 on 1.1.2 while in space but when at the cape all the way up to 139.99km I have no ocean. Anybody know why?

I used the scatterer configs and it works.

Share this post


Link to post
Share on other sites
Just now, StallionHurdler said:

@Epoxide the rve scatter configs or just the configs that come with scatter?

the configs that come with scatterer, I did everything that's explained in the scatterer OP

Share this post


Link to post
Share on other sites
15 hours ago, pingopete said:

How many mods you got running? They slowly bring down the fps, especially large part mods 

None.

EDIT: When are you gonna release the new version for 1.1.2?

Edited by Belerafon

Share this post


Link to post
Share on other sites

How can I only get the clouds? (Sadly my pc doesn't allow more :( )

Thanks

Share this post


Link to post
Share on other sites
On 5/4/2016 at 7:54 AM, Rhavoreth said:

Make sure you install the latest version of scatterer and EVE first. You'll need V0.0244 of Scatterer and when you get EVE make sure you get the 'AnyCPU-EVE-Release.zip' version of EVE. You don't need the configs, that is what RVE does :). For reference you can get both of them here:

Scatterer: http://spacedock.info/mod/141/scatterer

EVE: https://github.com/rbray89/EnvironmentalVisualEnhancements/releases/tag/EVE-1.1-1

 

Next, install both of those as normal. What you need to do now is find the RVE release with scatterer configs included. I use the latest linux 64 version found

here: https://github.com/Pingopete/RVE-KSP-1.0.4/tree/Linux64/

 

Drop the scatterer folder into the GameData, remember to copy and replace your 'planetsList.cfg'. Then drop the RVE folder into your GameData; this folder is the eve configs you'll need for it to work. Everything should work out of the box like that. No need to use Alt + 0 for anything. Just head to the tracking station to see if you've got clouds on Earth. I installed RSS using CKAN, EVE and Scatterer will have to be installed manually.

Thank you so much for this Rhavoreth!!! Finally got clouds in RSS + KSP(1.1.2). Just tested and I see the clouds. Not sure if I would run into issues later but for now it appears to be working. Thanks again!

Share this post


Link to post
Share on other sites

Interesting.

I was not sure but from my point of view as in Earth orbit looking at the sun it seems a little - small...

Perhaps you're right.

Share this post


Link to post
Share on other sites

People reading back and seeing that you can in fact get it to work in KSP 1.1.2 would be lovely.

(Literally, someone has quoted it 4 posts above mine)

Share this post


Link to post
Share on other sites
8 hours ago, MrMeeb said:

People reading back and seeing that you can in fact get it to work in KSP 1.1.2 would be lovely.

(Literally, someone has quoted it 4 posts above mine)

It is funny how some people aren't willing to spend 30 seconds of there own time finding the answer they want yet are willing to spend more time complaining about a free mod not being released as soon as they'd like.. Lol

Share this post


Link to post
Share on other sites
7 minutes ago, pingopete said:

It is funny how some people aren't willing to spend 30 seconds of there own time finding the answer they want yet are willing to spend more time complaining about a free mod not being released as soon as they'd like.. Lol

gladly - and not to be forgotten - there are still plenty of us who fully acknowledge the effort and time you put into this and keep rooting for you every day!!! :D

good things come for those who wait!!!!

Share this post


Link to post
Share on other sites

Untitled.jpg

This below me is the Atlantic. Water renders transparent but is there, splash-able.

Any of you experienced this before?

1.1.2 using the right versions of EVE and Scatterer as mentioned in a post by  Rhavoreth

Share this post


Link to post
Share on other sites

i didn't mean to be rude, sorry :(

i was literally just saying a 1.1.2 update would be nice to have, i wasn't trying to complain about it. i really am sorry, i didnt mean to do anything wrong.

Edited by lolcats121

Share this post


Link to post
Share on other sites

I'm confused.

Here

it says

Quote

-Shaders are messed up in directx11, If you're forcing directx11, your game will crash on load (64bit build) or will load without any effects (32bit build).

 

but here it says

and finally this

So does it mean if I only remove scatterer and live without clouds I could have DirectX11, less memory footprint, more fps, all together?

I should try it.

I hope that only scatterer is to be removed.
I would prefer it to remove another mod, but in kerbalism nothing is perfect and it needs years to become so.

Share this post


Link to post
Share on other sites
On 5/4/2016 at 10:54 AM, Rhavoreth said:

Make sure you install the latest version of scatterer and EVE first. You'll need V0.0244 of Scatterer and when you get EVE make sure you get the 'AnyCPU-EVE-Release.zip' version of EVE. You don't need the configs, that is what RVE does :). For reference you can get both of them here:

Scatterer: http://spacedock.info/mod/141/scatterer

EVE: https://github.com/rbray89/EnvironmentalVisualEnhancements/releases/tag/EVE-1.1-1

 

Next, install both of those as normal. What you need to do now is find the RVE release with scatterer configs included. I use the latest linux 64 version found

here: https://github.com/Pingopete/RVE-KSP-1.0.4/tree/Linux64/

 

Drop the scatterer folder into the GameData, remember to copy and replace your 'planetsList.cfg'. Then drop the RVE folder into your GameData; this folder is the eve configs you'll need for it to work. Everything should work out of the box like that. No need to use Alt + 0 for anything. Just head to the tracking station to see if you've got clouds on Earth. I installed RSS using CKAN, EVE and Scatterer will have to be installed manually.

 

Question about the RVE folder. I like to use a custom sunflare built for scatterer. Do I still need to include the sunflare folder include in this version of RVE?

Edit: Nevermind, it seems scatter's sun flare supersedes whatever changes this version of RVE does to the stock sun flare. Completely loaded with RP-0, RO, RSS, and too many other mods to count and the game is looking beautiful. Even added a little atmosphere to earth at 130Km to make it a little more authentic. Can't wait to dive into my realism career tomorrow. All I did was go to the tracking station, check through in-game tool that all planets were looking/working as intended, making a few adjustments here and there (seems to be an issue with planet shadows with RVE and SVE, I've had to disable them entirely in a few cases because they just leave a block spot on certain planets) but besides that, amazing stuff.

Edited by shoe7ess

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.