Jump to content

[1.4] SpaceY Heavy-Lifter Parts Pack v1.17.1 (2018-04-02)


Recommended Posts

3 minutes ago, Kerbas_ad_astra said:

Two oopses -- first is that the SRB625 "Thumper" is from SSR MicroSat, not SpaceY (though the naming convention tripped me up).  Secondly, the Hound (which does lack the name in its part tags) is in MRS, not SpaceY.

 

LOL, that explains things. I just thought you were mentioning the Thumper as an external example. :wink:  I'll take a look at MRS. :D

 

Link to post
Share on other sites

 

Updated:

 

1.12.8 (2016-05-31) - Tweaks.
 - Adjusted some nickname tags on engines.
 - Minor tech tree and config changes in MM patches. Partly for better compatibility with Real Scale Boosters.
 - Non-CTT tech nodes are now added, even if CommunityTechTree is installed.
 - Gigantic Rocketry node internally renamed to match CTT. May have to re-unlock if you don't use CTT.

1.12.9 (2016-05-31) - Hotfix.
 - Massive Rocketry/Structure tech nodes are now set to be hidden if empty.
 - Fixed a harmless mistake in the MM patches, as part of its self cleanup.

 

 

Link to post
Share on other sites

I don't know, if this is where I should post for this issue, as this is my first post.. I have tried searching for any answers to this issue on this form and elsewhere.. 

I am in a career, and during that career I had a Contract that had to do with SpaceY SRB S115. During that Contract, I used the SRB S115 on a Large Tourist Orbital Vehicle. I saved that vehicle, knowing I could not use it, until I fully unlocked and purchased that particular part. When I finally did Research the parts section, containing the S115, and purchased it, I have noticed it is still not showing in the career I did this on. I dont know if this is a bug, related to KSP or the Mod itself, or more over, if it is being effected by other mods I may be using, as I am using the Community Tech Tree mod.. I will list all my mods I am currently running, just in case.. But, I just wanted to bring this bug into light, as to help prevent or gather more info as to what may be causing this issue.. I still need to check my other careers to see if this part is still accessible in general, in the ones I have it unlocked in, just to be sure this bug is only effecting this particular Career.. Thank you for your work as I truly enjoy using your SpaceY parts.. :-) 

Mods I am Using:

KSP: 1.1.2 (Win64) - Unity: 5.2.4f1 - OS: Windows 7 Service Pack 1 (6.1.7601) 64bit
WildBlueTools - 1.1.5
Filter Extensions - 2.6
Toolbar - 1.7.12
USI Tools - 0.7.2.1
B9 Part Switch - 1.3
Buffalo - 0.2.10
Chatterer - 0.9.8.1230
Color Coded Canisters - 1.4.8
Community Resource Pack - 0.5.2
CryoEngines - 0.3.2
Firespitter - 7.2.4
Fuel Tanks Plus - 1.9.3
Interstellar Fuel Switch - 2.0.7
Kerbal Attachment System - 0.5.7
Kerbal Inventory System - 1.2.10
KSP-AVC Plugin - 1.1.6.1
Lithobrake Exploration Technologies - 0.3.5
Modular Rocket Systems - 1.12.7
NearFutureConstruction - 0.6.3
NearFutureElectrical - 0.7.4
NearFuturePropulsion - 0.7.2
NearFutureSolar - 0.6.1
NearFutureSpacecraft - 0.5
PlanetShine - 0.2.5
RCS Sounds - 5.0
SpaceY Expanded - 1.1.9
SpaceY Lifters - 1.12.9
TextureReplacer - 2.4.13
TweakScale - 2.2.12
USI Core - 0.2.3
Karbonite Plus - 0.6.3
Karibou - 0.2.3
Kolonization Core - 0.2.3.1
USI-LS - 0.4.3.1
Sounding Rockets - 0.4.3
USI Survivability Pack - 0.5.1
UKS - 0.40.3
USI Alcubierre Drive - 0.4.3
Universal Storage - 1.1.0.11
KSP Interstellar Extended - 1.8.22
WildBlueTools - 1.2.5

Link to post
Share on other sites

Small request: On the 1x 2.5m to 1x1.25m+8x0.25m adaptor, please make the 2.5m node and the center 1.25m node both Connected Living Spaces passable, and please make the center 1.25m nodes in the 3.75m to 5x1.25m and 3.75m to 7x1.25m nodes also CLS passable. If you can also make the center 2.5m node in the 5m to 1x2.5m+8x1.25m adaptor also passable, those are spots I like to put an aft docking-port..

Link to post
Share on other sites
14 hours ago, PCkarma112 said:

I don't know, if this is where I should post for this issue, as this is my first post.. I have tried searching for any answers to this issue on this form and elsewhere.. 

I am in a career, and during that career I had a Contract that had to do with SpaceY SRB S115. During that Contract, I used the SRB S115 on a Large Tourist Orbital Vehicle. I saved that vehicle, knowing I could not use it, until I fully unlocked and purchased that particular part. When I finally did Research the parts section, containing the S115, and purchased it, I have noticed it is still not showing in the career I did this on. I dont know if this is a bug, related to KSP or the Mod itself, or more over, if it is being effected by other mods I may be using, as I am using the Community Tech Tree mod.. I will list all my mods I am currently running, just in case.. But, I just wanted to bring this bug into light, as to help prevent or gather more info as to what may be causing this issue.. I still need to check my other careers to see if this part is still accessible in general, in the ones I have it unlocked in, just to be sure this bug is only effecting this particular Career.. Thank you for your work as I truly enjoy using your SpaceY parts.. :-) 

 

 

Huh, I'm not sure what could cause that. If it's listed in that tech node, it should be available when the node is unlocked. Can you double-check that the tech node is actually still unlocked? I made a change this week to how the nodes are created, but if you're using CTT it shouldn't make a difference.

 

11 hours ago, StevieC said:

Small request: On the 1x 2.5m to 1x1.25m+8x0.25m adaptor, please make the 2.5m node and the center 1.25m node both Connected Living Spaces passable, and please make the center 1.25m nodes in the 3.75m to 5x1.25m and 3.75m to 7x1.25m nodes also CLS passable. If you can also make the center 2.5m node in the 5m to 1x2.5m+8x1.25m adaptor also passable, those are spots I like to put an aft docking-port..

 

I'm going to mark all of the thrust plates and adapters as passable so that they can be used for station construction and the like. Good idea. Thanks :)

 

2 hours ago, lennie said:

Can the dockings port in this mod be used to dock whit another size? like the 5m docking port can dock whit 3,5m docking port?

 

Nope, they're configured to only be compatible with their own size.

 

Link to post
Share on other sites

Yes sir, I triple checked.. Part is Unlocked and Purchased (or atleast it def. it shows it too be) I personally think it has something to with how I used the part before it was fully unlocked and purchase, because I got that contract for the part, and while i had the part available through the contract I used it build and save a rocket.. But, ya it is def. odd.. Hehe..

Link to post
Share on other sites
16 hours ago, PCkarma112 said:

Yes sir, I triple checked.. Part is Unlocked and Purchased (or atleast it def. it shows it too be) I personally think it has something to with how I used the part before it was fully unlocked and purchase, because I got that contract for the part, and while i had the part available through the contract I used it build and save a rocket.. But, ya it is def. odd.. Hehe..

 

Strange. No idea why that would happen.

 

 

15 hours ago, Grimbal said:

How can I stop duplicate tabs of SpaceY appearing in my toolbar each time I load the game?

 

 

I'm assuming you mean the custom part's list tab in the VAB? If you accidentally save it after looking at it, a copy is made in your save, so you'll see that one and the one that SpaceY provides. You can delete either one. If you want to get rid of the one in SpaceY, the file is located at GameData/SpaceY-Lifters/Category/CustomCategory.cfg.

 

 

Link to post
Share on other sites

 

Updated:

 

1.13 (2016-06-08) - Update.
 - Adapters and Thrust Plates marked as passable for Connected Living Space so that they can be used for station construction, and docking ports, etc.
 - Added 5m/3.75m conical payload bay.
 - Adjusted the "hide if empty" rules for the tech nodes.

 

 

Link to post
Share on other sites
  • 2 weeks later...

Two three suggestions: First, rename the two "Rose" adaptor-plates (1x2.5m to 1x1.25m+8x0.625m, and 1x5m to 1x2.5m+8x1.25m) as "Rosette", second, give the "Rose" name to a 3.75m to 1x2.5m+12x0.625m adaptor-plate, and third, name the 3.75m to 7x1.25m adaptor-plate the "Honeycomb"

Edited by StevieC
Added name suggestion for the 3.75m-7x1.25m adaptor
Link to post
Share on other sites

@NecroBones,

I'm using SpaceY v1.11.2 on KSP 1.0.5 (I have my reasons, and never used 1.0.5 much, stuck with 1.0.4) and am getting a weird issue with the SpaceY custom category--the icon gets added everytime I start KSP, even if there is aleady one there. When I saw two of the icons I deleted them, but they kept reappearing.  So next I deleted the custom category folder from SpaceY (I use my own custom categories anyway), and the icon STILL keeps appearing.  If this has been already discussed before, just point me to it. :)

Thanks.

Link to post
Share on other sites
Just now, Laguna said:

@NecroBones,

I'm using SpaceY v1.11.2 on KSP 1.0.5 (I have my reasons, and never used 1.0.5 much, stuck with 1.0.4) and am getting a weird issue with the SpaceY custom category--the icon gets added everytime I start KSP, even if there is aleady one there. When I saw two of the icons I deleted them, but they kept reappearing.  So next I deleted the custom category folder from SpaceY (I use my own custom categories anyway), and the icon STILL keeps appearing.  If this has been already discussed before, just point me to it. :)

Thanks.

 

Strange. If you've deleted that, it shouldn't be able to re-add at all. If you get rid of the "GameData/SpaceY/Category" folder altogether, it should solve it. If not, then all I can think of is that it still exists as a saved copy in KSP. For that you'll have to take a look in "GameData/Squad/PartList/PartCategories.cfg".

Link to post
Share on other sites
20 minutes ago, NecroBones said:

 

Strange. If you've deleted that, it shouldn't be able to re-add at all. If you get rid of the "GameData/SpaceY/Category" folder altogether, it should solve it. If not, then all I can think of is that it still exists as a saved copy in KSP. For that you'll have to take a look in "GameData/Squad/PartList/PartCategories.cfg".

After the last in-game deletion of the icon, there's no longer a SpaceY category in the PartCategories config.  Haven't restarted KSP yet, so I may just delete the whole folder from SpaceY.

Link to post
Share on other sites

Possible bug: The RCS 5x7 thruster blocks don't respect the "Fore by throttle = OFF" setting. They always are hooked to the throttle and activate whenever the throttle is > 0%,
which make the Monopropellant tank emptying fast, if RCS is enabled while the main engine is being used.
I didn't test this with the other RCS blocks, but I guess it's the same for them.

Edited by Cairol
Link to post
Share on other sites
On 6/26/2016 at 9:48 AM, Cairol said:

Possible bug: The RCS 5x7 thruster blocks don't respect the "Fore by throttle = OFF" setting. They always are hooked to the throttle and activate whenever the throttle is > 0%,
which make the Monopropellant tank emptying fast, if RCS is enabled while the main engine is being used.
I didn't test this with the other RCS blocks, but I guess it's the same for them.

 

Not sure I fully understand the problem. The engine and RCS components of the combined OMS units should function independently, and if they're not, then you probably have a separate mod interfering with it.

 

Link to post
Share on other sites
1 hour ago, NecroBones said:

 

Not sure I fully understand the problem. The engine and RCS components of the combined OMS units should function independently, and if they're not, then you probably have a separate mod interfering with it.

 

I found the culprit.
As soon as I add the MechJeb control part (this walky-talky thingie) onto my vessel, all RCS ports start to react to the throttle control in the usual direction of an engine.
I'll report this in the MechJeb thread then. Nevermind. ^_^

EDIT: It's actually not a bug, but a feature of MechJeb I didn't know about.
In the "Smart RCS" menu there is an option "RCS throttle when engines are offline" which is by default active. Must be new...

Edited by Cairol
Link to post
Share on other sites

Quick question, I just started playing KSP again from 1.05, now I've updated this mod to 1.1.3 per new version. So in 1.05 I could remove the base of the engine, now in 1.1.3 it is not working.

I tested it using stock KSP with only this mod. So i don't no if this was intentional or not. 

Thanks for the amazing mod btw!

Link to post
Share on other sites
6 minutes ago, manatee321 said:

Quick question, I just started playing KSP again from 1.05, now I've updated this mod to 1.1.3 per new version. So in 1.05 I could remove the base of the engine, now in 1.1.3 it is not working.

I tested it using stock KSP with only this mod. So i don't no if this was intentional or not. 

Thanks for the amazing mod btw!

 

Glad you like it. :) Yeah, you'll need to install Firespitter or InterstellarFuelSwitch to enable the engine tweakables. Mesh-switching isn't supported directly in the stock game.

 

Link to post
Share on other sites

I haven't unlocked most of the parts yet but I've found one I love--the separator nosecones.  They're so much easier to handle than separatrons.  However, I play with Stage Recovery and normally put chutes on my boosters--the biggest chutes go on top.  Thus I am hoping for a version of the separators that is a flat disc, the same ease of placement while allowing a chute on top of them.

Link to post
Share on other sites
7 hours ago, Loren Pechtel said:

I haven't unlocked most of the parts yet but I've found one I love--the separator nosecones.  They're so much easier to handle than separatrons.  However, I play with Stage Recovery and normally put chutes on my boosters--the biggest chutes go on top.  Thus I am hoping for a version of the separators that is a flat disc, the same ease of placement while allowing a chute on top of them.

 

Huh, interesting idea. I could see that being useful!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...