JPLRepo

[1.3.0] ResearchBodies V1.9.3 (15th July 2017)

369 posts in this topic

Posted (edited)

Hi @JPLRepo,

Thanks so much for making this mod! I appreciate you taking the time to do this.

I'm not sure if I'm doing something wrong or if this is a bug, but I can't seem to further research any celestial bodies. I've managed to discover most of them with the telescope, which I know only discovers the bodies, but I cant accept a contract to use the telescope to research the bodies because it says in the contract  "The Observatory must be level 1: Unmet" even though the observatory is level 1 (I also tried upgrading it to level 2 to see if that solves the issue which it did not.)

I tried researching a planet in the observatory but the research plan has been at 10% and has not budged. I'm playing on career mode, 1.3, and I updated to your latest version of Research Bodies 1.9.3.

EDIT: I also noticed that another part of the contract seems odd: "There must be Bodies yet to have their research completed that are within range of a Telescope: Unmet." 

Edited by t rock

Share this post


Link to post
Share on other sites
3 hours ago, t rock said:

Hi @JPLRepo,

Thanks so much for making this mod! I appreciate you taking the time to do this.

I'm not sure if I'm doing something wrong or if this is a bug, but I can't seem to further research any celestial bodies. I've managed to discover most of them with the telescope, which I know only discovers the bodies, but I cant accept a contract to use the telescope to research the bodies because it says in the contract  "The Observatory must be level 1: Unmet" even though the observatory is level 1 (I also tried upgrading it to level 2 to see if that solves the issue which it did not.)

I tried researching a planet in the observatory but the research plan has been at 10% and has not budged. I'm playing on career mode, 1.3, and I updated to your latest version of Research Bodies 1.9.3.

EDIT: I also noticed that another part of the contract seems odd: "There must be Bodies yet to have their research completed that are within range of a Telescope: Unmet." 

You have to upgrade the Tracking Station to Level 2 before the Observatory will work.
Once you discover a body. Start a research plan and upgrade the TS to level 2.
Then the contracts will work.

Share this post


Link to post
Share on other sites
6 minutes ago, JPLRepo said:

You have to upgrade the Tracking Station to Level 2 before the Observatory will work.
Once you discover a body. Start a research plan and upgrade the TS to level 2.
Then the contracts will work.

Yeah the tracking station is already level 2 (upgrading to level 3 didn't help.) I have access to the Observatory and can start research projects there, but once started they just sit at 10% and the only option given is to stop the research project which sets it back to 0%.

I suppose I could research all the planets just by accepting contracts to research a body, but that takes a long time and would be very expensive to do 10x times per planet since each contract just bumps up the research completion by 10%. I assume that I can eventually accept a contract so I can use my telescope to research the planets, but I either haven't figure that out yet or it doesn't seem to be working.

Share this post


Link to post
Share on other sites
5 hours ago, t rock said:

Yeah the tracking station is already level 2 (upgrading to level 3 didn't help.) I have access to the Observatory and can start research projects there, but once started they just sit at 10% and the only option given is to stop the research project which sets it back to 0%.

I suppose I could research all the planets just by accepting contracts to research a body, but that takes a long time and would be very expensive to do 10x times per planet since each contract just bumps up the research completion by 10%. I assume that I can eventually accept a contract so I can use my telescope to research the planets, but I either haven't figure that out yet or it doesn't seem to be working.

That's the idea... Research doesn't happen in an instant.
You either have to do the contracts in the observatory or contracts using the telescope (which are quicker).
Upgrading the Observatory also means they can research bodies further away, and research contracts are faster (90 days each).

Sounds like I haven't made it clear about the contracts - and they are a work in progress and I plan to expand them to more interesting ones.
But to get a research a body contract with a telescope you first have to have one in orbit. The initial orbit has to be > 200000km.
The contract should show this info.. the contracts will require you to reposition the telescope each time.

Share this post


Link to post
Share on other sites

Posted (edited)

23 hours ago, JPLRepo said:

That's the idea... Research doesn't happen in an instant.
You either have to do the contracts in the observatory or contracts using the telescope (which are quicker).
Upgrading the Observatory also means they can research bodies further away, and research contracts are faster (90 days each).

Sounds like I haven't made it clear about the contracts - and they are a work in progress and I plan to expand them to more interesting ones.
But to get a research a body contract with a telescope you first have to have one in orbit. The initial orbit has to be > 200000km.
The contract should show this info.. the contracts will require you to reposition the telescope each time.

Right, I understand that part. Maybe I'm not explaining my problem well. :/ Basically I want to use my telescope, that's already in orbit >200000km, to further research already discovered celestial bodies (by pointing the telescope at them and clicking "Track Bodies" a few times) so I can go to them. The contract for this is grayed out because there are two "Unmet" conditions: "The Observatory must be level 1: Unmet" and "There must be Bodies yet to have their research completed that are within range of a Telescope: Unmet." But I definitely do have a level 1 observatory and I haven't completed research on any new bodies, let alone all of them...

I have a bunch of other mods installed, including the New Horizons planet pack, but they all seem to be playing nicely with each other so I'm not sure that this is a mod conflict issue.

EDIT: I tried to recreate the problem in sandbox mode, which didn't entirely work because of the whole no contracts thing, but I did notice something: Once I discovered a body I could start a research plan for it (just like I was able to before) and underneath the button I clicked to start the research plan was another button that allowed me to Research: Aspect. After clicking that a couple of times I could research the orbit and characteristics by clicking another button. Neither of these buttons showed up in my career save. (I also still couldn't use my telescope in sandbox mode to do what clicking the buttons in the observatory did, but that's probably tied to the contracts.)

Edited by t rock

Share this post


Link to post
Share on other sites

Sorry if this got answered earlier in the thread and I missed it.  Is there a way to add this to an existing save, or would I have to start an entirely new save to use this?  This does look really interesting.  Thanks

Share this post


Link to post
Share on other sites
1 hour ago, Lone Star said:

Sorry if this got answered earlier in the thread and I missed it.  Is there a way to add this to an existing save, or would I have to start an entirely new save to use this?  This does look really interesting.  Thanks

See the change log in the OP. The latest version 1.9.3 does this.. Kinda.

Share this post


Link to post
Share on other sites
2 hours ago, JPLRepo said:

See the change log in the OP. The latest version 1.9.3 does this.. Kinda.

But work this with bug in Tracking Station.

Share this post


Link to post
Share on other sites
5 minutes ago, nickicool said:

But work this with bug in Tracking Station.

I think you are trying to say you think there is a bug? with loading a save game (from before installing this mod) and in the tracking station the bodies appear.. just with no orbits, etc.
Have you tried again with version 1.9.3 because I made some changes since your first post about this.

Share this post


Link to post
Share on other sites

Posted (edited)

Yes my friend - i try install 1.9.3 (manualy delete previous version)!

I start new carieer, without ReserchBodies (but with Outer Planet Mod). After few days you released update mod 1.9.3, and I decided to try again, especially given the fact that there is no need to start a new game. I made a backup of the saves and installed the updated mod from CKAN (especially the checked out version was 1.9.3.) The logs and the save file I posted above in the topic.

On 14 page, last message.

Edited by nickicool

Share this post


Link to post
Share on other sites

Posted (edited)

Edit 3: Bug solved, see problem below.

After looking at the output_log and seeing a bunch of errors between Rsearch Bodies and Contract Configurator, it turned out to be a problem with the CKAN install. CKAN installs only the ResearchBodies folder from your REPOSoftTech folder. Doing a manual install solved the problem. The observatory model is friggin cute:sticktongue:

I will take the problem over to the CKAN people.

I had also noticed that undiscovered planets were not grey blobs, but after the manual install they are now grey as advertised. Neat mod!


Any reason why I wouldn't see the observatory model? I have the three model files in GameData/ResearchBodies/Assets. This is in sandbox mode, but it didn't seem to work in career mode too after I cheated some money and upgraded the tracking center first and then the observatory, as a test.

No other mods besides ContractConfigurator and MM are installed. Here's the output log (dropbox link).

Edit: Sorry, here is RB's log too! (dropbox link)

Edit 2: I enabled Extra Debug Logging, so here are the new logs (output_log, ReasearchBodies)

GK6n8f7.png

Zgt1Vyz.png

Edited by ev0
Solved

Share this post


Link to post
Share on other sites
1 hour ago, ev0 said:

Bug solved, see problem below.

After looking at the output_log and seeing a bunch of errors between Rsearch bodies and Contract Configurator, it turned out to be a problem with the CKAN install. CKAN installs only the ResearchBodies folder from your REPOSoftTech folder. Doing a manual install solved the problem. The observatory model is friggin cute:sticktongue:

I will take the problem over to the CKAN people.

I had also noticed that undiscovered planets were not grey blobs, but after the manual install they are now grey as advertised. Neat mod!

 


Any reason why I wouldn't see the observatory model? I have the three model files in GameData/ResearchBodies/Assets. This is in sandbox mode, but it didn't seem to work in career mode too after I cheated some money and upgraded the tracking center first and then the observatory, as a test.

No other mods besides ContractConfigurator and MM are installed. Here's the output log (dropbox link).

Edit: Sorry, here is RB's log too! (dropbox link)

Edit 2: I enabled Extra Debug Logging, so here are the new logs (output_log, ReasearchBodies)

 

Because I can see in your log:

Quote
Spoiler

7/18/2017 11:09:32 PM,ResearchBodies,Failed to Load Observatory Level1 Prefab Model
7/18/2017 11:09:32 PM,ResearchBodies,Failed to Load Observatory Level2 Prefab Model

And you have lots of Contract Configurator errors as well
 

Spoiler

ArgumentException: 'REPOSoftTech' is not a valid agent.
  at ContractConfigurator.ConfigNodeUtil.ParseAgentValue (System.String name) [0x00000] in <filename unknown>:0
  at ContractConfigurator.ConfigNodeUtil.ParseSingleValue[Agent] (System.String key, System.String stringValue, Boolean allowExpression) [0x00000] in <filename unknown>:0
  at ContractConfigurator.ConfigNodeUtil.ParseValue[Agent] (.ConfigNode configNode, System.String key, Boolean allowExpression) [0x00000] in <filename unknown>:0
  at ContractConfigurator.ConfigNodeUtil.ParseValue[Agent] (.ConfigNode configNode, System.String key, System.Action`1 setter, IContractConfiguratorFactory obj, Contracts.Agents.Agent defaultValue, System.Func`2 validation) [0x00000] in <filename unknown>:0
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

ArgumentException: No contract group with name 'ResearchBodies'
  at ContractConfigurator.ConfigNodeUtil.ParseSingleValue[ContractGroup] (System.String key, System.String stringValue, Boolean allowExpression) [0x00000] in <filename unknown>:0
  at ContractConfigurator.ConfigNodeUtil.ParseValue[ContractGroup] (.ConfigNode configNode, System.String key, Boolean allowExpression) [0x00000] in <filename unknown>:0
  at ContractConfigurator.ConfigNodeUtil.ParseValue[ContractGroup] (.ConfigNode configNode, System.String key, System.Action`1 setter, IContractConfiguratorFactory obj, ContractConfigurator.ContractGroup defaultValue, System.Func`2 validation) [0x00000] in <filename unknown>:0
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)


 

and the reason for all this is right here:
Non platform assembly: xxxxxxxx\GameData\ResearchBodies\Plugins\ResearchBodies.dll (this message is harmless)

You moved the folder that ResearchBodies is meant to be installed in.
Please don't..... you will break mods as they expect to be in a certain folder.
In this case ResearchBodies should be where it installs to if you unzip the mod as is (IE): \GameData\REPOSoftTech\ResearchBodies
This is why: a) the models don't load, b) Contract Configurator can't find it.. c) the mod doesn't work.

[EDIT] this is also why the greyed out bodies doesn't work.. because there should be a folder called \GameData\REPOSoftTech\ProgressiveCBMaps
Which I don't see in your log at all.. so you deleted it?

 

[EDIT2]

So I also see on the CKAN site that user @ev0 says CKAN is doing this...
Yeah, so here's the tip. I don't support installs done via CKAN.
Please install the mod as per the instructions in the OP.
I used to have that text really big and in red so people wouldn't miss it... and I scaled it  down.. maybe I have to make it big and red again.

Share this post


Link to post
Share on other sites
10 minutes ago, JPLRepo said:

So I also see on the CKAN site that user @ev0 says CKAN is doing this...
Yeah, so here's the tip. I don't support installs done via CKAN.
Please install the mod as per the instructions in the OP.
I used to have that text really big and in red so people wouldn't miss it... and I scaled it  down.. maybe I have to make it big and red again.

Yeah, sorry about that. I noticed it was a CKAN problem only after I posted the bug, but probably not fast enough for you to see the edit where I moved the problem over the CKAN people. Cheers!

Share this post


Link to post
Share on other sites

First, after few tests have determined that the bug I was talking about earlier, appears when the installation of CKAN: it installs the mod in \GameData\ResearchBodies instead of manual install in the \GameData\REPOSoftTech\ResearchBodies. If you don't want to support users CKAN - delete mod from the repository CKAN. I always have previously installed your mod from CKAN so were the bugs I described above.

Second, if install your mod, the mod/patch CustomBarnKit and CustomBarnKit(SETIconfig) is not working. I think your mod or overwrite their configs. Therefore, while installing your mod won't because CustomBarnKit(SETIconfig) makes an important for my game changes in the cost and number of upgrades. I'll be waiting.

Share this post


Link to post
Share on other sites
4 hours ago, nickicool said:

First, after few tests have determined that the bug I was talking about earlier, appears when the installation of CKAN: it installs the mod in \GameData\ResearchBodies instead of manual install in the \GameData\REPOSoftTech\ResearchBodies. If you don't want to support users CKAN - delete mod from the repository CKAN. I always have previously installed your mod from CKAN so were the bugs I described above.

Second, if install your mod, the mod/patch CustomBarnKit and CustomBarnKit(SETIconfig) is not working. I think your mod or overwrite their configs. Therefore, while installing your mod won't because CustomBarnKit(SETIconfig) makes an important for my game changes in the cost and number of upgrades. I'll be waiting.

1) - I never added my mod to CKAN., Thanks. I have no intention of deleting it as I never added it. Not my responsibility. CKAN is a mod I have nothing to do with.

2) - So there is an incompatibility here with another mod? See OP - No logs = No support.

1 person likes this

Share this post


Link to post
Share on other sites

How are other contract packs regarding other celestial bodies affected? Will they still pop up or are they postponed?

Share this post


Link to post
Share on other sites
On 7/16/2017 at 10:28 PM, t rock said:

Right, I understand that part. Maybe I'm not explaining my problem well. :/ Basically I want to use my telescope, that's already in orbit >200000km, to further research already discovered celestial bodies (by pointing the telescope at them and clicking "Track Bodies" a few times) so I can go to them. The contract for this is grayed out because there are two "Unmet" conditions: "The Observatory must be level 1: Unmet" and "There must be Bodies yet to have their research completed that are within range of a Telescope: Unmet." But I definitely do have a level 1 observatory and I haven't completed research on any new bodies, let alone all of them...

I have a bunch of other mods installed, including the New Horizons planet pack, but they all seem to be playing nicely with each other so I'm not sure that this is a mod conflict issue.

EDIT: I tried to recreate the problem in sandbox mode, which didn't entirely work because of the whole no contracts thing, but I did notice something: Once I discovered a body I could start a research plan for it (just like I was able to before) and underneath the button I clicked to start the research plan was another button that allowed me to Research: Aspect. After clicking that a couple of times I could research the orbit and characteristics by clicking another button. Neither of these buttons showed up in my career save. (I also still couldn't use my telescope in sandbox mode to do what clicking the buttons in the observatory did, but that's probably tied to the contracts.)

I'm having this exact same problem. I have a telescope in an orbit of 1,000 km, and it says that's unmet. I do have my observatory at level 2, but why would a better observatory disable research? That makes no sense. *Edit* I see in the .cfg that it's a minimum level, so level 2 should be fine.

In either case, I can't do telescope missions, and I don't have the Research Aspect buttons either. Any ideas anybody?

Edited by FirroSeranel

Share this post


Link to post
Share on other sites
13 hours ago, FirroSeranel said:

I'm having this exact same problem. I have a telescope in an orbit of 1,000 km, and it says that's unmet. I do have my observatory at level 2, but why would a better observatory disable research? That makes no sense. *Edit* I see in the .cfg that it's a minimum level, so level 2 should be fine.

In either case, I can't do telescope missions, and I don't have the Research Aspect buttons either. Any ideas anybody?

 

On 7/17/2017 at 1:28 PM, t rock said:

Right, I understand that part. Maybe I'm not explaining my problem well. :/ Basically I want to use my telescope, that's already in orbit >200000km, to further research already discovered celestial bodies (by pointing the telescope at them and clicking "Track Bodies" a few times) so I can go to them. The contract for this is grayed out because there are two "Unmet" conditions: "The Observatory must be level 1: Unmet" and "There must be Bodies yet to have their research completed that are within range of a Telescope: Unmet." But I definitely do have a level 1 observatory and I haven't completed research on any new bodies, let alone all of them...

I have a bunch of other mods installed, including the New Horizons planet pack, but they all seem to be playing nicely with each other so I'm not sure that this is a mod conflict issue.

EDIT: I tried to recreate the problem in sandbox mode, which didn't entirely work because of the whole no contracts thing, but I did notice something: Once I discovered a body I could start a research plan for it (just like I was able to before) and underneath the button I clicked to start the research plan was another button that allowed me to Research: Aspect. After clicking that a couple of times I could research the orbit and characteristics by clicking another button. Neither of these buttons showed up in my career save. (I also still couldn't use my telescope in sandbox mode to do what clicking the buttons in the observatory did, but that's probably tied to the contracts.)

How far away are the planets? You say you have planet packs installed. There is a range.. so perhaps that is the issue as I never tested with planet packs. only stock.
The research buttons (old way) is enabled in sandbox because there are no contracts. That method is not available in career mode.
I would need more info. Like what packs you have installed, what planets you have discovered, and well, as per the OP, the KSP log and ResearchBodies log.

Share this post


Link to post
Share on other sites
12 hours ago, JPLRepo said:

 

How far away are the planets? You say you have planet packs installed. There is a range.. so perhaps that is the issue as I never tested with planet packs. only stock.
The research buttons (old way) is enabled in sandbox because there are no contracts. That method is not available in career mode.
I would need more info. Like what packs you have installed, what planets you have discovered, and well, as per the OP, the KSP log and ResearchBodies log.

I'm using stock planets only, and was having trouble researching Minmus, so definitely not range. If the buttons aren't supposed to work in career, then that's fine.

In that case, I suspect a Contract Configurator bug. I have similar problems with Clever Sats not recognizing that I had access to deployable antennas.

Yet other contract packs work fine (SCANSat, Tourism Plus, Bases and Stations). I scoured all the configs and logs for all four mods plus CC, as well as the save, and ksp.log, and could find nothing amiss, and nothing done particularly differently in the two that weren't working versus the two that were. So, stumped, I sadly uninstalled Clever Sats and Research Bodies. I've played since, so the ksp log is since overwritten. I think I still have the last ResearchBodies log though... *searches*

Yep, here it is. https://drive.google.com/file/d/0BwzmApevAhiLUzhncGUtRWlaQW8/view?usp=sharing

I was able to discover planets with the telescope (though like some others, I got the full reward just for discovery). I was also able to begin "Search the Skies" and "Research a Celstial Body", just not the two telescope contracts. However, while Search the Skies seemed to behave normally (though I didn't fast-forward all the way through it to see if it completed at the end), Research a Celestial Body failed on scene change, consistently.

Mods...

Spoiler

CKAN Managed:

6 Crew Science Lab (SixCrewScienceLab 1.1)
6 Seat Mk3 Cockpit (SixSeatMk3cockpit 1.1)
Ablative-Airbrake (AblativeAirbrake 0.2.0)
Alternate Resource Panel (AlternateResourcePanel v2.9.2.0)
Ambient Light Adjustment (AmbientLightAdjustment 2.6.3.8)
AmpYear (AmpYearPowerManager 1:V1.4.9.0)
AugmentedReality (AugmentedReality 0.2.0)
AutomatedScienceSampler (AutomatedScienceSampler 1.3.3)
B9 Aerospace Procedural Wings - Fork (B9-PWings-Fork 1:0.40.13)
B9 Part Switch (B9PartSwitch v1.9.0)
Basic DeltaV (BasicDeltaV 1.1)
Basic Orbit (BasicOrbit 7.0)
BetterBurnTime (BetterBurnTime 1.6)
Blast Awesomeness Modifier (BAM) (BAMCont 1.3.0)
BOMPs (BOMPs 1.0.1.1)
BZ-1 Radial Attachment Point (BZ1RadialAttachmentPoint 1.0.0)
Celestial Body Science Editor (CelestialBodyScienceEditor 10.0)
Collision FX (CollisionFX v4.0)
Community Tech Tree (CommunityTechTree 1:3.1.2)
Contract Configurator (ContractConfigurator 1.23.1)
Contract Pack: Bases and Stations (ContractConfigurator-KerbinSpaceStation 1:6.7.0.0)
Contract Pack: Clever Sats (ContractConfigurator-CleverSats 1.4)
Contract Pack: Tourism Plus (ContractConfigurator-Tourism 1.5.2)
CorrectCoL (CorrectCoL 1.6.0)
CTTStockRebalance (CTTStockRebalance 1.01)
DefaultActionGroups (DefaultActionGroups 1.2.3)
Deflatable Heat Shield (DeflatableHeatShield 0.0.3)
Distant Object Enhancement (DistantObject v1.9.1)
Distant Object Enhancement default config (DistantObject-default v1.9.1)
DMagic Orbital Science (DMagicOrbitalScience 1.3.10)
Docking Port Sound FX (DockingPortSoundFX v2.1.12)
Duna Restoration Project (DunaRestorationProject 2.0)
EditorTime (EditorTime KSP1.3.0)
EVA Enhancements Continued (EVAEnhancementsContinued 0.1.10)
EVA Handrails Continued (EVAHandrailsPackContinued 0.2.1.5)
EVA Parachutes & Ejection Seats (EVAParachutes 0.1.14)
EVA Struts (EVAStruts 4.0)
EVA Transfer (EVATransfer 7.0)
ExceptionDetector (ExceptionDetector 3)
Feline Utility Rovers (FelineUtilityRovers 0.6.1)
Flexible Docking (FlexibleDocking 5.0)
FlightPlan (FlightPlan 1.0.2)
GravityTurn Continued (GravityTurnContinued 1:1.7.6)
HangerExtender (HangerExtenderExtended 3.5.0)
Heat Control (HeatControl 0.4.1)
Hide Empty Tech Tree Nodes (HideEmptyTechNodes 0.8.0)
IndicatorLights (IndicatorLights 1.2.11)
IndicatorLights Community Extensions (IndicatorLightsCommunityExtensions 1.3)
Inline Ballutes (InlineBallutes 1.2.8)
JoolBiomes (JoolBiomes 1.1)
KEI (KEI 1.2.2.130)
Kerbal Alarm Clock (KerbalAlarmClock v3.8.5.0)
Kerbal Attachment System (KAS 0.6.3.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.3.0)
Kerbal Inventory System (KIS 1.5.0)
KerbNet Controller (KerbnetController 3.0)
KerboKatz - SmallUtilities - FPSViewer (KerboKatzSmallUtilities-FPSViewer 1.5.3)
KerboKatz - SmallUtilities - PhysicalTimeRatioViewer (KerboKatzSmallUtilities-PhysicalTimeRatioViewer 1.5.3)
KerboKatzUtilities (KerboKatzUtilities 1.5.0)
Kopernicus Planetary System Modifier (Kopernicus 2:release-1.3.0-4)
KSP ExtendedAntennaProgression (ExtendedAntennaProgression v0.1.1)
KSP Rescue Pod Fix (KSPRescuePodFix 1.1.0.7)
KSPCasher Continued (KSPCasherCont 0.2.4)
Landing Height Display (LandingHeight 2.1)
Lights Out (LightsOut v0.2.1)
Maneuver Node Evolved (ManeuverNodeEvolved 3.1)
MechJeb 2 (MechJeb2 2.6.1.0)
MechJeb and Engineer for all! (MechJebForAll 1.2.0.0)
MK-1 Stockalike open cockpit ( inline external seat ) (MK1StkOpenCockpit 1:1.0)
ModularFlightIntegrator (ModularFlightIntegrator 1.2.4.0)
Navball Docking Alignment Indicator CE-2 (NavballDockAlignIndCE 1.0.2)
NavHud (NavHud 1.3.3)
Near Future IVA Props (NearFutureProps 0.7.2)
Near Future Launch Vehicles (NearFutureLaunchVehicles 1.0.2)
Near Future Solar (NearFutureSolar 0.8.4)
Near Future Solar Core (NearFutureSolar-Core 0.8.4)
Near Future Spacecraft (NearFutureSpacecraft 0.7.2)
Off Stage (OffStage 0.0.5)
PicoPort (PicoPort 0.1.3)
PicoPort for all sizes (PicoPort4AllSizes 0.1.2)
Pood's Calm Nebula Skybox (PoodsCalmNebulaSkybox 1.0.0)
Portrait Stats (PortraitStats 14.0)
Procedural Fairings (ProceduralFairings v4.0)
RCS Sounds (RCSSounds 5.2)
Real Plume (RealPlume 2:v10.5.1)
Real Plume - Stock Configs (RealPlume-StockConfigs v0.11.4)
RealChute Parachute Systems (RealChute v1.4.4)
Realistic Atmospheres (RealisticAtmospheres 1.2.3)
ReCoupler (ReCoupler 1:1.3.0)
RecoveryController (RecoveryController 0.0.2)
Reentry Particle Effect (ReentryParticleEffect 1.2a)
REPOSoftTech-Agencies (REPOSoftTech-Agencies V1.4.9.0)
SCANsat (SCANsat v18.0)
Science - Full reward! (NMSG 2.5)
Science Relay (ScienceRelay 4.1)
Science Revisited Revisited (ScienceRevisitedRevisited 1.5.0)
Simple Mk2 Lander Can Patch (SimpleMk2LanderCanPatch any_version_because_its_a_ModuleManager_patch)
Slingshotter Reslung (SlingShotterReslung 1.1.1)
Smart Actuation (SmartActuation 1.1.0.2)
SmokeScreen - Extended FX Plugin (SmokeScreen 2.7.5.0)
SMURFF (SMURFF 1.6.2)
SMURFF Extras - Ven Stock Revamp (SMURFF-Extras-VenStockRevamp 1.6.2)
Solar Science (SolarScience v1.06)
Space Opera (SpaceOpera 1.1.1b)
StageRecovery (StageRecovery 1.7.2)
Stockalike Station Parts Expansion (StationPartsExpansion 0.5.1)
Structural Disks (StructuralDisks 1.2.0.1)
Surface Experiment Pack (SurfaceExperimentPack v2.3)
TakeCommandContinued (TakeCommandContinued 1.4.9)
TextureReplacer (TextureReplacer v2.6.0)
The Kurrikane Probe (KurrikaneExpanded 1.1.0.1)
Toolbar (Toolbar 1.7.14)
Tough Love (ToughLove 0.0.1)
Trajectories (Trajectories v1.6.6)
Transfer Window Planner (TransferWindowPlanner v1.6.2.0)
TriggerAu Flags (TriggerAu-Flags v2.9.2.0)
TweakScale - Rescale Everything! (TweakScale v2.3.6)
Ven's Stock Part Revamp (VenStockRevamp v1.9.6)
Ventral Drill for Stock ISRU (VentralDrill 1.3.0)
Waypoint Manager (WaypointManager 2.7.0)
 

Plus manual installs of:

USI (Entire constellation) 2017.05.28 plus USI Tools 0.9.2.0
SVE (High-Res) 1.2.5.0 with EVE 1.2.2.1 and Scatterer 0.0320b
Airline Kuisine 1.3.0
Configurable Containers 2.4.1
Contract Configurator 1.23.1
CSI Cargo Freighter 0.2.3
Dr. Jet's Chop Shop 0.11.0.1
Infernal Robotics 2.0.12 with Rework Pack 1.1.2
Kerbal Joint Reinforcement 3.3.2
Module Manager 2.8.1
NIMBY 1.0.1.0
RCS Build Aid 0.9.1.2 Unofficial Beta by LGG (last page of posts)
Research Bodies 1.9.3.0 (uninstalled)

 
 
 

Hope that helps, and sorry about the lack of ksp.log. If @t rock posts a similar mod list, maybe you can cross-correlate and see what mods we have in common that might be messing with things.

If you really need, I could reinstall it, start a new save, cheat in some funds, and see what happens. Let me know.

Edit: Screw it, I'm gonna go ahead and do it...

Edit 2: Okay, so here are the new ksp.log and ResearchBodies.log, along with a video demonstrating contract failure on scene change. I can also confirm that Search the Skies completes correctly (it discovered Moho. I'd used the satellite to find Minmus).

Research a Celestial Body reports success, but didn't find or accomplish anything.

Log Files (Zipped Folder from Google Drive)

Video Bug Report for Contract Failure on Scene Change

Also pinging @nightingale since it may involve a CC bug (Some of the issues are shared with CleverSats)

Edited by FirroSeranel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now