taniwha

[1.2.2] Extraplanetary Launchpads v5.7.2

4821 posts in this topic

Posted (edited)

@akumanochi: First, make sure you have a survey station on your vessel. Second, assuming you do have a survey station, it sounds like your survey stake is too far from your survey station. Put a better surveyor into your survey station. EL treats pilots as surveyors.

Actually, even an unmanned survey station can be used, but it will have a range of only 20m. A non-surveyor kerbal in the station gives it a range of 50m, but pilots start at 100m for level-0 (zero stars), doubling every level but capped at 2000m.

@Test-Bob50: as per @cgwhite4, unless you installed Kethane, in which case you have a shader issue (covered in that thread, but the gist is there are three .ksp files in Kethae: delete two keeping the one for your OS).

Edited by taniwha

Share this post


Link to post
Share on other sites

For future reference, if you try loading a vessel at an EL-supported Launchpad, and it appears nearly horizontal instead of vertical and undergoes Rapid Unscheduled Disassembly, it could indicate that your vessel file has become corrupted.  This happened to a rover I was planning to send to Tylo from the Launchpad at my base on Pol.  No sooner had I pressed the load button than the vessel appeared on the pad but was nearly horizontal instead of vertical.  Rapid Unscheduled Disassembly promptly ensued.

Thankfully, I was able to revert to a previous save, determine that the vessel had indeed become corrupted, and re-create it from scratch, overriding the corrupted version.  The new version was successfully loaded.

2 people like this

Share this post


Link to post
Share on other sites

@cgwhite4: good tip, though another possibly is a PartModule mod throwing an exception during OnStart.

3 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

Help/hint needed

EL 5.7.1, MKS, and lotta other stuff.

Assembled orbital station with EL dock and ExWorkshop. Manned with eng. kerbals, supplied resources (MKS ones), build my 1st satellite, finalized, refueled it and released. Setup construction of next identical sat. Resources go down, satellite completion goes to 100%, get message on completion on KAC. NO FINALIZE BUILD OPTION, just pause build (plenty resources spare, including consumable fuels etc.). On KAC message close, EL generates another remainder that vessel is ready. Installed update 5.7.2, NO EL UI at all (O_O)!. Downgraded to 5.7.1, pad construction empty, re-setuped construction, nothing being built. Transferred kerbals out/in from workshop, no change. No other mods were installed between successful sat1 construction and sat2 failure. Tried to cancel 0% complete build, tear-down pause appears, yet no change. EL keeps generating messages of constructions completed.

Is there a way to successfully reset pad and make it working again?

Edited by silvan78

Share this post


Link to post
Share on other sites

@silvan78: Actually, I recently had trouble with EL's build menu not showing, but it turned out to be another mod causing problems. I think it was KerbalKrash for me.

The build not stopping sounds like a math error with the final insignificant portion of some resource. I thought I'd fixed that, but I'll double check the math.

Share this post


Link to post
Share on other sites

How exactly do I stop my spacecraft from materializing in the ground when using a survey stake?

Share this post


Link to post
Share on other sites
3 hours ago, CheckYoStaging said:

How exactly do I stop my spacecraft from materializing in the ground when using a survey stake?

Well, that all depends. Where is the site (flat ground, sloping? the side of the VAB*)?. How is your site set up (modes of the stakes (5.7.2 gives the stakes signs showing their mode when highlighted))? You are using 5.7.2, aren't you?

Share this post


Link to post
Share on other sites

Posted (edited)

Using 5.7.1.  I'll try downloading the latest version and see if I can figure it out.  Thanks.

Edited by CheckYoStaging

Share this post


Link to post
Share on other sites

Ah, cool, because 5.7.2 corrects an error in survey build placement. For me, the build was too high, but for others it was in the ground.

Share this post


Link to post
Share on other sites
2 hours ago, taniwha said:

Ah, cool, because 5.7.2 corrects an error in survey build placement. For me, the build was too high, but for others it was in the ground.

Isn't including launch clamps in the design a sure-fire way to spawn your rocket above ground?

Share this post


Link to post
Share on other sites

@MatterBeam: no. 1) Some of the people who had trouble with ships spawning in the ground (even on flat terrain) still had trouble with clams. 2) Even when the system is working correctly, launch clamps will not guarantee the build will be out of the ground.

What including launch clamps does is ensure that the build will stay where you put it, even vertically (ie, the build will not drop to the ground or roll down the hill).

Share this post


Link to post
Share on other sites

Hopefully an easy one - has anyone else had an issue with input locks? Can get them cleared so it's not a game breaker, just a bit annoying.

Description on the Alt-F12 has "EL" in it - anything to do with this mod? Can get a screenshot or better description when I get home.

Share this post


Link to post
Share on other sites

A screenshot would help, but I thought I removed them all. I'll check.

Ok, turns out I removed them from only the build window. I now know how to do click-through prevention properly (doesn't work too well with mixed IMGUI and the new gui stuff, though).

Share this post


Link to post
Share on other sites
8 hours ago, taniwha said:

A screenshot would help, but I thought I removed them all. I'll check.

Ok, turns out I removed them from only the build window. I now know how to do click-through prevention properly (doesn't work too well with mixed IMGUI and the new gui stuff, though).

Still want that screenshot?

Share this post


Link to post
Share on other sites

Yes please. I want to see if the cause is visible.

Share this post


Link to post
Share on other sites
3 hours ago, taniwha said:

Yes please. I want to see if the cause is visible.

There we are sir

Share this post


Link to post
Share on other sites

Thanks for the shot. That is an odd one. I'll take care of it soon.

Share this post


Link to post
Share on other sites

So here's another question - Is there a way to make the stock drills mine metal ore and/ or ore (I believe it's this mod that implements it)? Or is there a parts pack that changes out the augers with deployable drills?

By no means is it a criticism of the mod - it's great and adds something I really like.

Edited by Das_Sheep
Clarification

Share this post


Link to post
Share on other sites

It's quite possible to make the stock drills extract MetalOre, but there are a couple of problems with it:

  • I prefer to work with mass rather than volume, so that's how EL's augers are set up (custom extractor module derived from the stock one, but with custom recipe handling). This means doing a balanced config for stock drills will take some skull-sweat.
  • Stock drills are suited only to gaseous and liquid resources: how are you supposed to get rock, even powdered, up that pipe?

Yeah, the auger is not the nicest thing to look at, and it doesn't fold away, but it does at least look right for the job.

As an aside: I don't use the stock system at all (minus the fact that the auger will automatically pull MetalOre from the stock system). I much prefer Kethane's mechanics (part of why I took it over) and I'm quite happy with using multiple drills: kethane drills for Kethane, augers for MetalOre.

I really need to get around to doing a tutorial series, but of all the bases I've made (8 now, I think), I have flown augers (or even smelters) out to only one: the very first one. At all other bases, I built everything on-site. I even usually build better workshops on-site. I have launched exactly two workshops (the big blue thing) into LKO, but built many stations. When I fly a good workshop out to a base, usually it was built in LKO (my current Jool mission is an exception: didn't have time before the launch window to build the engire ship, so I flew up a workshop to build the Jool ship.

In summary: all you need to start a base is a survey station, some survey stakes, and sufficient RocketParts to build a tiny auger (0.5328t), tiny smelter (1.5t), and a rocket workbench (1.5t), plus a few extras (batteries, solar panels, legs, KAS connectors).

The smelter has built-in storage for MetalOre, Metal and ScrapMetal, you already have storage for RocketParts (though you will want to build more), and with the above, you will have everything you need to get a fully functional base up and running.

Share this post


Link to post
Share on other sites
7 hours ago, taniwha said:

In summary: all you need to start a base is a survey station, some survey stakes, and sufficient RocketParts to build a tiny auger (0.5328t), tiny smelter (1.5t), and a rocket workbench (1.5t), plus a few extras (batteries, solar panels, legs, KAS connectors).

Will go with something along those lines, although for the base start I just used a couple of pre-positioned probe drops with 7K rocketparts each (configurable containers and orange tanks) and then dropped a glorified lander next to them filled to the gills with engineers and a pilot and just enough life support to last until the recyclers were built. Was only asking as I had visions of an absurdly sized rover wandering around mining metal ore, but I've actually looked into the kind of mass that creates having even a couple hundred units and I suspect I'm better feeding it into a smelter as I mine it anyways. So I guess I'll just have to find another excuse to built a giant rover, what a shame.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now