Jump to content

JWS

Members
  • Content Count

    58
  • Joined

  • Last visited

Everything posted by JWS

  1. Nice idea indeed. One silly question: If a ship runs out of battery, all animated part on it won't function?
  2. Experiencing the same issue. To confirm that the issue is not from any other mod, tried the latest KCT on fresh 1.8.1 install with all DLC. The issue was still there. While remembering the button existed until recently, the obvious next step was rolling back until the button reappears. Used the latest version of ClickThroughBlocker, ToolbarController, MagicCore. Changed only KCT mod itself. It didn't take much time as the button reappeared when using KCT 1.4.6.10. So it seems that whatever the change happened between 1.4.6.10 and 1.4.6.11 got rid of the button. I hope
  3. I posted the FR for openGL support long time ago and didn't get any response. So I complied the shader for myself and using since then, completely forgot to share the result. Here's a shader I'm using right now. https://1drv.ms/u/s!AnCGI7wKaBjLlccEIqPfTjfaqlIZTQ?e=b3hhXd Download the file and replace the original one in the AssetBundles folder in B9_Aerospace_ProceduralWings. I literally changed nothing, but just clicked a checkbox in PlayerSettings in the Unity editor (I don't remember the option name) and complied the shader as-is. Hope this helps.
  4. Thanks for the update! The rendering indeed seems nice. However, after the recent update I see endless NullRef exceptions popping up when I click any engines at VAB scene. Attaching it to any node doesn't help. After finding the error persist even in a fresh install with minimal mods, and reverting back to SmokeScreen 2.8.1 solved the issue, I thought the recent update might be the curlpit. Attaching my log file. https://1drv.ms/u/s!AnCGI7wKaBjLlccDN0Ko-Jw_g5rt5w?e=rO57uW Replication. 1. Launch KSP(1.7.3 or 1.7.1 with all DLC) with SmokeScreen (2.8.2
  5. Thanks for the great work! It really goes well with big ships or complex robotics parts. I think I found an odd behavior of kerbal on EVA with this mod installed. The kerbal cannot walk or fly straight, and keep falling to the ground. Literally uncontrollable. Removing this mod fix the problem instantly. I'm using mod version 4.0.1 on KSP 1.7. If you have time, please look into this problem. Thanks!
  6. Ah, I see. That explains the problem. So in that context, if I use a part pack which has crew part without internals, the problem will show up again? Must check IVA before installing parts pack for now. Thanks!
  7. I think I found the curlpit. It was a MM patch I googled a while ago to reduce lags in game when launching crewed vessel. // MM-removeinternals.cfg // single patch to delete all INTERNAL from command pods // to alleviate fps problems with animated portraits // NOTE: obviously portraits will be gone, and IVA will no longer be possible // EVA and transfers can still be done by clicking the hatch of pods // // suggestion by NathanKell, initiative by FungusForge, implementation by swjr-swis // // usage: place this text in a file ending with .cfg anywhere in the GameData directory /
  8. @Jake_IV Thanks! @garwel First I found the bug on Mk2 cockpit, then hitchiker container, Mk1 lander pod, and some fighter cockpit from Airplane plus mod(this is the case for the linked log file). I just checked that it happens in Mk1 pod, MK3 pod, and Mk2 landing can, too. And another thing. On the status window, 'Location' of the kerbal is updating well regardless of change/day.
  9. Thank you for new release! This mod really enhances my game experiences. Unfortunately, I've been suffering from possible error related to this mod, recently. In the game console, below message keeps pop up from the beginning of any crewed flight. in KSP 1.6.1 with MakingHistoryDLC with KerbalHealth 1.3.5 or KerbalHealth 1.3.4. What's really happening during the game play is that nothing goes wrong as long as I keep my kerbals inside their vessel. (Destpie the message continues to appear) In status window, Change/day and Time left, Radiation shows numbers as expecte
  10. Hi. Before talking about some errors, thank you very much for maintaining this amazing mod. I think I found some EVA related error. It happens when EVA begins, or entering vessel from EVA. KSP version 1.6.1 wtih MakingHistory dlc. [ERR 13:23:30.645] Exception handling event onVesselCreate in class VesselStatsManager:System.InvalidCastException: Cannot cast from source type to destination type. at TrackResource.VesselStatsManager.Add (.Vessel v) [0x00000] in <filename unknown>:0 at TrackResource.VesselStatsManager.OnVesselCreate (.Vessel Vessel) [0x00000] in <filename unk
  11. It was the BetterTimeWaprConitnued mod, and changing the 'Use LosslessPhysics' option on and off stopped the spamming.
  12. First of all, thank you for maintaining this amazing mod. I found that, when using -force-opengl command to run the game, B9 PW parts are shown in complete black. Without any error message or warning. I've read previous posts and the issue was already reported before, but it still exists. Attaching screenshot. I understand that supporting openGL may not be a priority, but could you plz consider fixing this in future update? Thanks.
  13. Thank you very much for this magnificent mod! I almost forgive to find out the cause of log spam that says "Launcher here(in write): False", which brings awful lagging of my game. Tried to eliminate some suspiscious mods, reset game settings, google for similar problems, but to no vail. But thanks to Your mod, finally I can point out the problem and now I can continue my main save game. Again, thanks for Your fantastic work.
  14. After the update that makes kerbal scientists to restore the Goo and the material box infinitely, I rarely use the 'Clean up experiments' function. Obviously bringing a kerbal VS MoblieLab on my journey differs a lot, even from the lifter design. But sometimes I thought that resetting by scientist is too easy, and somewhat unrealistic(Requires no additional resource, instant resetting, infinite times... etc.). So, how about limiting the ability of our scientists by letting them to run experiment few times? (let's say 3 for Goo and 2 for the box) After that, those instrumen
  15. Nope. Just tried for my career save(1.5.1) with FAR(LightHill) and the game crashed. I lost another shuttle, full of rescuees, right down on the runway because of the bouncing and skidding. Beside my poor landing skills, too much landing speed was the cause, I believe. Desperately need this mod for the safe landing. EDIT: the crash was not from this mod. Can open game without any problem, but the mod is not working.
  16. I see your point. It might be meaningless as subtle change of EC won't change game play much. And I don't think it should be neither. But what I cannot agree is that although the scale of impact might be small, it can affect much larger part of gameplay. For example, probe lander have to wait until sunrise if it doesn't have enough battery to operate antenna in night time. Or newly attached fuelcells can distort center of mass so that tiny probes have to use reaction wheel, which also require EC to operate, to maintain attitude. It might be negligible difference, but the effect can c
  17. Thanks for your response. That's what makes difference when choosing relay antenna over direct ones. When it comes to Sandbox or satellite orbiting near Kerbol you don't really have much to care. But when designing a ship under part number constraint or probe for Jool system those things do matter. If stock game supports Background EC consumption, You will need to considerate battery reserves for night time operations(Although it's not the point we are talking about in this thread.)
  18. Thank you for the suggestion. :-) I'm aware of the mod, and I did install it every new save except for recent new one. Stock and RT2 comm systems are quiet differ, and I'm not talking about integrating some features of RT2 into stock system. It's more like making clear functional distinction between direct and relay antennas. Current relay antennas can function also as direct ones. Except for their design(This is huge, I know) and some subtle cost differences, they can be replaced with relay antennas which not only act like direct ones but also have relay functionality.
  19. Recently starting new career saves using CommNet, and found out that no antenna is consuming any EC when i'ts idle. It was a bit strange because I could still control probes and activate various parts at no cost at all. As this is the case for both relay and direct antennas, relay antennas which can handle signals from various sources has no disadvantage of the feature, making direct antenna somewhat less attractive. How about add a module that forces base EC consumption whenever an antenna is deployed? And set those values differently for their target range, actual communicati
  20. I couldn't find anyone's upload of something like this, but I'll post it anyway. I recently changed my desktop setups from Intel 3570 to Ryzen 1700. And OC'd it to 3.8Ghz with RAM to 2,666Mhz. This is the CPU usage of heavily modded(including SVE, Scatterer) KSP*64 on my setup. https://imgur.com/a/AMDq2 I'm at the begging of my new career save so no data available for 100+ parts ships in 2.2km range. It seems, though, that modded KSP is utilizing multiple threads well at the moment.
  21. Same thing happened to me. Luckily solved the issue by disabling AVAST's gaming mode function. The mode is intended to provide minimal interference between your game and system monitoring function. But an option, included in the mode, called 'Power triggering' modifies PC's power management policy, resulting in terrible SSD access speed overall. It simply overrides whatever the default value is, and doesn't restore the original setting even though the game is closed. Disabling the function brought back the original loading speed of the game. So check anything that touc
  22. About the 'science loss after docking' bug... I found a weird interaction between the science loss and vessel switching. Below is a link to screenshots which shows what has happened to my mun rover. http://imgur.com/a/jtMCt Details are written in each image's description. I attached solar panels using KIS method. And after that, docked the rover to supply station using KAS winch. Hope this info. to be useful to find out what's happening under the hood. Thanks.
  23. Hi, I think I found a KAS and KIS related bug. When removing a part from a vessel via EVA kerbal(using driver or wrench), NRE spam occurs. I found this error while playing my heavily modded career save, and replicated it in sandbox on fresh new install with kOS, KAS, KIS, ModuleManager. Attaching something didn't cause any NRE. Removing anything(whether it was attached in VAB/SPH or during flight via KAS) always causing the error. Is this mod not compatible with KAS? I wasn't able to find any related issue in github, but thought that it would be better to ask here first.
×
×
  • Create New...