KospY

[1.1.2] Kerbal Inventory System (KIS) 1.2.12

Recommended Posts

Also did the equipment slots change for the female Kerbals? "equipSlot = eyes" is not working between male and female.

edit

just saw this

Did you try with equipMode = part in ModuleKISItem ?

Yes I have been working with Darren9 and we have a working vulcan with "equipMode = physic" under a ModuleKISItem. But there is still a lot of tweaking to do.

(Darren9 Figured out the euipmode that was the key I was missing)

Edited by V8jester

Share this post


Link to post
Share on other sites

must have patience ....must have patience ...rushes off to check ckan ...no nothing ....

must have patience ....must have patience ...rushes off to check ckan ...no nothing ....

must have patience ....must have patience ...rushes off to check ckan ...no nothing ....

must have patience ....must have patience ...rushes off to check ckan ...no nothing ....

soon so soon im sure ....must....just.... have.... patience .........rushes off to check ckan

I cant wait guys seriously thanks for all the hard work veritable legends you guys / girls / kerbals are legends

Share this post


Link to post
Share on other sites

KospY, would it be possible to set up the explosive to only explode the part that it's attached to?

Share this post


Link to post
Share on other sites
...rushes off to check ckan

Or you can just download it manually...

Share this post


Link to post
Share on other sites
Or you can just download it manually...

Its so nice to see a mod that stands alone and can be downloaded without needing something to track conflicts and dependencies.

But for convenience, I updated the metadata at CKAN, jsut waiting for the pull request to process. Should be relatively soon.

Share this post


Link to post
Share on other sites

Murdabenne: there will always be some mods at the top of the pyramid (usually, most actually). It's really the ones that have dependencies that are the exceptions. It's just that those mods that depend on others tend to be very popular because of the way they extend not only KSP itself, but those other mods on which they depend, and thus seem to be the rule.

That said, from what I've heard, the realism mods (RSS etc) would give a string theorist nightmares.

Share this post


Link to post
Share on other sites

Thanks, guys. New 1/3 container is lovely. Thanks for that - just what the parts range needed.

Share this post


Link to post
Share on other sites

Quick question: Does the weight of a container change when adding items to it?

Or can I always calculate with the weight displayed in the parts selector?

EDIT: Nevermind. The mass is dynamicly calculated in the UI. Nice.

Edited by Cairol

Share this post


Link to post
Share on other sites

Thank you guys for the Update. Quick hint from a dependant mod developer. Your assembly says it is version 1.1.6, which confuses my dependancy checker that tries to verify 1.2.0. Keep up the good work

Share this post


Link to post
Share on other sites

@KospY

What are these parameters in the settings?


EvaPickup
{
. . .

allowPartAttach = false
allowStaticAttach = false
allowSnapAttach = false
. . .
}

Share this post


Link to post
Share on other sites

How do I drag a subassembly into a container? I thought we had the ability to do that.

To clarify, what I'm trying to do is to take a subassembly under the advanced filter mode and add it to one of the large 2.5m containers.

Edit: Is it me or is the drag from editor screen into the container not working? I'm asking because the manual says that you can add tweaked items into the container. I've tried both dropping it into editor, tweaking, and dragging it in and attaching it to something, then tweaking and then dragging.

Edit2: Tried in a cleaner branchoff KSP and I still can't. The function that the user guide claims is possible on page 4 isn't working.

Edited by smjjames

Share this post


Link to post
Share on other sites
Thank you guys for the Update. Quick hint from a dependant mod developer. Your assembly says it is version 1.1.6, which confuses my dependancy checker that tries to verify 1.2.0. Keep up the good work

Re-download KIS. I made a mistake on the first release.

- - - Updated - - -

@KospY

What are these parameters in the settings?


EvaPickup
{
. . .

allowPartAttach = false
allowStaticAttach = false
allowSnapAttach = false
. . .
}

It's the pickupmodule parameters of kerbals. By default a Kerbal cannot attach (attach tools change those parameters when equipped)

- - - Updated - - -

How do I drag a subassembly into a container? I thought we had the ability to do that.

To clarify, what I'm trying to do is to take a subassembly under the advanced filter mode and add it to one of the large 2.5m containers.

Edit: Is it me or is the drag from editor screen into the container not working? I'm asking because the manual says that you can add tweaked items into the container. I've tried both dropping it into editor, tweaking, and dragging it in and attaching it to something, then tweaking and then dragging.

Edit2: Tried in a cleaner branchoff KSP and I still can't. The function that the user guide claims is possible on page 4 isn't working.

You cannot drag a subassembly into a container (it's something planned for later).

You right about dragging from editor screen... It didn't work anymore. I will fix this.

Thanks for the report.

Edited by KospY

Share this post


Link to post
Share on other sites

Well, mainly what I wanted to do was put all of the parts in the subassembly of a rover (well, the rover IS the subassembly) into the big container without having to remember all of the parts that I wanted, or needed.

Share this post


Link to post
Share on other sites

I seem to be having problems attaching parts with KIS/KAS (I do have other mods as well, about 25). Whenever i attach a part, it just slides off. It never becomes a real part of the craft i'm attaching it to.

Has anybody else had the same problem i'm having now and if so, what was the solution?

Share this post


Link to post
Share on other sites
I seem to be having problems attaching parts with KIS/KAS (I do have other mods as well, about 25). Whenever i attach a part, it just slides off. It never becomes a real part of the craft i'm attaching it to.

Has anybody else had the same problem i'm having now and if so, what was the solution?

Engineer? And tool equipped?

Share this post


Link to post
Share on other sites
Engineer? And tool equipped?

Also, press 'x' to actually use the tool. It's the only part of KIS that wasn't totally intuitive for me, the tooltip that shows up when placing really could use a "press X to mount/tool needed to mount" remark.

Share this post


Link to post
Share on other sites
Also, press 'x' to actually use the tool. It's the only part of KIS that wasn't totally intuitive for me, the tooltip that shows up when placing really could use a "press X to mount/tool needed to mount" remark.

Just to clarify this, you need to HOLD "X" to use the equipped tool.

Share this post


Link to post
Share on other sites

Could somebody tell me, is it possible to place a strut between two points with this mod? If it is, how does one do it? Please, help a noob in peril.

Share this post


Link to post
Share on other sites

KospY, your manual doesn't contain the one fundamental command to use when filling items in the storage container from the VAB/SPH, right clicking.

It says "DRAG (HOLD) AND DROP PARTS FROM PARTLIST TO CONTAINER INVENTORY SPACE." Following your instructions, I left clicked on the part and nothing would happen as I dragged it over the containers inventory. The parts would hang in the blank space of the VAB/SPH and i'd be left wondering if your mod was working correctly. It was the Right mouse button which does this, which your manual didn't mention.

It should read something like: "RIGHT CLICK ON THE PART/S YOU WANT, THEN DRAG (HOLD) AND DROP IT FROM PARTLIST TO CONTAINER INVENTORY SPACE." Just clarifies it better :)

Share this post


Link to post
Share on other sites

I have used both methods successfully. Also, using right click, you don't have to hold the button down. Just right click in parts list, drag to inventory, and click in inventory.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.