SuicidalInsanity

[1.7.x] Mk2 Expansion v1.8.6 [update 8/22/2019]

Recommended Posts

4 hours ago, SuicidalInsanity said:

The version of IFS included with M2X is only the core plugin, not the full version

FWIW, the metadata on CKAN has M2X depending on "Interstellar Fuel Switch", rather than "Interstellar Fuel Switch Core" - so when installed via CKAN it will pull in the full version of IFS, complete with parts and "complementary" patches.

Share this post


Link to post
Share on other sites
On 19/01/2017 at 9:25 AM, SuicidalInsanity said:

I've edited the Mk2Expansion netKAN, so IFS issues stemming from CKAN installs should be fixed as soon as the Pull Request goes through.

Any chance of doing the same for M3X?

Share this post


Link to post
Share on other sites

Question about the Hyperblast scramjet - how do you keep it from overheating? I get my craft up to speed, the X-43 activates, then immediately turns off due to overheating. I've tried spamming it with radiators, using precoolers, and mounting it away from other hot parts. No dice.

Any ideas? Thanks!

Share this post


Link to post
Share on other sites

@doggonemess: Shutdown due to overheat is a new one - normally engines simply explode. Are you running any mods that add engine heat mechanics?  Best guess is there's some sort of config weirdness going on between it and the scramjet.

Share this post


Link to post
Share on other sites

just asking, whats the best way to place all the folders in gamedata?

just put the gamedata folder in or all the ones inside it?

Share this post


Link to post
Share on other sites

Either way works. If you're moving the Gamedata folder from the Mk2expansion.zip, place that in the main KSP directory; if you've opened up the GameData directory in the zip, then move the files inside - Mk2expansion, CommunityResourcePack, and InterstellarFuelswitch and the ModuleManager.dll to inside your KSP/Gamedata folder. The Ships file in the .zip is optional, and that goes in the main KSP directory. The extras file in the .zip is also optional; open the file structure until you get to the two .cfgs, and choose one and place it in the GameData/Mk2Expansion/Patches directory.

Edited by SuicidalInsanity

Share this post


Link to post
Share on other sites

Also a question: With the Fuselage Junction parts in place, I've started making a space station "template" that can be lifted up in one go and even flowed around atmospheric planets by a tug-plane attachment.

The one thing that seems to be missing is an Mk2 form factor station "tube", that is much lighter than the crewed parts, but is passable and works well with the junction parts. Are there any plans for such a part?

Share this post


Link to post
Share on other sites

"Update 13/25/2016". Last year felt shorter than 13 month...

Ok, I'm here to report a issue: All the chine parts seem to be rotated 90 degree. Their lift is toward side instead of up. Looks like this:

vO5naWP.png

u2orUcM.png

(Took me a while to figure out how to post image)

When the stock wings works like this:

NTejTUG.png

Shouldn't the model be rotated 90 degree and the whole thing works like this?

DyA25cC.png

Edited by Tony422
Maybe I should say "the physics of the chines are 90 degree different to their model". I don't know how to describe this situation...

Share this post


Link to post
Share on other sites

I've also noticed very odd lift issues with chines; I agree with the above bug report, something is definitely off with all the chine parts.

Share this post


Link to post
Share on other sites

I've had a chance to take a look at the chine lift issue, and I have good news and bad news. The good news is I know what's wrong and how to fix it, the bad news is the fix is mutually incompatible with chine attach node symmetry. Chines can be placed individually with proper symmetry, but chine nodes can't be used to attach other chine parts with proper mirror symmetry.

Share this post


Link to post
Share on other sites

Couple of minor observations in using this pack recently for the first time -

The G-120 "Vector" engine has an attachment node that seems to float in front of the model, with a substantial open air gap to its parent part when attached. Almost like it's meant to have an auto-shroud but doesn't?

The SP-G Shrouded Solar Array has the 1200K thermal limit typical of the stock naked solar panels, not the 2000K limit of the stock SP-L and SP-W shrouded solar panels

The R-71 Cockpit has an unique all-over reflective texture that is very different than the rest of the pack's cockpits, or the stock ones.  All of the mod's cockpits have a lovely window reflective layer though, and it almost looks like the R-71 window reflections got applied to the whole part?

Thanks!

Edited by fourfa

Share this post


Link to post
Share on other sites
17 hours ago, SuicidalInsanity said:

I've had a chance to take a look at the chine lift issue, and I have good news and bad news. The good news is I know what's wrong and how to fix it, the bad news is the fix is mutually incompatible with chine attach node symmetry. Chines can be placed individually with proper symmetry, but chine nodes can't be used to attach other chine parts with proper mirror symmetry.

Bummer-- this would be for attaching a line of them so they snap together, right?

Share this post


Link to post
Share on other sites
3 hours ago, fourfa said:

The G-120 "Vector" engine has an attachment node that seems to float in front of the model, with a substantial open air gap to its parent part when attached. Almost like it's meant to have an auto-shroud but doesn't?

I keep noticing this and forgetting to say anything about it. I just use the offset to hide it, then forget about it by the time I am done playing KSP. :P

Share this post


Link to post
Share on other sites

@fourfa: Solar panel and vector attach node are easy fixes, I have my suspicions about what's going on with the R-71 cockpit, but it's been due for a remodel for a while now so it'll get fixed one way or the other.

@Beetlecat: Correct:
W3xdUDe.png
if stacking chines they'll have to be placed in 1x symmetry or with radial symmetry instead of mirror symmetry. Probably shouldn't be an issue with normal chine usage, wing root chines, if being used as wing roots will need to be placed without using stack attach nodes.

Edited by SuicidalInsanity
typo

Share this post


Link to post
Share on other sites

I haven't noticed this mentioned anywhere, so I'm going to ask here:

Has anyone noticed an unusually high drag value on the SpadeTail component (compared to other tails)?

I was looking at the part Aero data while flying and noticed the drag to be a bit higher than I expected. I replaced the tail with a different tail and the aircraft's top speed jumped from ~780m/s to ~850m/s.

Am I being a bit dense as to how the aero should work vs how it's working, or does this indicate some sort of bug?

Share this post


Link to post
Share on other sites

What in the name of the kraken does it take to keep the NUK-3 reactor cool?

Is it even possible with stock radiators?

I tried 8 of the largest stock radiators, and that only achieved about 81% thermal efficiency with a temperature of 1422K

And shouldn't it be producing around 240 ec/second at this efficiency?

Currently it is producing about 11 ec/second, which i can get from 14 RTG's, at about a third of the mass.

 

Edited by Shrike99

Share this post


Link to post
Share on other sites

@Shrike99: The first part is due to ModuleCoreHeat being incomprehensible, and the NUK-3 ended up with a Max Cooling value lower than the Req'd Cooling value; another thing to fix next update. The efficiency issue took a bit more experimenting; apparently ModuleResourceConverter parts like the reactor now require an engineer on board to operate at something approaching full efficiency (When did this get implemented?); quick testing showed a drone core would get 5% reactor/ISRU output efficiency, a L0 engineer would get 25%, a L5 engineer would get 125%. I've figured out how to override this, so that will also get fixed next update.

Share this post


Link to post
Share on other sites
On 2/22/2017 at 3:27 PM, SuicidalInsanity said:

@Shrike99: The first part is due to ModuleCoreHeat being incomprehensible, and the NUK-3 ended up with a Max Cooling value lower than the Req'd Cooling value; another thing to fix next update. The efficiency issue took a bit more experimenting; apparently ModuleResourceConverter parts like the reactor now require an engineer on board to operate at something approaching full efficiency (When did this get implemented?); quick testing showed a drone core would get 5% reactor/ISRU output efficiency, a L0 engineer would get 25%, a L5 engineer would get 125%. I've figured out how to override this, so that will also get fixed next update.

Awesome news, thanks

Share this post


Link to post
Share on other sites

Update 1.7.35 is now up on SpaceDock and GitHub, and mainly contains fixes for the various issues identified since the last update.
Changelog:

Spoiler

1.7.35
====================================================
-Fixes Vector turbojet attach node
-fixes shrouded solar panel MaxTemp
-Fixes Chine Lift vector issue. Craft using chines will need to fix chine part orientation in the SPH/VAB
-Fixes NUK-3 reactor cooling issue
-Max level engineers no longer required for full reactor output, but engineers will provide slight boost to reactor efficiency
-Added USI compatibility MM patches courtesy of Merkov
-Fixes MM patch conflict with GTindustries
-Fixes NFE issue with the Pluto NTR
-New Part: Mk2 Structural tube
-New custom DragCubes for a few parts, should fix drag issues
-Model Rework: R-71 cockpit, adds second seat, new IVA


 

Edited by SuicidalInsanity

Share this post


Link to post
Share on other sites

Question:

When using Community Tech Tree, the J-58 "Afterburn" TurboRamJet engine is available at node "High Altitude Flight," while the stock JX-4 TurboRamJet engine is unlock at the next node, "Hypersonic Flight."  Why is this?  Feels a bit cheaty to have it available one node sooner. 

Share this post


Link to post
Share on other sites

@JayPee: I honestly don't remember. By mistake, probably. I've reupped a fixed version of 1.7.35 that fixes this.

@MannaroThePatient; Banshee fans have always used LF/O by default. The Electric or LF/Air fuel modes for the Banshee are provided via MM patches found in the Extras folder.

Edited by SuicidalInsanity

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.