Acea

[WIP][1.6.x_TEMPORARY FIX] NAS - Naval Artillery System 0.7.0 (BDAc Addon, WW2 Naval Weapons) - "Land of Dragon" - 2018/4/28

Recommended Posts

On 2017-04-27 at 2:52 AM, ColonelVInnie said:

I found a possible fix for the torpedoes on their floatiness. Lower the mass to 0.5 or 1 and they should float.

Checking now, will report back. The problem with the massive plume is in the unity export. It needs to be redone.

 

Edit: Found a fix for the buoyancy! Does NAS have a Git or how do I push my fix?

 

Edited by Wulfle

Share this post


Link to post
Share on other sites

Hello I have bug for report. I'm building my first destroyer and picked 12.7cm/50 3rd Year model C turret and the ship started spinning and flying into air soon aftfer launch. When I picked 10cm/65 Type 98 it works perfectly. I don't get any debug messages though in the console. The other turret works perfectly but I haven't tried other turrets yet. If you need any logs, pictures or anything, tell me. @Acea

Share this post


Link to post
Share on other sites
4 hours ago, Toonu said:

Hello I have bug for report. I'm building my first destroyer and picked 12.7cm/50 3rd Year model C turret and the ship started spinning and flying into air soon aftfer launch. When I picked 10cm/65 Type 98 it works perfectly. I don't get any debug messages though in the console. The other turret works perfectly but I haven't tried other turrets yet. If you need any logs, pictures or anything, tell me. @Acea

Is that still happening or is this a new event?   what are the masses of those two turrets you mention. Is this with LBP parts?

Edited by SpannerMonkey(smce)

Share this post


Link to post
Share on other sites
11 hours ago, SpannerMonkey(smce) said:

Is that still happening or is this a new event?   what are the masses of those two turrets you mention. Is this with LBP parts?

This is still happening since last time, but I figured out its only with that turret. The mass is almost same, just 1.6 ton different so with 2 turrets its 3.2 tonnes. But the ship isn't sinking by weight, its just flipping and jumping at incredible speeds. :D Yeah except NAS, the ship had only LBP parts and procedural wing parts + some BDA radars and stuff.  But when I release the ship without the wrong turrets, its operating normally, just as with the not problematic turrets...

 

Edited by Toonu

Share this post


Link to post
Share on other sites
On 5/10/2017 at 2:24 PM, Toonu said:

This is still happening since last time, but I figured out its only with that turret. The mass is almost same, just 1.6 ton different so with 2 turrets its 3.2 tonnes. But the ship isn't sinking by weight, its just flipping and jumping at incredible speeds. :D Yeah except NAS, the ship had only LBP parts and procedural wing parts + some BDA radars and stuff.  But when I release the ship without the wrong turrets, its operating normally, just as with the not problematic turrets...

 

Have you tried Kerbal Joint reinforcement or the like? I had a similar problem before the installation on boats flying to oblivion on launch, seems to be a physics bug in the stock game. On a side note I am getting an unknown problem of torpedo turrets being permanently on (turning only) after switching away from guard mode.

Share this post


Link to post
Share on other sites
Just now, ColonelVInnie said:

Have you tried Kerbal Joint reinforcement or the like? I had a similar problem before the installation on boats flying to oblivion on launch, seems to be a physics bug in the stock game. On a side note I am getting an unknown problem of torpedo turrets being permanently on (turning only) after switching away from guard mode.

 

Yes, I have KJR as essential (Always on modpack) mod, so that'S no problem there. And I also see that only that ONE turret is causing it. Other works like a charm...

Share this post


Link to post
Share on other sites
1 minute ago, Toonu said:

 

Yes, I have KJR as essential (Always on modpack) mod, so that'S no problem there. And I also see that only that ONE turret is causing it. Other works like a charm...

Strange. I'm not having a problem with that turret. May I know what exactly is the ship like and your physics settings? That might help, I would take a look since I have nothing to do.

Share this post


Link to post
Share on other sites
2 hours ago, ColonelVInnie said:

Strange. I'm not having a problem with that turret. May I know what exactly is the ship like and your physics settings? That might help, I would take a look since I have nothing to do.

What you need to know exactly?

Share this post


Link to post
Share on other sites
22 minutes ago, Toonu said:

What you need to know exactly?

The craft file could let me see if it is universal, and your physics settings like delta time might make a difference.

Share this post


Link to post
Share on other sites
20 hours ago, ColonelVInnie said:

The craft file could let me see if it is universal, and your physics settings like delta time might make a difference.

Its not stock, its Large Boat Parts ship with some from SM Marine and NAS, BDAc of course plus some utilities. Still wanna craft file? There it is! :D Oh...no...I deleted it because the ship didn't worked xD and logs are rewritten from that time :(

Delta time is set default, cause I've never had many problems with that. :) If you want, I can partially rebuild the ship but, you know...it won't be exactly same.

 

Share this post


Link to post
Share on other sites

I use 0 deltatime and have no problem by manually editing the settings file. Maybe that will help.

Share this post


Link to post
Share on other sites

I recently tested "naval mines" by dropping structural fuselages with bombs within and have ships run into them, while effective, they are very straining in fps and tend to explode on dropping, can you make a simple small 0.625m or smaller sphere bomb that has a low mass and floats, along with a delay before exploding?

Share this post


Link to post
Share on other sites
On 2017/5/28 at 7:51 PM, ColonelVInnie said:

I recently tested "naval mines" by dropping structural fuselages with bombs within and have ships run into them, while effective, they are very straining in fps and tend to explode on dropping, can you make a simple small 0.625m or smaller sphere bomb that has a low mass and floats, along with a delay before exploding?

Yeah that would be neat, and we're gonna consider this. Now we're busy getting our plugin to work under 1.3 and working on NAS localization.

Share this post


Link to post
Share on other sites

First off I LOVE LOVE LOVE your mod pack! ! And i read something aboot the torpedos, what was the fix for them as i have had a lot of troubles with them in my test navy battle 1.4 KSP The ship launched ones just sit there and sink. IS the mass value change the right way to go for now, or is there something more?

 

In my testing I am not sure if it is your mod, another mod, BDArmory or just the stupid game engine, But i can not have gunfire got any farther than 5km. I also needed to edit out the FSfuelSwitch module and just replace it with each ammo type that you was able to select. It is a dirty workaround but it works for now. 

Otherwise I have no complaints for 1.3 and NAS working toget. 

Share this post


Link to post
Share on other sites

Hey @Acea So I found a bug with Torpedos. They are having huge particle emitters that are even seen when zoomed out in space.

So I decided to make a fresh KSP 1.2.2 install. Got the Bare Essential mods that are needed to run NAS. 

The Images are in the Spoiler so that I don't make a huge forum post filled with pictures.

Spoiler

w0K1gYR.png

R8AJ2JN.png


here shows the log of when I fire a torpedo. Says there's an NullreferenceExeception 

k6urVBd.png

Please don't mind the name of the plane. I just name stuff so I could keep a file for in case I need to reload the game and test with the same vessel.

And Those who are not able to keep torpedos from sinking. I'd suggest going into their Configuration files and setting Buoyancy to either 0.5 or 1, Mass can Stay the same.

Share this post


Link to post
Share on other sites

After more testing I really believe that the power of the small guns should be lowered. They shred and spread heat too easily, while in real life it would have taken several hits. Referring to the 13 and 20mm AA guns.

Share this post


Link to post
Share on other sites
7 hours ago, lancefoxcia said:

Hey @Acea So I found a bug with Torpedos. They are having huge particle emitters that are even seen when zoomed out in space.

And Those who are not able to keep torpedos from sinking. I'd suggest going into their Configuration files and setting Buoyancy to either 0.5 or 1, Mass can Stay the same.

I have noticed that also, I fire a torpedo and almost as soon as the torpedo hits the water, it stops moving forward and rapidly sinks. I have also noticed the same effect that Lancefoxcia posted. 

 

I will also attempt to raise the Buoyancy and see if dat works.

 

Share this post


Link to post
Share on other sites

The effect that you and Lancefoxcia are noticing is a problem I believe with the shaders which were updated in 1.2, and I wanna say it was affecting a few other mods too.  I think all we can do is wait on a fix from the NAS crew.

Share this post


Link to post
Share on other sites

I do hope that there would be a 1.2 fix for the effects before moving on to 1.3, not all mods update that often after all.

On a side note I notice the lack of a 6 inch dual mount turret. Preferably a British one, like on the Leander. While I can make do with destroyers by making other turrets pretend to be different calibers (and copy and paste edit the files for my purpose), a 6 inch dual mount is just not at the right size.

Though I did find the 5.25 ones for the Dido in SM armory though, so thank him for that.

Share this post


Link to post
Share on other sites
On Thu Jun 08 2017 at 6:43 PM, ColonelVInnie said:

I do hope that there would be a 1.2 fix for the effects before moving on to 1.3, not all mods update that often after all.

On a side note I notice the lack of a 6 inch dual mount turret. Preferably a British one, like on the Leander. While I can make do with destroyers by making other turrets pretend to be different calibers (and copy and paste edit the files for my purpose), a 6 inch dual mount is just not at the right size.

Though I did find the 5.25 ones for the Dido in SM armory though, so thank him for that.

On Wed Jun 07 2017 at 9:30 AM, The_Right_Arm said:

The effect that you and Lancefoxcia are noticing is a problem I believe with the shaders which were updated in 1.2, and I wanna say it was affecting a few other mods too.  I think all we can do is wait on a fix from the NAS crew.

On Sat Jun 03 2017 at 3:56 PM, Damaske said:

I have noticed that also, I fire a torpedo and almost as soon as the torpedo hits the water, it stops moving forward and rapidly sinks. I have also noticed the same effect that Lancefoxcia posted. 

 

I will also attempt to raise the Buoyancy and see if dat works.

 

On Sat Jun 03 2017 at 8:00 AM, lancefoxcia said:

Hey @Acea So I found a bug with Torpedos. They are having huge particle emitters that are even seen when zoomed out in space.

So I decided to make a fresh KSP 1.2.2 install. Got the Bare Essential mods that are needed to run NAS. 

The Images are in the Spoiler so that I don't make a huge forum post filled with pictures.

  Reveal hidden contents

w0K1gYR.png

R8AJ2JN.png


here shows the log of when I fire a torpedo. Says there's an NullreferenceExeception 

k6urVBd.png

Please don't mind the name of the plane. I just name stuff so I could keep a file for in case I need to reload the game and test with the same vessel.

And Those who are not able to keep torpedos from sinking. I'd suggest going into their Configuration files and setting Buoyancy to either 0.5 or 1, Mass can Stay the same.

Sure we have a fix, right here, just done yesterday. You can grab it HERE. Also I'd provide a preview of the next version.

Do remember to delete all the specified folders in GameData\NAS and Module Manager caches before merging them in, or something bad may happen.

 

P.S. We need your help with the localization progress of NAS. Thanks to any of you who're willing to help us improve it.

 

EDIT: After discussions we decided that it should be better to open our localization files pending translated to the community, which would be more convenient and community-alike, also we can gather more help easily. Anyone could edit this, so please leave your ID in the quotes for us to credit your contributions.

Español: DONE ON 2017/06/20

Русский: https://docs.google.com/document/d/1eXUhlGmZSuGViQ_SwiKMURhPH4-VCeA9h-Lh52Ru_wk/edit?usp=sharing

 

On Sat Jun 03 2017 at 10:23 AM, ColonelVInnie said:

After more testing I really believe that the power of the small guns should be lowered. They shred and spread heat too easily, while in real life it would have taken several hits. Referring to the 13 and 20mm AA guns.

We've been mentioned for a couple of times, and I guess that's something need to be done in next version.

Share this post


Link to post
Share on other sites

Is it just me or the Mark 15s have incorrect attachment nodes? Why is it in the center?

I changed the node from this:

node_stack_bottom = 0.0, 0.0, 0.0, 0, 0, -1, 2

to this

node_stack_bottom = 0.0, 0.0, -3.7, 0, 0, -1, 2

Edited by ColonelVInnie
Found a manual editing solution for the problem.

Share this post


Link to post
Share on other sites
5 hours ago, ColonelVInnie said:

Is it just me or the Mark 15s have incorrect attachment nodes? Why is it in the center?

I changed the node from this:

node_stack_bottom = 0.0, 0.0, 0.0, 0, 0, -1, 2

to this

node_stack_bottom = 0.0, 0.0, -3.7, 0, 0, -1, 2

We've redefined some settings in models of all torpedoes, maybe some mistakes were made then. Will make a quick fix, sorry about that.

 

EDIT: Done

Edited by Acea

Share this post


Link to post
Share on other sites

I have been working on many ships, so I decided to share one of them. This is the Scharnhorst sailing the blue seas.vMBUBrh.pngIt is somewhat inaccurate though.

Spoiler

12 inch guns instead of 11,

Lazily modified 5" guns to be 150 mm German ones,

Simplified superstructure to reduce part count,

Welded and more modified configs to prevent blowing up.

 

Share this post


Link to post
Share on other sites

fKaL2XC.png

Updatelog 0.6.5 (IMPORTANT) - "Crossroads"
*Special thanks to forum user eboshi, who greatly helped with localization progress of NAS!
Updated plugins for compatibility with KSP 1.3, and added the function of setting depths of all torpedoes/depth charges on board (UI localized in simplified Chinese and Japanese).
Updated to latest C.A.L++.
Tweaked Fritz X Guided Anti-ship Glide Bomb so it can work more smoothly.
Removed LoadingTipsPlus configuring file.
Rebalanced small caliber AA weapons, now they should be about 1/3 less powerful, and buffed range of Type 96 25 mm AT/AA Gun Triple Mount.
Overhauled all the tags, now it would be easier to search any parts.
Applied new exhaust effects to all torpedoes/rockets and Fritz X, now they behave normal.
Applied armor piercing settings to CA/BB guns, and rebalanced their powers.
Added localization support to simplified Chinese and Japanese. Sorry that we only have speakers of these two languages among our team members and volunteers, please help us with all these untranslated texts.
Added 2 new parts:
 - Kriegsmarine: 28 cm SK C/28 Twin Turret
 - US Army: 14-inch M1909 Twin Turret (Fort Drum Type)

P.S. in case anyone didn't see the announcement above, after discussions we decided that it should be better to open our localization files pending translated to the community, which would be more convenient and community-alike, also we can gather more help easily. Anyone could edit this, so please leave your ID in the quotes for us to credit your contributions.

Español: DONE ON 2017/06/20

Русский: DONE ON 2017/06/27

Edited by Acea

Share this post


Link to post
Share on other sites

What exactly is an "Armor piercing setting"? Since I only line the sides of ships with a layer of damageable components would it cause problems to destroying those? If it does all I can say is MLGB.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.