Pak

[1.7.1] Cormorant Aeronology - Mk3 Space Shuttle

Recommended Posts

So, I don't know if there is something wrong with the mod or something wrong with how I'm flying the shuttle, but I cannot do the roll maneuver. Whenever I try, even with fine controls on, the shuttle yaws WAY off to the side. SAS doesn't seem to want to compensate for this, and manual compensation is extremely hard to do. I end up several degrees off of my preferred orbital inclination.

I'm using the provided craft, before you ask, and it does this with or without a payload. Control surfaces are disabled during ascent and the 2-axis gimbal is disabled while SRB's are attached (enabled once separated, as per the instructions.)

So, is there something wonky with KSP's physics? Am I doing anything wrong? Or is there an autopilot mod that I should use? Mechjeb often times ends up spinning the shuttle out of control, so that doesn't seem to be an option.

Help would be appreciated.

Share this post


Link to post
Share on other sites
2 hours ago, Raptor22 said:

So, I don't know if there is something wrong with the mod or something wrong with how I'm flying the shuttle, but I cannot do the roll maneuver. Whenever I try, even with fine controls on, the shuttle yaws WAY off to the side. SAS doesn't seem to want to compensate for this, and manual compensation is extremely hard to do. I end up several degrees off of my preferred orbital inclination.

I'm using the provided craft, before you ask, and it does this with or without a payload. Control surfaces are disabled during ascent and the 2-axis gimbal is disabled while SRB's are attached (enabled once separated, as per the instructions.)

So, is there something wonky with KSP's physics? Am I doing anything wrong? Or is there an autopilot mod that I should use? Mechjeb often times ends up spinning the shuttle out of control, so that doesn't seem to be an option.

Help would be appreciated.

KSP SAS isn't great with asymmetric rockets. There is no real way around this, though something like atmospheric autopilot helps a lot. So it is not your fault.

try this mod, as far as I know it still works:

 

Share this post


Link to post
Share on other sites

the cockpit interior of mk3 block 2 is not showing anything, it just plain white, how to fix this?

Edited by Pirje

Share this post


Link to post
Share on other sites
16 hours ago, Raptor22 said:

Mechjeb often times ends up spinning the shuttle out of control

I got around this in MechJeb by using "Hybrid" under "Attitude Adjustment."  Set the roll to something like 2 and the other number (above it) to 1.5 to get nice, precise movements.

I can do full automated launches to ~almost~ orbit, (200 x 45ish) dump the ET, then circularize with OMS.

I also set this down at KSC every single time.

Share this post


Link to post
Share on other sites
14 hours ago, lrd.Helmet said:

KSP SAS isn't great with asymmetric rockets. There is no real way around this, though something like atmospheric autopilot helps a lot. So it is not your fault.

Huh, I thought that Atmospheric Autopilot was just for aircraft (hence "Atmospheric"). I didn't know it would work as a launch autopilot as well. I'll have to give that a shot.

42 minutes ago, slaintemaith said:

I got around this in MechJeb by using "Hybrid" under "Attitude Adjustment."  Set the roll to something like 2 and the other number (above it) to 1.5 to get nice, precise movements.

I can do full automated launches to ~almost~ orbit, (200 x 45ish) dump the ET, then circularize with OMS.

I also set this down at KSC every single time.

I'll have to try that. I was looking for something similar, trying to use SmartASS, but it seems that either I'm thinking of the wrong thing or they've simplified it since I last used it... oh, back in 1.1.3 I'd have to say. I swear that it you used to be able to put specific values into SmartASS (heading, roll, and pitch in degrees) to get it to execute precise maneuvers.

I've tried a lot of stuff, but it really is just a beast to control without guidance. I found that disabling the yaw on the SRB's did help a small bit with the yawing to the side (seems counter-intuitive, I know), but it still does go to the side and then I have the issue with not being able to correct that yaw, albeit reduced from earlier. It also seemed to stop this oscillating effect that I had with it on.

Either way, I'll have to give Atmospheric Autopilot and hybrid attitude adjustment a shot. Thanks for the help.

I've had a lot of fun with this mod. It makes me wish that the shuttle program lived up to what it was hoped to be, and continued to this day.

screenshot97.png

Share this post


Link to post
Share on other sites

Even with the SRB's attached?
I thought that it was only 1-axis pitch gimbal until the SRB's separated, then the 2-axis pitch, yaw, and roll kicked in.

I've tried that as well, with mixed results. But, I haven't tried it with mechjeb. At this point, it's worth a shot.

Share this post


Link to post
Share on other sites
24 minutes ago, Raptor22 said:

Huh, I thought that Atmospheric Autopilot was just for aircraft (hence "Atmospheric"). I didn't know it would work as a launch autopilot as well. I'll have to give that a shot.

Yeah it is. Though I found that it works pretty well as an fly-by-wire system. Might need to turn moderation on or off though during launch. Reentry with the autopilot is amazing, as long as you switch off moderation.

Share this post


Link to post
Share on other sites

Alright, I'll have to give it a try.

Atmospheric autopilot is quite unfamiliar to me, but with time I bet I can learn it.
I might give kOS a shot, as well, but that's a whole new beast in itself.

I'll let you know how it turns out.

Share this post


Link to post
Share on other sites

MechJeb Settings for Ascent:
Alt: 200
Inc: Whatever
Prevent overheat
Limit Q to 20000
Limit Accel: 29 m/s (Limits accel to 3g--realistic)
Keep Limited Throttle over: 59% (realistic)
Force roll: 180 climb 180 turn
Limit AoA: uncheck
Corrective Steering: check Gain 0.6
Autostage: on
(use default settings until)
Stop at Stage # (insert stage after SRB sep here)

Edit Ascent path: check.

Ascent Path Editor:
Automatic Altitude Turn: uncheck
Turn Start Altitude .5
Turn Start Velocity 75
Turn End Altitude 80 (65ish if stock size)
Final Flight Path Angle: -1
Turn Shape: 45

Mind you, during the top end of ascent when apoapsis starts to increase rapidly, I flip the shuttle over right-side up by changing the 180 climb number to 0.  You'll have to get a feel for this.
Once MechJeb finishes part 1 of ascent, you should be somewhere around 200km x 20-65km.  Ditch the ET and let MJ finish orbital insertion with the OMS engines.  I have action groups set up for all these things, but do however you prefer.  


Here's a video.

 

Edited by slaintemaith

Share this post


Link to post
Share on other sites

One thing that I did notice with the provided craft files is that the actuation for the RCS is a bit weird.

On the US shuttle, yaw and roll are disabled on the nose. On the OMS, on one side the roll is disabled and on the other yaw is disabled. It doesn't make much sense why the RCS would be disabled, especially when you disable some axes on one side but not the other. I'm going to guess that it was a mistake, but it's still kind of weird.

Similar thing with the Buran, as well. It's also weird that the boosters separate in two pairs, when they all burn out at once. Are they supposed to burn so that one pair is expended and jettisoned, and then the other, and just the fuel flow got messed up?
I dunno. It seems weird. Gimbal is also disabled on the core engines, and from what I've read those engines should have at least a 7 degree gimbal.

Also, are the control surfaces supposed to be disabled on launch? I'd imagine so, but seeing all of these controls (RCS, gimbals, etc.) being disabled kind of in a nonsensical way (asymmetric RCS authority on port and starboard, etc.), it's kind of hard to tell if this is another mistake.

Share this post


Link to post
Share on other sites

I ditched the provided craft files and built it myself from the parts.  In this way I could put another control core in the back, tweak it to the same angle as the OMS engines and have better control in orbit. 

The parts themselves have wonky default RCS settings.  And the tail has a reversed brake.  And I think the body flap is 'off' by default.

I don't disable the control surfaces with my MechJeb ascents.  It's just one more thing I'd forget to enable later on.

Share this post


Link to post
Share on other sites

Hi, so no matter what, after reaching 10km and being around 45 degrees pitch, I can then hold it there until 50km to then level out. The shuttle even with me fighting it levels out at around 20-30km. Any suggestions?

Share this post


Link to post
Share on other sites
On 11/3/2018 at 2:38 AM, SquaredSpekz said:

Hi, so no matter what, after reaching 10km and being around 45 degrees pitch, I can then hold it there until 50km to then level out. The shuttle even with me fighting it levels out at around 20-30km. Any suggestions?

I only ever do automated launches, so I don't have this issue--I'll ask: do you roll "Shuttle-side down" before pitching?  I think if you attempt ascent "Shuttle side up" you'll have this sort of behavior.

Edited by slaintemaith

Share this post


Link to post
Share on other sites

One part that seems to have vanished in the merging of MrMeeb's Shuttle Payload Tech mod with Pak's Cormorant Aeronology mod is MrMeeb's shuttle comms antenna

Share this post


Link to post
Share on other sites

Something strange is happening.

I downloaded this mod back in 1.3, updated to 1.3. There was no problem except, there were no parts!

I heard it was updated, and downloaded to 1.5. The same problem is here.

I decided to upon the Debug Toolbar and look through the "parts" directory. I scrolled and found every part that was supposed to be there, the SpaceShuttle file, and the add-ons. Despite this, there were no parts in the V.A.B. I would like to know your take one this, personally I believe I may have downloaded this wrong!

Here's my directory for this mod:

C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Cormorant Aeronology 1.5.1

This is where the file "Cormorant Aeronology," firespitter.dll, and ModuleManager.3.0.7.dll are located.

Let me know what you can find out!

Share this post


Link to post
Share on other sites
6 hours ago, Berad said:

Something strange is happening.

I downloaded this mod back in 1.3, updated to 1.3. There was no problem except, there were no parts!

I heard it was updated, and downloaded to 1.5. The same problem is here.

I decided to upon the Debug Toolbar and look through the "parts" directory. I scrolled and found every part that was supposed to be there, the SpaceShuttle file, and the add-ons. Despite this, there were no parts in the V.A.B. I would like to know your take one this, personally I believe I may have downloaded this wrong!

Here's my directory for this mod:

C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Cormorant Aeronology 1.5.1

This is where the file "Cormorant Aeronology," firespitter.dll, and ModuleManager.3.0.7.dll are located.

Let me know what you can find out!

extract the contents of "cormorant Aeronology 1.5.1" into gamedata. 

The game data folder should contain (at least):
- Squad
- Squadexpansion (if you have the dlc)
- Cormorant Aeronology
- Modulemanager 3.0.7.dll
- Firespitter

Share this post


Link to post
Share on other sites
15 hours ago, StevieC said:

One part that seems to have vanished in the merging of MrMeeb's Shuttle Payload Tech mod with Pak's Cormorant Aeronology mod is MrMeeb's shuttle comms antenna

The comms antenna was never included in SPT from the beginning IIRC, MrMeeb disappeared before he finished it.

Share this post


Link to post
Share on other sites
12 minutes ago, sslaptnhablhat said:

The comms antenna was never included in SPT from the beginning IIRC, MrMeeb disappeared before he finished it.

Thats wrong. Mr.Meeb added the KU-Band-Antenna with Beta 0.21 (31. March 2017, page 8 in SPT-Thread).

Quote

Changelog:
- KU Band Antenna added
- Balancing fixes
- Tiled control surfaces added
- Cormorant Aeronology tankage support added - ModuleManager will detect whether you have CA or DIRECT installed and display the appropriate parts. If you have both, there shouldn't be any issues I don't think
- Specular issue fixed with Shuttle Cockpit (thanks Avalon304)
- Texture updated on Shuttle Cockpit
- Daelkyr's Mid Deck IVA supported added
- Possibly other things

 

Share this post


Link to post
Share on other sites
1 hour ago, sslaptnhablhat said:

The comms antenna was never included in SPT from the beginning IIRC, MrMeeb disappeared before he finished it.

xObVUqk.png

Share this post


Link to post
Share on other sites

Hello,

I have some issues with textures on some parts, they appear black im running V1.5.1,  the following are the parts with issues

Igloo, Inglet, Eexperiment airlock, Inline airlock, tunnel adapter, and both structural tunnels.

Any advise?

Edited by djv25

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.