• 0
Insidious500

I think its a bug ? idk whats going on

Question

I need help with this potential bug, I really do not want to restart my game again, even more so when that may not even fix this problem.

Anyways, on to my problem! All the sudden I can't use items that I had researched. It first started with just one item, but now I can't use 2 items form the same category. I just used these 2 items to build a jet and I flew it. I went to go build a better jet and I couldn't find the air intake. So I loaded my old jet up and even though it has the intake it says in red letters *** CONTAINS LOCKED OR INVALID PARTS***. When I try to fly the jet it does not let me (because of the parts).
 
Things I've tried to do, for a fix - Verify integrity of game cache (through steam) When doing this it says "1 files failed to validate and will be reacquired." 
 
I also loaded an old saved file, this save file happened to be the one I used when I first flew my jet with no problem, and it still gives me the same message when i try to fly it.
 
I uninstalled the game (kept my saved files) reinstalled it, and still getting the same message.
 
I googled it for an hour and found nothing.
 
And yes I went back to make 100 % sure the 2 parts were still in the same place on the tec tree, and sure enough they are still under aviation, and its still unlocked, I can use all the other parts under aviation. On a side note, there are 38 copies of the Mk1 cockpit for whatever reason. I don't think it was like that before.
 
The two parts that I can't use are Delta-Deluxe winglet and XM-G50Radial Air intake.
 
Any help would be great, I feel like playing anymore of this could be a waste of time if I can't use the things I unlock. Sadly, that means I'm not going to play until this is sorted out . (sucks cuzz I really wanna play)
 
After typing this I also went back and checked sandbox mode, sure enough the same parts are grayed out and I can't even select them, there are more parts that I can't use in sandbox mode.
 
A fix for this problem would be amazing! Thanks

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

you should upload your persistent .sfs file and .craft file so people can check this :) 

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, sgt_flyer said:

you should upload your persistent .sfs file and .craft file so people can check this :) 

Hey man, I'm not sure where those files are. I looked but did not see them. let me know where they should be and ill grab them! 

Thanks!

Share this post


Link to post
Share on other sites
  • 0

all of this is in the game's save folder :) (the subfolder has the name you chose at creation when you picked career, science or sandbox mode) 

if you can zip the whole subfolder which has the name of your career save, and upload it, (on dropbox or google drive for example) then share the link like that people will be able to test your save directly :)

Share this post


Link to post
Share on other sites
  • 0
12 minutes ago, sgt_flyer said:

all of this is in the game's save folder :) (the subfolder has the name you chose at creation when you picked career, science or sandbox mode) 

if you can zip the whole subfolder which has the name of your career save, and upload it, (on dropbox or google drive for example) then share the link like that people will be able to test your save directly :)

Ok here is the saved file the problem started on. (Dropbox)

https://www.dropbox.com/s/5vm2bpi9lejl9zs/Andrew500.zip?dl=0

Share this post


Link to post
Share on other sites
  • 0

 

@Insidious500

ok, i checked out, looks like your research tree is corrupted in your save (by comparing the aviation research node of a fresh carreer save to your own) - the aviation research node in a fresh 1.1 save doesn't have wheesleys or delta-deluxe winglets in it (so that would explain why they are considered 'invalid').

here's the aviation node on the research tree of your save (weirdly plenty of MK1 cockpits btw !).

UTCIrpx.jpg
 
here's what the same node on a fresh 1.1 carreer research looks like :
 
t5PTpuv.jpg

 

did you start your career save pre 1.1 ? maybe the research tree in your save got corrupted during the switch to 1.1. Or if you started the career pre 1.1, maybe you had a modded research tree but forgot about it.

 

 

 

Edited by sgt_flyer

Share this post


Link to post
Share on other sites
  • 0

hmmmm interesting, I just started playing again yesterday, which is when I started that new game. 

 

Currently the game is up to date, I'm unsure if it was updated when I started the game.

 

Was the items totally removed from he game ? Or are they just later in the tec tree?

 

I guess its possible I modded it at some point, sadly I don't remember ever doing that.

 

You have any suggestions? 

 

 

Edited by Insidious500

Share this post


Link to post
Share on other sites
  • 0

This happened to me in pre-release, but I was a build behind so didn't report it. It was like my entire career reset to day 0. Cash, rep, science, tech. I don't remember but I think it also reset my contacts.

Edited by 5thHorseman

Share this post


Link to post
Share on other sites
  • 0
47 minutes ago, Insidious500 said:

hmmmm interesting, I just started playing again yesterday, which is when I started that new game. 

 

Currently the game is up to date, I'm unsure if it was updated when I started the game.

 

Was the items totally removed from he game ? Or are they just later in the tec tree?

 

I guess its possible I modded it at some point, sadly I don't remember ever doing that.

 

You have any suggestions? 

 

 

on my 'fresh' save the Delta-deluxe winglet is on the 'control' node at the same level of the tree than the aviation node. the wheesley and the radial intake is on the node just 1 level deeper in the tree after the aviation node - both of those are not yet researched in your tech tree :) - so it would look like more what you 'see' isn't the real stock tech tree the game refers too when testing if the parts are avaible.

 

Edited by sgt_flyer

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.