Jump to content

[1.11.x] The Malemute Rover


RoverDude
 Share

Recommended Posts

46 minutes ago, RoverDude said:

I'll have to peek RE tech tree placement, especially with CTT.  Possibly make them peers, as they have different purposes (the Karibou, now bundled with MKS, being more of a mobile base platform)

Thanks. Love the mods btw. The malamute is so cute!!!

Maybe the basic command pod, wheels, airlock and possibly a crew cabin could be put in earlier on, with the other stuff later down the line. I will have a look at writing a cfg tomorrow maybe.

Are you thinking of adding some sort of rear airlock to the karibou like the malamute has to "cap it off" neatly. Best phrase I could think of for it. Unless I have missed a piece, not got it in career yet and only had a quick look at it in sandbox.

Merry Christmas!

Link to comment
Share on other sites

Forgot how easy it is when the cfg is already written :P

 

Spoiler

//by SirCharizard17
@PART[Malemute_RoverFlatBed]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_RoverScienceLab]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_RoverServiceBay]:NEEDS[CommunityTechTree]
{
    @TechRequired = advExploration
}
@PART[Malemute_RoverTail]:NEEDS[CommunityTechTree]
{
    @TechRequired = advExploration
}
@PART[Malemute_RoverTankLong]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_RoverTankShort]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_RoverWheel]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_ExpandingDockingPort]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_MiniWheel]:NEEDS[CommunityTechTree]
{
    @TechRequired = advExploration
}
@PART[Malemute_RoverCab]:NEEDS[CommunityTechTree]
{
    @TechRequired = advExploration
}
@PART[Malemute_RoverCargoBed]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_RoverCrewCab]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}
@PART[Malemute_RoverDockModule]:NEEDS[CommunityTechTree]
{
    @TechRequired = experimentalScience
}

 

Link to comment
Share on other sites

  • 2 weeks later...

@RoverDude, I saw that you merged my fix for the lab, and I just downloaded v0.2.5.0, but the only differences are in the changelog (mentioning the bugfix) and in the version file (bumping the number).  The actual .cfg file is unchanged and still has RequiresAnimation set to True.

Did you accidentally build the release zip from your DEVELOP branch instead of from the 0.2.5.0 tag on master?

Link to comment
Share on other sites

51 minutes ago, thesandbar said:

This probably isn't the place to ask... but eh... does anyone know where the old MKS thread went? It seems like it just disappeared.

One of the forum mods had a fat-finger moment and deleted every thread on the front page of releases - there's details in a pinned thread.  They're trying to get them back, if they can.

Link to comment
Share on other sites

RD,

   I just have to ask why Patreon? I would love to support you directly through Paypal, but I cant be bothered to make a Patreon account and manage all the nonsense that comes with it just to send you some coffee funds. 

If you put up a paypal link on the USI catalog page, I will make a not insignificant donation, today! 

Link to comment
Share on other sites

2 hours ago, RoverDude said:

That link isn't the correct one. You totally got my hopes up. I just came home from work on payday looking forward to sending you a weeks worth of Starbucks. Well, shucks!

Let me know when you got this straightened out. I've been using versions of your mods for quite some time. My occupation has finally taken a turn for the better and I'm happy to offer my support in exchange for your continued production and maintenance of these works. 

Link to comment
Share on other sites

2 minutes ago, Aaron Also said:

That link isn't the correct one. You totally got my hopes up. I just came home from work on payday looking forward to sending you a weeks worth of Starbucks. Well, shucks!

Let me know when you got this straightened out. I've been using versions of your mods for quite some time. My occupation has finally taken a turn for the better and I'm happy to offer my support in exchange for your continued production and maintenance of these works. 

heh, should have double checked it :D

Fixed!

Link to comment
Share on other sites

On 1/9/2017 at 7:33 PM, marchingknight11 said:

I'm having trouble with the rover.  In fact, all the USI rovers seem to have a problem where the wheels don't work.  I attach them and the right click menu shows that the motor is running but the rover doesn't move at all.

I believe this has been linked to using the wrong attach points, but if you attach a craft file I'll take a look.

Link to comment
Share on other sites

On 10/01/2017 at 0:33 AM, marchingknight11 said:

I'm having trouble with the rover.  In fact, all the USI rovers seem to have a problem where the wheels don't work.  I attach them and the right click menu shows that the motor is running but the rover doesn't move at all.

Check out the KSPedia entry. It has all the wheel orientation diagrams.

wheelprofile.png

wheelminiprofile.png

Link to comment
Share on other sites

So, I've just installed this mod today, but for reasons unknown it's not showing up in career mode. The parts do show up in Sandbox mode, however. I had looked at previous posts and checked for the typo in the CFG file, and even tried changing the CFG file for one of the parts to require a lower-tier technology. That appeared to have no effect, unfortunately but that appeared to have no effect. Here is the list of mods I have installed (via CKAN):

  • B9 Part Switch
  • Better Burn Time
  • Community Resource Pack
  • Contract Configurator
  • DeepFreeze Continued
  • Firespitter Core
  • ForScience! (installed manually)
  • Hide Empty Tech Tree Nodes
  • Indicator Lights
  • Kerbal Attachment System
  • Kerbal Inventory System
  • Kopernicus Planetary System Modifier
  • Malemute Rover
  • MechJeb 2
  • ModularFlightIntegrator
  • Module Manager
  • Outer Planets Mod (installed manually)
  • Precise Node (installed manually)
  • RCS Build Aid
  • SCANSat
  • Smokescreen
  • Trajectories (installed manually)
  • USI Tools
  • Waypoint Manager

Any idea what the issue is or what the fix may be? Let me know if you need any additional information as well.

 

EDIT:  SOLVED! I tried uninstalling and reinstalling all of my mods except for the Malemute, and all of the parts mysteriously started showing up in the tech tree. Go figure!

Edited by ThePsion5
Link to comment
Share on other sites

  • 2 weeks later...

Would it be possible to add a fuel cell to the Malemute cockpit in a future release, or perhaps in the rear segment?

I really like using it, but the shape of the parts makes it difficult to attach solar panels or fuel cells ( in a nice looking way, at least ). Also, it seems weird that the tiny Akita rover has an integrated fuel cell and the more complicated Malemute does not.

That said, awesome mod ( as well as your others )!

Link to comment
Share on other sites

1 hour ago, Mudwig said:

Would it be possible to add a fuel cell to the Malemute cockpit in a future release, or perhaps in the rear segment?

I really like using it, but the shape of the parts makes it difficult to attach solar panels or fuel cells ( in a nice looking way, at least ). Also, it seems weird that the tiny Akita rover has an integrated fuel cell and the more complicated Malemute does not.

That said, awesome mod ( as well as your others )!

I find RTGs attach very neatly to the bottom on unused wheel attachment nodes.  :wink:

Link to comment
Share on other sites

This is probably a very noob question, but I'm trying to install this mod and when I run the game, there are no extra parts in my inventory. Obviously I'm doing something wrong. I've never messed around with game files on any other game before. I've managed to install MechJeb and a couple of other mods without much trouble. Here's what I'm doing:

1) Download zip file Malemute.

2) Extract to KSP -> Game Data

3) Start game.

Any ideas?

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
4 hours ago, Vanguard-Warden said:

Hello

I don't understand, no part show up in sandbox, and i don't understand what i should find in the .zip to make it work... :/

 

I only find the part in the tech tree in the R&D building when i start a new game in career mode, how can i fix that? 

Pics of your GameData and UmbraSpaceIndustries folders would good - if it's not showing up likely you have something missing or misplaced.

Link to comment
Share on other sites

Looks good to me, though you can probably delete the '.DS_Store' file - that's Mac-only, and likely came from some pack where the mod author didn't realize it was there.  (On a Mac it's invisible, and it's hard to remove.)

Just to be sure: You aren't seeing the 'Rovers' tab in the side menu at all?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...