icedown

[1.5.1] Cacteye Optics Community Takeover: Updated 10/22/2017

Recommended Posts

29 minutes ago, icedown said:

Was this prior to 1.2?

With current 1.2.1; Kerbol Origins and Extrasolar with 1.1.x

Share this post


Link to post
Share on other sites

@icedown Is there a way to increase the range/zoom level/magnification on the telescopes? i've got some distant bodies that are just way too far out to be seen.

Share this post


Link to post
Share on other sites

What planet pack are you using, I'll take a look at it.  Its a section I'm working on rewriting right now.

Share this post


Link to post
Share on other sites

Hey I made this latest mission using the space shuttle for paks mod to launch the amazing cacteye hubble telescope, so i though i might as well show it off!

Just 2 things though... 1 when i was looking at eve, (seen in the album) it was kinda fuzzy, is that meant to be? (was using the number 3 wide camera) and 2 @CobaltWolf, are you still goinf to revamp the Hubble based telescope or not?

Anyway here's the album: http://imgur.com/gallery/JfyvY

Share this post


Link to post
Share on other sites
6 hours ago, SpaceBadger007 said:

Hey I made this latest mission using the space shuttle for paks mod to launch the amazing cacteye hubble telescope, so i though i might as well show it off!

Just 2 things though... 1 when i was looking at eve, (seen in the album) it was kinda fuzzy, is that meant to be? (was using the number 3 wide camera) and 2 @CobaltWolf, are you still goinf to revamp the Hubble based telescope or not?

Anyway here's the album: http://imgur.com/gallery/JfyvY

I, uh, forgot that I hadn't finished it actually. I also didn't push my update for Taerobee, come to think...

Share this post


Link to post
Share on other sites

well i am kind of thinking of getting a mod or two and i need to ask. will science mods like these increase the speed i can get and unlock new parts? and how much? i don't want things that make the career easyer and stuff ofcourse.

Share this post


Link to post
Share on other sites
6 hours ago, jevry said:

well i am kind of thinking of getting a mod or two and i need to ask. will science mods like these increase the speed i can get and unlock new parts? and how much? i don't want things that make the career easyer and stuff ofcourse.

Just turn down the science return % when you start a new career.

Share this post


Link to post
Share on other sites

I don't know if it's intentional, but once you've gotten all science from observing a body you end up with 0 data to be transmitted back and thus, if you get a later contract mission to make an observation you can't complete it as it doesn't really transfer any data.

Share this post


Link to post
Share on other sites
5 minutes ago, Viper_607 said:

I don't know if it's intentional, but once you've gotten all science from observing a body you end up with 0 data to be transmitted back and thus, if you get a later contract mission to make an observation you can't complete it as it doesn't really transfer any data.

It is something that is hard to keep from happening as you can't gather all the science of a body until you have the fully upgraded processor.  The lower level ones limit the maximum science that can be obtained from them.  I will see if there is anything I can do with it though.

Edited by icedown

Share this post


Link to post
Share on other sites

Hi. First i want to thank you for continuing this mod had it installed on a previous version but didn't get use it. Anyway are the orbital lines or whaterver you want to call them supposed to show up in the GUI? I was looking at Jool and i see it like i was in map mode from kerbin. Im just asking if it's not working correctly. :D Added the image in the link. http://imgur.com/XCuwBCP

 

Share this post


Link to post
Share on other sites

Is there a reason my telescopes won't use attached antennae and will only use a probe core to transmit science?

Share this post


Link to post
Share on other sites

@EmilOrbiter96  I'm not sure about that.  I have not seen that before.  Can you post your output_log.txt

 

@archnem  I'm not sure what mean.  They scope has to have some form of probe core on board to operate.  The only part that this mod has that can act as a core is the Slim probe core that is side attached.  Just attaching an antenna to the parts with out the slim probe part or another probe/manned part will not allow the scope to transmit.

Edited by icedown

Share this post


Link to post
Share on other sites
1 hour ago, icedown said:

@EmilOrbiter96  I'm not sure about that.  I have not seen that before.  Can you post your output_log.txt

 

@archnem  I'm not sure what mean.  They scope has to have some form of probe core on board to operate.  The only part that this mod has that can act as a core is the Slim probe core that is side attached.  Just attaching an antenna to the parts with out the slim probe part or another probe/manned part will not allow the scope to transmit.

If I have a telescope with a probe core and antenna, it always uses the probe core to transmit science and never the antenna.  Which ofc, takes forever. I've tried multiple configurations of various cores and antennae, and it always ignores the antenna and uses the core to transmit.

Share this post


Link to post
Share on other sites

On 29/01/2017 at 11:27 PM, icedown said:

@EmilOrbiter96  I'm not sure about that.  I have not seen that before.  Can you post your output_log.txt

 

@archnem  I'm not sure what mean.  They scope has to have some form of probe core on board to operate.  The only part that this mod has that can act as a core is the Slim probe core that is side attached.  Just attaching an antenna to the parts with out the slim probe part or another probe/manned part will not allow the scope to transmit.

 https://www.dropbox.com/s/sxg9dk25z8yagpo/output_log.txt?dl=0 here is the output log.

Share this post


Link to post
Share on other sites

@archnem I do not have control over how the data gets transmitted.  Once the I generate the science, it is handed over to r&d system of ksp to be handled and from what I understand it generally chooses the best available transmission device on the vessel.  Since the data is a high resolution image though, the amount of data is fairly high compared to most experiments.

@EmilOrbiter96  I'm not sure what is causing this.  I cannot duplicate it in my test system. 

Has anyone else had this kind of issue with orbital lines showing up in the gui?

Share this post


Link to post
Share on other sites
5 hours ago, icedown said:

@archnem I do not have control over how the data gets transmitted.  Once the I generate the science, it is handed over to r&d system of ksp to be handled and from what I understand it generally chooses the best available transmission device on the vessel.  Since the data is a high resolution image though, the amount of data is fairly high compared to most experiments.

@EmilOrbiter96  I'm not sure what is causing this.  I cannot duplicate it in my test system. 

Has anyone else had this kind of issue with orbital lines showing up in the gui?

Camera configs tend to change with updates to KSP. This was one thing that plagued CactEye 2 for the longest time until moarDv pointed it out. It use to be that the visibility of UI objects in a camera object was configurable through the camera object's culling mask. My initial suggestion would be to start with the scaledspace camera object and adjust its culling masks.

Share this post


Link to post
Share on other sites
3 hours ago, Raven. said:

Camera configs tend to change with updates to KSP. This was one thing that plagued CactEye 2 for the longest time until moarDv pointed it out. It use to be that the visibility of UI objects in a camera object was configurable through the camera object's culling mask. My initial suggestion would be to start with the scaledspace camera object and adjust its culling masks.

My first problem is that I cannot duplicate it, without that I can't test or fix it.  I was looking for someone that has the issue so I can compare log files and see if I can check what is in common with them.

Share this post


Link to post
Share on other sites
2 minutes ago, Bornholio said:

in contracts

With module: Cact Eye Optics, Count: Exactly 1

What part(s) is needed?

That module is only attached to the processors.

Share this post


Link to post
Share on other sites
1 hour ago, icedown said:

That module is only attached to the processors.

I have a Sat failing a contract for SCANSat with

  1. CatEye Asteroid Camera 1
  2. CactEye Wide Field Camera 1
  3. SCAN Multispectral Sensor
  4. SCAN RADAR Altimetry Sensor

A couple of DMagic sensors from his science mod and assorted hardware for a complete probe. including a couple GRU-1000 Gyro's

Are the Asteroid and Wide field both counting towards the exactly 1 prohibition?

 

Nevermind, Need to Use the FungEye.... and only one of the Asteroid/Wide Field. 

Edited by Bornholio
Me Dumb

Share this post


Link to post
Share on other sites

They may be.   Due to some issues with the contracts I'm already in the processes of reworking the system to fix these and add some more options in. 

Share this post


Link to post
Share on other sites

How do I move the camera in small increments? I have my gyro sensitivity as low as it goes and my reaction wheels on the probe are off....at it still jumps all over the place.

Thanks!

Share this post


Link to post
Share on other sites

Small bug that probably isn't worth trying to track down or you may have already fixed. Running 1.1.3.8 on KSP 1.1.3 with 100+ mods in RSS, just to make finding bugs impossible.

Wide field observations have worked fine on everything out to Neptune but when I attempt to gather science from Pluto I get "Scope not zoomed in far enough" even though I'm at maximum zoom.

I've already had to hack my persistent for a few other reasons and if I just have to hack my way through the contract, so be it. The question is if there is a file somewhere I can edit to allow me to collect the direct science. Whether by removing the zoom requirement or just crediting the science or whatever. I can handle anything that can be opened in NP++ but any decompiling or whatever is beyond me.

Thanks

Share this post


Link to post
Share on other sites

Hi, 

 

i am new to the cacteye mod but found i have an issue whereby i launched the fungeye scope and right clicked to open the cover and then open the GUI but the GUI is empty, i cannot do anything with the scope, I'm running KSP 1.2.2 with the newest version of cacteye running the Galileo planet pack, basically i am running the same mods as Scott Manley in his latest videos and he too had the same issue whereby the GUI is black but the log shows no errors?

 

has anyone else experienced this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.