JPLRepo

[1.7.x] TAC - Life Support v0.13.13 - Release 29th Jun 2019

Recommended Posts

59 minutes ago, Zero333 said:
 

Very sad ... We'll have to use an earlier version of KSP, since such a state I (and many people) are absolutely not satisfied. 
It is so big problem with the integration of TAC GC?

This has already been discussed just a few days ago further up in this thread. The other mods just have to change their config files. It is not a big change. But it is for the better.

34 minutes ago, ThatHomelessGuy said:

Bug maybe with tourists?

They consume resources but don't show up in the GUI, this is space taxi 1 with a 4 kerb crew of tourists with a command probe flying it to maximise passengers. I'll do some more tests after this flight but in the past Jeb has shown up in these GUI's and resource timers have all shown up fine. It's concerning because I am planning on running my space agency as a tourist/colony based economy and If I don't get accurate timers well we all know what can happen if resources aren't being calculated for most of the crew.
83qRp5M.png

Your reference to Jeb confuses me somewhat. Are you saying just tourists are not showing up? And normal crew are? Or no one is showing up if the vessel has tourists? Please clarify. Details are important to track down the bug.

Share this post


Link to post
Share on other sites
 
Yes, I have read, but there was hope for the best, I wish that the expectations were not met. 
I think it is still a wrong decision knocks the ground from under the feet of the many mods 
(some of them probably will not have to redo it. As a result, we lose them)

Share this post


Link to post
Share on other sites
8 minutes ago, JPLRepo said:

This has already been discussed just a few days ago further up in this thread. The other mods just have to change their config files. It is not a big change. But it is for the better.

Your reference to Jeb confuses me somewhat. Are you saying just tourists are not showing up? And normal crew are? Or no one is showing up if the vessel has tourists? Please clarify. Details are important to track down the bug.

I have to reboot and test but If jeb is in the capsule he shows up. But this crew is all tourists and none of them show up. I will test with a mixed crew and get back to you I haven't done a mixed crew launch yet so I haven't actually noticed I only just thought Hmm I wonder how long I can leave them here. I might launch all my tourists first and then de-orbit them one crew at a time.

Share this post


Link to post
Share on other sites
16 minutes ago, Zero333 said:
 

Yes, I have read, but there was hope for the best, I wish that the expectations were not met. 
I think it is still a wrong decision knocks the ground from under the feet of the many mods 
(some of them probably will not have to redo it. As a result, we lose them)

Not sure what mods you are referring to. I have already spoken to @Nils277 about it and thought he had made changes already.
As for PAthfinder mod - I could find no reference to TACGenericConverter in that mod. @Angel-125 does Pathfinder or any of your mods use TACGenericConverter?
and @BetaguyGZT is already also making changes for Biomass.
Which mods are you referring to? Just be patient the other mods will be updated and everything will be fine.

 

18 minutes ago, ThatHomelessGuy said:

I have to reboot and test but If jeb is in the capsule he shows up. But this crew is all tourists and none of them show up. I will test with a mixed crew and get back to you I haven't done a mixed crew launch yet so I haven't actually noticed I only just thought Hmm I wonder how long I can leave them here. I might launch all my tourists first and then de-orbit them one crew at a time.

I'll take a look at the code when I can and wait for you to report back.

Share this post


Link to post
Share on other sites
26 minutes ago, JPLRepo said:

Not sure what mods you are referring to. I have already spoken to @Nils277 about it and thought he had made changes already.
As for PAthfinder mod - I could find no reference to TACGenericConverter in that mod. @Angel-125 does Pathfinder or any of your mods use TACGenericConverter?
and @BetaguyGZT is already also making changes for Biomass.
Which mods are you referring to? Just be patient the other mods will be updated and everything will be fine.

 

I'll take a look at the code when I can and wait for you to report back.

Mi9OT0P.png
Something strange is happening now it's all of them. Mixed and even with Jeb and Bill aren't showing up. Just crashed again because it crashes 1/5 times I have to load a new space. Could it be the modded cockpit? I'll try a Mk 1 when it loads back up.

Share this post


Link to post
Share on other sites
7 minutes ago, ThatHomelessGuy said:

Mi9OT0P.png
Something strange is happening now it's all of them. Mixed and even with Jeb and Bill aren't showing up. Just crashed again because it crashes 1/5 times I have to load a new space. Could it be the modded cockpit? I'll try a Mk 1 when it loads back up.

There is a known bug I have already fixed (but not released) with vessels that are prelaunch as mentioned here.

http://forum.kerbalspaceprogram.com/index.php?/topic/146465-12-tac-life-support-v0125-release-14th-oct-2016/&do=findComment&comment=2810480

 

Share this post


Link to post
Share on other sites
 
Thank you for the pleasant news of Kerbal Planetary Base Systems, missed the news)), 
Will wait others :) . Pathfinder installed TACLS 0.12.5 unfortunately 
work does not wish to resources TACLS. Again sadness. I went testing and reinstall KSP. 
Thank you for your attention :)
Edited by Zero333

Share this post


Link to post
Share on other sites
24 minutes ago, JPLRepo said:

There is a known bug I have already fixed (but not released) with vessels that are prelaunch as mentioned here.

http://forum.kerbalspaceprogram.com/index.php?/topic/146465-12-tac-life-support-v0125-release-14th-oct-2016/&do=findComment&comment=2810480

 

Ok So I have created an Imgur album for you to look at. It seems whatever code that iterates through occupants is stopping on tourists. (speculating as a programmer and gamedev based on what I see. But why we are good testers too because we can see more of what is happening or at least recognise code behaviour and also why I have somewhat ruined the magic of games for myself)

Anyway I also noticed that it doesn't identify the craft as a [ship] until the crew is all ksc "staff" so to speak.
I documented my observations in the picture descriptions, anything else you can glean from it the images is up to your perception and knowledge of the code. I would revert after launch and then recover the vessel and launch another with a different crew configuration. All crew are visible in the bottom corner and any that aren't from the first legendary 4 ksc staff are tourists.

http://imgur.com/a/0UlAf

Share this post


Link to post
Share on other sites
1 hour ago, JPLRepo said:

Not sure what mods you are referring to. I have already spoken to @Nils277 about it and thought he had made changes already.
As for PAthfinder mod - I could find no reference to TACGenericConverter in that mod. @Angel-125 does Pathfinder or any of your mods use TACGenericConverter?
and @BetaguyGZT is already also making changes for Biomass.
Which mods are you referring to? Just be patient the other mods will be updated and everything will be fine.

 

I'll take a look at the code when I can and wait for you to report back.

Pathfinder doesn't use it. I use the stock converter instead because Pathfinder's efficiency improvements needs the stock converter.

Share this post


Link to post
Share on other sites
8 minutes ago, Angel-125 said:

Pathfinder doesn't use it. I use the stock converter instead because Pathfinder's efficiency improvements needs the stock converter.

Thanks! And FYI the TAC one does as well now.

Share this post


Link to post
Share on other sites
1 hour ago, Zero333 said:
Thank you for the pleasant news of Kerbal Planetary Base Systems, missed the news)),

but seems to have problems with the Greenhouse was never solved. Will wait. Pathfinder installed TACLS 0.12.5 unfortunately 
work does not wish to resources TACLS. Again sadness. I went testing and reinstall KSP. 
Thank you for your attention :)

Can you report the problem with the Greenhouse in the thread of KPBS please? I'm not aware of any major problems with it.

The changes for the converters were necessary I think. They are much easier to implement and maintain now. :wink:

Share this post


Link to post
Share on other sites

Thank you so much guys for an explanation, as I have already started using foul language :).
Particularly pleased KPBS 1.3.1. I checked 15 minutes ago - is working. We will look further.
Thanks again to everyone, but this time as the re-installation of KSP is in full swing

Share this post


Link to post
Share on other sites
Very strange, but "cucumbers" do not consume oxygen, water and food - easily (intermediate test result). 
KSP is set again, enclosing a list of mods...

&

Edited by Zero333

Share this post


Link to post
Share on other sites

Also new thing I could be wrong but tourists only seem to be consuming oxygen. Refer to my first post about it with the ship in space and you will see that the only resource used is oxygen.

Share this post


Link to post
Share on other sites

Ok, I've created a new dev release v0.12.6dev that is only available via github at this location:
https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.12.6dev

There is a lot of changes in this under the hood as I have started the code cleanup to make it more efficient. So I need some of you great people to test it for me before I do a full release.
It should also fix a number of bugs that have been reported in the last day or two.
Please back up your save files before using this but I would appreciate more eyes testing this for me. Thanks.
Here is the changelog:

Spoiler

Fix PreLaunch Vessel handling. Any vessel that is PreLaunch will display as such and will not consume resources (with the exception of ElectricCharge), however, TACLS will not track EC drain for a PreLaunch vessel so it is possible if you leave a vessel on the pad with no EC generation that immediately on launchTACLS will see the vessel as having no EC available. https://github.com/KSP-RO/TacLifeSupport/issues/50
Fixed [UNKNOWN] vessel type showing for vessels in the UI.
Fixed Vessel list not showing the active vessel at the top of the list when switching between vessels. https://github.com/KSP-RO/TacLifeSupport/issues/51
Massive code clean-up for performance improvements begins. Internally TAC LS now uses KSP GameEvents for all vessel processing setting things up for future version resource processing of ALL vessels including unloaded vessels.
Fix Tourist processing/monitoring. https://github.com/KSP-RO/TacLifeSupport/issues/52


 

Share this post


Link to post
Share on other sites

 

Greetings, I'm not sure this is a TAC LS issue, but I simply want some advice about this problem I have. Actually I created a post in the Universal storage thread about this.

This is a Waste container config from Universal storage. All other resources are recognized and processed by TAC LS just fine (Oxygen, water, food, waste water, etc), but for some reason it doesn't recognize the fact that I actually mounted a waste container - TAC LS simply does not see it can store  waste here.

I'm not very good at understanding how different mods are working together in KSP, I checked everything I know and failed to come up with a solution.

Any ideas?

 

PART:NEEDS[TacLifeSupport]
{
\\Basic
	author = Paul Kingtiger & Daishi
	mesh = model.mu
	module = Part
	name = US_1R350_Wedge_Waste
	rescaleFactor = 1
	tags = Universal, life

//Node
	attachRules = 1,0,1,1,0
	node_stack_back = 0.187, 0.0, 0.0, 1.0, 0.0, 0.0, 0

//Description	
	category = Utility
	description = Tired of 0G snack wrappers jamming themselves inside the navball? Worried about the structural integrity of capsule vomit bags after a hard splashdown? Fret not! The US Waste Storage unit is designed with heavy duty sanitary waste containment in mind. Comes pre-packed with a "Grind-o-Matic" processing unit to purée and compress particulates into a highly competitive density of at least 250kg\m3. Features an easy access hatch and complementary cleaning chisel.   
	manufacturer = New Horizons & Nox Industrial
	subcategory = 0
	title = Universal Storage: Waste Tank

//Costs & RD	
	cost = 250
	entryCost = 1250
	TechRequired = spaceExploration

//Physical
	bulkheadProfiles = wedge
	crashTolerance = 7
	mass = 0.155
	maxTemp = 1200
	emissiveConstant = 0.95
	thermalMassModifier = 4.0

//Drag
	angularDrag = 1
	dragModelType = default
	maximum_drag = 0.2
	minimum_drag = 0.2	

//Animation
MODULE
    {
        name = ModuleAnimateGeneric
        animationName = Take 001
        actionGUIName = Toggle hatch
        startEventGUIName = Open hatch
        endEventGUIName = Close hatch
        allowAnimationWhileShielded = False
    }

MODULE
    {
        name = ModuleAnimateGeneric
        animationName = Take 002
        actionGUIName = Toggle Fairing
        startEventGUIName = Fairing Off
        endEventGUIName = Fairing On
        allowAnimationWhileShielded = False
    }unfocusedRange = 5
	}

//KIS
	MODULE
	{
		name = ModuleKISItemEvaTweaker
		editorItemsCategory = false
		carriable = true
		equipSlot = jetpack
		equipMeshName = jetpack_base01
		equipBoneName = bn_jetpack01
		equipPos = (0,-0.05,-0.3)
		equipDir = (0,270,0)
		runSpeed = 1
	}	

//Resources
	RESOURCE
	{
		name = Waste
		amount = 0
		maxAmount = 75
	}
}

 

Share this post


Link to post
Share on other sites

The same that we can disable the life support in the advanced options, is there a way to put another option that we can disable the life support parts also?

Share this post


Link to post
Share on other sites
Just now, kunok said:

The same that we can disable the life support in the advanced options, is there a way to put another option that we can disable the life support parts also?

Do you mean if you disable TAC LS for a save game you want the parts to also be disabled (not visible) in that save game?
That can be done.

Share this post


Link to post
Share on other sites
1 minute ago, JPLRepo said:

Do you mean if you disable TAC LS for a save game you want the parts to also be disabled (not visible) in that save game?
That can be done.

Yes, mostly because the cost in the R&D. And that they are too many parts in reality, can we also have a option to hide the hex cans parts? I rarely use them.

Share this post


Link to post
Share on other sites
18 minutes ago, kunok said:

Yes, mostly because the cost in the R&D. And that they are too many parts in reality, can we also have a option to hide the hex cans parts? I rarely use them.

I'll see what I can do.
If you don't want to use the hexcans just delete the folder: <KSPdirectory>\GameData\ThunderAerospace\TacLifeSupportHexCans
EDIT: https://github.com/KSP-RO/TacLifeSupport/issues/53

Edited by JPLRepo

Share this post


Link to post
Share on other sites
On 21/10/2016 at 6:02 AM, cicatrix said:

 

Greetings, I'm not sure this is a TAC LS issue, but I simply want some advice about this problem I have. Actually I created a post in the Universal storage thread about this.

This is a Waste container config from Universal storage. All other resources are recognized and processed by TAC LS just fine (Oxygen, water, food, waste water, etc), but for some reason it doesn't recognize the fact that I actually mounted a waste container - TAC LS simply does not see it can store  waste here.

I'm not very good at understanding how different mods are working together in KSP, I checked everything I know and failed to come up with a solution.

Any ideas?

 

 

Yep, that's a problem with that config file which is part of Universal Storage mod.
It's not a TAC LS issue.
The problem is the line in bold below. Remove it and it works. I've reported this as a bug on the Universal Storage mod thread.
 

Spoiler

PART:NEEDS[TacLifeSupport]
{
\\Basic
    author = Paul Kingtiger & Daishi
    mesh = model.mu
    module = Part
    name = US_1R350_Wedge_Waste
    rescaleFactor = 1
    tags = Universal, life

//Node
    attachRules = 1,0,1,1,0
    node_stack_back = 0.187, 0.0, 0.0, 1.0, 0.0, 0.0, 0

//Description    
    category = Utility
    description = Tired of 0G snack wrappers jamming themselves inside the navball? Worried about the structural integrity of capsule vomit bags after a hard splashdown? Fret not! The US Waste Storage unit is designed with heavy duty sanitary waste containment in mind. Comes pre-packed with a "Grind-o-Matic" processing unit to purée and compress particulates into a highly competitive density of at least 250kg\m3. Features an easy access hatch and complementary cleaning chisel.   
    manufacturer = New Horizons & Nox Industrial
    subcategory = 0
    title = Universal Storage: Waste Tank

//Costs & RD    
    cost = 250
    entryCost = 1250
    TechRequired = spaceExploration

//Physical
    bulkheadProfiles = wedge
    crashTolerance = 7
    mass = 0.155
    maxTemp = 1200
    emissiveConstant = 0.95
    thermalMassModifier = 4.0

//Drag
    angularDrag = 1
    dragModelType = default
    maximum_drag = 0.2
    minimum_drag = 0.2    

//Animation
MODULE
    {
        name = ModuleAnimateGeneric
        animationName = Take 001
        actionGUIName = Toggle hatch
        startEventGUIName = Open hatch
        endEventGUIName = Close hatch
        allowAnimationWhileShielded = False
    }

MODULE
    {
        name = ModuleAnimateGeneric
        animationName = Take 002
        actionGUIName = Toggle Fairing
        startEventGUIName = Fairing Off
        endEventGUIName = Fairing On
        allowAnimationWhileShielded = False
    }unfocusedRange = 5
    }

//KIS
    MODULE
    {
        name = ModuleKISItemEvaTweaker
        editorItemsCategory = false
        carriable = true
        equipSlot = jetpack
        equipMeshName = jetpack_base01
        equipBoneName = bn_jetpack01
        equipPos = (0,-0.05,-0.3)
        equipDir = (0,270,0)
        runSpeed = 1
    }    

//Resources
    RESOURCE
    {
        name = Waste
        amount = 0
        maxAmount = 75
    }
}

 

Edited by JPLRepo

Share this post


Link to post
Share on other sites
12 hours ago, JPLRepo said:

Yep, that's a problem with that config file which is part of Universal Storage mod.
It's not a TAC LS issue.
The problem is the line in bold below. Remove it and it works. I've reported this as a bug on the Universal Storage mod thread.

Thank you, I  missed that completely!

Share this post


Link to post
Share on other sites

I'm not sure if you're aware already, but the newest release of CC exposed a bug in Blizzy's toolbar. The fix requires all mods using it to update the toolbar wrapper.

More info here:

 

Edited by Booots

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.