RoverDude

[1.3] Konstruction! Weldable ports, servos, cranes, and magnets! [0.1.3]

Recommended Posts

33 minutes ago, chandlernic1 said:

im really new at this my picture wont attacch

 


You need to upload it somewhere so you can post a link. I find Imgur.com to be easy to use and free. 

Share this post


Link to post
Share on other sites

Trying to figure out if there's something wrong in my install or if there is still a known issue with the ConstructionPorts not docking well in Zero-G?

I spent a couple of hours trying to get two halves of a station to dock and eventually gave up and edited my save to replace the Construction Ports with standard ports.  I kept snap angle to 0, and I tried messing with the various sliders, but all I tended to do was rip things apart in rather violent ways :)

I know RoverDude had started to look at the problem during one of his Twitch broadcasts -- but I wasn't sure if there was a fix pushed yet.  

Share this post


Link to post
Share on other sites

some pro tips.

use the latest version - if you don't have compress with rotation it is not the latest.

roll pushes you towards alignment regardless of snap.  If you want to snap to an angle vs perfect match turn off roll and rotate manually.

snap can be toggled.  A snap angle of 0 means you want an exact fit.  Works best in zero g.  In that case, only have roll on one of the ports and have it near zero.

if it is still problematic turn off roll and snap, and use compress with rotation.

9 hours ago, Efour said:

I think I found a bug.

when compress(rotate), A space station I made doesn't weld correct angle.
It welded correct angle just 1 frame, but after first frame It rotated to previous angle.

and I tested almost 120 degree rotate, but it destroyed after 1 frame.

 

 Are you using KJR?

Share this post


Link to post
Share on other sites

I've wanted to build a Shuttle Mate-Demate Device. While I am starting out at the default scale for testing before I scale it up, I am honestly really confused by these parts, and a manual would help greatly. Please point me to it if it's already been discussed here, but the gui for servos I don't understand how to use. A sample craft would be helpful too.

Share this post


Link to post
Share on other sites

I dunno what I did horrible wrong for getting spammed this as I add a part with any resource to the vab:

MissingMethodException: Method not found: 'ResourceRatio..ctor'.

Only when I install this mod.

LOG: https://drive.google.com/file/d/0B4kd548FeSEpa2ZaREI0TmN4NHc/view?usp=sharing

MODS:

AtmosphereAutopilot-1.5.8.zip
BetterBurnTime-1.5.1.zip
CorrectCoL-1.4.4.zip
Community_Resource_Pack-0.6.2.0.zip
EasyBoard-v1.2.1.zip
EasyVesselSwitch_v1.1.1.zip
IndicatorLights-1.2.zip
KAS_v0.6.0.zip
Kerbal_Alarm_Clock-3.8.1.0.zip
Kerbal_Joint_Reinforcement-v3.3.0.zip
Kerbal_Reusability_Expansion-2.0.4.zip
KIS_v1.3.0.zip
Konstruction-1.2.zip
ModuleManager.2.7.1.dll
PreciseManeuver.zip
Reentry_Particle_Effect-1.2a.zip
SurfaceLights_v1.3.0.zip
Trajectories-v1.6.5.zip
VertVel131.zip

 

So after some kerbal stuff I removed this file AddConsumers.cfg from 000_USITools folder and the spam went away, hope it wont break anything without it ( I am not using other mods from Roverdude so I guess I am on the safe side )

Edited by brusura

Share this post


Link to post
Share on other sites
3 hours ago, RoverDude said:

if it is still problematic turn off roll and snap, and use compress with rotation.

 Are you using KJR?

At first, I'm using AVC and I can see compress(rotate). I'm sure that I'm using latest version.

KJR was out of my GameData when testing 120 degree rotation.

The bug I reported is this: When using compress(rotate), my space station module welded 0 degree(what I wanted) just 1 frame. After 1 frame, it rotated once more to unwanted angle(previous, the angle I docked manually).

It happened regardless KJR(I tested both of situation repeatly)

If I can record that situation, I will upload here. But my laptop has slightly old graphic driver(Evil God loves HP), so I can't say I can do zhat.

Edited by Efour
KJR

Share this post


Link to post
Share on other sites
10 hours ago, RoverDude said:

some pro tips.

use the latest version - if you don't have compress with rotation it is not the latest.

roll pushes you towards alignment regardless of snap.  If you want to snap to an angle vs perfect match turn off roll and rotate manually.

snap can be toggled.  A snap angle of 0 means you want an exact fit.  Works best in zero g.  In that case, only have roll on one of the ports and have it near zero.

Compress with rotation is there, although since they never docked that didn't help.

Behavior basically went like this:  approached fine, got magnetic pull as normal, but they just bumped but wouldn't latch.  Moving the sliders around appeared to put some torque on one or both halves, too much slider and things would spin/twist or otherwise move with enough force to cause collisions.  At one point I did try and change snap to 90 or 180, but that didn't help.  

Interestingly enough, I'm not sure at what point this happened -- I think it was after hitting the "Reset Acquire" or a button labelled similar to that, all docking ports on both vessels seemed to lose their magnetism -- even if I backed away 10m and re-approached..  That's when I gave up and edited the save file to switch to dockingPort1 -- which worked without issues.

I'll experiment more over the weekend, as station building is one of my "fun" activities :)

Thanks for everything you build RoverDude, I don't play KSP without USI.

Share this post


Link to post
Share on other sites
On 10/29/2016 at 0:46 PM, mcortez said:

Compress with rotation is there, although since they never docked that didn't help.

Behavior basically went like this:  approached fine, got magnetic pull as normal, but they just bumped but wouldn't latch.  Moving the sliders around appeared to put some torque on one or both halves, too much slider and things would spin/twist or otherwise move with enough force to cause collisions.  At one point I did try and change snap to 90 or 180, but that didn't help.  

Interestingly enough, I'm not sure at what point this happened -- I think it was after hitting the "Reset Acquire" or a button labelled similar to that, all docking ports on both vessels seemed to lose their magnetism -- even if I backed away 10m and re-approached..  That's when I gave up and edited the save file to switch to dockingPort1 -- which worked without issues.

I'll experiment more over the weekend, as station building is one of my "fun" activities :)

Thanks for everything you build RoverDude, I don't play KSP without USI.

I am also having this issue. 

Share this post


Link to post
Share on other sites
On 10/29/2016 at 0:46 PM, mcortez said:

Compress with rotation is there, although since they never docked that didn't help.

Behavior basically went like this:  approached fine, got magnetic pull as normal, but they just bumped but wouldn't latch.  Moving the sliders around appeared to put some torque on one or both halves, too much slider and things would spin/twist or otherwise move with enough force to cause collisions.  At one point I did try and change snap to 90 or 180, but that didn't help.  

Interestingly enough, I'm not sure at what point this happened -- I think it was after hitting the "Reset Acquire" or a button labelled similar to that, all docking ports on both vessels seemed to lose their magnetism -- even if I backed away 10m and re-approached..  That's when I gave up and edited the save file to switch to dockingPort1 -- which worked without issues.

I'll experiment more over the weekend, as station building is one of my "fun" activities :)

Thanks for everything you build RoverDude, I don't play KSP without USI.

How did you edit the save? What I mean is, what did you change.

Share this post


Link to post
Share on other sites
On 29-10-2016 at 6:46 PM, mcortez said:

Compress with rotation is there, although since they never docked that didn't help.

Behavior basically went like this:  approached fine, got magnetic pull as normal, but they just bumped but wouldn't latch.  Moving the sliders around appeared to put some torque on one or both halves, too much slider and things would spin/twist or otherwise move with enough force to cause collisions.  At one point I did try and change snap to 90 or 180, but that didn't help.  

...SNIP...

I had the same. The problem was located between my seat and my keyboard (i just didn't understand the mod sufficiently). Latching on only occurs when both conctruction docking ports are aligned properly. With stock docking port the rotation of the ports doesn't matter. If they are alligned in the horizontal, vertical and sideways plein, they will latch to each other. The construction docking ports require that the rotation of both ports is the same. The simplest way to achieve this after "bumping" is to rotate one of both crafts with the Q or E key. At some point, the rotation is the same and both ports will latch on to each other.

 

Share this post


Link to post
Share on other sites
16 minutes ago, TheCardinal said:

I had the same. The problem was located between my seat and my keyboard (i just didn't understand the mod sufficiently). Latching on only occurs when both conctruction docking ports are aligned properly. With stock docking port the rotation of the ports doesn't matter. If they are alligned in the horizontal, vertical and sideways plein, they will latch to each other. The construction docking ports require that the rotation of both ports is the same. The simplest way to achieve this after "bumping" is to rotate one of both crafts with the Q or E key. At some point, the rotation is the same and both ports will latch on to each other.

 

 

16 minutes ago, TheCardinal said:

I had the same. The problem was located between my seat and my keyboard (i just didn't understand the mod sufficiently). Latching on only occurs when both conctruction docking ports are aligned properly. With stock docking port the rotation of the ports doesn't matter. If they are alligned in the horizontal, vertical and sideways plein, they will latch to each other. The construction docking ports require that the rotation of both ports is the same. The simplest way to achieve this after "bumping" is to rotate one of both crafts with the Q or E key. At some point, the rotation is the same and both ports will latch on to each other.

 

This made it problematic for aligning the proper rotation. Is there a better method?

Share this post


Link to post
Share on other sites
1 hour ago, TheCardinal said:

I had the same. The problem was located between my seat and my keyboard (i just didn't understand the mod sufficiently). Latching on only occurs when both conctruction docking ports are aligned properly. With stock docking port the rotation of the ports doesn't matter. If they are alligned in the horizontal, vertical and sideways plein, they will latch to each other. The construction docking ports require that the rotation of both ports is the same. The simplest way to achieve this after "bumping" is to rotate one of both crafts with the Q or E key. At some point, the rotation is the same and both ports will latch on to each other.

 

Which that was the only problem, after enabling the Roll slider, my parts spun around multiple times -- so whatever rotation point they were looking for was passed more than once.  It was just a high level of frustration - I haven't yet had the opportunity to retest.

Still stands that something broke at some point, where I lost all attractive forces and wouldn't even draw ports together anymore.

3 hours ago, blnk2007 said:

How did you edit the save? What I mean is, what did you change.

In your persistent.sfs file you can search for parts where it has name = ConstructionPort1 and change it to something else, like dockingPort1 -- although you do this at significant risk to your save file.  Changing the file in the wrong place and one or more vessels will fail to load and be removed from your save completely.

Make sure you have backups of all relevant files before messing with them.

Share this post


Link to post
Share on other sites

As the Cardinal said you need to roll the vessel until the ports are lined up. The angle slider should select which orientation is the correct one. You can try to use the roll feature of the ports but that seems like more hassle than it's worth. If you do use it, start with a very small value on one port. 

Share this post


Link to post
Share on other sites
4 minutes ago, Tarheel1999 said:

As the Cardinal said you need to roll the vessel until the ports are lined up. The angle slider should select which orientation is the correct one. You can try to use the roll feature of the ports but that seems like more hassle than it's worth. If you do use it, start with a very small value on one port. 

Thanks, with help and time I got it to work. It needs to be planned well in the VAB prior to launch.

Share this post


Link to post
Share on other sites

OK so i have a station that has multiple weldable docking ports on it, however whenever I click on the smaller ports (clampotron standard size) and ask them to weld, I get an error stating that I must weld two weldable docking ports - what am I doing wrong here?  Screenshot are on dropbox...

https://www.dropbox.com/s/x5pe175tvdcd036/screenshot0.png?dl=0

https://www.dropbox.com/s/kkz1d8c7sp34vr4/screenshot1.png?dl=0

Persistents file (FYI, Im using a hand full of mods with parts, so this may not load for you, but all the same here it is)

https://www.dropbox.com/s/f59c0gz937jszbd/persistent.sfs?dl=0

Any help would be appreciated.

FYI I have already welded once on this station, the two halves of the core were welded together without a hitch, but they used the senior ports, not the standard ones.

 

RoBoC

 

Share this post


Link to post
Share on other sites

Since upgrading to 1.2.1 my ports are absolutely refusing to magnetize. this port on the side of the tank worked fine in 1.2, but in 1.2.1, this arm I sent up refuses to dock it no matter what. pkqbkZz.png

Any ideas?

Share this post


Link to post
Share on other sites

Perhaps someone can help shed some light on these 2 issues:

The first is that on every video related to this mod I've seen, the wheels are initially attached in a compact fashion. Mine attach straight down. Mine look nothing like this when I build my rover-crane. There's no "start extended/start retracted" option that I see in the vids, just "deploy", "stow left" and "stow right"

The second issue being when I deploy the legs, as soon as they're fully deployed, the vehicle starts twitching and bouncing around.

Help!

(screencap from random youtube vid)

8gCa7nN.png

My in game screen cap.

IVM4Dty.png

Edited by pheenix99

Share this post


Link to post
Share on other sites
28 minutes ago, Tarheel1999 said:

@pheenix99 there are three different legs, they have different options. 

Guess I need to go make some more science and unlock them then :P

Share this post


Link to post
Share on other sites

I had the same bouncing problem with the inline Adjustable wheels. Once deployed they started bouncing the craft all over the runway. Haven't tested the lateral ones yet.

I will put a proper report in Github when I get a moment later today. 

Thank you again for the mods @RoverDude o7

Share this post


Link to post
Share on other sites

Got a problem with the construction ports, same as the issue that somebody had further up, i'm trying to weld two 2.5m parts together, but the rotation isn't working atall no matter what i configure in the controls, also, this is with and without Kerbal Joint Reinforcement as you suggested could be an issue.

Am i possibly running a mod conflict? or is this a bug in the most recent release?

 

(I'm using the one with the new combine with rotation option)

Share this post


Link to post
Share on other sites

Think I finally got it figured out

Edited by pheenix99

Share this post


Link to post
Share on other sites

I'm having a problem with the forklift part in that collisions only register for the right side of the forklift. The right fork and piston will bump into objects but the left fork and piston passes through them. Could the collision box be incorrectly set? I just now installed the latest 0.1.6 version from the GitHub page.

Here's an image of it going through a fuel tank attached to a docking port. I've also seen the behavior while interacting with other objects.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.