Waz

[1.8] EnvironmentalVisualEnhancements [1.8.0-2]

Recommended Posts

Posted (edited)

How does the transition between day and night city detail textures work? Does it display both layered on top of each other and increase the light opacity as the time of day changes? Or does it slowly fade the day texture as the night texture gets brighter?

Also does the night texture support transparency? Or is black treated as transparent on it?

Edited by m4ti140

Share this post


Link to post
Share on other sites
On 7/26/2019 at 5:19 PM, Galileo said:

And?

Exactly why I was terrified to ask for help... and kept grinding along until I figured it out for myself! haha

Share this post


Link to post
Share on other sites

Hi, is there a way in the config file to adjust brightness, cos I want to get some of my clouds and aurora visible on the night side of the planet.

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

Is anyone having issues in the latest version of EVE (1.4.2-2) using cubemaps, I'm finding that eve doesn't seem to recognize predifined cubemap textures in textures.cfg. I'm not certain but I also found in some other examples that eve would read text editor config defined cubemap 'textures' fine but as soon as the apply was hit all eve features would stop running/appearing (perfmance boost at this point so assuming there actually no longer being loaded in game), I looked in the configs extensively before and after and noticed that the format of some parts of the config had changed e.g. from:

_DetailTex = modname/Assets/Atmosphere/Detail/filename

 _UVNoiseTex = modname/Assets/Atmosphere/Detail/filename 

to being bracketed like this:

_DetailTex
            {
                value = modname/Assets/Atmosphere/Detail/filename
            }
            _UVNoiseTex
            {
                value = modname/Assets/Atmosphere/Detail/filename
            }

 

Could be completely irrelevant but thought I'd mention it seen as it was a change that occurred when the cubemaps stopped working.

In addition to this a text editor defined cubemap texture name works until it is editied and changed back to the exact same name in the in-game GUI becoming red indicating EVE may no longer recognize the texture.

 

It should also be noted I'm running this with scatterer, and on some occasions I found that having the scatterer config setting usesCloudIntegration = false made the clouds reappear but not in every instance.

 

After some more digging it looks like scatterer 0.054 EVE cloud integration prevent EVE (1.4.2-2) from reading cubemapped clouds, they work with this feature disabled but there are then a host of other visual bugs sadly.

Can anyone else confirm this?

Edited by pingopete

Share this post


Link to post
Share on other sites
On 8/25/2019 at 5:59 AM, Aluminum Oxide said:

Hi, is there a way in the config file to adjust brightness, cos I want to get some of my clouds and aurora visible on the night side of the planet.

Thanks

Sounds like _MinLight is what you're after.

Share this post


Link to post
Share on other sites
5 minutes ago, 4x4cheesecake said:

Sneaky update to 1.7 :o

Much appreciated @Waz :):)

The old build was working fine in my testing, but there were some bits and pieces sitting in the repo that needed releasing. ... plus I'm starting a new KSP session :-)

The new build has support for BumpMaps on clouds. No idea if that's useful to anyone...

Share this post


Link to post
Share on other sites
1 minute ago, Waz said:

The old build was working fine in my testing, but there were some bits and pieces sitting in the repo that needed releasing. ... plus I'm starting a new KSP session :-)

The new build has support for BumpMaps on clouds. No idea if that's useful to anyone...

It's useful. Thank for releasing that feature :)

Share this post


Link to post
Share on other sites
1 hour ago, Waz said:

No idea if that's useful to anyone...

You had a test release a while ago didn't you? Or at least a call out for textures you could test with. I don't recall there being much response. Hopefully tho more people check it out now that it's released

Share this post


Link to post
Share on other sites

Has anyone managed to get the latest version of EVE (for 1.7.3) to work with cubemaps? I'm still having the GUI not recognise predifined cubemap 'texture' configs

EDIT: looking in the logs I found this:

[LOG 20:59:21.393] [EVE] Creating Clouds Cubemap
[LOG 20:59:21.393] [EVE TextureConfig]: Unable to parse config node:
OBJECT
{
	name = Clouds
	mipmaps = False
	type = TEX_CUBE_6
	texXn = RSSVE/Textures/Cubemaps/Cloud/CloudsXn
	texXp = RSSVE/Textures/Cubemaps/Cloud/CloudsXp
	texYn = RSSVE/Textures/Cubemaps/Cloud/CloudsYn
	texYp = RSSVE/Textures/Cubemaps/Cloud/CloudsYp
	texZn = RSSVE/Textures/Cubemaps/Cloud/CloudsZn
	texZp = RSSVE/Textures/Cubemaps/Cloud/CloudsZp
}

[EXC 20:59:21.394] NullReferenceException: Object reference not set to an instance of an object

EVEManager.EVEManagerBase.Apply ()
	Rethrow as UnityException: Unable to apply node!

[LOG 20:47:47.223] [EVE TextureConfig]: Unable to parse config node:
OBJECT
{
	name = Clouds
	mipmaps = False
	type = TEX_CUBE_6
	texXn = RSSVE/Textures/Cubemaps/Cloud/CloudsXn
	texXp = RSSVE/Textures/Cubemaps/Cloud/CloudsXp
	texYn = RSSVE/Textures/Cubemaps/Cloud/CloudsYn
	texYp = RSSVE/Textures/Cubemaps/Cloud/CloudsYp
	texZn = RSSVE/Textures/Cubemaps/Cloud/CloudsZn
	texZp = RSSVE/Textures/Cubemaps/Cloud/CloudsZp
}

[LOG 20:47:47.224] EVEManager: Issue loading TextureConfig! Error:
UnityEngine.UnityException: Unable to apply node! ---> System.NullReferenceException: Object reference not set to an instance of an object
  at Utils.CubemapWrapper..ctor (System.String value, UnityEngine.Texture2D[] textures, TextureTypeEnum cubeType, Boolean mipmaps, Boolean readable) [0x00000] in <filename unknown>:0 
  at Utils.CubemapWrapper.GenerateCubemapWrapper (System.String value, UnityEngine.Texture2D[] textures, TextureTypeEnum cubeType, Boolean mipmaps, Boolean readable) [0x00000] in <filename unknown>:0 
  at TextureConfig.TextureConfigObject.Apply () [0x00000] in <filename unknown>:0 
  at EVEManager.GenericEVEManager`1[T].ApplyConfigNode (.ConfigNode node) [0x00000] in <filename unknown>:0 

Just tested in fully stock KSP (without rss or CB naming and same thing, same errors in log file

 

just tested again by literally dropping the textures in place of an eto install and for some reason this works, despite trying every possible variation of config files and adjustments

Got it working intermediately with Scatterer although the scatterer cloud integration and cloud mapping seems to break cloud textures, here were some brief moments where they worked together:

 

Edited by pingopete

Share this post


Link to post
Share on other sites
2 hours ago, maculator said:

Where did the boulderCo folder go?

The BoulderCo folder is in the sample Configs package. These packages are huge and almost never change, so I don't ship a new one with every release.

Share this post


Link to post
Share on other sites

@Waz Ignore my older posts, I managed to figure it all out, and got what I wanted working. 

I have a question though, how doable would it be to add a terrain texture option that allows for mapping a global texture through cube maps? This would fix so many of the issues affecting scatterer and eve running terrain as a cloud layer in order to be able to use cubemaps 

Share this post


Link to post
Share on other sites
8 hours ago, pingopete said:

@Waz Ignore my older posts, I managed to figure it all out, and got what I wanted working. 

I have a question though, how doable would it be to add a terrain texture option that allows for mapping a global texture through cube maps? This would fix so many of the issues affecting scatterer and eve running terrain as a cloud layer in order to be able to use cubemaps 

I'm not sure I understand the question. Do you mean clouds plastered onto the terrain as one unmoving texture? That would be pretty ugly. TextureReplacer/Kopernicus for terrain, EVE for (moving) clouds.

Share this post


Link to post
Share on other sites
On 9/29/2019 at 11:55 PM, Waz said:

I'm not sure I understand the question. Do you mean clouds plastered onto the terrain as one unmoving texture? That would be pretty ugly. TextureReplacer/Kopernicus for terrain, EVE for (moving) clouds.

The old EVE terrain shader which used to allow mapping of repeated terrain/ground detail textures onto terrain in tiled positioning, it no longer works, but I was thinking maybe that system could be used to apply global terrain textures greater than the hard ksp 16384 px texture limit possible with a single texture file but instead using cubemaps. I understand this wouldn't exactly be as noticeable or as much of a use case on smaller planets, but on larger ones, or on any rss scaled planets it would make a huge difference. It may just be too much work to be worth doing, but I appreciate the consideration eitherway :)

 

Here are some examples of what's possible with terrain textures greater than the 16384^2 max, this is in RSS where the planets are typically 10x the size of those in the kerbol system and thus texture to screen resolution is a factor of that less by default, even with the highest possible texture size limit without 6 faced cube maps it's impossible to even get close to this level of fidelity:

(These are using terrain textures as cloud layer cubemap overlaid where the normal ScaledSpace/Kopernicus terrain would be)

ZjkKbXq.png

STqWexF.png

 

RSS with 8k Textures (from roughly 3x the height):

kJBQ5md.png

 

In these instances where people want terrain above the single texture resolution unity cap, global cubemap textures to terrain would allow Scatterer to run properly on terrain, allow these textures to be used continuously from PQS through ScaledSpace, allow for the base kopernicus height maps to produce correct shadings/shadows at the ternimators, and even allowing 3D planet surfaces and scatterer godrays between mountains while in ScaledSpace which I think would look beyond incredible.

I just want to clarify this is not a complaint, I'm still amazed at what has been achieved in EVE so far; the introduction of detail transparency, realistic shadow rendering, uv Noise edge deformation/animation and cubemaping for clouds were all huge leaps forwards and enabled the community to achieve things thought impossible prior, I just wanted to try and detail how much this could aid Visual modders in the future.

I'd try and play with the source code but I literally know nothing about that language, or about unity coding.

Thanks again for your continued support on EVE, it is much appreciated by virtually all KSP players

Edited by pingopete

Share this post


Link to post
Share on other sites
On 9/30/2019 at 10:02 PM, pingopete said:

The old EVE terrain shader which used to allow mapping of repeated terrain/ground detail textures onto terrain in tiled positioning, it no longer works, but I was thinking maybe that system could be used to apply global terrain textures greater than the hard ksp 16384 px texture limit possible with a single texture file but instead using cubemaps. I understand this wouldn't exactly be as noticeable or as much of a use case on smaller planets, but on larger ones, or on any rss scaled planets it would make a huge difference. It may just be too much work to be worth doing, but I appreciate the consideration eitherway :)

EVE certainly attempted to package too much into one mod (it's been around for a surprisingly long time, even though what it does would be far better implemented by the core game). I think Kopernicus is probably the better place for that sort of thing.

Share this post


Link to post
Share on other sites
8 hours ago, Waz said:

EVE certainly attempted to package too much into one mod (it's been around for a surprisingly long time, even though what it does would be far better implemented by the core game). I think Kopernicus is probably the better place for that sort of thing.

OK, I assumed this was the reasoning behind dropping the wip terrai support, I'll see what's possible in kopernicus

Share this post


Link to post
Share on other sites

New version is up for KSP 1.8, both on GitHub and CurseForge (though still waiting for them to notice that KSP 1.8 exists, so for now it's listed as for KSP 0.8 :-).

No visible changes (except a new icon), but quite some hoop-jumping to get it to build for KSP 1.8 / Unity 2019, so post here if anything weird happens that didn't happen in previous versions.

Edited by Waz

Share this post


Link to post
Share on other sites
7 minutes ago, Waz said:

New version is up for KSP 1.8

Thank you, Waz.

Share this post


Link to post
Share on other sites
11 hours ago, Waz said:

New version is up for KSP 1.8, both on GitHub and CurseForge (though still waiting for them to notice that KSP 1.8 exists, so for now it's listed as for KSP 0.8 :-).

No visible changes (except a new icon), but quite some hoop-jumping to get it to build for KSP 1.8 / Unity 2019, so post here if anything weird happens that didn't happen in previous versions.

Hey, friend!
After the update I started to experience this: 

AD5FC56151A0A94C1830A9B017959BF443D022C6

19317E3959C30679771B2011582435BD7F06E2C9

Any idea why this is happening? Although one picture was taken at night, The difference that I wanted to point out is that when zoomed out,  the "shade" takes over the screen and, as I zoom in, I begin to see the ground texture and buildings.

Those were taken with only EVE and its configs installed, that are StockVisualEnhancements, its HighRes pack and Scatterer.

 

Edit:

CB6024DAA17BD3D45EEE6D784A9F64C6D1A7A81D


This last picture was taken when I was trying figure it out which one was responsible for this bug and I got this result after removing Scatterer. There is still a shade line on the ground that persists when zooming in or out the camera and the clouds are squared now. Is there still a solution regarding EVE or is this a Scatterer issue that you can do nothing about it?

On main menu and on "tracking center view" the clouds are as they should be.

 

Thank you very much for your attention!

Edited by Drowssap
Explained on the post.

Share this post


Link to post
Share on other sites
1 hour ago, Carni35 said:

Hey

Scatterer is not compatible with KSP 1.8 yet

I see, but I thought I had read somewhere that we didn't have to worry about the other things since EVE was updated.
Thank you anyway =]

Share this post


Link to post
Share on other sites
8 hours ago, Drowssap said:

Hey, friend!
After the update I started to experience this: 

...


This last picture was taken when I was trying figure it out which one was responsible for this bug and I got this result after removing Scatterer. There is still a shade line on the ground that persists when zooming in or out the camera and the clouds are squared now. Is there still a solution regarding EVE or is this a Scatterer issue that you can do nothing about it?

On main menu and on "tracking center view" the clouds are as they should be.

 

Thank you very much for your attention!

 

I saw something similar, but it wasn't consistent. I've rebuilt the shaders (didn't think it would be necessary) and made a new patch release. Let me know if you still get those effects.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.