Jump to content

[1.7] KVV - Kronal Vessel Viewer = Exploded ship view


Recommended Posts

48 minutes ago, The-Grim-Sleeper said:

Hey, I am getting the 'button not showing up problem'.

 I did the CKAN install, saw the comments and removed the KVV, cleaned the cache and installed a fresh 0.0.9.5 release from spacedock, but still no button. The mod is mentioned in the 'toolbar controller', but no buttons are shown in the stock toolbar, the ''blizzy continued toolbar' and RasterPropMonitor also can't find it.

Other mods installed: as excrementsload, I haven't had the time for a full 'clean KSP', but I hope this is a quick fix.

Log file link: https://drive.google.com/open?id=15iVXgQriSAna2F34RlUwkosiUNbjZG-9

Make sure you have the latest version of the ToolbarController installed

Link to post
Share on other sites
1 hour ago, The-Grim-Sleeper said:

Hey, I am getting the 'button not showing up problem'.

I did the CKAN install, saw the comments and removed the KVV, cleaned the cache and installed a fresh 0.0.9.5 release from spacedock, but still no button. The mod is mentioned in the 'toolbar controller', but no buttons are shown in the stock toolbar, the ''blizzy continued toolbar' and RasterPropMonitor also can't find it.

Other mods installed: as excrementsload, I haven't had the time for a full 'clean KSP', but I hope this is a quick fix.

Log file link: https://drive.google.com/open?id=15iVXgQriSAna2F34RlUwkosiUNbjZG-9

First off, that's the wrong log file, the preferred one is the output_log.txt, see my sig for a link on how and where to find it.

Now, it seems from the log which you did provide that it was installed properly.  Look for a yellow wrench on the toolbar, click that, and look for the Kronal Vessel Viewer.

Make sure that either the Stock or Both toggle is set for it, then close it, go into the VAB and see if the KVV button shows up

 

Link to post
Share on other sites
3 hours ago, The-Grim-Sleeper said:

Linux: ~/.config/unity3d/Squad/Kerbal\ Space\ Program/Player.log, I could not find a output_log.txt there.

But I think I found the problem: I was looking for your 'Vessel Viewer Continued'-mod and this is 'Kronal Vessel Viewer'. :D

Oh, I thought you were on Windows.

Glad to hear you figured it out. 

Link to post
Share on other sites

A problem has been found with this mod on KSP 1.4.5. The issue is the offset views don't fully offset.

The current version is only good up to 1.4.3 (maybe 1.4.4)

For those interested, the problem is that the API changed in a very subtle way:

Just an FYI, in 1.4.3, the following:

public Transform jettisonTransform;


and in 1.4.5:
 

public Transform jettisonTransform { get; set; }

 

So, no code changes are required, but the mod does need to be rebuilt.

I'm going to have to do two releases. One for the current build, with the .version limited to 1.4.4. Another for 1.4.5. May take a day to get it out properly.

Edited by linuxgurugamer
Link to post
Share on other sites

New Releases

0.0.9.6

  • Rebuild for 1.4.3
  • .version updated to max KSP version of 1.4.3

0.0.9.7

  • Rebuild for 1.4.5
  • .version updated to KSP version 1.4.5 

If you use CKAN, the correct version should show up unless you have changed the compatible KSP versions, this would only be a problem with KSP 1.4.3

 

Edited by linuxgurugamer
Link to post
Share on other sites
14 minutes ago, Tweak[Box] said:
Picture of offset not working.... Can anyone help me?

Well, it would be nice if you posted a log file.

Which version of the game are you running?  and have you updated to the latest version of KVV for the game you are running? A bug release was done a few days ago to fix this very issue

Link to post
Share on other sites

Sorry for being a noob here. I am still using the 1.4.2 version and I downloaded the Kronal_Vessel_Viewer_Continued-0.0.9.5.zip on October 1 and is the log file named KSP.log? It's size is 52mb so i can't open it without lagging notepad... I'm currently uploading the log file to google.drive

Edited by Tweak[Box]
Link to post
Share on other sites
8 minutes ago, Tweak[Box] said:

Sorry for being a noob here. I am still using the 1.4.2 version and I downloaded the Kronal_Vessel_Viewer_Continued-0.0.9.5.zip on October 1 and is the log file named KSP.log? It's size is 52mb so i can't open it without lagging notepad... I'm currently uploading the log file to google.drive

Use this one:  https://spacedock.info/mod/1092/Kronal Vessel Viewer Continued/download/0.0.9.6

 

Link to post
Share on other sites

hello i have a probleme with KVV, when i am in VAB i can't see icon, so i can't make beautiful blue print.

I would like some help please.

KSP: 1.4.5 Windows 64bit

Problem: KVV icon doesn't appear.

Mods installed:

KSP: 1.4.5 (Win64) - Unity: 2017.1.3p1 - OS: Windows 10  (10.0.0) 64bit
ClickThroughBlocker - 0.1.6.7
Toolbar - 1.7.17.11
USI Tools - 0.12
ToolbarControl - 0.1.6.15
Ablative-Airbrake - 0.3
B9 Part Switch - 2.3.3
Community Category Kit - 3.0
Community Resource Pack - 0.10
CommunityTechTree - 3.3.2
Contract Configurator - 1.25
Contract Pack: Anomaly Surveyor - 1.7.1
Contract Pack: Field Research - 1.2.1
Contract Pack: RemoteTech - 2.1.4
Rover Missions - 0.1.7
Contract Pack: Tourism Plus - 1.5.2
CryoEngines - 0.6.1
CryoTanks - 1.0.1
StructuralTubingRestructured - 1.0.7.1
DMagic Orbital Science - 1.3.0.12
CapCom Mission Control On The Go - 1.0.2.9
Contract Parser - 1.0.8
Progress Parser - 1.0.10
DynamicBatteryStorage - 1.3.2
Firespitter - 7.9
HeatControl - 0.4.6
Interstellar Fuel Switch - 3.6.12.1
Kerbal Attachment System - 0.6.4
KerbalAtomics - 0.5.1
Kerbal Engineer Redux - 1.1.5.3
Kerbal Joint Reinforcement - 3.3.4
InlineBallutes - 1.2.9.5
Kerbal Inventory System - 1.14.6773.33741
Kopernicus- 1.4.5.4
KronalVesselViewer - 0.0.9.8
KSP-AVC Plugin - 1.2.0.2
KWRocketryRebalanced - 3.2.5.5
ModularFlightIntegrator - 1.2.5
Docking Port Alignment Indicator - 6.8.2
NearFutureAeronautics - 1.0.1
NearFutureConstruction - 1.0.3
NearFutureElectrical - 0.10.2
NearFutureLaunchVehicles - 1.1.6
NearFutureProps - 0.3.4
NearFuturePropulsion - 1.0.2
NearFutureSolar - 0.8.12
NearFutureSpacecraft - 0.7.10
Outer Planets Mod - 2.0
PatchManager - 0.0.16
Precise Maneuver - 2.4.1
RealChute - 1.4.6.1
RemoteTech - 1.8.13
AmpYear - 1.5.2
DeepFreeze Continued... - 0.23.8
ResearchBodies - 1.9.7
SCANsat - 1.1.8.7
TarsierSpaceTechnology - 7.3
TextureReplacer - 3.2
TAC Life Support - 0.13.9
Trajectories - 2.2.1
Kerbal Alarm Clock - 3.9.1
Alternate Resource Panel - 2.9.3
Transfer Window Planner - 1.6.3
TweakScale - 2.3.12
USI Core - 0.7
Freight Transport Tech - 0.10
Konstruction - 0.5
NuclearRockets - 0.7
USI Alcubierre Drive - 0.10
Kerbal Actuators - 1.6

 

Log:

https://drive.google.com/open?id=1KJVo60eYYgwjNUqzNzFOEoF4gSQDzYU3

 

 

Link to post
Share on other sites
  • 3 weeks later...
Just now, Trekkie148 said:

Why do every @linuxgurugamer mod have to use Clickbaitblocker and Toolbar Controller? It gets really annoying when I have to install these mods and it clutters up my gamedata folder which I only one or two. 

Because I maintain over 165 mods, and these are common to many of them.  You only need to have one copy of each installed (the latest), and then all the other mods which need them will use it.

This makes it easier to maintain all the mods

Link to post
Share on other sites
6 minutes ago, linuxgurugamer said:

Because I maintain over 165 mods, and these are common to many of them.  You only need to have one copy of each installed (the latest), and then all the other mods which need them will use it.

This makes it easier to maintain all the mods

Ok thanks mate.

Link to post
Share on other sites
  • 1 month later...

So I installed this mod along with it's 2 dependencies, and I'm not seeing it pop up anywhere in my KSP game when I am in the VAB/SPH. I'm worried I may have installed one of the dependencies wrong (there are several files in toolbar controller where I don't know where they go, I basically put the one file in the gamedata folder), or maybe there is a conflict with one of the other mods. Can anyone help me figure out what to do? I did not use CKAN for this (and the title page doesn't say this mod is updated for it anyways).

Link to post
Share on other sites
  • 4 weeks later...

Hello community!

I have been successfully using this mod for VAB crafts but I am struggling with (space)planes in the SPH. It is fine to display a ship from its top, its down, from its front or its rear but I cannot orientate it to make a capture from its side.

How that would be possible ?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...