RoverDude

[1.3] - Modular Kolonization System (MKS)

Recommended Posts

What was the reason behind such a drastical price change of the 'Tundra' Manufacturing modules? All big parts in the 'Manufacturing' category cost less than an MK1 Lander Can...

Share this post


Link to post
Share on other sites

@RoverDude May I also ask to shift the ladder collider a bit outwards on the 'Salamander' capsule. It's too close to the mesh collider. Kerbals' hands are clipping in and they start to slide.

PuqAY7I.jpg

https://github.com/BobPalmer/MKS/issues/1093

 

Also the ladder collider on Duna modules is of the same size as the airlock collider, which makes it impossible to click in flight.

ysfSrWu.jpg

Edited by Enceos

Share this post


Link to post
Share on other sites

Hi,

The Duna Ag says:

                name = ModuleResourceConverter_USI
                ConverterName = Cultivate(S)

                ...
                UseSpecialistBonus = true
                SpecialistEfficiencyFactor = 0.2
                SpecialistBonusBase = 0.05
                ExperienceEffect = BotanySkill
                Efficiency = 1

It seems to vaguely correspond to: 20% per Botanist level (botanists being scientists and biologists) + other ... stuff.

With a single Duna Ag, full of machinery, I'm getting:

  • load=0.25% at the KSC without crew or with no botanist
  • load=6.25% at the KSC with a level 0 scientist
  • load=42.25% at the KSC with either a level 2 scientist, a level 2 biologist, or both
  • load=75.94% landed on a moon, with level 2 scientist on board. I suspect in this case machinery was maybe a bit less than full, but this should have given me less load if anything

So it seems a bit more complicated than just 20% per skill level on the best Kerbal on board.

(the Greenhouses I can somehow understand, so I left them out of this experiment).

Can someone explain and/or give formulas ?

 

 

Share this post


Link to post
Share on other sites
14 minutes ago, TauPhraim said:

Can someone explain and/or give formulas ?

Probably a kolonization bonus of 179% you have on that moon? Check your kolonization dashboard.

There are four things that affect efficiency:

  • efficiency parts
  • highest level of the required skill (5% for level 0, 20% for each additional level)
  • machinery level
  • kolonization bonus

Share this post


Link to post
Share on other sites
3 hours ago, jd284 said:

@RoverDude, the combining of several bays/bits to the same output still doesn't work properly in 0.50.10. It only works for the vessel you switch to from the tracking station, not any others in physics range.

I made a new ticket about it. The issue was reported before by @Gilph for just Hydrates on the ASM but it actually affects all ModuleSwappableConverter parts. Basically you can never have combined converters on more than one vessel in a disconnected base at the moment, and then only if you switch to the right one every time from the tracking station (or F5+F9).

Hi, Thanks for validating and updating.  The save I have linked should also still show the problem.

Share this post


Link to post
Share on other sites
1 hour ago, jd284 said:

Probably a kolonization bonus of 179% you have on that moon? Check your kolonization dashboard.

There are four things that affect efficiency:

  • efficiency parts
  • highest level of the required skill (5% for level 0, 20% for each additional level)
  • machinery level
  • kolonization bonus

 

I have just 126% botany on that moon, so that' doesn't add up with only that.

The skill part would then read "5% for level 0, but if level is not 0, scrap that 5% and take 20% per level instead" ?

Would you know if the formula (or even code) is visible somewhere public , or is that hidden in stock KSP code now ?

Share this post


Link to post
Share on other sites

0.50.11 - 2017.01.08
--------------------
Fixed an issue where multi-bay modules were not operating at peak efficiency (Note that this is a USI Tools change so be sure to have the latest version!  This is why I bundle MiniAVC ;))
Reduced the size of Resource Lodes to 5kl
Added a new resource lode that can be found via the orbital survey scanner.  Unlike the smaller ones found with the Pioneer module, these are planet-wide and significantly larger (500kl).
Scouts can now be recruited.
The USI-LS window no longer conflicts with the Kolonization Dashboard.
Fixed prices of Tundra manufacturing modules.

Share this post


Link to post
Share on other sites

@RoverDude, where's the right place to submit patches for components that are bundled in more than one of your releases?  Kontainers is included in both MKS and FTT, with independent revision histories in each of the two Git repositories, and it's not clear which is the canonical one.

Share this post


Link to post
Share on other sites

Hello, quick question, did the OKS Hub get wiped out in recent version? Cant find it anywhere anymore (research or config files). What about the rest of the OKS modules? Did they get the boot too?

Share this post


Link to post
Share on other sites
11 minutes ago, Wyzard said:

@RoverDude, where's the right place to submit patches for components that are bundled in more than one of your releases?  Kontainers is included in both MKS and FTT, with independent revision histories in each of the two Git repositories, and it's not clear which is the canonical one.

USI Core

2 minutes ago, Boozdeuvash said:

Hello, quick question, did the OKS Hub get wiped out in recent version? Cant find it anywhere anymore (research or config files). What about the rest of the OKS modules? Did they get the boot too?

OKS bits have been deprecated for a while now

Share this post


Link to post
Share on other sites

BTW: Are you ever going to update SpaceDock so it knows your mods are compatible with 1.2?  (Github issue added as well, just as a reminder... :wink: )

Share this post


Link to post
Share on other sites
Just now, DStaal said:

BTW: Are you ever going to update SpaceDock so it knows your mods are compatible with 1.2?  (Github issue added as well, just as a reminder... :wink: )

heh, yeah I should do that at some point :P

Also need to work on Curse automation (rainy day project).

Share this post


Link to post
Share on other sites

@RoverDude, thanks for the quick bugfixes!

I have a question though regarding drill efficiency, they aren't getting bonuses from kolonization stats. Is this intentional? It seems like they should be benefitting from the geology bonus... or should I be adding more drills instead as the refinery gets better?

1 hour ago, TauPhraim said:

I have just 126% botany on that moon, so that' doesn't add up with only that.

The skill part would then read "5% for level 0, but if level is not 0, scrap that 5% and take 20% per level instead" ?

Would you know if the formula (or even code) is visible somewhere public , or is that hidden in stock KSP code now ?

That's odd then, I have no explanation for that jump in efficiency. I took the 5% and 20% from the part config, I'm pretty sure the actual efficiency calculation is in the KSP ModuleResourceHarvester code though.

Share this post


Link to post
Share on other sites
6 minutes ago, jd284 said:

I'm pretty sure the actual efficiency calculation is in the KSP ModuleResourceHarvester code though.

I used to find some code calculating efficiencies in some of the USI repos (monthes ago).

But ModuleResourceHarvester seems to be a stock KSP thing. Do you mean the code is available somewhere anyway ? I could only find some web page showing an "API", but that gives close to zero information, compared to source code.

Share this post


Link to post
Share on other sites

The part oscillation bug dboi was experiencing earlier might be influencing Tundra inflatable modules as well now, because I have a Minmus base with a 3.75m expandable hab module and, upon loading the base, the wing with the module on it begins to whip and thrash around wildly until the module breaks off (usually taking a large chunk of the base and several kerbals with it), at which point everything settles down again.

Picture won't embed

Here's the save-it's not a clean USI-mods-only save but given dboi was having a very similar problem and the oscillation originates exclusively from that one part, I think this an MKS issue (save uses OPM, NFS and MJ). Does it reproduce for anyone else?

Share this post


Link to post
Share on other sites

Maybe the modules haven't changed, but surely the underlying code has gone through some revisions? Both use USIAnimation which had some changes I think.

It might be worth testing with an older USITools release (which will have other bugs but maybe not this one).

Share this post


Link to post
Share on other sites
1 hour ago, RoverDude said:

At a loss given those modules literally have had no changes in months...

Ah well. Looks like I'm going to have to either quarantine my base until the issue is found, since it starts dubstepping the moment it comes into physrange, or let the damn thing break off and hope it misses the solar panels. Will try downgrading to 0.5.8 to check it it persists.

EDIT: Downgrading does NOT bring Minmus Base "Boogie" back under control. I have had a similar issue in vanilla before, so it might not be MKS after all. Will raise this on the main forums later.

Edited by voicey99

Share this post


Link to post
Share on other sites
1 hour ago, jd284 said:

Maybe the modules haven't changed, but surely the underlying code has gone through some revisions? Both use USIAnimation which had some changes I think.

It might be worth testing with an older USITools release (which will have other bugs but maybe not this one).

Yep the problem does seems to be related to USITools. I've run some more tests and all MKS versions 8 - 11 are fine and do not exhibit this behavior with USI Tools 0.8.7 installed. Switch to 0.8.8 and everything goes wild. There were changes to USIAnimation to do with control surfaces? between 0.8.7 and 0.8.8 some hopefully this might make some sense to you @RoverDude.

Edit: Save file  https://drive.google.com/file/d/0B_nRjcqonDoUbzRIT0JOd1psWnM/view?usp=sharing

Edited by dboi88

Share this post


Link to post
Share on other sites

So does my base actually dance for anyone else, or is it just me and not MKS-related? As in, should I hold off on filing a ticket in the mainstream modded support section for the moment?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.