Jump to content

CKAN (The Comprehensive Kerbal Archive Network); v1.28.0 - Dyson


Recommended Posts

1 minute ago, Rohaq said:

I'm guessing it has something to do with this?

xXb3wsC.png

Though I'm not sure how this would be resolved, seeing as I don't have the DLC.

I have MH installed and it's still not working. 

Link to post
Share on other sites
16 minutes ago, Tyko said:

Thanks! did I do something wrong? I see it come up under Filter (New) but there's no checkbox next to it as if I was running an incompatible version of KSP (I'm running 1.4.2)

MtoKGaX.png

CKAN 1.25.1 is needed to be able to install mods that depend on MakingHistory.

Link to post
Share on other sites
5 minutes ago, HebaruSan said:

CKAN 1.25.1 is needed to be able to install mods that depend on MakingHistory.

That worked. I didn't even know there was an update. I don't think CKAN ever notified me and I couldn't find an Upgrade option in the app. Do I just have to check the forum occasionally?

Thanks!

Edited by Tyko
Link to post
Share on other sites
2 minutes ago, Tyko said:

That worked. I didn't even know there was an update. I don't think CKAN ever notified me and I couldn't find an Upgrade option in the app. Do I just have to check the forum occasionally?

The auto-updater was broken in 1.24.0. It should be working again as of 1.25.0.

Link to post
Share on other sites
12 minutes ago, Tyko said:

I couldn't find an Upgrade option in the app

You can find what you're looking for in Settings > CKAN Settings and clicking on the "Check for updates" button at the bottom of the dialog box.

Link to post
Share on other sites
13 hours ago, HebaruSan said:

Thanks for the video. We have an investigation in progress for this here:  https://github.com/KSP-CKAN/CKAN/issues/2428

You mentioned that you had this problem for other mods as well, but so far it looks as though the cause is specific to Scatterer. Do you by any chance remember the other mods that had problems upgrading? That could be very helpful in identifying the cause; thanks!

I also had this issue with the dev version of MechJeb a few days ago. It was listing a conflict with the RO version of MJ in the "Relationships" tab, which I don't have installed. This was on CKAN 1.25.0, which I've subsequently updated to 1.25.1. As with Scatterer, uninstalling the mod and installing the new version solved the issue temporarily.

https://imgur.com/P7aHnkr
https://imgur.com/zhnDnDl
 
Edited by IntoSpaceAgain
Updating with imgur links
Link to post
Share on other sites

@HebaruSan@DasSkelett

Hey guys, I updated to KSP 1.4.3 and still on CKAN 1.25.1 otherwise nothing has changed.

FYI:
The update issue I mentioned about "Scatterer" and "VesselMover Continued". I experienced the issue again with VesselMover, that had new update to the mod yesterday. I will report back if I experience this issue with some other mod.

Link to post
Share on other sites
On 4/26/2018 at 4:47 PM, Tyko said:

Thanks! Is this all you need? 

{
    "spec_version" : 1,
    "identifier"   : "EngineTweaks_MH",
    "$kref"        : "#/ckan/github/TykoTek/EngineTweaks_for_MakingHistory",
    "license"      : "MIT License",
    "ksp_version"  : "1.4.99",
    "resources": {
        "homepage": "https://forum.kerbalspaceprogram.com/index.php?/topic/174303-14x-engine-tweaks-for-making-history/"
    }
}

I appreciate the suggestion about Spacedock. I'll look at adding a repository there too eventually.

@HebaruSan - the homepage link isn't working. I just confirmed the working link and it matches what I had in my request above. CKAN appears to have some added characters at the end that's messing it up

When you get a moment could you please check it out?  Thanks!

 https://forum.kerbalspaceprogram.com/index.php?/topic/174303-14x-engine-tweaks-for-making-history/

 

Link to post
Share on other sites

I am running 1.4.2 version of KSP_x64,it a relatively new version of the game therefore a lot of mods are still at 1.4.1.

Is there a way to trick ckan that I am runing 1.4.1, by doing this, installing 1.4.1 mods in my 1.4.2 KSP with ckan?

Link to post
Share on other sites
32 minutes ago, Tyko said:

@HebaruSan - the homepage link isn't working. I just confirmed the working link and it matches what I had in my request above. CKAN appears to have some added characters at the end that's messing it up

When you get a moment could you please check it out?  Thanks!

 https://forum.kerbalspaceprogram.com/index.php?/topic/174303-14x-engine-tweaks-for-making-history/

 

There was one of these in there:  http://www.fileformat.info/info/unicode/char/FEFF/index.htm

Should be gone now.

3 minutes ago, Iso-Polaris said:

Is there a way to trick ckan that I am runing 1.4.1, by doing this, installing 1.4.1 mods in my 1.4.2 KSP with ckan?

Yes:  https://github.com/KSP-CKAN/CKAN/wiki/User-guide#choosing-compatible-game-versions

Link to post
Share on other sites

Space y expanded and space y heavy lifters are showing up as not installed when I have them both installed. I know they are marked as not compatible with 1.4.2 but they should still be showing up as installed in the incompatible list.

Link to post
Share on other sites
3 hours ago, MikeO89 said:

Space y expanded and space y heavy lifters are showing up as not installed when I have them both installed. I know they are marked as not compatible with 1.4.2 but they should still be showing up as installed in the incompatible list.

I tried this, and it does show up as installed:

v43Db6S.png

Link to post
Share on other sites

On mine there are no check boxes to check as it's in the incompatible list. They were checked once and I think I upgraded them to newer versions (even though even the newer version are not 1.4.2 yet). Since I could not do that in ckan, I un-installed them in ckan, then installed  both again manually. CKan seems not to recognize that they are there.

Link to post
Share on other sites
27 minutes ago, MikeO89 said:

installed  both again manually

Oh, that makes sense. The checkbox is only for mods that CKAN installed (or manually installed mods containing a DLL with a name that exactly matches the mod identifier).

Link to post
Share on other sites

I thought when you installed manually, ckan put an AD there and you at least could see the version you had installed. I had to install them manually, ckan won't let you install if it's in the incompatibility list unless I'm missing something.

Link to post
Share on other sites
43 minutes ago, MikeO89 said:

I thought when you installed manually, ckan put an AD there and you at least could see the version you had installed. I had to install them manually,

Yup; that's why I mentioned "manually installed mods containing a DLL with a name that exactly matches the mod identifier". That's how that works.

43 minutes ago, MikeO89 said:

ckan won't let you install if it's in the incompatibility list unless I'm missing something.

Scroll up. :)  https://github.com/KSP-CKAN/CKAN/wiki/User-guide#choosing-compatible-game-versions

Link to post
Share on other sites

Well hell, I don't know what to then to get ckan to at least recognize both space y mods are installed because I can see no dll in either of the two folders. Dunno if should change ckan game versions to allow 1.4. Worried mods will pop in there that might cause me problems. Forgive me if I'm not understanding. If spacey undates their mods to 1.4.3, will they then appear in the compatibility list with an open checkbox?

 

Edit: Ok I got it. Let ckan show mods for 1.4 then both appeared with check boxes. Deleted the mods manually and let ckan install them again. Got check boxes checked. All good

Edited by MikeO89
Link to post
Share on other sites

I have a problem. I installed Making History over Ksp 1.4.1 from Steam. I have mods like deflateable heat shield that show up as incompatible despite it being compatible for 1.4.2. I am not spending $15 on the DLC from the store. Something is wrong as my compatible mod list in CKAN does not show many that are compatible. If anyone knows how to resolve without paying cash, please PM me. I am using the latest CKAN build but no logs as like I said it is probably an indexing issue. 

Link to post
Share on other sites

Could you check why Blue Dog Bureau is not showing up in compatibility list? Ckan currently shows it at 1.4.1 but even when I  change ckan to allow listing 1.4, it still doesn't show up as compatible.

Link to post
Share on other sites
18 hours ago, wizisi2k said:

I have a problem. I installed Making History over Ksp 1.4.1 from Steam. I have mods like deflateable heat shield that show up as incompatible despite it being compatible for 1.4.2. I am not spending $15 on the DLC from the store. Something is wrong as my compatible mod list in CKAN does not show many that are compatible. If anyone knows how to resolve without paying cash, please PM me. I am using the latest CKAN build but no logs as like I said it is probably an indexing issue. 

1.4.1 ≠ 1.4.2

Link to post
Share on other sites

Still not working on Linux.   Different errors this time. 

I posted a new bug report because of drastically different errors.  Feel free to link the two errors, of course.

Specifically, It's trying to call libcurl despite the curl code being removed.

Link to post
Share on other sites

HebaruSan,

I am using 1.4.3 versions of KSP and MHE with V1.25.1 Broglio.

I have gone into "Compatible KSP Versions" and selected 1.4.2 and 1.4.1 as compatible with my build.

When I do this I get an old update for "KW Rocketry Rebalanced" trying to ovewrite a newer update.
KW-R-R 3.2.5.1 trying to overwrite KW-R-R 3.2.5.3 as newer due to the marking mistake that 3.2.5.1 is marked as KSP 1.3.0 -1.4.99 compatible. KW-R-R 3.2.5.3 is only marked as 1.4.1 compatible.

Are you able to modify this to correct it?

 

Edited by Prowler_x1
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...