Nertea

[1.7.x] Near Future Technologies (NFC update Oct 4th)

Recommended Posts

On 11/2/2018 at 6:23 PM, AmpCat said:

Hmm, I dunno, Lithium engines are my favorite. Strikes just the right balance of energy efficiency and thrust, in my book. Normal ion engines just aren't worth using in most cases. You might not have taken into account that the engine design, not just the fuel, can be a differentiating factor.

But, I digress. :)

The big difference between KSP and real life is that in real life if your ion satellite takes six weeks to boost itself from LEO to its final orbit, it's no big deal. But it's boring as hell in a game, particularly since time warp with engines running is so fraught with computer-crashing peril.

Share this post


Link to post
Share on other sites
7 minutes ago, mikegarrison said:

The big difference between KSP and real life is that in real life if your ion satellite takes six weeks to boost itself from LEO to its final orbit, it's no big deal. But it's boring as hell in a game, particularly since time warp with engines running is so fraught with computer-crashing peril.

That's exactly my point. I give myself a target TWR so I won't get bored doing a 5 minute burn (much less hours or months). The lithium engines allow me to make an ion engine craft that gets close to enough thrust to not be boring. I really never use ion engines otherwise.

Share this post


Link to post
Share on other sites

Hey guys, did the cooling for the nuclear reactors get nerfed sometime recently?  Are they now putting out more heat than they previously were?

A ship that I built using NFT engines and reactors that ran perfectly fine is now overheating, and from looking at the specs in the VAB I definetly don't have enough cooling for the reactors.  But I swear when I built this ship I worked out the cooling needs very specifically, I had plenty of cooling capacity and I took it to Jool and back with no problems.  So was there a config change sometime in the last year?  (I'm still running way behind on versions due to mod compatibility)

Share this post


Link to post
Share on other sites

Guys how in hells bells would you get Kerbal Engineering to ascertain the "Burn Time" of the Electrical Engine types in NF Propulsion?

Is it even possible?

Share this post


Link to post
Share on other sites

And... just because I don't think we see enough of what people make with Near Future Tech, here's my latest mission; first trip to Duna. Using a lithium drive and trying out cryo-stasis from the DeepFreeze mod, for the first time:

bNmx5Zm.png

Yes, it's dark... but space is cold and black.

Edit: Oh, this is about 80% NFT. Aside from the module with the green gardens on it (the DeepFreeze module, though the green hydroponics domes are from USI Life Support) and the service bay (from Universal Storage II) just aft of it, the rest is almost entirely @Nertea's parts.

Edited by AmpCat

Share this post


Link to post
Share on other sites

You can also look up my STS missions. I'm using Mk 4 Spaceplanes, Cryo Tanks/Engines, Launch Vehicles, Spaceflight, and probably some other ones I've forgotten.

Share this post


Link to post
Share on other sites
5 hours ago, tsaven said:

A ship that I built using NFT engines and reactors that ran perfectly fine is now overheating

No intentional changes IIRC, though without you mentioning what version you came from and what version you use now it's impossible to say for sure.

In what situations is your craft overheating? Time warp? Loading an unfocused craft? Normal flight?

Which radiators are you using for which reactor? In case of fixed panels, are they all turned on?

Can you replicate the cooling issue if you use the same reactor and cooling configuration in a barebones instance with only NF Electrical and its dependencies?

 

4 hours ago, ToastyOats said:

Guys how in hells bells would you get Kerbal Engineering to ascertain the "Burn Time" of the Electrical Engine types in NF Propulsion?

Is it even possible?

I have no idea what you mean. Kerbal Engineer has always worked fine for me.

Since I am slow, explain with pictures, please? :) 

Share this post


Link to post
Share on other sites

Sorry if this is off topic as I am not trying to rustle any feathers.

 

but I recently got back into playing and into modding and want to use these mods, but I am currently on 1.5.1 and it won't load them.  is there something I need to do or an ETA for 1.5.1?

Share this post


Link to post
Share on other sites
14 hours ago, AmpCat said:

And... just because I don't think we see enough of what people make with Near Future Tech, here's my latest mission; first trip to Duna. Using a lithium drive and trying out cryo-stasis from the DeepFreeze mod, for the first time:

bNmx5Zm.png

Yes, it's dark... but space is cold and black.

Edit: Oh, this is about 80% NFT. Aside from the module with the green gardens on it (the DeepFreeze module, though the green hydroponics domes are from USI Life Support) and the service bay (from Universal Storage II) just aft of it, the rest is almost entirely @Nertea's parts.

 

cool ship! i agree, i think folks should share more of their designs. helps us to crowd source ideas and best practices. it's all good to reinvent the wheel each time but to each their own! XD

Share this post


Link to post
Share on other sites
17 hours ago, tsaven said:

Hey guys, did the cooling for the nuclear reactors get nerfed sometime recently?  Are they now putting out more heat than they previously were?

A ship that I built using NFT engines and reactors that ran perfectly fine is now overheating, and from looking at the specs in the VAB I definetly don't have enough cooling for the reactors.  But I swear when I built this ship I worked out the cooling needs very specifically, I had plenty of cooling capacity and I took it to Jool and back with no problems.  So was there a config change sometime in the last year?  (I'm still running way behind on versions due to mod compatibility)

We did a modification to this in version 0.9.0, which was around KSP 1.3 (May 2017). Nothing since then.

I'm still probably a week away from finishing NF Spacecraft updates, so as a result here are the 1.5.x updates for the remaining mods. 

NF Propulsion 1.0.4

  •  KSP 1.5.x
  •  Updated ModuleManager to 3.1.0
  •  Updated B9PartSwitch to 2.4.5
  •  Updated CRP to 1.0.0
  •  Removed MiniAVC distribution
  •  Updated Gas Separator part to use new CRP atmospheric rules
  •  Updated ModuleRCSEmissive with options for other color curves than simply alpha and ability to specify the shader property to work on

NF Electrical 0.10.3

  •  KSP 1.5.x
  •  Updated B9PartSwitch to 2.4.5
  •  Updated CRP to 1.0.0
  •  Updated ModuleManager to 3.1.0
  •  Updated DynamicBatteryStorage to 1.3.3
  •  Removed MiniAVC

NF Construction 1.0.4

  •  KSP 1.5.x
  •  Updated MM to 3.1.0
  •  Updated B9PartSwitch to 2.4.5
  •  Fixed a issue with some parts that would cause B9PS to throw errors in versions >2.4.0
  •  Modified the orientation of the 2.5m octo-docking port to be consistent
  •  Fixed tech tree nodes for both linear docking connectors

NF Solar 0.8.13

  •  KSP 1.5.x
  •  Updated MM to 3.1.0
  •  Removed MiniAVC distribution

NF Launch Vehicles 1.1.7

  •  KSP 1.5.x
  •  Updated B9PartSwitch to 2.4.5
  •  Updated MM to 3.1.0
  •  Removed MiniAVC distribution
  •  Fixed an issue with the 5m docking port's collider

NF Aeronautics 1.0.2

  •  KSP 1.5.x
  •  Updated MM to 3.1.0
  •  Updated CRP to 1.0.0
  •  Updated B9PartSwitch to 2.4.5
  •  Removed MiniAVC distribution
  •  Added Spanish translation (Sergi Ruiz Zarzuelo)

Share this post


Link to post
Share on other sites

@Nertea Excluding the included dependencies, were the various .dll files recompiled against 1.5.1? Of your mods I only use NF Electrical, Solar and Dynamic Battery Storage. I downloaded the new versions from Spacedock and comparing against a 1.4.5 save the only files that show an actual difference are  the .version files. This was a binary comparison in Beyond Compare of the downloaded update against the installed version I've been running since August.

Share this post


Link to post
Share on other sites
6 minutes ago, Tonka Crash said:

@Nertea Excluding the included dependencies, were the various .dll files recompiled against 1.5.1? Of your mods I only use NF Electrical, Solar and Dynamic Battery Storage. I downloaded the new versions from Spacedock and comparing against a 1.4.5 save the only files that show an actual difference are  the .version files. This was a binary comparison in Beyond Compare of the downloaded update against the installed version I've been running since August.

NF Propulsion was recompiled, as new content was added. The rest are configuration, dependency and distribution changes. If you don't care about those you can stick with the ones you have. 

Share this post


Link to post
Share on other sites

@Nertea Thanks, I just wanted to confirm that something hadn't been left out by mistake. I've seen it happen before from other mods.

 

Share this post


Link to post
Share on other sites

@Nertea, there's a bug being flagged by B9, although it's not a show-stopper:

B9PartSwitch has encountered a serious warning. The game will continue to run but this should be fixed ASAP.

Subtype has no name: PartSubtype

Duplicated subtype names found on ModuleB9PartSwitch (moduleID='meshSwitch3') on part truss-spinal-01:

Please see KSP's log for additional details

Despite the last line there's no further information in the log about the error.

Share this post


Link to post
Share on other sites
8 minutes ago, JH4C said:

@Nertea, there's a bug being flagged by B9, although it's not a show-stopper:

B9PartSwitch has encountered a serious warning. The game will continue to run but this should be fixed ASAP.

Subtype has no name: PartSubtype

Duplicated subtype names found on ModuleB9PartSwitch (moduleID='meshSwitch3') on part truss-spinal-01:

Please see KSP's log for additional details

Despite the last line there's no further information in the log about the error.

This is the fix mentioned here: 

3 hours ago, Nertea said:
  •  Fixed a issue with some parts that would cause B9PS to throw errors in versions >2.4.0

Are you sure you have the new version?

Share this post


Link to post
Share on other sites
2 minutes ago, Nertea said:

This is the fix mentioned here: 

Are you sure you have the new version?

Hm, I thought I did; I spent all afternoon updating things today. I'll re-install anyway; sorry for the (probably) unnecessary report.

Share this post


Link to post
Share on other sites
Just now, JH4C said:

Hm, I thought I did; I spent all afternoon updating things today. I'll re-install anyway; sorry for the (probably) unnecessary report.

I could still have made a mistake in an upload somewhere so appreciated. 

Share this post


Link to post
Share on other sites
3 minutes ago, Nertea said:

I could still have made a mistake in an upload somewhere so appreciated. 

You're in the clear, it was me; I grabbed all the others I use, but somehow overlooked that pack.

Share this post


Link to post
Share on other sites

[snip]

Thanks for all the work you do.

 

Hopefully that didn't sound too serious... 

I am dying of anticipation though.

Edited by Vanamonde

Share this post


Link to post
Share on other sites

I was wondering how NF Spacecraft was working in 1.5.1, Ive been looking for more thruster options since stock has very few. Considered installing it to see if it was ok or not.

Share this post


Link to post
Share on other sites
2 hours ago, overkill13 said:

[snip]

Thanks for all the work you do.

 

Hopefully that didn't sound too serious... 

I am dying of anticipation though.

Please don't get carried away with enthusiasm when expressing appreciation for a mod maker's work. It can come across as harsh, especially when expressed with coarse language, even in jest. 

Share this post


Link to post
Share on other sites
21 hours ago, Streetwind said:

No intentional changes IIRC, though without you mentioning what version you came from and what version you use now it's impossible to say for sure.

In what situations is your craft overheating? Time warp? Loading an unfocused craft? Normal flight?

Just totally normal flight, and from looking at the specs in the VAB I simply don't have enough radiators.  But I know I DID have enough radiators previously, so I'm assuming the specs changed.

I've got four M2-XL reactors, 40x edge mounted radiators and 2x of the Large active radiators.  They're all on, but that's clearly not enough to cool down 16,000kw of heat.

8 hours ago, Nertea said:

We did a modification to this in version 0.9.0, which was around KSP 1.3 (May 2017). Nothing since then.

Oh.  Yeah, that's it then. I only recently upgrade from 1.2.2 to 1.3.1 (OPM VO is still holding me up).

Time to go slap a bunch more radiators on this thing! 

Share this post


Link to post
Share on other sites
11 minutes ago, tsaven said:

Just totally normal flight, and from looking at the specs in the VAB I simply don't have enough radiators.  But I know I DID have enough radiators previously, so I'm assuming the specs changed.

I've got four M2-XL reactors, 40x edge mounted radiators and 2x of the Large active radiators.  They're all on, but that's clearly not enough to cool down 16,000kw of heat.

Oh.  Yeah, that's it then. I only recently upgrade from 1.2.2 to 1.3.1 (OPM VO is still holding me up).

Time to go slap a bunch more radiators on this thing! 

If it's any consolation, once you make the switch, you will get some better performance than before!

1 hour ago, Vanamonde said:

Please don't get carried away with enthusiasm when expressing appreciation for a mod maker's work. It can come across as harsh, especially when expressed with coarse language, even in jest. 

It was fine dude!

1 hour ago, Kevin Kyle said:

I was wondering how NF Spacecraft was working in 1.5.1, Ive been looking for more thruster options since stock has very few. Considered installing it to see if it was ok or not.

Best to wait a week. 

Share this post


Link to post
Share on other sites

I had zero issues with the last full release of NF Spacecraft in 1.5.1... And the dev branch is working quite well atm, too.

Share this post


Link to post
Share on other sites
56 minutes ago, Nertea said:

If it's any consolation, once you make the switch, you will get some better performance than before!

Haha, well I'm likely on 1.3.1 for a while now.  I've got so many mods that are hacked into working together that I want to put some time into actually playing the game for a while, rather than constantly writing MM configs to make things work properly.  :)

Maybe mid next year once mods are caught up, then I'll think about looking at 1.5.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.