themaster401

[KSP 1.8.0] Astronomer's Visual Pack [v3.83 "Endgame"]

Recommended Posts

When I look at some planets in map or regular view there are white/blue dots randomly and quickly jumping around planet, look like on screenshot below. There are also some fumes around Moho..

screenshot0.png screenshot1.png

Any ideas?

Edited by Mystique

Share this post


Link to post
Share on other sites

Hey, I have a gtx 1070ti ryzen 7 2700x and 16gb ram , and am only avraging 35 fps , how can i fix this

Edited by exia00tronrzr

Share this post


Link to post
Share on other sites

Hey guys, mod works great and looks great. I'm using the 8k texture pack with the 43k clouds but whenever I try to install a terrain texture pack (either KSPRC or SVT) they overwrite my AVP settings for atmosphere/clouds. I've followed installation properly including removing atmosphere/city lights from KSPRC before installing but still to no joy. I feel like i'm stuck in a dilemma where I can either have stock terrain and nice atmosphere/clouds or have nice terrain with underwhelming clouds... If there's anyone who has any help would be greatly appreciated.  

7 hours ago, JojoGames114 said:

hi, having problems with clouds. they won't show up at all, in the main menu and ingame. other than AVP and the dependencies, i have only a couple other mods. any solutions? here's my gamedata folder: https://drive.google.com/file/d/10urNzgSstLXtGeUavn9d8q7Hz-j-APZJ/view?usp=sharing

from what I can see, you've installed your AVP Textures wrong, you need to open the AVPtextures file and drag the 'EVE' file into the 'EVE' folder located inside your 'AstronomersVisualPack' folder, there should only be 1 AVP folder

Edited by Louis93

Share this post


Link to post
Share on other sites
On 2/20/2019 at 1:01 PM, Mystique said:

When I look at some planets in map or regular view there are white/blue dots randomly and quickly jumping around planet, look like on screenshot below. There are also some fumes around Moho..

 

I looked into it, the white/blue dots are lightning, and mono just has that.

This means you have a working mod.

Share this post


Link to post
Share on other sites
5 hours ago, Louis93 said:

Hey guys, mod works great and looks great. I'm using the 8k texture pack with the 43k clouds but whenever I try to install a terrain texture pack (either KSPRC or SVT) they overwrite my AVP settings for atmosphere/clouds. I've followed installation properly including removing atmosphere/city lights from KSPRC before installing but still to no joy. I feel like i'm stuck in a dilemma where I can either have stock terrain and nice atmosphere/clouds or have nice terrain with underwhelming clouds... If there's anyone who has any help would be greatly appreciated.  

from what I can see, you've installed your AVP Textures wrong, you need to open the AVPtextures file and drag the 'EVE' file into the 'EVE' folder located inside your 'AstronomersVisualPack' folder, there should only be 1 AVP folder

i moved the EVE folder inside the AVP folder in the AVPtextures folder to the EVE folder in the AVP folder in my gamedata. still doesn't work, assuming i did it wrong

Share this post


Link to post
Share on other sites
1 hour ago, JojoGames114 said:

i moved the EVE folder inside the AVP folder in the AVPtextures folder to the EVE folder in the AVP folder in my gamedata. still doesn't work, assuming i did it wrong

For SVT, do you only have Kopernicus installed with it or did you install Stock Visual Enhancements as well? SVE would be the only thing that overwrites AVP I believe.

Share this post


Link to post
Share on other sites
1 minute ago, SpaceFox25 said:

For SVT, do you only have Kopernicus installed with it or did you install Stock Visual Enhancements as well? SVE would be the only thing that overwrites AVP I believe.

No I haven't installed SVE with it, just Kopernicus and SVT and I don't even see any atmosphere configs in either of these mods which I find strange.

Share this post


Link to post
Share on other sites
3 hours ago, SpaceFox25 said:

For SVT, do you only have Kopernicus installed with it or did you install Stock Visual Enhancements as well? SVE would be the only thing that overwrites AVP I believe.

I don't have any of those mods installed. here's my gamedata folder:  https://drive.google.com/file/d/10urNzgSstLXtGeUavn9d8q7Hz-j-APZJ/view?usp=sharing

Share this post


Link to post
Share on other sites
42 minutes ago, JojoGames114 said:

tried reinstalling AVP and the dependencies. highlighted folder is the AVP textures. still no clouds. https://photos.app.goo.gl/Fi8oZMuCHEkPkawk9

No, the textures folder has to be inside the AstronomersVisualPack folder, and inside the EVE folder in there, so that the location will be ...Kerbal Space Program\GameData\AstronomersVisualPack\EVE\Textures

Share this post


Link to post
Share on other sites
19 hours ago, SpaceFox25 said:

No, the textures folder has to be inside the AstronomersVisualPack folder, and inside the EVE folder in there, so that the location will be ...Kerbal Space Program\GameData\AstronomersVisualPack\EVE\Textures

thanks for clarifying. clouds finally work now. im using KS3P and the KSPRC textures with it, so it looks absolutely beautiful.

annnnd i have another problem. IVA isn't working. the mini IVA views are just black and when i hit C i get a view inside the capsule that's all glitched out with no interior. probably something to do with texturereplacer.

Share this post


Link to post
Share on other sites
On 2/22/2019 at 5:49 PM, The_Arcitect said:

I looked into it, the white/blue dots are lightning, and mono just has that.

This means you have a working mod.

Wow, I feel for those poor creatures that live on planets where lightning strikes live every second or two across whole planet (provided that there is any life form that can survive this). maybe there is way to decrease flash frequency so it'll look less like a disco ball?)

Share this post


Link to post
Share on other sites

Many apologies for the lack of responses; let's get to the support queries!

On 2/21/2019 at 12:07 AM, exia00tronrzr said:

Hey, I have a gtx 1070ti ryzen 7 2700x and 16gb ram , and am only avraging 35 fps , how can i fix this

Check to make sure you have no conflicting visual mods or mods in general. Alt+F12, check to make sure your console isn't being spammed with nullrefs. If that doesn't give any pointers, shoot me your KSP.log.

On 2/20/2019 at 10:01 AM, Mystique said:

When I look at some planets in map or regular view there are white/blue dots randomly and quickly jumping around planet, look like on screenshot below. There are also some fumes around Moho..

screenshot0.png screenshot1.png

Any ideas?

Respectively, that is lightning and the other is Moho's ablation. Both are intentional effects; Eve has vicious storms while Moho is being bombarded by Kerbol's energy.

On 1/31/2019 at 2:49 PM, The Spac said:

Yeah hi, so I have this problem with the non atmosphere moons. It looks like all of them have an atmosphere, when they don't. Like the Mun for example. I'll try to land on it, and once I get lower and lower, it looks like i'm going into an atmosphere. Of course, there is none. But it's odd.

 

I could use some help with this, thank you

The glow around non-atmospheric bodies is an aesthetic choice. It shouldn't look like an atmosphere once you are near the surface, though I will take this into consideration and change it next update :)

 

On 1/18/2019 at 12:17 PM, BARRAGAN said:

Hello,

I really enjoy the graphic improvements of this mod but this add-on is a such gpu/cpu killer. During takeoff phases I'm having between 5 and 10 fps. Yet, I own a solid rig (specs: gtx1080, r5 1600x, 16gb ddr4). Although, once I'm in space, it's much better as I'm often over 60 fps.

What can i do to improve my framerate during takeoff phases? Would it help if I use 4k textures instead of 8k?

At last, how can I remove or decrease the amount of aurora borealis? it seems to me that they are either too large, too green or either too much on the upper layer of the atmosphere. moreover I would say that they are too homogenously distributed (their pattern  are not chaotic enough) which gives the impression of two verdatres couples that crown the poles of kerbin.

Best regards, f.

In the tracking station, you can open the EVE GUI using the cloud button in the bottom right, scroll to EVE_CLOUDS then the aurora.cfg file, and modify the parameters of Kerbin's aurora effects to your liking.

 

Share this post


Link to post
Share on other sites
20 hours ago, themaster401 said:

Eve has vicious storms

Yeaaah, ok, but first I noticed this effect on Kerbin (Eve was just in view to make a screenshot), then on Jool and somewhere else, taking into account rapid blinking I thought it was some sort of texture bug or something. Flashing frequency seems to be about the same on all these planets, btw.

Share this post


Link to post
Share on other sites

Hi guys.

Does this mod really work with KSP 1.6.1 as the title suggests?

My CKAN lists it as incompatible.

Any way around this?

Share this post


Link to post
Share on other sites
9 minutes ago, fabianovc said:

Hi guys.

Does this mod really work with KSP 1.6.1 as the title suggests?

My CKAN lists it as incompatible.

Any way around this?

This is the one bad thing about CKAN and I know that many people on the forum will disagree with me. CKAN checks out the version file included with all CKAN compatible mods. The mod may work perfectly fine with CKAN but if the version file has not been updated to reflect this, then it will show the mod as being incompatible.

The best way to know is to test it yourself. Go to the mod's page on the forum and go to the GitHub link and download the entire zip file. Then in whatever file explorer program you are in, go into the GameData folder of the zip file, then right click on the folder name within the GameData folder. Select copy, then go paste it in your GameData file in the game folder. Test it. If it doesn't cause any crashes, ignore CKAN's warning. If it does crash your game, just delete it from your game's GameData folder. You can then reload the game and play without the mod.

I hope that helps.

 

Share this post


Link to post
Share on other sites
1 minute ago, adsii1970 said:

This is the one bad thing about CKAN and I know that many people on the forum will disagree with me. CKAN checks out the version file included with all CKAN compatible mods. The mod may work perfectly fine with CKAN but if the version file has not been updated to reflect this, then it will show the mod as being incompatible.

The best way to know is to test it yourself. Go to the mod's page on the forum and go to the GitHub link and download the entire zip file. Then in whatever file explorer program you are in, go into the GameData folder of the zip file, then right click on the folder name within the GameData folder. Select copy, then go paste it in your GameData file in the game folder. Test it. If it doesn't cause any crashes, ignore CKAN's warning. If it does crash your game, just delete it from your game's GameData folder. You can then reload the game and play without the mod.

I hope that helps.

 

Thats a bugger.

In any case, thank you so much. =)

Using this manual method I'd also need to download/copy all dependencies individually, right?

Share this post


Link to post
Share on other sites
35 minutes ago, fabianovc said:

Using this manual method I'd also need to download/copy all dependencies individually, right?

Not if the dependencies are already showing as up to date. I use this mod myself in 1.6.1 and have not had any problems. But please be aware - the other mods I have in my GameData folder may not be the same as yours. And this is why I am hesitant to tell you, "sure, go ahead, it's compatible" because as soon as I do that - it won't work for you.

:)

 

Share this post


Link to post
Share on other sites

Is there any way to reduce the frequency of lightening strikes? Kerbin looks like a strobe light at night.

Share this post


Link to post
Share on other sites
18 hours ago, adsii1970 said:

Not if the dependencies are already showing as up to date. I use this mod myself in 1.6.1 and have not had any problems. But please be aware - the other mods I have in my GameData folder may not be the same as yours. And this is why I am hesitant to tell you, "sure, go ahead, it's compatible" because as soon as I do that - it won't work for you.

:)

 

Nice, thx man!

Share this post


Link to post
Share on other sites

hello master, May I ask you some questions?

1 How to modify the color of the atmosphere, such as dark blue.

2 Are there any websites where you can learn about settings like scatter and Eve parameters?

3 I've changed a lot of mods, like SVE GEA and spectra. But the effect is not very satisfactory. I want to try to fine-tune the parameters myself

Thankyou

Share this post


Link to post
Share on other sites
On 1/31/2019 at 4:49 PM, The Spac said:

Yeah hi, so I have this problem with the non atmosphere moons. It looks like all of them have an atmosphere, when they don't. Like the Mun for example. I'll try to land on it, and once I get lower and lower, it looks like i'm going into an atmosphere. Of course, there is none. But it's odd.

I could use some help with this, thank you

@The Spac  NOTE!  If you want to edit a configuration file to remove the glows around the moons, you'll find the instructions below.  BACK UP the file someplace safe BEFORE you start to edit it.  That way you can repair any accidentally induced issues.  Skills necessary for this are the ability to navigate the folders inside the game directory and the skill to use a text editor to edit the contents of a text file.  (Do not use a word processor, unless you laughed at that statement because you know how to use a word processor to get around the problem.) 

In ..\GameData\AstronomersVisualPack\EVE\ there is a file named "glow.cfg"  If you open that file up with a text editor you will see it contains a number of blocks of text, each starting with "OBJECT".  Each of the OBJECTS represents a celestial body.  That body is on the first line, where it says "name = <bodyname>-glow"

Find each <bodyname>  you don't want to have this glow/atmosphere on, and comment out the block of text.  To do that, put two two slashes in the front of the OBJECT line, and every line after that until the line just above the next OBJECT.  (That last line should just be a "}" character.

Save said file and restart KSP.  You should find a nice set of airless moons now inhabiting your solar system.  The spoiler below shows Dres losing its glow.

Spoiler

//    OBJECT
//    {
//        name = Dres-glow
//        body = Dres
//        altitude = 6000
//        settings
//        {
//            _DetailDist = 1E-05
//            _Color = 255,255,255,20
//            _MainTex
//            {
//                value = AstronomersVisualPack/EVE/Textures/blank
//            }
//            _DetailTex
//            {
//                value = AstronomersVisualPack/EVE/Textures/clear
//            }
//        }
//        layer2D
//        {
//            macroCloudMaterial
//            {
//                _RimDistSub = 1E-05
//            }
//        }
//    }
    OBJECT
    {
        name = Duna-glow
        body = Duna
        altitude = 8000
        speed = 0,0,0
        settings
        {
            _DetailDist = 1E-05
            _Color = 0,0,70,60
            _MainTex
            {
                value = AstronomersVisualPack/EVE/Textures/blank
            }
            _DetailTex
            {
                value = AstronomersVisualPack/EVE/Textures/clear
            }
        }
        layer2D
        {
            macroCloudMaterial
            {
                _MinLight = 1
                _RimDistSub = 1E-05
            }
        }
    }

 

Share this post


Link to post
Share on other sites
Posted (edited)

Is it not working with CKan for anyone else?

 

I get this error:

AVP-4kTextures v1.7 depends on AstronomersVisualPack, which is not compatible with the currently installed version of KSP

 

Edited by SpacecraftX

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.