FreeThinker

[1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] KSP Interstellar Extended 1.22.9 Continued Development Thread

Recommended Posts

MyfAlUf.jpg

 

Magnetically confined fission something like this?
Ignore the fact that parts dont line up. this is 5 minutes of work. :D

*edit* I should probably tag @FreeThinker since hes the one that seemed interested.

Edited by SpaceMouse

Share this post


Link to post
Share on other sites

bX7krhy.jpg

Well, i wasn't planning on re-doing the whole thing, but i pretty much did.I may have made it look TOO beefy. lol
@Eleusis La Arwall, While i got the tag to sort-of work, the fairings don't show up in the VAB or in game until they seperate. Is it Part Triggers?

Share this post


Link to post
Share on other sites

@SpaceMouse I have actually no experience with engines so far but I made a quick test and it worked. No need for Triggers. Pics.
The fairings only show up if you attach something to the node called "bottom", as defined in the config:

...
node_stack_bottom = 0.0, -2.00, 0.0, 0.0, -2.0, 0.0
...
MODULE
{
    name = ModuleJettison
    jettisonName =
    bottomNodeName = bottom
...
}

As soon as the node is decoupled, the fairing pops away.

Btw you can add 7th value to stack nodes to set the node size (0=0.625 m parts; 1=1.25; 2=2.5; 3=3.75) like this:

node_stack_bottom = 0.0, -2.0, 0.0, 0.0, -1.0, 0.0, 2
9 hours ago, SpaceMouse said:

I may have made it look TOO beefy

The re-done version looks great. I assume you speak of the rings/magnets and I think they are not too beefy. Personally I'd make them even bigger but it's a question of taste :wink:

Share this post


Link to post
Share on other sites
1 hour ago, Eleusis La Arwall said:

@SpaceMouse I have actually no experience with engines so far but I made a quick test and it worked. No need for Triggers. Pics.
The fairings only show up if you attach something to the node called "bottom", as defined in the config:


...
node_stack_bottom = 0.0, -2.00, 0.0, 0.0, -2.0, 0.0
...
MODULE
{
    name = ModuleJettison
    jettisonName =
    bottomNodeName = bottom
...
}

As soon as the node is decoupled, the fairing pops away.

Btw you can add 7th value to stack nodes to set the node size (0=0.625 m parts; 1=1.25; 2=2.5; 3=3.75) like this:


node_stack_bottom = 0.0, -2.0, 0.0, 0.0, -1.0, 0.0, 2

The re-done version looks great. I assume you speak of the rings/magnets and I think they are not too beefy. Personally I'd make them even bigger but it's a question of taste :wink:

Yes, i figured out the node stack thing quite a while ago. The tag seems to work but its definitely still doing the same thing. Guess it will have to be hidden in the VAB menu for now. lol.

Share this post


Link to post
Share on other sites

@SpaceMouse The fairings do not appear in the VAB when you attach something to the bottom node? That is strange. Don't know what is going wrong there. If you send me the .mu file and/or a model I can take a closer look.

Edited by Eleusis La Arwall

Share this post


Link to post
Share on other sites

No, They appear in the VAB. Or at least they did till i tried applying the tag. I'm gonna fiddle with the wire placement  a little, then i'll send the file to freethinker and you. Feel free to fiddle with it if ya want.

Share this post


Link to post
Share on other sites

When we will get engines perfect for VTOL on Earth/Venus?

If I wanted to build powerplant, that powers both nearby ships and far away missions, then I should install 3 different beam generators/emitters on it?

Edited by raxo2222

Share this post


Link to post
Share on other sites

Does anyone here know if there's a way to get MechJeb to understand the thrust capability of a KSPI-E electric engine? I've got a lander with a minmus TWR over 5 and abundant microwave power. The vessel is highly capable, but MechJeb only seems to recognize the engine performance when it's trusting (the MechJeb Delta-V window shows 0 TWR if the engine is off, but the correct value when it's thrusting). This makes it impossible to use any of the MechJeb maneuver planing capabilities or landing guidance, etc.

I'm posting here since the engine I'm using is from this mod, but I'll be happy to post in the MJ forum as well. It's not clear to me if the solution should be found here or there.

Share this post


Link to post
Share on other sites
9 minutes ago, schlosrat said:

Does anyone here know if there's a way to get MechJeb to understand the thrust capability of a KSPI-E electric engine? I've got a lander with a minmus TWR over 5 and abundant microwave power. The vessel is highly capable, but MechJeb only seems to recognize the engine performance when it's trusting (the MechJeb Delta-V window shows 0 TWR if the engine is off, but the correct value when it's thrusting). This makes it impossible to use any of the MechJeb maneuver planing capabilities or landing guidance, etc.

I'm posting here since the engine I'm using is from this mod, but I'll be happy to post in the MJ forum as well. It's not clear to me if the solution should be found here or there.

The problem for MechJeb is that the Interstellar engines have variable ISP and thrust. For microwave ships this can get only worse, cause MJ can't know how much energy the ship will receive any time. For now, KER is a little more precise, in the editor, but for now there is not a solution, just tries.

Share this post


Link to post
Share on other sites

This is curious because I recall that previously I saw a different behavior where MJ would not initially know the thrust of the engine, but after you've used it once it would know it. Previously I was able to give such a vessel a nudge - even just a touch of throttle - then cut the thrust and MJ would be able to take it from there. Sort of like teaching MJ what the engine could do. This was not perfect as the next time MJ used the engine it might do something different, but at least maneuvers could be planned. Now, that's not possible.

Thanks for the suggestion to use KER. It may indeed have a more precise estimate of engine performance, but it's not an autopilot and therefore fundamentally incapable of standing in for MJ. What is needed here is a persistent way for MJ to understand at least some sort of estimate of the engine performance.

Edited by schlosrat

Share this post


Link to post
Share on other sites

As far as I understand, this issue is related to the module KSPI handle the engines. I don't know if @FreeThinker can change this in a way MJ or KER can understand well enough.

Share this post


Link to post
Share on other sites
7 hours ago, raxo2222 said:

When we will get engines perfect for VTOL on Earth/Venus?

If I wanted to build powerplant, that powers both nearby ships and far away missions, then I should install 3 different beam generators/emitters on it?

freethinker mentioned a few pages ago that he's currently focusing KSPI on electric engines. The thermal turbojet could probably do VTOL with enough of them but the answer at least unless plans change is probably never.

Share this post


Link to post
Share on other sites
30 minutes ago, SpaceMouse said:

freethinker mentioned a few pages ago that he's currently focusing KSPI on electric engines. The thermal turbojet could probably do VTOL with enough of them but the answer at least unless plans change is probably never.

Well reactors directly connected are too vertical...  I would have to downscale them and put in cargobays

Reactors and radiators are CPU hogs.

Share this post


Link to post
Share on other sites
7 minutes ago, raxo2222 said:

Well reactors directly connected are too vertical...  I would have to downscale them and put in cargobays

Reactors and radiators are CPU hogs.

On Venus nothing will ever work due to the high pressure. For other planets, ATTILA wasn't so bad for V-TOL-ing.

Share this post


Link to post
Share on other sites
1 hour ago, raxo2222 said:

Well reactors directly connected are too vertical...  I would have to downscale them and put in cargobays

Reactors and radiators are CPU hogs.

I've been mildly sucessfull getting THings to fly FAST with thermal turbojets. I think i'll see if i can VTOL with a reactor. :D


I modified a EM ship of mine to escape about 99% of the atmosphere with a thermal turbojet and relative ease. Needs a circularization boost but it wasn't that hard. Shouldn't be too hard to do it more planelike than rocket like.

Edited by SpaceMouse

Share this post


Link to post
Share on other sites

I'm apparently an idiot, but I can't make any of the reactors work. I grab, for example, a molten salt reactor, put a thermal electric generator on top and/or bottom, directly attached to the reactor, and then add some radiators, as shown in the tutorials. My reactor says that it's running, (6%) but I get zero power out of the TEGs, and cannot see how to increase the power of the reactor. 

Running 1.2.1, fresh install from Steam, with KSPI-E installed, then new versions of Community Tech Tree and TweakScale so I don't get complaints about incompatible mods at start up.

What am I doing wrong?

 

Share this post


Link to post
Share on other sites
4 hours ago, Nansuchao said:

As far as I understand, this issue is related to the module KSPI handle the engines. I don't know if @FreeThinker can change this in a way MJ or KER can understand well enough.

It's curious because it used to work in a limited way. I'm not sure how far back, but it definitely did work pre 1.2 with the caveat that MJ wouldn't know the thrust of the engine until it had been activated at least one. After that MJ would use the most recent engine performance, which is certainly a better estimate for performance than assuming it's non-functional.

Share this post


Link to post
Share on other sites

 

6 hours ago, Submho said:

I'm apparently an idiot, but I can't make any of the reactors work. I grab, for example, a molten salt reactor, put a thermal electric generator on top and/or bottom, directly attached to the reactor, and then add some radiators, as shown in the tutorials. My reactor says that it's running, (6%) but I get zero power out of the TEGs, and cannot see how to increase the power of the reactor. 

Running 1.2.1, fresh install from Steam, with KSPI-E installed, then new versions of Community Tech Tree and TweakScale so I don't get complaints about incompatible mods at start up.

What am I doing wrong?

 

You cannot manually increase the reactor's power, you have to have something "demand" it.
The simplest example for using TEG's would be the emdrive, since you don't need to worry about propellant. Or add a magneto plasma dynamic thruster and some hydrogen tanks.
Try adding one of those, then testing it in space. It should accelerate, raising the AP very slowly. The reactor should also use a lot more than 6% power.
If you don't have an engine actively demanding power, it should only be generating enough power to keep electriccharge full, which should be easily covered by the reactors idle power.
To do a simpler test by the way, remove the TEG, and just stick a thermal nozzle straight onto the reactor.



I do have some questions of my own however:

How exactly do i use the "persistent rotation" mod to achieve timewarp propulsion with low thrust systems?
Nothing on the mods thread suggests it can be used this way, and i can't find any other information about it.



The other question is about the disparity between the thermal mechanics helper and what actually happens in practice.
For a start, it lists 30% as the reactors idle power, as does the wiki, but the ingame reactor control window displays 6%
Also, it seems to use radiator heat dispersion values for the fully upgraded parts, regardless of the actual current tech level.
According to the helper, 12 mk2 double edge radiators can  keep a pebble bed reactor at 2500k at 30% power.
In practice, they are unable to keep a reactor running at 6% power producing 150MW cooled to 2500k.

Should i just be ignoring it completely?

Edited by Shrike99

Share this post


Link to post
Share on other sites
51 minutes ago, Shrike99 said:

-snip-

Persistent Rotation it's not about thrust, it just keep the ship's attitude in a more realistic way during TimeWarp. 

Persistent Thrust was something inside KSPI-E, achievable with some engines (Magnetic Nozzle I.E.) at low level throttle, but I have no idea if it still works in 1.2.1, you can test it and report.

Share this post


Link to post
Share on other sites
1 minute ago, Nansuchao said:

Persistent Rotation it's not about thrust, it just keep the ship's attitude in a more realistic way during TimeWarp. 

Persistent Thrust was something inside KSPI-E, achievable with some engines (Magnetic Nozzle I.E.) at low level throttle, but I have no idea if it still works in 1.2.1, you can test it and report.

I figured as much.

Why then, is this on the main mod post on the first page?
 

 

Quote

 

Recommended Mods:

 

 

 

Share this post


Link to post
Share on other sites

Cause if you try to accelerate in TineWarp without Persisten Rotation, your ships will loose the correct attitude, rotating with the planet.

With that mod instead, your ship will maintain the attitude you want all the time. This is an important feature to accelerate in TimeWarp in a useful way.

Share this post


Link to post
Share on other sites

 

12 minutes ago, Nansuchao said:

-snip-

So it is designed to be used alongside something like persistent thrust?

Share this post


Link to post
Share on other sites
13 minutes ago, Shrike99 said:

 

So it is designed to be used alongside something like persistent thrust?

Exactly. You can it also without it, but it will not have the same usefulness. Engines like the Daedalus has the ability to travel to other stars, but you need to accelerate for days. Difficult to do if you have to tweak your attitude every few hours/minutes.

Share this post


Link to post
Share on other sites

So, I've been trying to make sense of the mod for a while, and came up with some sort of Infograph tutorial (because you know.. this mod can never have too many tutorials). It's very superficial but quicker to look at than video tutorials, and a wee less scary than the tables on the OP :P I`d like everyone`s input to what is horribly wrong with it or any hints, so I can tidy it up the placement of things, create a legend and make it more visually pleasing later for a final version:

Spoiler

3iBxOq8.jpg

 

Edited by markinturamb
tidying

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.