whale_2

[1.3.1 - 1.7.x] WorldStabilizer - Bugfix for vessels bouncing on scene load

Recommended Posts

One problem: I got used to filling my miners in warp and then getting a free jump off the ground to get back into orbit. I barely have the TWR to get a full miner off the ground otherwise. I miss that free dV:cool:

I'm kidding, of course :D. This mod works great, I no longer have to be ready to re-land my craft when I switch to it or exit warp. Thanks a bunch for this! :thumbsup:

Share this post


Link to post
Share on other sites

Mod is great, I've been using it in my current game and it solves so many problems and lets me just focus on building stuff.  Thanks for the work!

Share this post


Link to post
Share on other sites

Thumbs up!  Seeing craft pogo-sticking gave me the heebie-jeebies.

However, I've just seen this.  I parked rover one under the veranda at the Astronaut Complex and went off to bring another one back.  "Where's my rover?"  On the roof.

Well, there are two possibilities: this is KSP (doing what World Stablizer is supposed to stop) or World Stabilizer picked the wrong altitude for the rover due to the roof over it.

Let me know if you want me to try to reproduce it without WS installed, but it should be easy to set up and try...  Grab a stock Prospector Rover...

bFhY7LR.png

 

Edited by Hotel26

Share this post


Link to post
Share on other sites

@Hotel26 that's most likely a bug in WorldStabilizer, I didn't test that exact situation. Theoretically the vessel should not be moved that high, there's a limit of 2 meters and the roof seems to be a bit higher. Still it would be nice if you could check it without the mod.

Share this post


Link to post
Share on other sites
1 minute ago, whale_2 said:

check it without the mod

Wilco.

Share this post


Link to post
Share on other sites

KSP without World Stabilizer caused the rover under the parapet to jump and explode as it impacted the roof.  That caused a sympathetic explosion from the rover I was driving which was still 100m from the scene.

So putting it on the roof is WS but it's not a scenario KSP got right anyway.

Looks like it is trivially easy to reproduce and that you will get a 100% rate.  On the other hand, the priority to attempt to rectify this one is pretty low in my judgement.

Thanks for your work!

Share this post


Link to post
Share on other sites

Sweet, it works. So far, im getting the issue on Eloo with a large landing craft; it only happens when coming down from time warp, and not when I just load the craft. But knock on wood it fixed the issue. Much thanks @whale_2

Share this post


Link to post
Share on other sites
On 3/5/2018 at 2:35 PM, Hotel26 said:

However, I've just seen this.  I parked rover one under the veranda at the Astronaut Complex and went off to bring another one back.  "Where's my rover?"  On the roof.

Well, there are two possibilities: this is KSP (doing what World Stablizer is supposed to stop) or World Stabilizer picked the wrong altitude for the rover due to the roof over it.

 

I hope I've fixed this. 

https://github.com/whale2/WorldStabilizer/releases/tag/0.8.4

Seems like Squad finally had fixed this bug - I can't reproduce any bouncing in 1.4.1. One mod less to care about :)

Some stuff still might be here - like vessels moored with KAS harpoons and winches and KAS ground blocks. I didn't check it yet, so if anyone have something to say, please do.

Share this post


Link to post
Share on other sites

Will this help with vessels beeing dropped on the ground due to low terrain settings?

I've played with low terrain settings and sometimes KSP spawns the vessel above the ground and just drops it.

Share this post


Link to post
Share on other sites
2 minutes ago, maculator said:

Will this help with vessels beeing dropped on the ground due to low terrain settings?

I've played with low terrain settings and sometimes KSP spawns the vessel above the ground and just drops it.

Likely it will. I didn't check that particular situation, why not give it a try?

Share this post


Link to post
Share on other sites

@maculator, hmm... I don't quite understand what's happening on these screenshots. Could you please upload a log file? I tried 1.4.1 and found no situation where WorldStabilizer is helpful, so have yet no reason to rebuild it for 1.4.1, but your case could change it...

Share this post


Link to post
Share on other sites

My Ksp log?

Well the case is this:

If you play on low terrain settings it verry often loads your vessel some meters above ground. The screenshot shows a place I certainly know it will always happen, the border of the island runway. If you put your vessel close to it, quick save and then load it will spawn you in mid air, where the terrain on "default" would be, but there is no terrain :S

It's not a problem with your mod, stock game manages that all by itself...

Edit: I just hoped you mod would help, because it seems to pause the game and look for the actual terrain a few ticks.

 

Log:

https://github.com/maculator/Alles/blob/master/log19032018

 

Edit Edit:

I set the ticks to wait to 200, the grounding ticks to 2000 and the minDownMovement to 100, no help. Vessel stays in mid ari for a longer time but stil gets dropped.

 

Another edit:

Spoiler

Hs4XdJq.jpg

The parts in the ditch are the remains of the vessel. I parked it at that exact location before saving and loading again.

When loading the game put it in mid air (where your debug marks are located), I guess because thats where the terrain on default would be.

Then it of course drops on the floor and crashes.

Your mod also detects only the default terrain so even I got the values all up to rediccolous numbers the vessel only remains in mid air for an eternity before crashing...

Edited by maculator

Share this post


Link to post
Share on other sites
25 minutes ago, maculator said:

Your mod also detects only the default terrain...

I'm definitely not aware how one can detect the default or non-default terrain. I do raycasts with some reasonable (at least it seems to me so) mask - do you mean that there should be some some other mask for detecting non-default terrain colliders? (However, I try to detect not only the terrain, but parts as well, though maybe this if of little help here)  

 

MinDownMovement has different meaning - if you set it to 100, WST won't put the vessel down below 100 m, so I'd suggest you leave it as is and maybe increase grounding ticks to 10-20 but not above stabilization ticks.

 

Checking your log file now...

Share this post


Link to post
Share on other sites

I tinkered alot with the settings, the vessel always spawns where the default terrain would be. I have no idea how to fix that and there also is a bug report for it allready, just hoped this mod could fix it. Kerbal Engineer for example detects that the vessel is above ground, don't know how he does it when stock certainly can't ^^

Share this post


Link to post
Share on other sites

@maculator, I think I know the reason. This is a real corner case that I thought of but never actually addressed. The raycast shot from topmost part and raycast from bottom-most part hit different colliders because the vessel is in fact lying on the edge of two colliders - this was the safety measure when the mod can't say for sure how high above the ground is the vessel. In that case it just refuses to ground the vessel. 

I think, no further config tweaking can help here, but I can make a switch, that would force this check for different colliders to be ignored. This could lead to explosions in other situations, something like placing one vessel on top of the other, but could help in your case. Or maybe something in between like still moving down, but with greater "safety" margin, like it still will be dropped to the ground, but from 2 m instead of 50.

What do you think?

Share this post


Link to post
Share on other sites

I too thought that would happen because of the runway beeing an asset and I'm right at the border, but it also happens on any small island for example.

Happens everywhere were the terrain changes height between low and default settings.

Share this post


Link to post
Share on other sites
5 minutes ago, maculator said:

I too thought that would happen because of the runway beeing an asset and I'm right at the border, but it also happens on any small island for example.

Happens everywhere were the terrain changes height between low and default settings.

Can't say for sure what happens there without a log file.

Hold on, I'm trying to cobble together a quick fix for that. 

Share this post


Link to post
Share on other sites

Okay. I'm just flying to an island to check what happens with/without the mod. I provided a log, was it the wrong one?

Share this post


Link to post
Share on other sites
2 minutes ago, maculator said:

Okay. I'm just flying to an island to check what happens with/without the mod. I provided a log, was it the wrong one?

No, the log is fine, but it captured only one single case that the mod tried to handle. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.