• 4
henr1k

1.4 Partial part icons on first row - MacOS

Question

Since the update to 1.4, the icons for the parts in the first rows in each category are not showing the top half.

MacOS: 10.13.3

KSP: 1.4.0.2077 (Steam)

Screenshots:

https://imgur.com/a/ATXLa

Starting a new career or sandbox does not fix the issue. I have removed all mods to test, it still happens.

Does anyone else have this issue?

Edited by henr1k

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

Thanks to everyone for the great suggestions!

This seems to be fixed in 1.4.1 (2089 - DLC) on Mac.

Share this post


Link to post
Share on other sites
  • 0

The update gave me the same problem and I run the game on Windows 10. At first it didn't happen but after I configured the graphics settings the problem appeard.

REASON FOR THE PROBLEM: I found that turning off Anti-Aliasing causes this.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Stone Blue said:

its from forcing either DirectX11 or 12, supposedly.....

I'm sorry what is that exactly? I did the test turning Anti-Aliasing on and off and the problem appeard and dissapeard.

Am I forcing DirectX? I don't know what it is. I have an i7 10gb ram with Windows 10 and pretty bad graphics card, Intel Graphics 4600.

Share this post


Link to post
Share on other sites
  • 0

Thank you both for your replies!

I played with the Anti Alias slider to no avail. Whether it is disabled or enabled, same result for me, partial/cut icons.

I do not have any launch command lines in place regarding DX, however I played with the -force-opengl command (as suggested in the pinned post for mac users) but that also showed no difference. Isn't DX in way connected to Direct3D where OpenGL is a different API set?

After all, it is not the end of the world. I am considering getting the DLC. Maybe that will magically fix this issue!?

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, SebaQuiros said:

The update gave me the same problem and I run the game on Windows 10. At first it didn't happen but after I configured the graphics settings the problem appeard.

REASON FOR THE PROBLEM: I found that turning off Anti-Aliasing causes this.

I confirm that, Windows 10, top half missing with anti-aliasing disabled,
all is fine with 2x anti-aliasing. (1920x1200 resolution)

Share this post


Link to post
Share on other sites
  • 0

I am also having this problem on Mac. I've tried all the launch command lines and nothing helps. It would be really nice to have a fix because that texture cutoff is really annoying.

Share this post


Link to post
Share on other sites
  • 0

I have tried it with various anti-aliasing settings and the icons keep bing cut in half. I have anti-aliasing on turning it off doesn't help. :( Given all the bugs so far... 1.4 really needs a QA team and some more time in the oven.

Share this post


Link to post
Share on other sites
  • 0

I've had same problem on Linux (Debian), no AA setting helps tho. Tested on completely mod-less install

 

GPU: NVidia with drivers 384.111

Share this post


Link to post
Share on other sites
  • 0

It can (does) happen on Windows as well...

 

Edited by Stone Blue

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Mat van Kerman said:

I still have this problem on 1.4.1. :/ I will play with the settings a bit and see if I can fix it.

Check your antialias settings

Share this post


Link to post
Share on other sites
  • 0

I have the same problem on the latest Debian Linux release since KSP version 1.4 and also with version 1.4.1
Changes to AA settings have no effect.

Share this post


Link to post
Share on other sites
  • 0

I still have this issue with 1.4.1 and the new DLC under linux . Windows users might be able to fix it by playing with the AA settings because of direct X. I don't believe that this will do anything for windows and mac users on Open GL . I'm also having the issue where the game will only run in the native resolution of your monitor and will freeze in window mode or launch black screen. I had to set my second monitor as default so I could play . My main one is a 4k panel and theirs no way my card can handle native resolution on it. I was not able to play all during 1.3.0 because squad didin't compile the new unity right for GL users. They fixed it but forgot to include some Microsoft only fonts with that release and I could not read any windows in the VAB or SPH until 1.3.1 came out. Looks like all the New Dev's are windows users? Their QA is dropping the ball. I have to just take this as Karma for all the years I ran 64bit heavily mod installs with no problem while all the windows users freaked out about no 64 bit.

     

Edited by Delbrutis
Fix my crappy punctuation

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, SebaQuiros said:

I still don't understand what DirectX is...

DirectX is the name of a technology standard, that makes it easier for games programmers to draw things on the screen, generally MS Windows specific. It enables a lot of stuff.  OpenGL is a different standard that does some similar things, and is more commonly found as the default or only choice on Mac and Linux.

Edit: And I re-created this bug, by disabling anti-aliasing, like others report. W10, Nvidia GTX 660.  Looks just fine with AA 2x. That's what I had enabled before the update so I never had a reason to complain :wink:

Edited by basic.syntax

Share this post


Link to post
Share on other sites
  • 0

Without seeing the code, it looks to me like the whole part-icon layer is shifted down - the top is cut off, and the bottom overlaps the cost display.
Gentoo GNU/Linux, Nvidia 390.25, graphics settings (inc. AA) have no effect.
Did anyone even QA this thing on *nix?

Edited by steve_v

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, steve_v said:

Did anyone even QA this thing on *nix?

Or MacOS?

I didn't grab the update yet, but have this problem on my Mac.

Share this post


Link to post
Share on other sites
  • 0

I used to have this problem on 1.4 on MacOS Sierra 10.12.6. But the 1.4.1 seems to have fixed this bug for me.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, tater said:

Or MacOS?

*nix includes MacOS, 'tis a unix derivative, if well hidden.

Share this post


Link to post
Share on other sites
  • 0

1.4.1 fixed it on the Mac.

Share this post


Link to post
Share on other sites
  • 0

Hello all. We are aware of this problem and know that it affects some openGL systems. It is not apparent on all, and can also vary in severity with screen resolution or window size. We are working on identifying the cause and a possible solution. Your reports and feedback are already helping immensely. Player.log is always very useful in identifying what hardware combinations are most affected, so while they might be error free for this particular problem, the detected GPU capabilities are.

Share this post


Link to post
Share on other sites
  • 0

@Squelch Now that I have some mods installed I see with longer part lists that the part icons also overlap the GUI elements at the bottom of the window. I know this is an "unmodded installs" thread but likely it is another manifestation of the same bug.

Screenshot and log at https://bugs.kerbalspaceprogram.com/issues/17828?next_issue_id=18075&prev_issue_id=17941#note-11

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.