JadeOfMaar

[1.9.1+] OPT Legacy 2.1.1 | Reconfig 2.1 [Aug 07, 2020]

Recommended Posts

23 hours ago, Not a Spy said:

and is there a patch to make the engines run on liquid fuel?

and should i get rid of avatar and stail since they are practically the same as k and j?

The engines all run on LiquidFuel by default. I assume you have CryoEngines or KerbalAtomics installed. When either of these is present, OPT engines become CryoEngines. To stop that behavior, delete OPT_Reconfig\CRP\OPT_CryoEngine.cfg

I would delete Avatar and Stail for that reason and because of the secondary reason that since I don't use them (personally) their textures are a weight that my PC does very well without.

Share this post


Link to post
Share on other sites
3 hours ago, JadeOfMaar said:

The engines all run on LiquidFuel by default. I assume you have CryoEngines or KerbalAtomics installed. When either of these is present, OPT engines become CryoEngines. To stop that behavior, delete OPT_Reconfig\CRP\OPT_CryoEngine.cfg

I would delete Avatar and Stail for that reason and because of the secondary reason that since I don't use them (personally) their textures are a weight that my PC does very well without.

but when i delete that file it says "lh2 deprived"

Share this post


Link to post
Share on other sites
8 hours ago, Not a Spy said:

but when i delete that file it says "lh2 deprived"

Maybe you confused that file and actually deleted OPT_B9PS_Cryo.cfg which supplies tank options. Delete your ModuleManager.ConfigCache. If you still get OPT engines asking for LH2, then maybe you have OPT_Reconfig installed twice, accidentally buried inside another mod folder. But if that's the case you should get a lot of B9 warnings about repeat tank options.

Share this post


Link to post
Share on other sites
2 hours ago, JadeOfMaar said:

Maybe you confused that file and actually deleted OPT_B9PS_Cryo.cfg which supplies tank options. Delete your ModuleManager.ConfigCache. If you still get OPT engines asking for LH2, then maybe you have OPT_Reconfig installed twice, accidentally buried inside another mod folder. But if that's the case you should get a lot of B9 warnings about repeat tank options.

k, it says in the menu though that it uses liquid fuel

Share this post


Link to post
Share on other sites

when i try to launch my spaceplane, as soon as it lifts off it flies apart and explodes, i have all the right things installed but i dont know what im doing wrong.

Share this post


Link to post
Share on other sites
Posted (edited)

@pidgeypotato Any number of the following factors may be involved:

  • The body of your spaceplane is far too heavy. / You don't have enough wheels near the CoM to support the plane's weight.
  • The wheels are attached to the wings or (worse yet) to radial engine assemblies which are also really heavy, and not attached to the core stack of the spaceplane body.
  • Your wings are heavier than the core stack.
  • You're not using well-placed autostruts (or KJR) to fight off the fragility of (I expect) a very flashy, very long, and very heavy craft.
  • Your engines (assuming they're on the wings) are somehow producing enough thrust at that point to tear themselves off.
  • Your plane is very flimsy or lightweight (or both) in the middle (or where the wings are immediately attached) while everything around it is very heavy.
  • Your wheels are too far back from your CoM, forcing you to accelerate to near Mach 1 on the runway (I call this "Table Leg" Syndome), at which point, when you pull up, your plane may be meeting enough dynamic pressure and may be flexing hard enough that it breaks. Your main wheels should be near your CoM.
Edited by JadeOfMaar

Share this post


Link to post
Share on other sites

Jadeofmaar already said this but to summarize:

Radial attachments are naturally weak. All wings radially attach. You need to strut them to the heavier chunks (central mass) of the plane. Otherwise, as soon as you take off, the force of your thrust will literally tear it apart.
It's REALLY easy to do once you start putting anything on your wings like engines or fuel tanks. I learned the hard way when I started building SSTO's (especially w/ OPT) that you had to use balanced strut'ing or your flights over before it begins.

Share this post


Link to post
Share on other sites

Question: What are conditions for automatic switching for the nebula engines, rarely ever see them switch, sometimes it happens around 38km+ altitude then immediately flame-out as I get to 40Km alt shortly thereafter

Share this post


Link to post
Share on other sites
3 hours ago, docthaspok said:

Question: What are conditions for automatic switching for the nebula engines, rarely ever see them switch, sometimes it happens around 38km+ altitude then immediately flame-out as I get to 40Km alt shortly thereafter

Automatic switching happens when you reach Mach 7.5 on the Turbojet mode or you're flying exactly high enough that IntakeAir demand is excessive and the engine switches due to flameout from starvation... :P

Automatic switching should not be pursued on engines where both modes use (mostly or wholly) the same propellants. Both modes use LiquidFuel and intakeAir but the Shcramjet mode additionally requires ElectricCharge, high altitude and speeds above Mach 4.

Turbojet mode has such a high upper speed limit because for players on stock scale, it's not worth it to lower that limit and encourage the preparation for, and use of Shcramjet mode. Scramjet engines are pointless because of stock scale's low orbital velocity.

Using a scramjet/shcramjet for the upper ascent phase is very different from using any rocket engine. In this situation you want to keep a very, very shallow ascent at high altitude (let's say, 10deg pitch at about 25km altitude) to balance maximizing the operating time of the engine and dodging excessive thermal load on the nose or cockpit. If you ever find yourself playing 2.5x scale or higher, where target speeds on air-breathing are Mach 12+, you'll find the Nebula's Shcramjet mode very valueable. Moreover, the best time to swtich to Shcramjet mode is Mach 5. That's where thrust is sufficient or self-sustaining.

Share this post


Link to post
Share on other sites
24 minutes ago, JadeOfMaar said:

Automatic switching happens when you reach Mach 7.5 on the Turbojet mode or you're flying exactly high enough that IntakeAir demand is excessive and the engine switches due to flameout from starvation... :P

Automatic switching should not be pursued on engines where both modes use (mostly or wholly) the same propellants. Both modes use LiquidFuel and intakeAir but the Shcramjet mode additionally requires ElectricCharge, high altitude and speeds above Mach 4.

Turbojet mode has such a high upper speed limit because for players on stock scale, it's not worth it to lower that limit and encourage the preparation for, and use of Shcramjet mode. Scramjet engines are pointless because of stock scale's low orbital velocity.

Using a scramjet/shcramjet for the upper ascent phase is very different from using any rocket engine. In this situation you want to keep a very, very shallow ascent at high altitude (let's say, 10deg pitch at about 25km altitude) to balance maximizing the operating time of the engine and dodging excessive thermal load on the nose or cockpit. If you ever find yourself playing 2.5x scale or higher, where target speeds on air-breathing are Mach 12+, you'll find the Nebula's Shcramjet mode very valueable. Moreover, the best time to swtich to Shcramjet mode is Mach 5. That's where thrust is sufficient or self-sustaining.

Thanks, that clears things up, now I gotta try 2.5x scale

Share this post


Link to post
Share on other sites
5 minutes ago, docthaspok said:

Thanks, that clears things up, now I gotta try 2.5x scale

You will never fly stock scale again. ;D

Spoiler

Welcome, brother, to the Church of Scramjet. We've been expecting you.

 

Share this post


Link to post
Share on other sites

I have a problem with the OPT Fuel tanks with Kerbalism and B9 Part Switch installed - There is no option to change fuel type as usual with other tanks and B9 Part switch.

Modular Fuel tanks fixes the issue but introduces yet another UI

Is this intended behaviour? Seems weird. I've looked at bit into the module manager logs and AFAIK there are some things defined based on !Kerbalism and B9 Part Switch but I dont understand module manager enough to really judge that.

Share this post


Link to post
Share on other sites
3 hours ago, dragon_irl said:

There is no option to change fuel type as usual with other tanks and B9 Part switch.

I'm not sure I get what you're saying. If you mean that you're missing the ability to change OPT tank contents using Kerbalism's UI, then that is intentional. Except for crewed parts, OPT's tanks are for fuel and not much else. The level of customization (of tank ratios and resource combos) you may be expecting is left to crewed parts for the resources that matter there and whatever capability Kerbalism's tank switcher provides. Even Kerbalism is using B9PS now for resource switching in its newly added tanks.

Share this post


Link to post
Share on other sites
4 hours ago, JadeOfMaar said:

I'm not sure I get what you're saying. If you mean that you're missing the ability to change OPT tank contents using Kerbalism's UI, then that is intentional. Except for crewed parts, OPT's tanks are for fuel and not much else. The level of customization (of tank ratios and resource combos) you may be expecting is left to crewed parts for the resources that matter there and whatever capability Kerbalism's tank switcher provides. Even Kerbalism is using B9PS now for resource switching in its newly added tanks.

Probably explained that poorly. There is no option configure tank contents at all - without the reconfig in OPT I had a button next tank type and could switch between some standard fuels or no contents at all. With the reconfig this is always stuck at no fuel at all and no next tank type button.

Share this post


Link to post
Share on other sites
15 hours ago, dragon_irl said:

based on !Kerbalism

I don't think I have that anymore. I've fixed every Kerbalism problem already, so your installed Reconfig must be very old.

7 hours ago, dragon_irl said:

next tank type

Your OPT Legacy must also be very old, or you're using OPT Main without Reconfig. The button with that for its name is powered by Firespitter.

Share this post


Link to post
Share on other sites
Posted (edited)

38dgNQT.jpg

rE9i35F.jpgV9WK6kY.pngdgXKbb6.png

Legacy 2.1

  • Added RCS thrusters to Humpback SAS.
  • Added tags to Avatar Shuttle Cockpit. It was not appearing under CCK.
  • Added Avatar: inline SAS/RCS; short hollow fuselage; short tank.
  • Added Stail: inline SAS/RCS; short tank.
  • Added missing SAS module to K Drone Core.
  • Fixed CoL in Winglet Type D.
  • Fixed texture and material problems in K lab, K cabin, Legacy Wings II (the huge wings and fighter wings).
  • Fixed DepthMask meshes' default material when Restock not installed.
  • Fixed drag cubes in some Avatar parts.
  • Raised crew capacity from 4 to 6 in K cabin and lab.

Reconfig 2.0.6

  • Added stack nodes to KH fuselage for mounting payloads without causing CoM offset.
    • Added B9 switcher for these stack nodes and for KH inline SAS and cargo tails.
  • Changed Covert Aeronautics tech nodes to hide if empty (when obscure tech trees are installed and if they move OPT end-game parts).
  • Fixed B9PS RCS options to properly need or not need CRP where appropriate.
  • Fixed missing Dark Science in K lab.
  • Some housekeeping.

DOWNLOAD LEGACY :: SPACEDOCK :: GITHUB

DOWNLOAD RECONFIG :: SPACEDOCK :: GITHUB

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
Posted (edited)

Getting an error trying to install 2.0.6 w/ CKAN

CKAN.InvalidModuleFileKraken: OPTReconfig 2.0.6: <...>\Temp\tmp2384.tmp has length 2799708, should be 2799702
   at CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   at CKAN.NetAsyncModulesDownloader.ModuleDownloadComplete(Uri url, String filename, Exception error)

@JadeOfMaar Is this a CKAN-specific error or something on your end? Reconfig 2.0.5 installed just fine w/ CKAN.

On a side note, I updated manually and when I start KSP I get this error:

5lDULs5.png

KSP Log:
https://drive.google.com/file/d/1GpEZbBrzAFkFk6mKVYtZ0_GKTPREa1id/view?usp=sharing

 

Edited by DefenderX1
Error on KSP loading after updating Reconfig.

Share this post


Link to post
Share on other sites

@DefenderX1 KSP is a real heart-breaker sometimes. There is absolutely no way you should get that B9PS warning. There are two configs in Reconfig that setup the B9 switch there, and they are right next to each other. :/ And it's not a complicated config.

But I get the CKAN problem. I ended up doing some rapid re-uploads of Reconfig.

Share this post


Link to post
Share on other sites
28 minutes ago, JadeOfMaar said:

@DefenderX1 KSP is a real heart-breaker sometimes. There is absolutely no way you should get that B9PS warning. There are two configs in Reconfig that setup the B9 switch there, and they are right next to each other. :/ And it's not a complicated config.

But I get the CKAN problem. I ended up doing some rapid re-uploads of Reconfig.

The simplest things seem to be the most troubling, eh?

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, JadeOfMaar said:

But I get the CKAN problem. I ended up doing some rapid re-uploads of Reconfig.

Hello @JadeOfMaar

The problem is still there,  probably the re-uploads corrupted the HashSet:

ckan.exe install --headless --no-recommends OPTSpacePlaneParts OPTReconfig
About to install...

 * Orbit Portal Technology [OPT] Spaceplane Parts (Legacy) 1:2.1 (cached)
 * OPT Reconfig 2.0.6 (spacedock.info, 2,7 MiB)

Downloading "https://spacedock.info/mod/1808/OPT%20Reconfig/download/2.0.6"
0 B/sec - downloading - 0 B left - 100%           CKAN.InvalidModuleFileKraken: OPTReconfig 2.0.6: D:\Temp\tmp4FE9.tmp has SHA1 A429598E93438AE7AD82FD71008F006E9E38A3BA, should be 0B13DD47ABD946080E1006C76868B00E93BB74B7
   at CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   at CKAN.NetAsyncModulesDownloader.ModuleDownloadComplete(Uri url, String filename, Exception error)

Edited by pmborg

Share this post


Link to post
Share on other sites

@JadeOfMaar Well damn, I just realized Legacy was updated a cuople of days ago, so I only have the new reconfig, not Legacy. I'm missing whatever updates that brought, which may very well be the culprit of my B9PS error. Downloading now, stay tuned.

Share this post


Link to post
Share on other sites
Posted (edited)

Actually, now my game hangs on loading. Strangely enough, it hangs on trying to load a B9_Aerospace part. That hasn't been updated in ages. It's on the body_mk2_section_0m_sas/B9_Body_Mk2_SAS_050m. 

This is freakin weird.

Edited by DefenderX1

Share this post


Link to post
Share on other sites
1 minute ago, DefenderX1 said:

Actually, now my game hangs on loading. Strangely enough, it hangs on trying to load a B9_Aerospace part. That hasn't been updated in ages. It's on the body_mk2_section_0m_sas/B9_Body_Mk2_SAS_050m. 

This is freakin weird.

Is it on trying to draw the drag cube? Also, do you have Kopernicus continued?

Share this post


Link to post
Share on other sites
Posted (edited)

@Azic Minar No, it's just while trying to start the game up. It just stops loading on that part so I renamed the config file to see if it'll still load.

And no, I don't think I have Kopernicus. It's not in my mod list/folder.

Edit: I deleted the config for the part in question and now it locks up on another part, body_mk2_cockpit_a/B9_Body_Mk2_Cockpit, so I'm wondering if it is something to do w/ the drag cubes.

Edited by DefenderX1
Updates

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.