Jump to content

[1.12.x] Textures Unlimited Recolour Depot


Manwith Noname
 Share

Recommended Posts

@DominiquiniI've had a similar report some time ago and it turned out that user had not installed the supplied version of Textures Unlimited. I've just rerun the test I did back then and have the same result, things are working for me. So, can you ensure you use the version of the TU plugin supplied with the pack and not one you may have downloaded from CKAN or elsewhere. If you are interested in a more complete explanation, you can read the original response here.

 

If this is not your issue, please report back with some more detail (steps to reproduce perhaps, potentially conflicting mods and so on) because as I said, I've checked a bunch of engines with shrouds and they're functioning as expected here.

 

Edit: Also, the problem I mention with the 909, I'm pretty sure is related to a stock bug.

Edited by Manwith Noname
Link to comment
Share on other sites

2 hours ago, Manwith Noname said:

@DominiquiniI've had a similar report some time ago and it turned out that user had not installed the supplied version of Textures Unlimited. I've just rerun the test I did back then and have the same result, things are working for me. So, can you ensure you use the version of the TU plugin supplied with the pack and not one you may have downloaded from CKAN or elsewhere. If you are interested in a more complete explanation, you can read the original response here.

 

If this is not your issue, please report back with some more detail (steps to reproduce perhaps, potentially conflicting mods and so on) because as I said, I've checked a bunch of engines with shrouds and they're functioning as expected here.

 

Edit: Also, the problem I mention with the 909, I'm pretty sure is related to a stock bug.

I have installed the CKAN version of 'Texture Unlimited'! I will try this version...

I tried with the new DLL, but appears to be the same problem. I was able to recolour almost all parts of the vessel, but not the shroud of the 'Terrier' engine. I also try to change to 'Swivel', that works better, but still is bugged:

The Terrier I try using PartVariants, but no options appear to open Recoloring Gui. The Swivel, it only change part of the shroud! The option to change the engine itself appears to do nothing, in both engines!

https://imgur.com/a/krdsq5Z

IsYypV8.jpg

01yyiYq.jpg

Thanks.

Edited by Dominiquini
Link to comment
Share on other sites

@Dominiquini I can't reproduce it...

Spoiler

?imw=5000&imh=5000&ima=fit&impolicy=Lett

Like is also said though, I think there are underlying issues with the game that might be contributing to this problem. Although right now I can't reproduce either issue, I have randomly noticed things stop working when once they worked fine and the next day the problem goes away again. This is certainly not related to the configs themselves.

For the swivel, the glitchy horrible look is due to the low resolution normal map Squad supply with it but you also appear to have some sort of UV mapping issue. Can you post a list of the mods you have installed?

Link to comment
Share on other sites

9 hours ago, Dominiquini said:

When I selected "Bob Ross Paints", it automatically apply the Stored Pattern! That way I don't need to click 'Open Recoloring GUI' in every part of my vessel!

 

I would also love to see this feature in the mod...

Link to comment
Share on other sites

5 hours ago, Manwith Noname said:

@Dominiquini I can't reproduce it...

  Reveal hidden contents

?imw=5000&imh=5000&ima=fit&impolicy=Lett

Like is also said though, I think there are underlying issues with the game that might be contributing to this problem. Although right now I can't reproduce either issue, I have randomly noticed things stop working when once they worked fine and the next day the problem goes away again. This is certainly not related to the configs themselves.

For the swivel, the glitchy horrible look is due to the low resolution normal map Squad supply with it but you also appear to have some sort of UV mapping issue. Can you post a list of the mods you have installed?

My mods list:

19/06/2021  13:24    <DIR>          000_ClickThroughBlocker
12/07/2021  03:13    <DIR>          000_TexturesUnlimited
01/07/2021  15:09    <DIR>          000_UICore
19/06/2021  13:24    <DIR>          001_ToolbarControl
07/07/2021  23:19    <DIR>          002_CommunityPartsTitles
06/07/2021  09:13    <DIR>          ABCORS
19/06/2021  09:53    <DIR>          Ablative-Airbrake
13/06/2021  16:03    <DIR>          AdjustableModPanel
18/12/2020  16:58    <DIR>          AntennaSleep
08/07/2021  21:29    <DIR>          AstronomersVisualPack
04/07/2021  18:51    <DIR>          AtmosphereAutopilot
27/06/2021  04:42    <DIR>          AttitudeAdjuster
17/12/2020  21:53    <DIR>          AutoAGL
25/06/2021  04:25    <DIR>          B9PartSwitch
01/07/2021  15:34    <DIR>          Benjee10_X-37B
04/07/2021  20:45    <DIR>          BetterBurnTime
01/07/2021  01:22    <DIR>          BetterSRBs
04/07/2021  14:35    <DIR>          BetterTimeWarp
08/07/2021  17:14    <DIR>          BonVoyage
10/07/2021  04:59    <DIR>          Chatterer
14/06/2021  20:58    <DIR>          CModuleLinkedMeshFix
30/06/2021  21:37    <DIR>          CommNetAntennasConsumptor
30/06/2021  03:09    <DIR>          CommNetAntennasExtension
22/06/2021  11:26    <DIR>          CommNetAntennasInfo
16/06/2021  14:49    <DIR>          CommunityCategoryKit
16/06/2021  14:49    <DIR>          CommunityResourcePack
03/07/2021  13:18    <DIR>          CommunityTechTree
09/07/2021  04:44    <DIR>          ContractConfigurator
09/07/2021  01:48    <DIR>          CTTP
27/06/2021  14:22    <DIR>          CustomBulkheadProfiles
11/07/2021  23:35    <DIR>          DecouplerShroud
26/06/2021  21:44    <DIR>          DefaultActionGroups
07/07/2021  14:44    <DIR>          DeployableBatteries
17/06/2021  03:18    <DIR>          DistantObject
17/06/2021  20:37    <DIR>          DockingCamKURS
16/06/2021  23:02    <DIR>          DraggableAltimeter
16/06/2021  23:02    <DIR>          DraggableNavball
02/07/2021  03:37    <DIR>          EasyVesselSwitch
26/06/2021  14:26    <DIR>          EditorExtensionsRedux
08/07/2021  17:58    <DIR>          EngineLightRelit
08/07/2021  17:14    <DIR>          EnvironmentalVisualEnhancements
23/06/2021  23:04    <DIR>          FlightPlan
17/06/2021  23:43    <DIR>          HaystackContinued
16/06/2021  14:51    <DIR>          HideEmptyTechTreeNodes
01/07/2021  15:09    <DIR>          ImprovedChaseCamera
11/07/2021  03:55    <DIR>          JanitorsCloset
18/12/2020  16:58    <DIR>          JX2Antenna
03/07/2021  14:01    <DIR>          KAS
23/06/2021  21:59    <DIR>          KeepItStraight
12/07/2021  02:55    <DIR>          KerbalEngineer
02/07/2021  04:04    <DIR>          Kerbaltek
09/07/2021  02:02    <DIR>          Kopernicus
17/06/2021  23:24    <DIR>          KRASH
20/03/2021  04:14    <DIR>          KSPRescueContractFix
11/07/2021  12:09    <DIR>          KSP_PartVolume
01/07/2021  15:09    <DIR>          LightsOut
11/07/2021  15:27    <DIR>          ManeuverNodeEvolved
05/07/2021  09:37    <DIR>          masTerTorch
11/07/2021  18:53    <DIR>          MechJeb2
22/06/2021  22:56    <DIR>          MiningExpansion
26/06/2021  12:58    <DIR>          MissingHistory
19/06/2021  09:53    <DIR>          MK1CabinHatch
22/06/2021  22:56    <DIR>          Mk2Expansion
22/06/2021  22:56    <DIR>          Mk3Expansion
10/07/2021  22:15    <DIR>          ModRocketSys
09/07/2021  01:48    <DIR>          ModularFlightIntegrator
25/06/2021  05:04    <DIR>          MouseAimFlight
17/06/2021  21:17    <DIR>          MSP3000-A
20/06/2021  14:33    <DIR>          NavBallDockingAlignmentIndicatorCE
06/07/2021  09:13    <DIR>          NavHud
10/07/2021  19:08    <DIR>          NavyFish
06/07/2021  00:12    <DIR>          NCRC
09/07/2021  02:02    <DIR>          OPM
22/06/2021  22:56    <DIR>          Orion
10/07/2021  12:59    <DIR>          Parallax
10/07/2021  12:59    <DIR>          Parallax_StockTextures
17/06/2021  20:37    <DIR>          PartCommanderContinued
01/07/2021  15:34    <DIR>          PartWizard
26/06/2021  04:54    <DIR>          PAWRangeBuff
23/06/2021  04:37    <DIR>          PersistentRotation
14/06/2021  02:35    <DIR>          PreciseEditor
26/06/2021  14:26    <DIR>          PreciseManeuver
07/07/2021  02:44    <DIR>          RCSBuildAid
30/12/2020  13:47    <DIR>          ReCoupler
30/06/2021  01:44    <DIR>          RemoteTechRedev
16/06/2021  23:10    <DIR>          REPOSoftTech
07/07/2021  13:26    <DIR>          scatterer
26/06/2021  19:20    <DIR>          ScienceAlert
22/06/2021  13:04    <DIR>          ScienceLabInfo
20/06/2021  18:44    <DIR>          ShowFPS
14/06/2021  17:54    <DIR>          SimpleFuelSwitch
06/07/2021  09:13    <DIR>          SituationModuleInfo
20/06/2021  15:07    <DIR>          SmartDockingAid
17/06/2021  23:37    <DIR>          SmartParts
26/06/2021  02:08    <DIR>          SmartStage
17/06/2021  20:37    <DIR>          SpaceTuxLibrary
10/07/2021  15:29    <DIR>          SpeedUnitAnnex
24/06/2021  14:11    <DIR>          Squad
02/06/2019  20:35    <DIR>          SquadExpansion
04/07/2021  00:15    <DIR>          SteeringTweaker
03/07/2021  12:40    <DIR>          SurfaceLights
09/07/2021  01:48    <DIR>          TextureReplacer
06/07/2021  09:14    <DIR>          ThroughTheEyes
08/07/2021  16:31    <DIR>          ThunderAerospace
30/06/2021  16:14    <DIR>          TooManyOrbits
14/06/2021  20:09    <DIR>          TrackingLights
11/07/2021  15:27    <DIR>          TrackingStationEvolved
27/06/2021  13:53    <DIR>          Trajectories
25/06/2021  12:33    <DIR>          TrimIndicators
12/07/2021  03:13    <DIR>          TURD
16/06/2021  21:27    <DIR>          UtilityWeight
17/12/2020  21:53    <DIR>          VABReorienter
17/12/2020  21:53    <DIR>          VariantPersist
23/06/2021  13:03    <DIR>          VentralDrill
01/07/2021  15:39    <DIR>          WalkAbout
25/06/2021  04:24    <DIR>          WasdEditorCamera
01/07/2021  13:23    <DIR>          WaypointManager
08/07/2021  17:14    <DIR>          WhoAmI
24/06/2021  12:21    <DIR>          WorldStabilizer
21/06/2021  15:03    <DIR>          XyphosAerospace
17/06/2021  20:37    <DIR>          ZeroMiniAVC
11/07/2021  20:09    <DIR>          ZZZ_CustomMMPatches

Thanks.

Link to comment
Share on other sites

@Dominiquini Looking at your mod list, the swivel problem might be a weird conflict with decoupler shroud perhaps? At least, the swivel is connected to a decoupler if my eyes do not deceive me?

 

Could you also try creating a completely clean install of KSP (separate from this install, not necessarily deleting what you have) and only install TU, the stock recolour pack and module manager?

Link to comment
Share on other sites

7 minutes ago, Manwith Noname said:

@Dominiquini Looking at your mod list, the swivel problem might be a weird conflict with decoupler shroud perhaps? At least, the swivel is connected to a decoupler if my eyes do not deceive me?

 

Could you also try creating a completely clean install of KSP (separate from this install, not necessarily deleting what you have) and only install TU, the stock recolour pack and module manager?

@Manwith Noname I'm sure I wasn't using the decoupler's shroud, but I'll try it without other mods later.

* I was testing in the Stock vessel 'AeroEquus'.

Thanks.

Edited by Dominiquini
Link to comment
Share on other sites

@Manwith Noname I tested here with only this mod installed and works better, at least the Swivel engine. The Terrier remains broken.

But I don't check if was really the mod "Decoupler Shroud" that is causing this problems.

* Another think I found out: With this mod installed along side of all my other mods, the default shroud of the Swivel is already broken (before I attempt to change his color). But the shroud works fine with all other my mods, excluding this. Works fine too with only this mod!

Thanks for the help!

Edited by Dominiquini
Link to comment
Share on other sites

@Manwith Noname Thank you for this amazing mod! This has made my KSP sessions so much more fun! :)

I recently downloaded the Last KSP Update ever and I'm now facing some missing textures for the following Docking ports:

  • Clampotron
  • Clampotron Jr.
  • Clampotron Shielded
  • Inline Clampotron
  • MK2 Clampotron

I removed Textures Unlimited, Texture Replacer and TURD, and then installed them one by one. I noticed that the docking ports had their textures intact till I installed TURD.

Here are some screenshots:

https://imgur.com/a/0HXoPWm

Link to comment
Share on other sites

21 hours ago, red_prime said:

I recently downloaded the Last KSP Update ever and I'm now facing some missing textures for the following Docking ports:

  • Clampotron
  • Clampotron Jr.
  • Clampotron Shielded
  • Inline Clampotron
  • MK2 Clampotron

Yep. These and new parts are already reconfigured. Things are currently making their way through the spray booths...

Spoiler

?imw=5000&imh=5000&ima=fit&impolicy=Lett

 

Link to comment
Share on other sites

18 hours ago, Manwith Noname said:

Yep. These and new parts are already reconfigured. Things are currently making their way through the spray booths...

  Hide contents

?imw=5000&imh=5000&ima=fit&impolicy=Lett

 

Looking forward to it :D .

For the time being I've commented the docking ports in the config file to make the stock textures work. 

Link to comment
Share on other sites

  • 2 weeks later...

This is a really great mod. Though i have experiencing a slight hiccup. I'm a noob at coding and I downloaded the TU 1.9 mod for 1.12. And most parts including DLC didn't really work with the mod. Is there any way to apply the mod for the new parts and the dlc parts? 

Link to comment
Share on other sites

2 hours ago, KㅤSㅤP said:

This is a really great mod. Though i have experiencing a slight hiccup. I'm a noob at coding and I downloaded the TU 1.9 mod for 1.12. And most parts including DLC didn't really work with the mod. Is there any way to apply the mod for the new parts and the dlc parts? 

In some previous post, I see a wonderful person that apply recolor to the DLC's parts! He publish on github...

Link to comment
Share on other sites

3 hours ago, Chris Bolland said:

So bit of a noob question, 

I can't get the toolbar icon to show up in-game at all, and so... I can't really use the mod. I wanna make my parts more metallic and shiny. 

Anyway how do I get it to show up.

Right click on the part, and click 'show recolouring GUI'.

Link to comment
Share on other sites

in 1.12 Version,  with the newest Airplane-Plus mod and with TURD mod installed, All propeller engine fail to show rotating disc, which means when engine is started, the blade just rotate fast but never switch to rotating disc.

Even when the engine is in stock texture, the rotating disc still doesn't show up. 

And I tried other mod's propeller engine, they also fail to show rotating disc.

I guess it's some 【MODULE = FSplanePropellerSpinner】problem,  but can't find a way to fix it.

Link to comment
Share on other sites

On 7/17/2021 at 10:54 AM, red_prime said:

Looking forward to it :D .

For the time being I've commented the docking ports in the config file to make the stock textures work. 

Hey there! Do you think you could link that docking port hotfix you mentioned? I can't find that comment for the life of me!

For now I've just deleted all references to docking ports in the TU config files. (It's pretty easy, just search the part names in notepad). You get no sexy paints for docking ports, but they default back to their stock textures instead of being grey.

Edited by jonathan_92
Spelling & Grammar
Link to comment
Share on other sites

  • 2 weeks later...

Hello, I got one problem: when I use TURD Airplane Plus and AJE or AJE Extended, engines, modified by AJE/AJEE, don't changing their textures. I understand that this is due to the change in the name of the parts. I tried hard, but I cannot write the correct patch. Maybe somebody knows how to solve this problem? Thank you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...