Jump to content

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]


Recommended Posts

5 hours ago, Alex33212 said:

Well, there's two major ones:
Firstly, the new food/water/oxygen combo part doesn't have any water storage when using Kerbalism; I haven't tried it with any other life support mods though. Secondly, several of the science modules seem to interact weirdly with Kerbalism in regards to their animations; cover doors can't be toggled on/off on the science wedges that have them. Additionally, some of the deployment animations are either messed up or simply don't happen; the physical and atmospheric science wedges suffer from the latter, and the goo pod wedge has the former (the main goo pod is stuck in the extended position and the second one is missing from the model). This is limited to the base USII wedges though; the DMagic Orbital Science wedges animate fine.

 

5 hours ago, Daishi said:

The water one should be easy enough to fix, i'll have a look and see what Kerbalism is doing with the animations. 

...what Kerbalism config pack do you use? Replicated it with the science-only config pack. I'll have a chat with the Kerbalism devs :)

Edited by Daishi
Link to post
Share on other sites
8 hours ago, Alex33212 said:

Secondly, several of the science modules seem to interact weirdly with Kerbalism in regards to their animations; cover doors can't be toggled on/off on the science wedges that have them. Additionally, some of the deployment animations are either messed up or simply don't happen; the physical and atmospheric science wedges suffer from the latter, and the goo pod wedge has the former

What game mode are you playing in? Career, Science, or Sandbox? Kerbalism science parts have a lot of weird interactions in Sandbox, so if you're seeing issues there, you might bring it up in the Kerbalism thread. Also, if you're not in career, try starting a new game in career mode and see if the behavior exists there. (So you don't have to play for hours first, start the game with the science and money sliders all the way up so you can "buy" the research center upgrades and as many part nodes as possible) In any case, Kerbalism plugs into so much stuff, and the science parts act differently depending on game mode, so that's a useful piece of info for troubleshooting.

Link to post
Share on other sites

Please do not install this beta if your crafts have a 1.875m ACD on board. The craft will likely fail to load and get deleted. 

Changelog (issues found, to be hotfixed)
-------------------------------------------

* The ACDs have had their SAS modules and decouple functionality deleted. This will be restored
* 1.875m ACD was not loading into game, fixed
* Science experiment wedges have had their localisation fields fixed. 
* 1.25m -> 1.875m Adaptor shroud has had their solar panel toggle between payloadbay to wedge-mount bay fixed. 
* Adaptor shroud localisation fields restored 
 

17 minutes ago, panarchist said:

What game mode are you playing in? Career, Science, or Sandbox? Kerbalism science parts have a lot of weird interactions in Sandbox, so if you're seeing issues there, you might bring it up in the Kerbalism thread. Also, if you're not in career, try starting a new game in career mode and see if the behavior exists there. (So you don't have to play for hours first, start the game with the science and money sliders all the way up so you can "buy" the research center upgrades and as many part nodes as possible) In any case, Kerbalism plugs into so much stuff, and the science parts act differently depending on game mode, so that's a useful piece of info for troubleshooting.

Been having a chat to the devs, it was definitely an oversight on the assumption US2 used the same modules as DMOS. Because of the methods used by Kerbalism to collect science doesn't really work with the multi-sample collection used by these new parts, all the extra animations play at once and everything looks a bit wonky. We'll try and patch that once we work out how to get around it :)

Link to post
Share on other sites

A bug/issue I found is that the Vostok fairing (fueled)  does not work with the monopropelant toroidal tankage option.

Using one xor the other gives 40 RCS fuel, using both still give 40, and not 80 as it should.

Also, the radiator is amazing ! any plan to add this as an option on the soyouz fairing ? That would kick ass.

Link to post
Share on other sites
5 hours ago, Daishi said:

* The ACDs have had their SAS modules and decouple functionality deleted. This will be restored

Oh yeah, forgot to say that I tried using the 0.625m ACD and it wasn't decoupling; glad to see y'all caught that bug!

5 hours ago, Daishi said:

Been having a chat to the devs, it was definitely an oversight on the assumption US2 used the same modules as DMOS. Because of the methods used by Kerbalism to collect science doesn't really work with the multi-sample collection used by these new parts, all the extra animations play at once and everything looks a bit wonky. We'll try and patch that once we work out how to get around it :)

Well, had a look through Kerbalism stuff and turns out this bug was already found on their end?
https://github.com/Kerbalism/Kerbalism/issues/596

Seems I've somehow been using an out-of-date version (3.4 not 3.7); I could have sworn I was using the most recent version. I'll update, see if the problems still persist!

(Also, that's likely why the science-only config still has the bug; the fix was done last month)

Sorry for the trouble ^^;

Edited by Alex33212
Link to post
Share on other sites

Alright, can confirm that updating to Kerbalism 3.7 fixed the pre-deployed goo pod issue, so that's taken care of ^^;

However, the inability to toggle covers remains (as does the lack of animations on the physical & atmospheric science units), and once used the goo pod doesn't retract. Is this still something I should be pursuing on this thread, or us it more on the Kerbalism side?

Edited by Alex33212
Tone clarifications & stuff
Link to post
Share on other sites

One more small bug: the 1.5m cylindrical fairing has the title, tags, and description of the 1.25m one.

(BTW, this US2 update is the first time I've seen 1.5m parts; I don't have any other parts (besides US2) in that size.  The description for the 1.5m 5-bay core mentions that it's a BDB size, but I'm not using BDB.  Are the 1.5m parts intended to be always available, or should they be hidden unless something like BDB is installed to make them useful?)

Also, a suggestion: the parts related to life support (such as the food and waste wedges) ought to have the "cck-lifesupport" tag, so that they appear in the editor's "Life Support" category when CCK is installed.  Life-support mods tend to put their own food/waste containers there (I know USI-LS and Snacks both do), so it's weird that the US2 ones aren't there too.

And edited with some more parts showing #autoLOC tags: USCargoStorageWedge, USFluidSpectroWedge, and USMatBayWedge, USAdaptorShroud0625

Edited by Wyzard
Link to post
Share on other sites
5 minutes ago, Wyzard said:

One more small bug: the 1.5m cylindrical fairing has the title, tags, and description of the 1.25m one.

(BTW, this US2 update is the first time I've seen 1.5m parts; I don't have any other parts (besides US2) in that size.  The description for the 1.5m 5-bay core mentions that it's a BDB size, but I'm not using BDB.  Are the 1.5m parts intended to be always available, or should they be hidden unless something like BDB is installed to make them useful?)

1.5m is about the largest size that fits in a 1.875m fairing's base diameter, so it's decently useful that way

Link to post
Share on other sites

Seem to be having an issue on load with OSE Workshop trying to get the part recipe for the Single Probe Core.  The loading screen hangs at this point and never comes back.  Here is an excerpt from the log file:


[OSE] - Loading PartRecipe for USDoubleProbeCore
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[OSE] - Loading PartRecipe for USSingleProbeCore
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at Workshop.Recipes.WorkshopRecipeLoader+<LoadPartRecipes>d__4.MoveNext () [0x0005d] in <8b6b401254ab4a19939e53366ee51f8d>:0 
  at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 
(Filename: <8b6b401254ab4a19939e53366ee51f8d> Line: 0)

I am using the latest Beta2 for 1.9.1 downloaded from the OneDrive link.  It has never worked, this happened right after I installed it.  If you know off the top of your heads what needs to change and it is editable, can you let me know so I can make the manual change before the next Beta patch?  

Thank you guys for all you do for the modding community!!! 

 

Link to post
Share on other sites
On 3/30/2020 at 11:29 AM, SkyPunch said:

Seem to be having an issue on load with OSE Workshop trying to get the part recipe for the Single Probe Core.  The loading screen hangs at this point and never comes back.  Here is an excerpt from the log file:

I am using the latest Beta2 for 1.9.1 downloaded from the OneDrive link.  It has never worked, this happened right after I installed it.  If you know off the top of your heads what needs to change and it is editable, can you let me know so I can make the manual change before the next Beta patch?  

Thank you guys for all you do for the modding community!!! 

 

 

On 3/28/2020 at 4:11 PM, Wyzard said:

One more small bug: the 1.5m cylindrical fairing has the title, tags, and description of the 1.25m one.

(BTW, this US2 update is the first time I've seen 1.5m parts; I don't have any other parts (besides US2) in that size.  The description for the 1.5m 5-bay core mentions that it's a BDB size, but I'm not using BDB.  Are the 1.5m parts intended to be always available, or should they be hidden unless something like BDB is installed to make them useful?)

Also, a suggestion: the parts related to life support (such as the food and waste wedges) ought to have the "cck-lifesupport" tag, so that they appear in the editor's "Life Support" category when CCK is installed.  Life-support mods tend to put their own food/waste containers there (I know USI-LS and Snacks both do), so it's weird that the US2 ones aren't there too.

And edited with some more parts showing #autoLOC tags: USCargoStorageWedge, USFluidSpectroWedge, and USMatBayWedge, USAdaptorShroud0625


Hotfix build (Beta 3) here
Overwrite Beta 2 and replace files when prompted. This should fix most issues until Paul can compile an official Beta 3. Let me know if it fixes that probe core issue @SkyPunch  :)

https://1drv.ms/f/s!As-w_rlhH66Hlv0wt62Udh3oHpv78w

@Wyzard Yeah, running without BDB and Tantares really means there isn't much of a usecase for the 1.5m size, but i'd rather not hide them. I do suggest using those mods if you're a fan of Making History, the Russian crew capsules are scaled down to an accurate size, and the colouring in the parts match what I've done with US2's new colour variants. 

Edited by Daishi
Link to post
Share on other sites

Out of curiosity, what's meant to be between the Vostok-style shroud and the 1.5m shroud in bulkhead configuration? I've tried a number of things - including the Tantares engine for the Vostok - and I haven't been able to find anything with the right spacing.

Link to post
Share on other sites
36 minutes ago, Alex33212 said:

Out of curiosity, what's meant to be between the Vostok-style shroud and the 1.5m shroud in bulkhead configuration? I've tried a number of things - including the Tantares engine for the Vostok - and I haven't been able to find anything with the right spacing.

It was a tricky call, because Beale included the radiator structure with his engine it kinda doesn't work unless you inset it. Otherwise, I often clip a small Oscar fuel tank until the rim is just visible, and put a 0.625m engine on with a set of small RCS thrusters around the edge. 

https://giant.gfycat.com/ShadowyFlawlessIrishterrier.mp4

There's probably trashy music in that clip, I apologise in advance :P

Edited by Daishi
Link to post
Share on other sites
5 minutes ago, Daishi said:

It was a tricky call, because Beale included the radiator structure with his engine it kinda doesn't work unless you inset it. Otherwise, I often clip a small Oscar fuel tank until the rim is just visible, and put a 0.625m engine on with a set of small RCS thrusters around the edge. 

https://gfycat.com/shadowyflawlessirishterrier 

Ah, so it's mainly a matter of using the part-translation tool to get it just right. Gotcha, thanks!

Link to post
Share on other sites
1 hour ago, Daishi said:

Hotfix build here
Overwrite Beta 2 and replace files when prompted. This should fix most issues until Paul can compile an official Beta 3. Let me know if it fixes that probe core issue @SkyPunch  :)

@Daishi That patch worked perfectly, and also fixed the localization tags!  

I can't tell you how much I appreciate you guys working on this and responding so quickly.  Thank you for your dedication to making mods that allow us to enjoy our quarantine more! :)

Link to post
Share on other sites
9 hours ago, Daishi said:

Hotfix build here

I looked through the parts and didn't see any #autoLOC stuff in-game.  However, USCylindricalShroud1500 still uses strings that belong to USCylindricalShroud125 (so its title in-game says it's a 1.25m fairing when it's actually 1.5m).

On a different note: the USDoubleProbeCore description says it's "capable of attitude control, remote guidance, and fulfilling the role of a skilled pilot", but it actually has no ModuleSAS.  For comparison, the more-advanced USSingleProbeCore has ModuleSAS with SASServiceLevel = 1.

Also, the single probe core's description says its gyroscope has been removed (compared to the double core), but it has ModuleReactionWheel and the double core does not.  The double core has two USReactionWheel modules, which seem to be for animating gyroscopes in the part's model, so I'm guessing it was meant to have the ModuleReactionWheel too.

Also, "convenient" is misspelled in the double probe core's description (#autoLOC_US_DoubleProbeCore_Description) — both in en-us.cfg, and in the comment in DoubleProbeCore.cfg.

Link to post
Share on other sites

Hello @Paul Kingtiger

I noticed a discrepancy that would not show a wedge on the back of a Kerbal when using KIS.
This could be that something changed the way KIS is working.

Anyway I was able to fix the problem by changing the line: equipSlot = back  ---> equipSlot = jetpack
Also the line equipSkill = <null> has to be removed.

Both lines are in MODULE:NEEDS[KIS]

Kind Regards,
EngineerMartijn

Link to post
Share on other sites
1 hour ago, EngineerMartijn said:

Anyway I was able to fix the problem by changing the line: equipSlot = back  ---> equipSlot = jetpack

Also, the "equipMeshName = jetpack_base01" line should probably be removed.  Having it there might be a bug — KIS had bug #269 where items would appear on the backpack of male kerbals but not female, and it was fixed by removing equipMeshName and changing equipBoneName to "aliasJetpack".  US2 has equipBoneName set to aliasJetpack, but also still has the equipMeshName attribute.  I'm not sure whether that attribute by itself causes the bug with it not working on female kerbals, but at any rate it's deprecated.

Link to post
Share on other sites
58 minutes ago, Wyzard said:

Also, the "equipMeshName = jetpack_base01" line should probably be removed.  Having it there might be a bug — KIS had bug #269 where items would appear on the backpack of male kerbals but not female, and it was fixed by removing equipMeshName and changing equipBoneName to "aliasJetpack".  US2 has equipBoneName set to aliasJetpack, but also still has the equipMeshName attribute.  I'm not sure whether that attribute by itself causes the bug with it not working on female kerbals, but at any rate it's deprecated.

For a cleaner coding that would be better to remove it, if it is deprecated. However I just checked with a female scientist, she could grab a foodbag and it was visible on the back. I still have the line equipMeshName still there. Will try later what will happen without that line.


Edit:
Did some testing, line equipMeshName = jetpack_base01 can also be removed. Saves another line of code

Edited by EngineerMartijn
Function testing
Link to post
Share on other sites
On 3/31/2020 at 2:06 AM, EngineerMartijn said:

Would it be possible to upload this nice project to GitHub.
This way it would be much easier for others to contribute code and files if they find some things that could be fixed or missing

I agree: it'd be great to have US2 in Git, so people can look at diffs and contribute fixes.

Just last night, I submitted two GitHub merge requests for fixes in some USI parts — coincidentally, one was for the KIS female backpack bug, which I just learned about while working on the other change.  And I learned about that bug by doing a search on the KIS revision history to find the specific Git commit that removed the "equipMeshName" line; that commit has a description that mentions it being for bug #269.  Having changes tracked like that is pretty valuable, and if there was a GitHub project for US2, I could submit merge requests with fixes for some of the issues I've found.

Edit: Found one more small bug: the KIS storage wedge's description says "three size variants are available", but the USSwitchControl actually only has one variant, named "Double".  (There's a comment saying the other two were disabled due to a bug.)

Edit: Going back to the probe-core wedges, the double core is 50kg and the single core is 100kg, which I think is backward — especially since the single core's description mentions "50kg of mass savings".

Edited by Wyzard
Link to post
Share on other sites
18 hours ago, Darkuss said:

Will there be any fuel tanks with liquid hydrogen from Cryogenic Engines?

That is a fantastic idea. Just the ability to fuel switch would already be awesome. Gold foil texture would be gravy.

Link to post
Share on other sites

Using the B2 build from 27 Mar, (without the patch suggested a few posts up yet), and in career mode I'm running into an issue where the 2.5m core isn't showing up. The three other core sizes (1.25, 1.5, 1.875) are all there, but not the 2.5. All the fairings (including 2.5) are there fine.

Thoughts? 

Link to post
Share on other sites

I'm getting "Cannot run experiment; science module full" after using the advanced materials bay on Universal Storage for the first time in a mission (I was trying to reset it). Not using [x] Science, but ScienceAlert. Any thoughts?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...