benjee10

[1.7.x] Shuttle Orbiter Construction Kit | Stockalike Space Shuttle Orbiter! | (Initial Release!) | v1.0.0

Recommended Posts

5 hours ago, Thomas Edison said:

I tried that earlier today. Is there a certain folder I need to delete? Sorry I'm not great with configs and stuff.

Yes the folder you need to get rid of is "Configs" inside of PlumeParty. 

Thats what I was trying to say with PlumeParty/Configs :P 

 

Share this post


Link to post
Share on other sites

This pack is really great, as are your other packs (HabTech2 and reDIRECT) however I am really struggling to fly this thing effectively (what's new, Shuttles are always a pain!). Thanks for putting in the time and effort, benjee!

The first problem is I am trying to roll the stack to the right heading for my target orbit (a 45-degree inclined orbit) and rolling the stack using the roll controls sends stuff haywire. The stack tends to nose-down (relative to the flight deck) when rolling, and also sways sideways sometimes. Is this caused by the flight surfaces or the SRBs being right out to the sides or something?

Secondly I am really struggling to get a good gravity turn working for it and always hit my target apoapsis way before the ET has emptied. I have succeded partially by running a longer flatter trajectory but this causes a lot of heating in the atmosphere.

Thridly, is there any reason why, even using Jeb as a pilot, I don't get access to any SAS funtions aside from Pro/Retrograde?

Fourthly The SRBs have exploded the ET a couple of times. This is reDIRECT parts rather than this pack, I guess, but is there any reason this could be happening? It looks like the nose cone sep SRBs are cooking the part in between them.

Also is there anything that can be done to stop the robotic arm waving around in the breeze? XD

I should add I'm using the craft file provided with the mod (Stock robitics version)

Edited by MDBenson

Share this post


Link to post
Share on other sites
15 minutes ago, MDBenson said:

This pack is really great, as are your other packs (HabTech2 and reDIRECT) however I am really struggling to fly this thing effectively (what's new, Shuttles are always a pain!). Thanks for putting in the time and effort, benjee!

The first problem is I am trying to roll the stack to the right heading for my target orbit (a 45-degree inclined orbit) and rolling the stack using the roll controls sends stuff haywire. The stack tends to nose-down (relative to the flight deck) when rolling, and also sways sideways sometimes. Is this caused by the flight surfaces or the SRBs being right out to the sides or something?

Secondly I am really struggling to get a good gravity turn working for it and always hit my target apoapsis way before the ET has emptied. I have succeded partially by running a longer flatter trajectory but this causes a lot of heating in the atmosphere.

Thridly, is there any reason why, even using Jeb as a pilot, I don't get access to any SAS funtions aside from Pro/Retrograde?

Fourthly The SRBs have exploded the ET a couple of times. This is reDIRECT parts rather than this pack, I guess, but is there any reason this could be happening?

Also is there anything that can be done to stop the robotic arm waving around in the breeze? XD

Okay so a couple of things to unpack!

First, are you using the stock vector engine, or the variant that comes with reDIRECT? If it’s the stock vector then you want the one from reDIRECT, and then you’ll change the ET to hydrolox.

 

Second, are you flying in a stock scale system or in something like 2.5x rescale? Most mods, and even stock parts, are balanced for a kerbin that is 2.5x larger than what’s present in stock. This should make your trajectory much more realistic. If you’re already using rescale then idk why it’s like that.

 

Third, I honestly can’t tell you why you don’t have the controls that you should, I don’t have that issue personally.

 

Fourth, the SRBs in reDIRECT only come with the separation motors in the nose. Adding separatrons on the aft skirt are needed to get it to work a little bit better.

 

And finally, you should be able to lock the motors on the arm joints and use auto strut to help with that. Also avoid physics warp during launch. iirc there isn’t really a perfect solution but this stuff should help.

Share this post


Link to post
Share on other sites
36 minutes ago, DylanSemrau said:

Okay so a couple of things to unpack!

First, are you using the stock vector engine, or the variant that comes with reDIRECT? If it’s the stock vector then you want the one from reDIRECT, and then you’ll change the ET to hydrolox.

As the provided craft file uses all the right parts, I think it is using the right config, LH2/Ox in the ET and the RS-25B?

Quote

Second, are you flying in a stock scale system or in something like 2.5x rescale? Most mods, and even stock parts, are balanced for a kerbin that is 2.5x larger than what’s present in stock. This should make your trajectory much more realistic. If you’re already using rescale then idk why it’s like that.

Stock scale. I have admit using things like Tantares and the lkike make orbital launches rather *too* easy on stock scale, you are correct. I suppose I could run something 2.5x for a better challenge. I have built a rather nice station in orbit in this playthrough but haven't crewed it as yet, this was the first docking flight, so I guess I could re-build it in the new save and then boot it up there using Hyperedit :)

Any recomendations for a 2.5x pack that works with 1.7.x?

Quote

Third, I honestly can’t tell you why you don’t have the controls that you should, I don’t have that issue personally.

Yes, it's odd, I have the full tech tree unlocked (I'm in a Science game but only so I can actually do stuff when I get to places and use science instruments) and I'm using Jeb who usually has access to everything.

Quote

Fourth, the SRBs in reDIRECT only come with the separation motors in the nose. Adding separatrons on the aft skirt are needed to get it to work a little bit better.

Again, I am usig the craft file from the Orbiter pack, so the aft skirt seps are there too. I am starting to thing it's partly an issue with the atmospheric forces actring on the stack at the altitude i am doing the booster sep. I think it's causing some kind of weird interaction. Is it better to separate the boosters before the flame out or leave them to stop?

Quote

And finally, you should be able to lock the motors on the arm joints and use auto strut to help with that. Also avoid physics warp during launch. iirc there isn’t really a perfect solution but this stuff should help.

I don't see options for that on the hinges but I'll give it another prod once I've got the stack to work.

Edited by MDBenson

Share this post


Link to post
Share on other sites
4 hours ago, MDBenson said:

Any recomendations for a 2.5x pack that works with 1.7.x?

 

You can use Sigma Dimensions and ReScale! to make the stock system 2.5x, or even larger. although the ReScale! page says that it is for 1.3.1, rest assured that it works splendidly in 1.7 :).

Share this post


Link to post
Share on other sites
1 hour ago, Barzon Kerman said:
 

You can use Sigma Dimensions and ReScale! to make the stock system 2.5x, or even larger. although the ReScale! page says that it is for 1.3.1, rest assured that it works splendidly in 1.7 :).

Thanks for the tip, I'd already sussed out Kopernicus and Sigma dimensions, but the ReScale config probably tweaks a few values I didn't delve into. I'm now on a 2.5x scale system and I like it tbh, it looks a lot more realistic without being too hard xD

I'm still battling ascenbt profiles. I decided to try MechJeb ascent guidance. It's better than trying to fly it by hand. To a point. The problem I have is that the profile flies perfectly until I drop the SRBs (which are still smassing into the ET sometimes :\) then the orbiter/ET stack doesn't seem to be able to stick to the ascent curve, which I'd like to flaten out at altitude. The result is it goes high and hit's Apoapsis altitude (250km in this case) way to early before it's exhausted the ET and tehn burns all the OMS fuel circularising, and the OMS circularisation burn is very difficult as it's too long (and the OMS has low TWR).

Share this post


Link to post
Share on other sites
1 hour ago, MDBenson said:

Thanks for the tip, I'd already sussed out Kopernicus and Sigma dimensions, but the ReScale config probably tweaks a few values I didn't delve into. I'm now on a 2.5x scale system and I like it tbh, it looks a lot more realistic without being too hard xD

I'm still battling ascenbt profiles. I decided to try MechJeb ascent guidance. It's better than trying to fly it by hand. To a point. The problem I have is that the profile flies perfectly until I drop the SRBs (which are still smassing into the ET sometimes :\) then the orbiter/ET stack doesn't seem to be able to stick to the ascent curve, which I'd like to flaten out at altitude. The result is it goes high and hit's Apoapsis altitude (250km in this case) way to early before it's exhausted the ET and tehn burns all the OMS fuel circularising, and the OMS circularisation burn is very difficult as it's too long (and the OMS has low TWR).

Have a read of the manual in the OP - it gives pretty detailed instructions of how to fly the shuttle manually or using MechJeb. You need to make use of PVG and the cockpit’s adjustable control point for smoothest results.

Share this post


Link to post
Share on other sites

Hi all, 

Continuing my series of updates on the future of my mods. Go read my latest post in HabTech2 for a detailed explanation of my overall plans. 

Basically, the next update of this mod will be the last. Here's what it'll add:

- IUS cradle
- PAM cradle
- A few other payload structural bits
- Orbiter boom system
- Canadarm2
- A few fun things

I'm not looking for feature requests at this time. I will continue to maintain the mod after I consider it finished to ensure it always works with the latest version of KSP1. 

Many thanks for your understanding,

Benjee10

Share this post


Link to post
Share on other sites
22 hours ago, benjee10 said:

Have a read of the manual in the OP - it gives pretty detailed instructions of how to fly the shuttle manually or using MechJeb. You need to make use of PVG and the cockpit’s adjustable control point for smoothest results.

I've found that if you add the spare control point and make the -15 degree angle offset upside down then you only have to link its control from here to a custom action group.  Activate this at 2:30, after the SRBs separate, and you'll get the pitch correction plus roll maneuver with one keypress.  Orbital maneuvers "upside down" aren't atypical for the shuttle anyway, and after deorbit burn, you simply switch the control back to the cockpit.  It's more convenient for me to add the part instead of using the cockpit adjustable control point--although I like that you thought of it when you designed it.

Re: PVG.  You'll want to use that.  It works great with this shuttle--and I'm not sure how, because I've only had issues with it using anything other than RSS/RO.  No matter.  Set apoapsis for <desired height> and periapsis for <something just below "space">.  (Typically this is 70km in a default setting, 140 for RSS)  In this way the external tank eventually deorbits, and you only have to make a minimal burn at apoapsis to complete orbit.  This is how the real one worked.

Edited by slaintemaith

Share this post


Link to post
Share on other sites
20 hours ago, slaintemaith said:

Re: PVG.  You'll want to use that.

Would you be able to explain for a dork like me who has no idea what PVG is?

Edited by MDBenson

Share this post


Link to post
Share on other sites

PVG is Primer Vector Guidance.

It’s a mechjeb ascent mode based on real world algorithms designed for RO, but works great on SOCK in JNSQ ksp.

Share this post


Link to post
Share on other sites

Oh! Sorry, yes I've been using that. It was about the only way I could get a decent orbital ascent path.

8d2RXVl.png

Incidentally, I think I solved the exploding ET by using Bluedog's Prometheus-III seperation nose cones tweakscaled to match the SRB diameter. They are facing directly at the ET and don't cause it to explode. I suspect the reDRIECT SRB nose cones might need tweaking to reduce the heating factor or something (I've never modded engine dynamics in KSP so I dunno how it works). I get no issues using them on the pad in a test but at altitude after they burn out (and the shuttle stack hasd been subjected to quite a lot of friction, mayber heating the ET a bit?) they will 80% of the time cause the ET to explode.

Share this post


Link to post
Share on other sites
29 minutes ago, MDBenson said:

Oh! Sorry, yes I've been using that. It was about the only way I could get a decent orbital ascent path.

8d2RXVl.png

Incidentally, I think I solved the exploding ET by using Bluedog's Prometheus-III seperation nose cones tweakscaled to match the SRB diameter. They are facing directly at the ET and don't cause it to explode. I suspect the reDRIECT SRB nose cones might need tweaking to reduce the heating factor or something (I've never modded engine dynamics in KSP so I dunno how it works). I get no issues using them on the pad in a test but at altitude after they burn out (and the shuttle stack hasd been subjected to quite a lot of friction, mayber heating the ET a bit?) they will 80% of the time cause the ET to explode.

How are you aligning the separation nosecones? They shouldn’t point directly into the stack, but should be at around a 45 degree angle, so that they push the boosters both out and down (away from the orbiter). I’ve never had issues with them exploding the ET due to overheating even with them pointed right at it - I suspect that if you’re missing separation rockets on the bottom of the SRBs, they may not quite be clearing the stack properly and be pivoting into and colliding with the ET, causing it to explode. The flight log will be able to tell you whether it’s overheating or colliding.

Share this post


Link to post
Share on other sites
2 hours ago, benjee10 said:

How are you aligning the separation nosecones? They shouldn’t point directly into the stack, but should be at around a 45 degree angle, so that they push the boosters both out and down (away from the orbiter). I’ve never had issues with them exploding the ET due to overheating even with them pointed right at it - I suspect that if you’re missing separation rockets on the bottom of the SRBs, they may not quite be clearing the stack properly and be pivoting into and colliding with the ET, causing it to explode. The flight log will be able to tell you whether it’s overheating or colliding.

Suggestion noted, I'll spin em around 45, but again, your craft file had your versions at the 'correct' angle and I was still having issues.

You're the second person to sugggest the sepratron thing. I'm using your craft file, so yes the aft skirt sep motors are there, and they fire. I verified that as soon as I had a problem. I'll run a check flight and see what's up.

Edited by MDBenson

Share this post


Link to post
Share on other sites

@Zorg wow wonderful pics, what mod are the pars for that payload from? The one inside the shuttle? Also what did you use to get those visuals?

Share this post


Link to post
Share on other sites
2 hours ago, The-Doctor said:

@Zorg wow wonderful pics, what mod are the pars for that payload from? The one inside the shuttle? Also what did you use to get those visuals?

Which picture did you mean? One my pictures Benjee used in the OP? or this one I posted?
 

8uxchKQ.png

In this case the Centaur G upper stage is from Bluedog Design Bureau. The Satellite is a custom build mostly with Coatl Probes Plus parts and some ReStock bits.

 

Visuals use Scaterrer, EVE, PlanetShine, Distant Object Enhancement and KS3P

This is the best place to start for instructions to get similar visuals:

 

Share this post


Link to post
Share on other sites

 I have two problems about this mod. The first is elbow joint can't  display properly in the shuttle when lanuching. I mean it will beat unsteadily. The second is that the landing gear is unstable when shuttle just land on the runway. I don't know if it's a problem of my Method of use or just mod bug. how can I fix that?

Share this post


Link to post
Share on other sites
On 8/13/2019 at 2:15 PM, benjee10 said:

Ah yes, that makes sense - although you should only need to autostrut the outermost part to get it stable, not all of them.

In terms of IVAs, it would be more work to convert those mods for this IVA than doing it from scratch. As the dimensions of the shuttle cockpit are different from the mk3 cockpit the interiors don’t match up.

It would be easier, in terms of my IVA, to just build a version directly into your IVA rather than trying to adapt mine to fit this. One could, perhaps, just copy my IVA into your IVA, delete the old model, and then just adjust the locations of props and bingo, bango you've got an IVA. 

But whats more likely is that I won't bother doing this lol. With KSP2 on the horizon (and having only just got to a place where I could potentially take the IVA back up like, today) I'm unsure if I want to bother with it right now. 

Share this post


Link to post
Share on other sites

LPcrUHR.jpg

n1O2v3G.jpg

Does anyone know what happen to my shuttle? It still in one piece, but every part dislocate.

Edited by rogerwang86

Share this post


Link to post
Share on other sites

This is amazing mod to be honest but I'm missing the right wing of the shuttle. In SPH mirroring wont work as well. What could it be wrong?

Thanks.

Share this post


Link to post
Share on other sites
1 hour ago, dragonflyGT said:

This is amazing mod to be honest but I'm missing the right wing of the shuttle. In SPH mirroring wont work as well. What could it be wrong?

Thanks.

It can't. You should download B9 partswitch, than you will find the option for change left wing to right wing. 

Share this post


Link to post
Share on other sites
5 hours ago, rogerwang86 said:

It can't. You should download B9 partswitch, than you will find the option for change left wing to right wing. 

oh my... I might be an idiot or something.. You saved my life dude thanks a lot!

Share this post


Link to post
Share on other sites

Love this mod, probably one of the better shuttle mods since the space shuttle system one. Anyways, I've had this 'problem' with the mod where the Canadarm would clip through the mid fuselage. It's only a minor problem that I'm able to deal with but a problem nonetheless. Some help would be greatly appreciated :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.