Jump to content
  • 3

weird pink square keeps appearing


Question

24 answers to this question

Recommended Posts

  • 0

@Mercyfon I also have this problem, the pink cube started to appear when I installed KAS, when I deleted that mod, it still appears, I have a few outdated mods, but they don't seem to be the problem, the only visual mods I have are EVE and Para-Sci High Performance Atmosphere Pack, these mods also don't seem to cause the problem

Link to post
Share on other sites
  • 0

Here's a way. It's nuclear but don't worry. IT WILL WORK. So, delete your entire thing. Download it again. Go to recycled and grab the ksp folder and merge (Slap) it into the new ksp. (Don't bother with the message. Click X) Files already in the new ksp will overwrite the old ones but any files that didn't exist in the new one don't get overwritten.

You may have to change settings and stuff but it should solve most problems. This means all you craft and files are okay...

Extra: Delete, download again, go to recycled, pull the folder out, merge it with existing ksp, Click X on the message box that comes up, Test it to see if it works, if working configure settings and do anything else, if in steam, turn off steam cloud in updates, retry. 

Comment me if you have problems. If it does then just slap your mods into there and call it a day.

Edited by Arco123
Link to post
Share on other sites
  • 0
On 2/19/2020 at 7:56 PM, LoltheVI said:

I had the pink square. I think it was Procedural fairings. Does anyone else get it during VAB or SPH as well as flight?

Apparentley I was partially correct. Fairings from the base game were turned into pink squares, and sometimes they did appear in the VAB. But during flight, It is a graphical mod, I just hope I don't have to nuclear. I've removed EVE and no luck.

Link to post
Share on other sites
  • 0
13 hours ago, LoltheVI said:

Apparentley I was partially correct. Fairings from the base game were turned into pink squares, and sometimes they did appear in the VAB. But during flight, It is a graphical mod, I just hope I don't have to nuclear. I've removed EVE and no luck.

Now how do i say that going nuclear did not work?

Link to post
Share on other sites
  • 0
On 12/28/2019 at 6:22 PM, Arco123 said:

Here's a way. It's nuclear but don't worry. IT WILL WORK. So, delete your entire thing. Download it again. Go to recycled and grab the ksp folder and merge (Slap) it into the new ksp. (Don't bother with the message. Click X) Files already in the new ksp will overwrite the old ones but any files that didn't exist in the new one don't get overwritten.

You may have to change settings and stuff but it should solve most problems. This means all you craft and files are okay...

Extra: Delete, download again, go to recycled, pull the folder out, merge it with existing ksp, Click X on the message box that comes up, Test it to see if it works, if working configure settings and do anything else, if in steam, turn off steam cloud in updates, retry. 

Comment me if you have problems. If it does then just slap your mods into there and call it a day.

It didn't really work in my case. Mostly since there is no ksp folder in recycled. Maybe I'm doing something wrong.

Link to post
Share on other sites
  • 0

You gotta restore it to a different location when you find the folder that KSP resides in. After that you wanna re-download whatever verison you had before and put it in. After that, grab the old ksp and merge it with the new ksp and click X. Boot it up to see if it works. 

Link to post
Share on other sites
  • 0
21 hours ago, Arco123 said:

You gotta restore it to a different location when you find the folder that KSP resides in. After that you wanna re-download whatever verison you had before and put it in. After that, grab the old ksp and merge it with the new ksp and click X. Boot it up to see if it works. 

I tried it again as you said it, and it works. but it appears that if i used parts from Hooliganlabs the square would appear, if I didn't it just vanishes. I'm just gonna delete that mod.

Link to post
Share on other sites
  • 0

I get the pink square too.  I uninstalled every mod and it went away in vanilla.  I slowly began adding mods back in and it reappears with Module Manager, which was added as a dependency via CKAN.  I removed everything again but Module Manager and it still appeared.  When I finally removed Module Manager, it disappeared.

Link to post
Share on other sites
  • 0

I realize this thread is quite old, but it gave me an idea of what to look for and helped me fix it regardless. I think it's not to do with any one mod in particular, I think it's any mod trying to overlay a texture in an outdated/unsupported way and Unity has no clue what it's doing so it places a pink square over your spaceship rather than the specific texture or effect it was meant to place.

Try removing any mods that might be outdated or that focus on texture placing. For me it was Planet shine (With AVP and EVE), which I believe has some added textures and shaders. Either way, the fact that there's seemingly no one specific mod that causes it is kinda suspicious, so just look for if it adds certain shaders or textures on things (on your spacecraft), or if it has to do with certain mod parts that might have conflicting or invalid textures.

Cheers!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...