ferram4

[1.3] Kerbal Joint Reinforcement v3.3.3 7/24/17

Recommended Posts

56 minutes ago, siimav said:

Did you fix line 67 in CompatibilityChecker?

no I did not... now I did... going to try it again. :)

Share this post


Link to post
Share on other sites

Props to you guys for taking it upon your selves to fix things. Shame on you guys giving them crap about it. The mod is MIT mind your own business. In fact, you can post a download link to a quick fix and people do it for mods all the time. RSS would never have been playable in 1.3 if it weren’t for someone writing a quick fix and posting it in the forum.

Edited by harrisjosh2711

Share this post


Link to post
Share on other sites

If you install 3.3.3 and then replace the DLL file with this one: https://www.dropbox.com/s/9fnmjih10nw6f2r/KerbalJointReinforcement.dll?dl=0

that should get you going.  All I did was change the Compatibility string as described above, and recompile with Visual Studio 2017.  It works for me; no warranty or support is provided, and this is an unofficial build, do not ask Ferram4 or anyone else for help with this either, this is strictly at-your-own risk.  It does,  however, work for me.

Share this post


Link to post
Share on other sites
On 3/18/2018 at 8:44 PM, ss8913 said:

If you install 3.3.3 and then replace the DLL file with this one:  [Download link removed by moderator]

that should get you going.  All I did was change the Compatibility string as described above, and recompile with Visual Studio 2017.  It works for me; no warranty or support is provided, and this is an unofficial build, do not ask Ferram4 or anyone else for help with this either, this is strictly at-your-own risk.  It does,  however, work for me.

Thanks i will try it right way :)

Edited by Snark
Download link removed by moderator

Share this post


Link to post
Share on other sites

I think that this has been asked before, but what's the stats for 1.4? 

I haven't launched any spacefaring craft in fear since 1.4.

Share this post


Link to post
Share on other sites
2 hours ago, Thorn_Ike said:

I think that this has been asked before, but what's the stats for 1.4? 

I haven't launched any spacefaring craft in fear since 1.4.

I *literally* just posted a fixed DLL which at least seems to work.  There's no official word from Ferram4 on an actual update, but the DLL I posted a couple messages up should get you going.  It works for me at least.

Share this post


Link to post
Share on other sites
On 3/18/2018 at 8:44 PM, ss8913 said:

If you install 3.3.3 and then replace the DLL file with this one:  [Download link removed by moderator]

that should get you going.  All I did was change the Compatibility string as described above, and recompile with Visual Studio 2017.  It works for me; no warranty or support is provided, and this is an unofficial build, do not ask Ferram4 or anyone else for help with this either, this is strictly at-your-own risk.  It does,  however, work for me.

Thanks! Goodbye, spaghetti rockets that invite the Kraken for tea and tear themselves to shreds!

Edited by Snark
Download link removed by moderator

Share this post


Link to post
Share on other sites
On 3/18/2018 at 8:44 PM, ss8913 said:

If you install 3.3.3 and then replace the DLL file with this one:  [Download link removed by moderator]

that should get you going.  All I did was change the Compatibility string as described above, and recompile with Visual Studio 2017.  It works for me; no warranty or support is provided, and this is an unofficial build, do not ask Ferram4 or anyone else for help with this either, this is strictly at-your-own risk.  It does,  however, work for me.

Thank you, I'll let you know if there are any errors.

Edited by Snark
Download link removed by moderator

Share this post


Link to post
Share on other sites

I've noticed a problem with my build where framerate is TERRIBLE when you first go to fly anything... but it clears up after 5-15 seconds, so it's not game-breaking, at least for me.  Wish I knew more about how KSP internals worked so I could do more to help with updating this and some of my other favorite mods when the maintainers don't have time to update every time KSP gets a new version...

Share this post


Link to post
Share on other sites
57 minutes ago, ss8913 said:

I've noticed a problem with my build where framerate is TERRIBLE when you first go to fly anything... but it clears up after 5-15 seconds, so it's not game-breaking, at least for me.  Wish I knew more about how KSP internals worked so I could do more to help with updating this and some of my other favorite mods when the maintainers don't have time to update every time KSP gets a new version...

Are you using ScienceAlert? That sounds like ScienceAlert.

Share this post


Link to post
Share on other sites
7 hours ago, ss8913 said:

not using sciencealert, no.

I doubt it's KJR related. Post logs and someone who knows what they're doing might look at it.

Share this post


Link to post
Share on other sites

so this seems to be 1.4.1 compatible? do I have that right?

Share this post


Link to post
Share on other sites
On 3/25/2018 at 2:10 PM, RaiderMan said:

so this seems to be 1.4.1 compatible? do I have that right?

 

On 3/18/2018 at 8:44 PM, ss8913 said:

If you install 3.3.3 and then replace the DLL file with this one: [Download link removed by moderator]

that should get you going.  All I did was change the Compatibility string as described above, and recompile with Visual Studio 2017.  It works for me; no warranty or support is provided, and this is an unofficial build, do not ask Ferram4 or anyone else for help with this either, this is strictly at-your-own risk.  It does,  however, work for me.

 

 

Edited by Snark
Download link removed by moderator

Share this post


Link to post
Share on other sites

thanks for your help man.

Share this post


Link to post
Share on other sites
17 hours ago, filipucci said:

 

HELLO Please update to version 1.4.1 !!! thank you in advance

No need - see the post 2 above yours.

Share this post


Link to post
Share on other sites
On 3/25/2018 at 6:10 PM, viperwolf said:

 

 

 

Works great, thanks... Wish others can read and see that this will work with 1.4.1, thanks again

Share this post


Link to post
Share on other sites
On 3/25/2018 at 11:07 PM, filipucci said:

 

HELLO Please update to version 1.4.1 !!! thank you in advance

Please don't ask mod authors to update their mods as they have real lives, real jobs, real family etc. and are contributing their talent to the community with free time for free. Mod authors do not owe anything to the community, but we who use those mods owe them. Consider donating to those authors and be considerate and patient. Many times by reading through the last few pages you may come across "interim fixes" such as on this mod and in some cases, the previous version may still work just fine.
Thank you for your understanding!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.