Jump to content

[1.8.x] DMagic Orbital Science: New Science Parts [v1.4.3] [11/2/2019]


DMagic
 Share

Recommended Posts

In one of weekly updates, SQUAD mentioned that 1.2.2. will be much less mod breaking update compared to previous releases.
In most cases is just recompile and apropriate numbers in version file. In some cases, only version file would need update for AVC and CKAN to be able to understand it.

Link to comment
Share on other sites

2 hours ago, maranble14 said:

Well all of my parts disappeared with the 1.2.2 update thanks to steam/ckan. But the update is much appreciated DMagic!

KIS did an update removing direct handling of parts kerbals can carry. Now it's handled by CCK? You have to add a tag to the cfg's for the parts to show up in the tab and since some parts don't show in any other tab, they went poof in the vab, like that little power connector for surface science mode. There is a patch note about it in the KIS thread. Might be ckan  updated KIS, but didn't know how to manually patch the other cfg's until mods get updated. Just one of the many reasons to dump ckan and and install the mods yourself. It's just a drag/copy folder. 

Link to comment
Share on other sites

2 hours ago, Vorg said:

KIS did an update removing direct handling of parts kerbals can carry. Now it's handled by CCK? You have to add a tag to the cfg's for the parts to show up in the tab and since some parts don't show in any other tab, they went poof in the vab, like that little power connector for surface science mode. There is a patch note about it in the KIS thread. Might be ckan  updated KIS, but didn't know how to manually patch the other cfg's until mods get updated. Just one of the many reasons to dump ckan and and install the mods yourself. It's just a drag/copy folder. 

The problem with manually installing mods is how annoying it is to update them all whenever AVC starts annoying the bejesus out of me every time I start the game up lol

Link to comment
Share on other sites

3 hours ago, Vorg said:

KIS did an update removing direct handling of parts kerbals can carry. Now it's handled by CCK? You have to add a tag to the cfg's for the parts to show up in the tab and since some parts don't show in any other tab, they went poof in the vab, like that little power connector for surface science mode. There is a patch note about it in the KIS thread. Might be ckan  updated KIS, but didn't know how to manually patch the other cfg's until mods get updated. Just one of the many reasons to dump ckan and and install the mods yourself. It's just a drag/copy folder. 

Just a heads up, I think you're talking about the Surface Experiment Pack parts. This is the DMOS thread. There shouldn't be any parts here that are affected by KIS's update.

Link to comment
Share on other sites

I have a problem using Bluedog DB combined with DMagic Orbital Science. Whenever I install the latter, the antanna's from Bluedog DB don't work anymore, No animation, no function, nothing. They become more or less a aesthetic prop. I am using KSP version 1.1.3 and Bluedog 0.11.2.

I can't seem to figure out wether it is bc of DMagic Orbital Science itself, or bc of the plugin from DMModuleScienceAnimateGeneric. Can someone look into this and help me figure out a fix?

I also posted the problem on the forum post of Bluedog DB.

Edited by Pointblank66
Link to comment
Share on other sites

1 hour ago, Pointblank66 said:

I have a problem using Bluedog DB combined with DMagic Orbital Science. Whenever I install the latter, the antanna's from Bluedog DB don't work anymore, No animation, no function, nothing. They become more or less a aesthetic prop. I am using KSP version 1.1.3 and Bluedog 0.11.2.

I can't seem to figure out wether it is bc of DMagic Orbital Science itself, or bc of the plugin from DMModuleScienceAnimateGeneric. Can someone look into this and help me figure out a fix?

I also posted the problem on the forum post of Bluedog DB.

It will be much easier for developers to help you if you give them log files. Launch KSP, load your save game file, go in flight with craft that gives you issue, click on some Bluedogs antenna function, try to extend it, whatever should trigger animation etc.
Then exit game and inspect folders. On windows OS, you should find "output_log.txt" file in folder KSP_x64_Data.

Upload that somewhere, like patebin or dropbox or any other cloud service you prefer, so devs can download and help you.
Without it, it is pure guess work what is going on. If you are not certain how to find stuff developers need to help you, search for more info in this thread:

 

Link to comment
Share on other sites

2 hours ago, kcs123 said:

It will be much easier for developers to help you if you give them log files. Launch KSP, load your save game file, go in flight with craft that gives you issue, click on some Bluedogs antenna function, try to extend it, whatever should trigger animation etc.
Then exit game and inspect folders. On windows OS, you should find "output_log.txt" file in folder KSP_x64_Data.

Upload that somewhere, like patebin or dropbox or any other cloud service you prefer, so devs can download and help you.
Without it, it is pure guess work what is going on. If you are not certain how to find stuff developers need to help you, search for more info in this thread:

 

I got the Output log, I have updated back to the current version of Bluedog DB, but the problem was still the same.

Output log link: https://drive.google.com/open?id=0B5kNuN4ki0U1SUdIeTVEVzlYTWc

Link to comment
Share on other sites

@Pointblank66 I don't see any way that Orbital Science would affect the antennas from BDB. None of the antennas have any of modules on them. The only thing that might cause a problem could be some error with an Orbital Science part that prevents other parts on the vessel from loading? Does this happen with any vessel?

You do have a mod that's filling up your error log though. It looks like something that is meant for KSP 1.2. 

This line repeats over and over:

MissingMethodException: Method not found: 'MapView.get_MapIsEnabled'.

That field was changed from 1.1 to 1.2, causing that error if a mod is used in the wrong version. I can't tell where it comes from though.

Link to comment
Share on other sites

7 minutes ago, DMagic said:

You do have a mod that's filling up your error log though. It looks like something that is meant for KSP 1.2. 

This line repeats over and over:

MissingMethodException: Method not found: 'MapView.get_MapIsEnabled'.

That field was changed from 1.1 to 1.2, causing that error if a mod is used in the wrong version. I can't tell where it comes from though.

I have no hard evidence, but I just saw this field/method being used in the Kerbalism pre-release. See the middle of this post for circumstantial evidence.

In any case, if you haven't already @Pointblank66, remove everything but the 1.1.3 versions of BDB and DMagicScience and see if it can be reproduced. I also don't have a clue why the antennas would be affected :(  

Link to comment
Share on other sites

Version 1.3.7 is out; get it on Space Dock.

It should work fine on KSP 1.2.1 or 1.2.2.

It fixes bugs with resetting experiments and fixing broken SIGINT dishes with EVA Kerbals, it will now look for the relevant experience skill rather than checking the Kerbal type.

It also adds a ModuleDataTransmitter to the Soil Moisture experiments, which now works with the parts' animations. These are direct signal antennas, like the SIGINT dishes. The SIGINT antenna signal strength was made stronger.

An upgrade package is available for all SIGINT and Soil Moisture parts that turns them into relay antennas and further boosts their signal strength.

Link to comment
Share on other sites

15 minutes ago, DMagic said:

It also adds a ModuleDataTransmitter to the Soil Moisture experiments, which now works with the parts' animations. These are direct signal antennas, like the SIGINT dishes. The SIGINT antenna signal strength was made stronger.

An upgrade package is available for all SIGINT and Soil Moisture parts that turns them into relay antennas and further boosts their signal strength.

New parts?  Awesome! Do you have pictures?

Link to comment
Share on other sites

  • 2 weeks later...

@ParkerArt Pictures might help. The part has big red arrows pointing in the direction where the ground needs to be. The drill that comes out from the bottom has a range of about 5-10m. Run the animation (Systems Check button) to see it working.

@SmashBrown That shouldn't affect it. I'll have to look into it.

Edited by DMagic
Link to comment
Share on other sites

Seems to have fixed itself.... weird... getting the same issue now with another craft.

1 hour ago, DMagic said:

@ParkerArt Pictures might help. The part has big red arrows pointing in the direction where the ground needs to be. The drill that comes out from the bottom has a range of about 5-10m. Run the animation (Systems Check button) to see it working.

@SmashBrown That shouldn't affect it. I'll have to look into it.

Switching vessels has worked for the new craft. Not sure what I did with the other one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...