WAS

BlueHarvest ENB Series +GEM-FX

Recommended Posts

I thought this update deserves a new post. Mainly because the other topic already contained two versions, and this one has some significant improvements and shaders.

:cool: This version contains the GEM-FX core for a brilliant new shader package, on top of SweetFX, and ENB Series. Pushing the limits of post processing on KSP as we know it. Lucifer Hawk has done some amazing work and shown me some great new ways of implementing shaders, and getting the best desired results. With that in mind, remember, ENB, in general, is more of a artistic approach. Something to the Eye-of-the-Beholder. As in, what you may think is rubbish, the creator of the 'art' may in fact adore it. :wink: So lets not gripe about "Oh I hate ENB" etc, etc.

In general this mod is for screenshots and HUD-Off gameplay for movies / trailers / game promotion.

download.png

( ENB License | SweetFX License | GEM-FX )

Quote
INSTALLATION:

In order for this plugin to work, your Antialiasing and Antistropic Filtering must be turned off.

1) Head over to ENB Dev and download ENB Series Generic: http://www.enbdev.com/mod_generic_v0076.htm

2) Extract the "d3d9.dll" ENB Plugin from the "Wrapper" folder in the generic ENB download to your KSP_win folder with your KSP.exe, or wherever you have installed it.

3) Extract the contents of the "INSTALLATION FILES" in your BlueHarvest download into your KSP_win folder with your KSP.exe, or wherever you have insalled it.

4 Optional) Pick a palette from the "OPTIONAL PALLETTES" folder and replace the "enbpalette.bmp" in your KSP_win folder with your KSP.exe, or wherever you have installed it.

5) Ensure KSP is not in Borderless Windowed mode and only in Fullscreen! Than, simply enjoy!

NOTE: You can change palettes while in gameplay! This is convenient for setting your mood on other planets. :)

On some computers, settings may need to be tweaked. These files are enbseries.ini, SweetFX_settings.txt, and GEM_settings.txt Be careful and read documentation where available. :wink:

Quote
ENB Series is the property of Boris Vorontsov copyright © 2007-2014 (http://enbdev.com/)

All other parts, graphics, and customized settings herin not dictated by ENB Licensing, or SweetFX Licensing, or GEM-FX (http://gem-fx.tk/) Licensing

are the intellectual work of Jordan Thompson (WAS), Including, but not limited to artwork, settings, and graphical assets.

Do not edit, redistribute, or sell any assets of this package without explicit permission from Jordan Thompson (WAS).

Here are some preview images to get the taste buds going.

Share your Screenshots!

Quote
KSP_2014_05_22_16_41_09_03.png

KSP_2014_05_22_16_43_18_21.png

KSP_2014_05_22_16_43_45_33.png

KSP_2014_05_22_16_43_51_55.png

KSP_2014_05_22_16_45_08_58.png

KSP_2014_05_22_16_45_26_64.png

KSP_2014_05_22_16_45_39_95.png

KSP_2014_05_22_16_46_01_24.png

KSP_2014_05_22_16_46_41_68.png

Edited by WAS

Share this post


Link to post
Share on other sites

That looks really pretty. Can I get an option to turn it off at times (like VAB) and how much does this impact performance?

Share this post


Link to post
Share on other sites

For me performance is moderate (HD7770). Currently there is only a option to turn off ExpEffects in GEM and ENB Editor options (Shift + Enter)

Share this post


Link to post
Share on other sites

This is really nice, it gave me a whole new experience in KSP. After one day of fun though, I uninstalled it again due to a few glitches and observations. Maybe these can be addressed at some time in the future so I thought I'd share:

- the whole display becomes quite grainy, which is an issue for reading the glass cockpits provided with RasterPropMonitor

- I noticed a weird glitch when in EVA or map view: Kerbins landmass turn an orangy-red at times. The oceans are unchanged. The whole of Mun / Minmus turns red as well. Whe whole affair seems to be dependent on where the camera is in relation to the Sun.

- I've noticed several weird glitches / flicker events in conjunction with the EnvironmentalVisualEnhancements and Better Atmosphere package.

Lastly, I know this is reaching into aesthetics which are always personal preference but something inside the Bloom settings seems to be killing the "nice" lighting of the Sun. the whole thing turns into a white & bleached-out blob. I tried various settings in the enbsettings.ini but couldn't really fix it. But as I said, the last thing is personal preference and not a glitch in itself :)

Share this post


Link to post
Share on other sites
This is really nice, it gave me a whole new experience in KSP. After one day of fun though, I uninstalled it again due to a few glitches and observations. Maybe these can be addressed at some time in the future so I thought I'd share:

- the whole display becomes quite grainy, which is an issue for reading the glass cockpits provided with RasterPropMonitor

- I noticed a weird glitch when in EVA or map view: Kerbins landmass turn an orangy-red at times. The oceans are unchanged. The whole of Mun / Minmus turns red as well. Whe whole affair seems to be dependent on where the camera is in relation to the Sun.

- I've noticed several weird glitches / flicker events in conjunction with the EnvironmentalVisualEnhancements and Better Atmosphere package.

Lastly, I know this is reaching into aesthetics which are always personal preference but something inside the Bloom settings seems to be killing the "nice" lighting of the Sun. the whole thing turns into a white & bleached-out blob. I tried various settings in the enbsettings.ini but couldn't really fix it. But as I said, the last thing is personal preference and not a glitch in itself :)

Do not run KSP in Borderless Window mode. Ensure you are running in Fullscreen mode. Red planet flickering is from Windowed mode in most every case.

The grain is from the Film grain shaders. Turn these off in GEM_settings.txt

#define GGrain 0.0335		//[0.00 to 1.00]	Adjust GEM-Grain amount (standard 0.0335)

To:

#define GGrain 0		//[0.00 to 1.00]	Adjust GEM-Grain amount (standard 0.0335)

Flickering may be due to ExpEffects. You can turn these off in GEM_settings.txt or by pressing F11 in-game. (if enabled) Or by turning off Occlusion in ENB settings in enbseries.ini

EnableOcclusion=1

to

EnableOcclusion=0

These errors are rare and usually due to DX compatibility with your GPU. This has been documented with DarkSouls II occlusion and other effects as well with GeDoSaTo and GEM and ENB.

In general this mod is for screenshots and HUD-Off gameplay for movies / trailers / game promotion. Sometimes needs settings changed for different GPU's and computers. These files are enbseries.ini, SweetFX_settings.txt, and GEM_settings.txt ;)

Edited by WAS

Share this post


Link to post
Share on other sites

Thanks for the pointers. I'm running fullscreen though, so that leaves the red planet flicker open. Anyway, I'll probably try out the other settings in a day or two. GPU in question is a GTX 560 Ti btw.

Share this post


Link to post
Share on other sites

Interesting. Must be your card or something else interfering with it. I only ever experience the red-shift in window mode for quick testing, same for the bugs on BlueHarvest and BlueHarvest +SweetFX users.

You may also think you're in fullscreen, there is no difference. Check the KSP Launcher.

Share this post


Link to post
Share on other sites
Trust me, I'm in fullscreen :)

What OS, and what resolution are you at? Does your refresh rate correspond to your resolution and framerate? Like I said I can't reproduce this bug at all except in windowed mode.

Share this post


Link to post
Share on other sites

I've been having an issue with the brightness spiking to a really high level when I turn off the HUD in map view or occasionally during launch.

Share this post


Link to post
Share on other sites

Try disabling ExpEffect in GEM settings. You can do this in-game via F11. By spiking, do you mean flickering? Is this could also be due to AO. ENB is very much a beta as it is not compliant with all video cards and systems, and some things preform differently for different systems, so sometimes you have to fiddle with some settings.

Share this post


Link to post
Share on other sites

Will this work in KSP's opengl mode?

edit: given that it uses d3d9's dll, I imagine that the answer is a clear "no". Too bad, I hope 64-bit KSP becomes stable because right now opengl is the only way I can play with mods and I'd love to use ENB with Kerbal.

Share this post


Link to post
Share on other sites

I'm getting issues with the skybox being highlighted, and planets turning red and transparent from certain angles. Anyone know the cause/a fix?

N6V8oLJ.jpg

EDIT: It only happens after the first launch/revert to KSC main menu. First launch and load runs perfectly fine. It breaks after that.

Share this post


Link to post
Share on other sites

Seen it uses DirectX, i supposed is not for OSX.

Share this post


Link to post
Share on other sites

Hey there great work! looks sweet :)

You got me wondering tho.....you know about ENBoost?

And even more curious if sutch a thing could be done for kerbal ?

I guess its boris himself. I would have to ask since he made it for skyrim as i understand.

But you are probably a lot more in to the whole ENB thing than me so figured i would ask!

Again great work.

Share this post


Link to post
Share on other sites

Hi ! Nice work on adapting an ENB to KSP ! I've already tasted it in Skyrim, and loved it :P

However, it seems that your link is dead, could you update it ?

Thanks !

Share this post


Link to post
Share on other sites
Hi ! Nice work on adapting an ENB to KSP ! I've already tasted it in Skyrim, and loved it :P

However, it seems that your link is dead, could you update it ?

Thanks !

Indeed, "Download is disabled for this file." Perhaps try a better host? I'd love to give this a spin, used ENB in Skyrim extensively.

Share this post


Link to post
Share on other sites

Either I'm doing something wrong or this does not work on x64. Please be that im doing something wrong.;.; On x86 though I am experiencing the same bugs that Avera9eJoe mentioned above. Also your link isn't working.

Edited by dudefinal

Share this post


Link to post
Share on other sites

Doesn't seem to work for me. I put the unwrapper into the file, and I put the installation files in too, but nothing.

Also FYI, the gemfx link on the front page goes to a rather infuriating pop up spam.

Share this post


Link to post
Share on other sites

Is there anyway to get this to work in KSP that is not full screen? I purposefully play in windowed so I can multi task.

Share this post


Link to post
Share on other sites

For whatever reason, these shaders just aren't working. I followed the instructions correctly, I hope :/  It says something about shaders in green text when I start the game, and I assume that means it's installed correctly, but it just doesn't make anything fancy happen. KSP looks more or less the same. I disabled Anistropic FIltering and Antialiasing both in-game and in the NVIDIA Control Panel, but it still does nothing. Help?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.