magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

[...] Since it sounds like it might be an issue, I'll have a go at some cleaner reproductions and a log file later on.

OK, I've not had much luck finding guaranteed reproduction steps; the problem of the game reverting to an earlier KCT launch immediately on switch to the Center seems to come and go. I uploaded the end of a log where the following occurred:

1. I launched a craft to orbit the Mun and did that.

2. After that craft exited the Mun's SOI I launched another craft to orbit Kerbin.

3. After getting the #2 craft circularized, I switched back to #1.

4. I brought #1 down in the ocean and recovered the vessel (the log begins at here at splashdown.)

5. The Center view loaded then immediately switched to the launchpad with craft #2 there un-launched and all other state and time reverted back to that of #2.

https://gist.github.com/Famous-Shoes/e39f94ecf02e44e01b33

Let me know what I can check to help nail this down (or rule out KCT as the root cause.)

Update 1: Note, I ran no simulations with the #2 craft.

Update 2: Also, after launching craft #1, I switched to the Center and building views and other craft many times without issue. After launching craft #2, I did not switch to the Center again until clicking Recover on craft #1.

Update 3: I'd been thinking KCT was the only mod I had that should have any "reverting" logic in it, but I just realized I'd installed Flight Manager for Reusable Stages based on a Manley video and then forgotten all about it. Looking at it's thread, it seems to be known to be a bit buggy and so I'll uninstall that and see if this ever recurs.

Edited by Faster

Share this post


Link to post
Share on other sites

Anyone else have an issue where when the simulation time ends and you buy more time that your apoapsis and periapsis change sometimes dramatically. I run a crap ton of mods so it may be some conflict. The one I would really suspect is KJR. Just wondered if anyone else has experienced this.

Edited by Svm420

Share this post


Link to post
Share on other sites
Anyone else have an issue where when the simulation time and and you buy more time that your apoapsis and periapsis change sometimes dramatically. I run a crap ton of mods so it may be some conflict. The one I would really suspect is KJR. Just wondered if anyone else has experienced this.

I have and I don't run KJR.

Share this post


Link to post
Share on other sites

If you jiggle the "warp to" button too much while having a vessel active and under control - KSP will sometimes bug out and cause the orbit to drastically shift. Not sure if it's a KSP bug or a KCT bug. But I can get it to happen with some regularity with KCT's "warp to" button.

The workaround that I use is to never click the "warp to" button more then once every few seconds, unless I'm controlling a landed vessel or (better) back at the space center view.

Share this post


Link to post
Share on other sites

One workaround for the KCT causing orbits to shift would be if it changes the warp factor slower instead of a big immediate step. Maybe take cues from how MechJeb does it, with a slow ramp-up / ramp-down.

Share this post


Link to post
Share on other sites

I Think I may have found a glitch. When adding a ship to the build to queue that is beyond your available build slots when moving that up to be worked on immediately if you warp to completion. Warp will continue beyond its new completion time to the old estimated time it would be completed if never being advanced within the queue. I do use a system resize mod if that matters. Hope that makes sense. Thanks been loving the update!

Share this post


Link to post
Share on other sites
Okay, I found an incompatibility between Real Fuels and this mod. Whenever I build a ship that has cryogenic fuel (like liquid oxygen), by the time the vessel actually is built, some of the fuel has evaporated off.

Damn That bug just won't stay dead. Pretty sure I remember he fixed that one once before.

Edit: Actually that bug was supposed to be fixed this patch. huh.

Share this post


Link to post
Share on other sites

Sorry I've been out of touch guys, I've got two midterms tomorrow (of course, my only two tests other than finals and they're the same day). After that I'll take a hard look at everything that's been reported the past couple days.

Are you using the latest KCT version and getting that Real Fuels bug? I think I know why it happened before, but I thought I fixed it. Next update is supposed to be about better cross compatibility, so that's one I'll take a harder look at (been wanting to play with RO anyway). Add launch clamps to your craft and you shouldn't have that issue anymore.

Share this post


Link to post
Share on other sites
Kerbal Crush Saga? Really??

What? Am I the only one who doesn't understand?

Share this post


Link to post
Share on other sites
Kerbal Crush Saga? Really??

I take it you're in a much later time zone than me ;) PM if you have actual questions/are having trouble. I'd like to save the surprise for a little while :D

Share this post


Link to post
Share on other sites
Was told to post this here...

Output log: http://www./view/n5jot08ea435iuq/output_log(6).txt

By the in-game error popup, I'm assuming? Based on your post history, it looks like you've already reported the error to the source: Contract Configurator. The following error was listed when you switched to Flight mode, which would indeed cause that popup to occur (since KCT will not have gotten to load it's data as a result):


InvalidOperationException: Operation is not valid due to the current state of the object
at System.Linq.Enumerable.First[UInt32] (IEnumerable`1 source) [0x00000] in <filename unknown>:0
at ContractConfigurator.ContractVesselTracker.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioRunner.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0
at ProtoScenarioModule.Load (.ScenarioRunner host) [0x00000] in <filename unknown>:0
at ScenarioRunner+ .MoveNext () [0x00000] in <filename unknown>:0

/Begin Ramble/ This makes me wonder if I'd be able to forcibly load KCT's data from the persistence when it detects that the OnLoad didn't complete. The only issue with that is then KCT would work properly, but a bunch of other mods would still be broken. The error popup was actually implemented to catch errors usually caused by other mods (like, 9 times out of 10) that then visibly break KCT but may not visibly break other mods, that are often reported as KCT errors. If I fixed KCT when other mods cause it to break, the player would still be playing with broken mods and might not even know, which undoubtedly would cause additional problems. Might not be worth it. /End Ramble/

Addressing other issues: I'll take a look at the issues with buying more time and "Warp To" causing trajectory changes. The first one isn't terribly surprising because it pauses the game instantly (except, so does pressing Esc and they work the same way). I don't recall if it resumes your last warp state or not if you purchase more time. If it does, I'll try resetting the warp to 1x. Warp To actually does ramp up/down time. It's just a very fast ramp up (one step a frame). I can try slowing it down, but there's a chance that it won't stop in time for short warps. I don't generally use it during flight, almost always at the Space Center or Tracking Station (if it's gonna be a few days and I don't want to watch the sun rise and set a bunch of times really fast), so I haven't noticed the problem myself yet. I'll take a look at everything else tonight if I get a chance.

Share this post


Link to post
Share on other sites

Looks like, something broken in facility upgrade delay. I've upgraded R&D, it shows upgrade time of 40 days. But when time has come, nothing happens. At the moment of upgrade I've tracked the satellite in time warp, so time warp may case this error.

Share this post


Link to post
Share on other sites

SVlad, I had the same problem. If you have a save from before the upgrade completed, staying in KSC view while it completes will upgrade the building properly.

Share this post


Link to post
Share on other sites

how about the incessant pop up? how to stop this...?

- - - Updated - - -

fix:

open KCT_Config and make this line True:

DisableSpecialSurprise = True

Share this post


Link to post
Share on other sites

Nice April Joke :-)

With that sense of humor, you promoted yourself to my favourite modder :-)

Congrats to that nice idea, gave me a nice laugh:-)

Especially the Cerbal Crush Logo :D

Share this post


Link to post
Share on other sites

Well, It seems that I'm not the only one who is scared the crap out.

You get me for a while :D Just thought I installed some weird mod.

Dat Logo :)

Share this post


Link to post
Share on other sites

you bas*%£d!

i thought either A) someone actually did the unthinkable and wrote a virus for ksp on linux?! or B) you're actually serious about this little scam

thank you for the wicked sense of humour and thank god for April for being the 1st and not some bad Kerbalian dream

damn... now i have to wait the 10 minutes for ksp to boot up again :confused:

Edited by Maars

Share this post


Link to post
Share on other sites
SVlad, I had the same problem. If you have a save from before the upgrade completed, staying in KSC view while it completes will upgrade the building properly.

Thank you for advice. I've solved this problem in other way: turned off delay, upgraded building in normal way and edited persistence file to restore lost funds.

Share this post


Link to post
Share on other sites
Kerbal Crush Saga? Really??

Is this from Kerbal Construction Time? I can't get the damn popup to go away. :(

Share this post


Link to post
Share on other sites
how about the incessant pop up? how to stop this...?

- - - Updated - - -

fix:

open KCT_Config and make this line True:

DisableSpecialSurprise = True

This is the worst, annoying, april fool ever! :(

I read intentional nothing in the internet on april the first, because it is only written crap on that day. And now this takes the crap even down to the game.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.