Jump to content

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017


Recommended Posts

I know this for a fact as I have spent the last 2 hours figuring out which parts (that I use) have changed, what they have changed to, if they are indeed the same actual part AND then replacing each parts changed name in each instance it is used in all my craft files... and it worked... The Kurgan is happy :)

Link to post
Share on other sites
2 minutes ago, stali79 said:

What parts is KSP listing as missing?

Just checked them all on my end, they all seem to have unique names in the Master.

Hmmm... search for     name = ilsCockpit. There are definitely two (well, in the version I downloaded, which is 1.8.5 from earlier...): they are in Spaces/ILSIVA and Spaces/ILSCockpit. Maybe I'm not understanding what the configs are doing though.

Link to post
Share on other sites
2 minutes ago, PickledTripod said:

I haven't used that since 1.0.5, and AFAIK it hasn't been updated since before that... Totally unnecessary now that DDS textures are standard.

I have no idea what's causing this, all other mod parts on my install are just fine.

I opted to NOT use DDS textures due to file sizes.

6 minutes ago, TheKurgan said:

I know this for a fact as I have spent the last 2 hours figuring out which parts (that I use) have changed, what they have changed to, if they are indeed the same actual part AND then replacing each parts changed name in each instance it is used in all my craft files... and it worked... The Kurgan is happy :)

you shouldn't have had to have done that, no parts were renamed on the back end...

5 minutes ago, AccidentalDisassembly said:

Hmmm... search for     name = ilsCockpit. There are definitely two (well, in the version I downloaded, which is 1.8.5 from earlier...): they are in Spaces/ILSIVA and Spaces/ILSCockpit. Maybe I'm not understanding what the configs are doing though.

ok found it. gonna test now.

Link to post
Share on other sites

Only thing "missing" is a cockpit that nobody uses...

Here is an example of 2 parts that have changed internally within the .cfg files and inside the .craft files:

title - OPT A Cargo bay  - In the .cfg file it's called a_6m_cargo - in the .craft file it is a.6m.cargo 

has changed to 

Title - OPT 'Avatar' Class Cargo Bay - in the .cfg file c_6m_cargo - in the craft file it is c.6m.cargo

 

title - OPT A Bicoupler  - In the .cfg file it's called a_2m_bicoupler - in the .craft file it is a.2m.bicoupler 

has changed to 

Title - OPT 'Avatar' Class Bicoupler - in the .cfg file c_2m_bicoupler - in the craft file it is c.2m.bicoupler

 

I used Notepad++ to find and replace each of the changed parts names in my .persistent.sfs file and all my .craft files and all my broken stuff was fixed.

 

Link to post
Share on other sites
9 minutes ago, TheKurgan said:

Only thing "missing" is a cockpit that nobody uses...

Here is an example of 2 parts that have changed internally within the .cfg files and inside the .craft files:

title - OPT A Cargo bay  - In the .cfg file it's called a_6m_cargo - in the .craft file it is a.6m.cargo 

has changed to 

Title - OPT 'Avatar' Class Cargo Bay - in the .cfg file c_6m_cargo - in the craft file it is c.6m.cargo

 

title - OPT A Bicoupler  - In the .cfg file it's called a_2m_bicoupler - in the .craft file it is a.2m.bicoupler 

has changed to 

Title - OPT 'Avatar' Class Bicoupler - in the .cfg file c_2m_bicoupler - in the craft file it is c.2m.bicoupler

 

I used Notepad++ to find and replace each of the changed parts names in my .persistent.sfs file and all my .craft files and all my broken stuff was fixed.

 

Really odd as i never renamed those. The avatar cargo bay and bicoupler were completely removed. The cargo bay had no fuel capacity and a different textuse and the bicoupler was exactly the same as the c version hence why both were removed.

 

For those unable to use the included ships, install the Mark IV mod I forgot I had the rcs pods from it on the ships.

Edited by stali79
Link to post
Share on other sites
On 30/08/2016 at 0:48 PM, MeCripp said:

My bad and the drop ship craft one of the engines are cutting out guessing and will test maybe needs more air and it's the J-92 engine the fx are backwards on the runway there expanded and about time to cut them off the fx are what they should be on the runway and there is no errors in the log and I have changed the wheels to stock so that parts fix just don't know why you would have craft files with gear that don't work and I fix the FX on my end to my likely and add some RPMs to a couple of the command pods that don't have them.

The craft files you would have been using would have been from BEFORE KSP went to UNITY 5. Back in the day when ALL landing gear worked.

 

EDIT:  the ones included in this release are all ones I made myself.

Edited by stali79
Link to post
Share on other sites
8 hours ago, BioRoots said:

Not sure if this has been talk about but the wing in my install are gone.

edit: i delete the folder and re install and it seem to fix the issue 

Did you copy the new version over your old one to begin with?

Link to post
Share on other sites

Oh my word, log in to see what new mods are out just for fun, and could it be? OPT updated to work on 1.1.3?? Well, not quite... Ok, I'm going to detail exactly what I did.

1) Removed everything from KSP, clean as a whistle

2) Installed OPT 1.8.5 as it is on Spacedock right now

3) I see that it is bundled with a 1.1.3 compatible Firespitter

4) I tested all the parts and I still have issues with no parts having fuel. Instead of naming every single part that has no fuel options, its easier if I name the ones that do (OPT stail class fuel tank 4m, OPT avatar class fuel tank 6m, OPT avatar class space shuttle cockpit adaptor, OPT avatar to stail adaptor) so only 4 parts have fuel. No other fuel tanks, utility cargo bays, or main wings A,B,&C have fuel options as they did in previous working versions. I did not include cockpits in this, they are working fine so far. I can still provide a list of every single part that has a problem though...

5) I installed IFS from Spacedock, and the problem persisted. There were no changes.

6) Module Manager is also up to date

I read through the past several pages, and the main problems I've noticed are regarding tweakscale (which doesn't work for me anyway and I don't use it), file name changes (which according to stali79 shouldn't be there. Not sure on this, I wouldn't know what to look for anyway), and missing landing gear (I don't have it either, even looking through the OPT master file. Sad panda... because OPT landing gear! But I suspect this has to do with the supposedly changed names in the files, and/or KSP now can't handle landing gear apparently now, anyway)

Having looked through all the parts that do not have fuel as they should, I noticed none of them have RESOURCE instructions in the .cfg file. Again, this is with the exception of the 4 parts that do have fuel options. Would I be able to copy the Resource info from a working part into a non-working part? Its the same problem I had before a few weeks ago, which was kind of expected, but now that this has supposedly been updated it kind of frustrating.

Here is a link to my log  https://www.dropbox.com/s/eo4zluei7vcf6qa/output_log.txt?dl=0 which was obtained with instructions from this page http://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

What can I try to finally make this work? Or even, what can I do to help?

Also I have some suggestions

1) These two parts: OPT Stail class inline docking & utility bay & OPT stail class inline docking port, should have RCS fuel

2) I think it would be a super cool option in OPT to have flat streamlined rcs tanks and thrusters like B9 had. It looks clunky and lame when a super sleek OPT ship has ugly pokey stock rcs parts.

 

 

Link to post
Share on other sites
On 8/9/2016 at 0:48 AM, AccidentalDisassembly said:

Evident in your post are a couple of atrocious misunderstandings, FYI. 

1. The fact that the issue with FireSpitter has been repeated many times means it is not a needle in a haystack; it is common. It's likely that you would have found an answer to your question without much effort, because it is common, and because you don't have to look through 78 pages to find it: only the last couple of pages in order to see if someone else has asked the same thing. The issue is that it is clear from your question that you didn't take the initiative in that respect.

2. The forum name of the person currently updating this mod is stali79. The name of the person who originally made this mod and posted the thread is K.Yeon. That means the first post of the thread does not belong to stali79. As a result, so far as I know, he cannot simply update the post on the first page.

3. It seems like you have a fundamental misconception of what to expect when updating KSP, because it appears you think KJR, MechJeb, etc. are a part of it - they are not. Squad is responsible for KSP, but they have no control over third-party modifications to the game. As third-party mods, KJR, MechJeb, FireSpitter and such must be adapted to the base game when it changes, not the other way around. You will forever be disappointed if you expect KSP and third-party mods (or any program and third-party mods) to continue functioning together when a bunch of code in the game is changed. When they do keep working well together, it's an unexpectedly happy occurrence. In light of all of that, what you say bout 1.1.3 not being ready for release doesn't make sense - except if you had mentioned wheels, of course, or minor bugs that persist in 1.1.3. Still, in the case of wheels, at least, Squad did the best with what was actually possible given their tools.

I hope that helps you understand what you are asking for and why you would receive a peevish response on the ol' internet.

Ok I didn't notice this before, so I'm just going to nip this in the butt right now.

1) The fact that no working links to Firespitter were provided is a problem, and indeed a needle in the haystack. I was one of many others who had this same problem. I found one eventually which was quite the adventure. Vaguely mentioning Firespitter over and over but with no link to it is useless. Also it was NOT in the last "couple pages"

2) stali79 was(IS) very helpful and this was resolved.

3) Fundamental misconception? I know all the mods are not part of the stock game. To assume otherwise is ignorant. I have been playing this since it was first released. Will there be bugs even when a mod is updated? Of course, but many mods I think just say they were updated to keep up with subscribers. As far as 1.1.3 being broken? If basic things like landing gear wont work, it is. I know they switched to a new version of Unity, and changed/updated many things in the game. Regardless, I know its not on Squad to micro manage every single thing. Again, I know its up to the modding community to maintain their own mods, and if said mods aren't working when they supposedly should be, then that's just bad business. But KSP has one of the most insanely loyal and smart communities I've ever seen, so with any problem its only a matter of time before things are fixed.

Giving peevish responses to problems shows you're not actually willing to help. 

This is irrelevant anyway. OPT has been updated to 1.1.3 and while I'm still having some problems, I'm hoping I can get them fixed (look at this comment I made just before this one). 

Edited by Victorsaurus
Link to post
Share on other sites
24 minutes ago, Victorsaurus said:

Oh my word, log in to see what new mods are out just for fun, and could it be? OPT updated to work on 1.1.3?? Well, not quite... Ok, I'm going to detail exactly what I did.

1) Removed everything from KSP, clean as a whistle

2) Installed OPT 1.8.5 as it is on Spacedock right now

3) I see that it is bundled with a 1.1.3 compatible Firespitter

4) I tested all the parts and I still have issues with no parts having fuel. Instead of naming every single part that has no fuel options, its easier if I name the ones that do (OPT stail class fuel tank 4m, OPT avatar class fuel tank 6m, OPT avatar class space shuttle cockpit adaptor, OPT avatar to stail adaptor) so only 4 parts have fuel. No other fuel tanks, utility cargo bays, or main wings A,B,&C have fuel options as they did in previous working versions. I did not include cockpits in this, they are working fine so far. I can still provide a list of every single part that has a problem though...

5) I installed IFS from Spacedock, and the problem persisted. There were no changes.

6) Module Manager is also up to date

I read through the past several pages, and the main problems I've noticed are regarding tweakscale (which doesn't work for me anyway and I don't use it), file name changes (which according to stali79 shouldn't be there. Not sure on this, I wouldn't know what to look for anyway), and missing landing gear (I don't have it either, even looking through the OPT master file. Sad panda... because OPT landing gear! But I suspect this has to do with the supposedly changed names in the files, and/or KSP now can't handle landing gear apparently now, anyway)

Having looked through all the parts that do not have fuel as they should, I noticed none of them have RESOURCE instructions in the .cfg file. Again, this is with the exception of the 4 parts that do have fuel options. Would I be able to copy the Resource info from a working part into a non-working part? Its the same problem I had before a few weeks ago, which was kind of expected, but now that this has supposedly been updated it kind of frustrating.

Here is a link to my log  https://www.dropbox.com/s/eo4zluei7vcf6qa/output_log.txt?dl=0 which was obtained with instructions from this page http://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

What can I try to finally make this work? Or even, what can I do to help?

Also I have some suggestions

1) These two parts: OPT Stail class inline docking & utility bay & OPT stail class inline docking port, should have RCS fuel

2) I think it would be a super cool option in OPT to have flat streamlined rcs tanks and thrusters like B9 had. It looks clunky and lame when a super sleek OPT ship has ugly pokey stock rcs parts.

 

 

You sir are awesome for giving me lots of details. Will respond/investigate as best I can :) (this first bit is BEFORE reading your logs)

 

1) good lad, I wish more people would do this.

2) something everyone has been wanting to do.

3) yup been using this version in my install for a while.

4) ALL parts were tested working with fuel, this is where checking your logs will come in handy.  The fuel configs are in the MM_Patches folder.

There is a patch for default resources (no FS IFS or MFT or RF) this should work if none of the others do. That being said, there IS patches for if you use IFS, FS, MFT and RF.

5) Thanks for the info on your debugging :)

6) Should be.

As for renaming is concerned, TECHNICALLY no parts were renamed on the back end, but some parts WERE removed because the alternate parts either looked/performed better or was flat out duplicates.  I removed the landing gear from the release so people don't need to worry about them at this stage BUT if someone has an idea how to make them work let me know and I will give you the Github link. The parts you mentioned as having fuel in them were the ones that @K.Yeon initially did for the Stail class parts and they use FSFuelSwitch and FSTextureSwitch commands hence why I didn't touch them.  

Your suggestions:

1) Will check those tomorrow, one of them at the very least shouldn't have mono as they were designed to have tanks manually attached inside them (the one with 2 sets of doors)

2) That is certainly something to consider, will add this to the suggested features file.

 

NOW am taking a look at the logs. I can't see any issues with your Output log, can you post your KSP.Log please. Output_log.txt is the KSP crash log, the KSP.Log is your initialisations etc, that shows loading errors.

EDIT: do me a favour, delete the following files in your gamedata folder. ModuleManager.ConfigCache, ModuleManager.ConfigSHA, ModuleManager.Physics, ModuleManager.TechTree  Deleting these will clear ALL MM cached settings and will redo them on your next restart of KSP.

EDIT2: What you described to me was something going funky with ModuleManager, as it didn't seem to be applying ANY of the OPT patches, can't confirm though until I see your KSP.Log

Edited by stali79
Link to post
Share on other sites
17 minutes ago, stali79 said:

You sir are awesome for giving me lots of details. Will respond/investigate as best I can :) (this first bit is BEFORE reading your logs)

 

1) good lad, I wish more people would do this.

2) something everyone has been wanting to do.

3) yup been using this version in my install for a while.

4) ALL parts were tested working with fuel, this is where checking your logs will come in handy.  The fuel configs are in the MM_Patches folder.

There is a patch for default resources (no FS IFS or MFT or RF) this should work if none of the others do. That being said, there IS patches for if you use IFS, FS, MFT and RF.

5) Thanks for the info on your debugging :)

6) Should be.

As for renaming is concerned, TECHNICALLY no parts were renamed on the back end, but some parts WERE removed because the alternate parts either looked/performed better or was flat out duplicates.  I removed the landing gear from the release so people don't need to worry about them at this stage BUT if someone has an idea how to make them work let me know and I will give you the Github link. The parts you mentioned as having fuel in them were the ones that @K.Yeon initially did for the Stail class parts and they use FSFuelSwitch and FSTextureSwitch commands hence why I didn't touch them.  

Your suggestions:

1) Will check those tomorrow, one of them at the very least shouldn't have mono as they were designed to have tanks manually attached inside them (the one with 2 sets of doors)

2) That is certainly something to consider, will add this to the suggested features file.

 

NOW am taking a look at the logs. I can't see any issues with your Output log, can you post your KSP.Log please. Output_log.txt is the KSP crash log, the KSP.Log is your initialisations etc, that shows loading errors.

EDIT: do me a favour, delete the following files in your gamedata folder. ModuleManager.ConfigCache, ModuleManager.ConfigSHA, ModuleManager.Physics, ModuleManager.TechTree  Deleting these will clear ALL MM cached settings and will redo them on your next restart of KSP.

EDIT2: What you described to me was something going funky with ModuleManager, as it didn't seem to be applying ANY of the OPT patches, can't confirm though until I see your KSP.Log

I'm glad I could provide some good info! :)

Alright, so dumb questions:

How do I find the actual KSP.Log? I'm gonna check the link for submitting help logs again but I think it only mentioned the output log. (EDIT: It actually says specifically not to use KSP.Log for missing valuable data?)

Where do I find the files to delete in Game Data? My module manager just shows up as ModuleManager.2.6.25.dll, and none of the other folders have those files. (right now my Game Data only has: CommunityResourcePack, Firespitter, InterstellarFuelSwitch, OPT, Squad, and the .dll)

I see the patches and fuel configs in the OPT folder, so would I just copy/paste where needed? 

Edited by Victorsaurus
x
Link to post
Share on other sites

Ksp.log lives in the game's root folder.

The output log is great for debugging crashes, but not what happens when the game is loading up.

The other files you need to delete will be sitting just below ModuleManager.dll in the GameData folder. If not there then you will need to do a manual search for them in your ksp install.

Link to post
Share on other sites
15 minutes ago, stali79 said:

Ksp.log lives in the game's root folder.

The output log is great for debugging crashes, but not what happens when the game is loading up.

The other files you need to delete will be sitting just below ModuleManager.dll in the GameData folder. If not there then you will need to do a manual search for them in your ksp install.

So I did find a log, not sure if its the one you need, let me know. I will keep looking for KSP.Log (this one said goglog) https://www.dropbox.com/s/2472qa1qjfaz8po/goglog.ini?dl=0

I also cant find the various MM files I need to delete so I will keep looking for those as well.

I did find that copy/pasting the FS patches manually... Works! It will be super time consuming to do it that way though. Gonna keep playing around and looking for what you told me to find.

Link to post
Share on other sites
15 minutes ago, Victorsaurus said:

So I did find a log, not sure if its the one you need, let me know. I will keep looking for KSP.Log (this one said goglog) https://www.dropbox.com/s/2472qa1qjfaz8po/goglog.ini?dl=0

I also cant find the various MM files I need to delete so I will keep looking for those as well.

I did find that copy/pasting the FS patches manually... Works! It will be super time consuming to do it that way though. Gonna keep playing around and looking for what you told me to find.

Hmmm i cant open that one.

Link to post
Share on other sites
8 minutes ago, stali79 said:

Hmmm i cant open that one.

Yeah I wasn't sure if you'd be able to. Dropbox kept uploading it as .ini and not as a text file.

Like I said I'll keep messing around with it. At least we did figure out a solution, even if it is time consuming with lots of copy/paste. My MM just needs to get its act together lol

As always thanks for you help! And thanks for keeping this mod going. It literally is my favorite mod, makes the whole game worth all the frustration that sometimes comes with it.

Link to post
Share on other sites

So in case anyone is having the same problems as I am, just wanted to give an update for a couple things I've tried in order to get ModuleManager to do its job.

Under MM_Patches in the OPT folder, you'll see OPT_FS for Firespitter. You'll see a parts patch that looks like this for example:

@PART[c_6m_cargoTail]:NEEDS[Firespitter]
{
    MODULE
    {
        name=FSfuelSwitch
        
resourceNames=Structural;LiquidFuel;LiquidFuel,Oxidizer;LiquidFuel,Oxidizer;LiquidFuel,Oxidizer,MonoPropellant
        resourceAmounts=0;586;432,586;216,293;200,244,60
        basePartMass=5.5
        tankMass=0;0;0;0;0
        tankCost=0;0;0;0;0
        displayCurrentTankCost=false
        hasGUI=true
        showInfo=true
    }

The trick, I think, is to change the top line to match whatever is in the actual parts file that KSP can read. So where it says "@PART[c_6m_cargoTail]:NEEDS[Firespitter]" I have tried:

@PART[c_6m_cargoTail]:NEEDS[Firespitter]

@Part[c_6m_cargoTail]:NEEDS[Firespitter]

@PART[OPT_c_6m_cargoTail]:NEEDS[Firespitter]

@Part[OPT_c_6m_cargoTail]:NEEDS[Firespitter]

The bottom two are important because in the parts folders, like for this part for example, it says "OPT_c_6m_cargoTail" And anyone who has tried to move anything around knows KSP is big on having every little letter and space just right (even whether it should be lower or upper case, at least in my tinkering around). So basically every part with the exception of some engines and the wings are preceded by "OPT_" then the part name.

stali79 helped me figure out that copying the MODULE instructions down and pasting into each respective part will work, but it is time consuming. (I've only tried it on a couple parts as well, so for all I know that could be on the whole wrong.) So I'm just trying to get the ball rolling to see if someone maybe figures out so weird little detail preventing module manager from looking up the parts properly, to make the process more efficient than copy/paste. A big part of this is I seem to be missing some MM files that I need to delete, and cant because I don't see them anywhere. I'm gonna get this figured out lol, not going to let my favorite mod down.

Link to post
Share on other sites

I am going to have to check. I may need to rerelease. If parts have the OPT_ preceeding them then something may have gone screwy on my end. I am out all day but will check when i get home.

 

EDIT: making myself late for class today to stay and try to sort this out.  Just checked the part file that you used as an example, MM doesn't patch according to file name, it patches according to game name. So while the FILE may be named OPT_c_6m_cargoTail, the actual name that MM is searching for is c_6m_cargoTail.  

 

if you notice these lines in the cfg, these relate to the file names online

MODEL
{
    model = OPT/Parts/Avatar/OPT_c_6m_cargoTail
}

 

But that isn't the name of the part, the parts name is determined by the following line, and it is the name that MM searches for.

name = c_6m_cargoTail

Download UltraSearch and do a search for the files I said you need to delete. If they aren't appearing in your GameData folder then there is something not going right.

 

Check the following 2 screenshots to see what I am referring to for the KSP.log and those MM files to delete.

 

 

Edited by stali79
Link to post
Share on other sites
2 hours ago, stali79 said:

Not on hand no. Spacedock MAY archive older versions.

Not only does Spacedock archive older versions, but users can access the older versions simply by clicking the Changelog tab. All versions of the mod which have been previously uploaded to Spacedock are available there (not just OPT, but all mods)

 

By the way, the fuel tank which I spoke about last night was the Avatar hollow fuel tank. I don't know why it doesn't hold fuel, but the "regular" Avatar fuel tank and the Avatar cargo bay both hold fuel properly (with the cargo bay holding about half as much per configuration as the regular fuel tank, and having the same amount of payload volume capacity as the hollow fuel tank along with a pair of topside doors). I haven't noticed any other problems regarding parts which should hold fuel but don't.

Link to post
Share on other sites
2 minutes ago, King Something said:

Not only does Spacedock archive older versions, but users can access the older versions simply by clicking the Changelog tab. All versions of the mod which have been previously uploaded to Spacedock are available there (not just OPT, but all mods)

 

By the way, the fuel tank which I spoke about last night was the Avatar hollow fuel tank. I don't know why it doesn't hold fuel, but the "regular" Avatar fuel tank and the Avatar cargo bay both hold fuel properly (with the cargo bay holding about half as much per configuration as the regular fuel tank, and having the same amount of payload volume capacity as the hollow fuel tank along with a pair of topside doors). I haven't noticed any other problems regarding parts which should hold fuel but don't.

Cheers man will take a look when i get home.

Link to post
Share on other sites
On 8/30/2016 at 10:13 PM, stali79 said:

@Starwaster can you take a look at the J-92 engine please, the visual FX does appear to be moving forwards instead of in direction of thrust

Haven't had a chance to look at this yet. Been busy all day. We've got a tropical storm about to hit us. Maybe hurricane status by the time it gets here.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...