NecroBones

[1.4] SpaceY Heavy-Lifter Parts Pack v1.17.1 (2018-04-02)

Recommended Posts

On 5/11/2017 at 8:01 PM, theaveragepxtseryu said:

Getting a REALLY strange bug; all the textures are flickering like crazy. Possibly overlapping textures. Is there a fix for this?

same but for me, it's only on the blue 5m fuel tanks, I can't figure out what the problem is, I know I installed the mod correctly

Share this post


Link to post
Share on other sites

 

Hey all, just a quick note that I'm still here. I'll try to catch up on this thread and my other mods soon. Been super busy lately, and this past week has been just crazy. But I haven't vanished completely. :)

 

On 5/11/2017 at 8:01 PM, theaveragepxtseryu said:

Getting a REALLY strange bug; all the textures are flickering like crazy. Possibly overlapping textures. Is there a fix for this?

 

Check out the troubleshooting in the first post. Usually this is a problem with ModuleManager (missing, wrong version, not working with a new KSP version, etc), or one of the model switcher mods not being installed or configured correctly (Interstellar Fuel Switch, B9, etc).

Share this post


Link to post
Share on other sites
On 5/11/2017 at 3:33 PM, MaxL_1023 said:

Would it be possible to get a somewhat larger radial decoupler? The triple-packed is sized perfectly for 5m parts, but is a little small when you want 7.5m or especially 10m radial boosters.

Also, could there be a larger Vacuum engine than the Penguin? It's undersized for second stage duties on 10m stacks - the dual and quad penguins waste a lot of space and don't fit well. 

As of the radial decoupler,  there are several options.  There is the autostruts added in the newer versions of KSP that should work well.  You can use the ridged attachment setting as well to boost strength.  

For improving the separation force, you will absolutely have to go with separation sold rockets.   There is simply no other choice to make it work.   There are additional ones of those in Modular Rocket Systems if you need them.

Share this post


Link to post
Share on other sites
On 6/2/2017 at 1:20 PM, NecroBones said:

 

Hey all, just a quick note that I'm still here. I'll try to catch up on this thread and my other mods soon. Been super busy lately, and this past week has been just crazy. But I haven't vanished completely. :)

I look forward to the greatness of the NecroBones suite coming to 1.3!  Thanks for the work!

Share this post


Link to post
Share on other sites
On 6/5/2017 at 5:20 AM, klgraham1013 said:

I look forward to the greatness of the NecroBones suite coming to 1.3!  Thanks for the work!

It's here.   

(Looks like most recent version was just marked compatible with 1.3).    Thanks to NecroBones!

Share this post


Link to post
Share on other sites

Awesome. Hopefully I can load the Overkill in KSP 1.3 now. And if I can, I'm one step closer to redoing Why I Love SpaceY, Part 2.

Share this post


Link to post
Share on other sites

to separate stages you can just use the ejectatrons and flingatrons well placed on the radial booster. 

859801screenshot487.png

Share this post


Link to post
Share on other sites

Hi, my game is crashing while loading in a SpaceY part after it does all the module manager stuff. The part that is on the loading bar is SpaceY-Lifters/Parts/Decoupllers/SYdecouplerRadial/SYdecouplerRadial2/SYdecouplerRadial2. Uninstalling the mod doesn't cause the game to crash when loading, and I'll try just deleting this part. I'll attach the output log and error files below.

Output:

https://1drv.ms/t/s!Ak8xxGyCFaNNygTiy8NChMA1K_vh

Error:

https://1drv.ms/u/s!Ak8xxGyCFaNNygOvjysW9Whlxqk7

Edit: So looking through the logs, it seems to be crashing while trying to compile the 5m stack separator. 

Edited by HoveringKiller

Share this post


Link to post
Share on other sites

Hi Necro, not sure if you're willing to take part suggestions? But if so, would multiport or universal docking port versions of the SpaceY ports fit in with your vision for the mod? (Considering Universal Docking Port covers 3.75 and below, having the 5 and up ports cover at at least to 3.75 if not all the way down would fill out the family, so to speak, and be a pretty cool addition.) Thanks for any reply on the matter!

Share this post


Link to post
Share on other sites

Just wondering if anyone is having the issue where engines like the penguin, ratite, or moa do not have the ability to change the base like in previous versions? 

Share this post


Link to post
Share on other sites

@NecroBones, I've been having a slight issue since 1.3 and now in 1.3.1 as well.  The textures are USUALLY weird on most of the SRBs and the bigger engines.  It's like they've got 2 or 3 different textures trying to occupy the same space.  Thus, they're often z-fighting.  Or so it appears.  At first I thought I'd accidentally put multiple pats int he same place but no, it's really a texture issue.

Share this post


Link to post
Share on other sites
On 10/30/2017 at 1:50 PM, Geschosskopf said:

@NecroBones, I've been having a slight issue since 1.3 and now in 1.3.1 as well.  The textures are USUALLY weird on most of the SRBs and the bigger engines.  It's like they've got 2 or 3 different textures trying to occupy the same space.  Thus, they're often z-fighting.  Or so it appears.  At first I thought I'd accidentally put multiple pats int he same place but no, it's really a texture issue.

It's possible you're missing a part-switching mod - I think this issue can sometimes occur when the absence of a part-switching mod (like B9PartSwitch or Firespitter or whatever) means that the editor scene doesn't hide alternate textures or meshes that are supposed to be hidden. Or something like that.

Share this post


Link to post
Share on other sites
1 hour ago, AccidentalDisassembly said:

It's possible you're missing a part-switching mod - I think this issue can sometimes occur when the absence of a part-switching mod (like B9PartSwitch or Firespitter or whatever) means that the editor scene doesn't hide alternate textures or meshes that are supposed to be hidden. Or something like that.

Hmmm.  Well, there are certainly some parts that I know should have multiple versions but which I can't get to switch.  So I'll definitely look into this.  But I wasn't aware any Space-Y SRBs had multiple versions.

Share this post


Link to post
Share on other sites

Suggestion, the short and long launch clamps should feed more then 2 EC/s to the craft.  Maybe have them feed 10 EC/s.

(I've ModuleManager'd a clone part for both of those in my game that kicks it up to 10 EC/s to go with some energy-heavy relay antennas.  I kept running out of power while waiting for Kerbin to line up under a polar orbit contract.)

Share this post


Link to post
Share on other sites

Why do you use those big antennas on the pad while you can just use the first one to launch your ship or those integrated on some probe core?

Share this post


Link to post
Share on other sites

All SpaceY fuel tanks only have a single snap point in 1.3.1 at least on my system. It does show the centering ball out on what would be the second snap point but can't attach anything. Have tried with brand new saves and different parts but no difference.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.