Youen

[old thread] Trajectories : atmospheric predictions

Recommended Posts

I've tested, but it's not working.

Seems to be working (can't say if it's accurate though) with FAR

Share this post


Link to post
Share on other sites

Errr, so, does it work or not? If it works, I'd like to update the compatibility info, but I'm not playing KSP right now, so I'd be glad if someone could test that for me.

@Kaleaze: should I assume you mean it doesn't work for the stock aerodynamic model? That could explain kendoka15 reports it works (with FAR)?

Share this post


Link to post
Share on other sites
Errr, so, does it work or not? If it works, I'd like to update the compatibility info, but I'm not playing KSP right now, so I'd be glad if someone could test that for me.

@Kaleaze: should I assume you mean it doesn't work for the stock aerodynamic model? That could explain kendoka15 reports it works (with FAR)?

i confirm trajectories 1.4.3.0 doesn't work with the stock aero of KSP 1.0.5.1028 :

uYMWSNn.png

tell if you need more infos (logs,...)

Edited by Skalou

Share this post


Link to post
Share on other sites

Aero has been changed with 1.0.5, so it had to be expected that this mod wouldn't work.

Even if it did, trajectories would have been wrong due to the changes.

I wonder if it stops throwing errors/exceptions when it doesn't have to predict atmospheric trajectories anymore, ie: does it work on airless bodies ?

Share this post


Link to post
Share on other sites
Errr, so, does it work or not? If it works, I'd like to update the compatibility info, but I'm not playing KSP right now, so I'd be glad if someone could test that for me.

@Kaleaze: should I assume you mean it doesn't work for the stock aerodynamic model? That could explain kendoka15 reports it works (with FAR)?

Yeah, the stock aerodynamic, it doesn't show on the map where I'll land.

Share this post


Link to post
Share on other sites

Hi Youen - had a quick look at your mod with visual studio - it's not working in 1.0.5 because ModuleLiftingSurface.SetupCoefficients() no longer takes the air density as a parameter. If you change line 255 in Trajectories.StockAeroUtil

FROM: wing.SetupCoefficients(v_wrld_vel, rho, out nVel, out liftVector, out liftdot, out absdot);

TO : wing.SetupCoefficients(v_wrld_vel, out nVel, out liftVector, out liftdot, out absdot);

It'll work. I tried building the mod and running it, and it worked for me!

Hope that helps you :)

Share this post


Link to post
Share on other sites

Hmm this didn't post the first time I think

The bug for 1.0.5 is in StockAeroUtil.cs, line 255

The function ModuleLiftingSurfare.SetupCoefficients() has been changed so it no longer takes the air density (rho) as a parameter.

If you remove rho from the call to SetupCoefficents at that line, it builds and runs correctly! (At least it display a trajectory in game :P)

Hope this helps!

Rob

Share this post


Link to post
Share on other sites

I noticed a bug that causes my ship's orbit to change, and explode if I enable this mod. I think it is a special case, though... Didn't have the issue before.

Share this post


Link to post
Share on other sites

Mod is bust :(

Please update it!

I noticed a bug that causes my ship's orbit to change, and explode if I enable this mod. I think it is a special case, though... Didn't have the issue before.

Did this happen whilst Entering/Leaving an SOI? I had a problem that my Ion Test Probe kept switching orbits 20 Mins away from entering the Mun's SOI.

No explosions, but...

Share this post


Link to post
Share on other sites

Thanks to atomicfury and BigFluffyTRex who pointed where the problem is. I'll test the fix and update ASAP.

Share this post


Link to post
Share on other sites

Here is the new version. It seems to work fine with stock aerodynamics when I tested with the stock Kerbal X craft, and also with FAR.

However, I get NullReferenceExceptions related to DragCubeList.AddSurfaceDragDirection when I test with the Dynawing stock craft (and stock aero model). Probably an issue related to one of the parts in that craft. I'll release on Kerbal Stuff once this bug is fixed (to avoiding notifying too many people with a not-completely-stable version).

Share this post


Link to post
Share on other sites
Here is the new version. It seems to work fine with stock aerodynamics when I tested with the stock Kerbal X craft, and also with FAR.

However, I get NullReferenceExceptions related to DragCubeList.AddSurfaceDragDirection when I test with the Dynawing stock craft (and stock aero model). Probably an issue related to one of the parts in that craft. I'll release on Kerbal Stuff once this bug is fixed (to avoiding notifying too many people with a not-completely-stable version).

it seems to me it is the fuel-lines and the struts.

Edit:

their features changed with the 1.0.5 upgrade, i asked it heir:

http://forum.kerbalspaceprogram.com/threads/139497-Drag-of-fuel-lines-and-struts

Edited by Skalou
added quote

Share this post


Link to post
Share on other sites
Here is the new version. It seems to work fine with stock aerodynamics when I tested with the stock Kerbal X craft, and also with FAR.

However, I get NullReferenceExceptions related to DragCubeList.AddSurfaceDragDirection when I test with the Dynawing stock craft (and stock aero model). Probably an issue related to one of the parts in that craft. I'll release on Kerbal Stuff once this bug is fixed (to avoiding notifying too many people with a not-completely-stable version).

Youen, thank you so much for your continued work.

Share this post


Link to post
Share on other sites
This doesn't seem to actually like FAR. For whatever reason Trajectories is causing my craft to get minced because of aerodynamic stress whenever I go to the map. Even on the runway.
[imgur]nfqMM[/imgur]

Removing Trajectories fixed the issue, so I figured I'd bring it here.

Share this post


Link to post
Share on other sites
[quote name='Thegamer211']Does the mod work in 1.0.5?[/QUOTE]
Not at the moment. Stock aero has changed and requires corresponding changes to this mod.

Youen has already updated the code (see the previous page in this thread), but there are still some issues that need to be ironed out before it's ready for release.

If you play with FAR it might work, but there may be problems (see FungusForge's post above).

Share this post


Link to post
Share on other sites
[quote name='FungusForge']This doesn't seem to actually like FAR. For whatever reason Trajectories is causing my craft to get minced because of aerodynamic stress whenever I go to the map. Even on the runway.

Removing Trajectories fixed the issue, so I figured I'd bring it here.[/QUOTE]

I have the same problem(not on the runway per say). Whenever im in the atmosphere and switch te map view, then my vessel starts spinning around violently, changing it's axis of spin quickly as well, also my orbit (stock and predicted) changes dramatically, by the amount of about 5g in random directions(velocity seems to slow down though by more that 10x atmospheric resistance).
-I can see the rotation(10+ revolutions per sec?) in the navball in map view, the longer i stay in map the worse it gets.
-It stops as soon as i switch back to flight("real world" view)...except for the spinning inertia left over from this.
-This was tested with multiple vessel designs(at first it looked like phantom acceleration by part clipping, so i tested with simple rockets as well), starting from launch, and again after re-entry back into atmosphere(both situations before and after going to "space centre" and back again).
-Enabling/disabling "fixed-body trajectory" did not affect results

I do however get no glitches out of atmosphere. Anything above 70km is business as usual to adjust orbits and the like. Mun landings work perfectly(i constantly switch between map view to double check my landing site), I landed with pin-point accuracy where your red cross predicted and with very little effort.

Using:
KSP 1.0.5 build1028
Trajectories-v1.4.4
FAR v0.15.5.3 "von Helmholtz", 11/12/15
RemoteTech v1.6.9
ScienceAlert-1.8.9

P.S. Awesome mod, Squad should really get this into stock.

EDIT: Found this. It would explain my results(but i have no clue about the source code)
I know this mod is still a pre-release for ksp1.0.5, but i find this mod so useful. I hope all this is useful

This issue was fixed by removing RemoteTech. I think the probe autopilot computer/feature interferes.

post-number:[URL="http://forum.kerbalspaceprogram.com/threads/20451-1-0-5-Ferram-Aerospace-Research-v0-15-5-3-von-Helmholtz-11-12-15?p=2303362&viewfull=1#post2303362"]#11395[/URL]
[URL]http://forum.kerbalspaceprogram.com/threads/20451-1-0-5-Ferram-Aerospace-Research-v0-15-5-3-von-Helmholtz-11-12-15/page1140[/URL] Edited by Blaarkies
found ugly workaround

Share this post


Link to post
Share on other sites
I wrote a quick fix that just ignores fuel lines and structs in stock aero. Its not a great sollution but I really needed this mod to work, at least partially :)
If someone is interested, download is here
[URL]https://github.com/martinjaros/KSPTrajectories/releases/download/v1.4.4-quickfix/Trajectories.zip[/URL]

EDIT: it actually ignores any part that generated the exception, it seems there are more[URL="https://github.com/martinjaros/KSPTrajectories/releases/download/v1.4.4-quickfix/Trajectories.zip"] [/URL] Edited by 80dBm

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.