taniwha

[1.2.2] Extraplanetary Launchpads v5.7.1

4690 posts in this topic

@Trigonaut: Kerbal Inventory System is required for the stakes and mallet to be available (since they are unusable without KIS).

Share this post


Link to post
Share on other sites
1 hour ago, taniwha said:

@Trigonaut: Kerbal Inventory System is required for the stakes and mallet to be available (since they are unusable without KIS).

I am using both KIS and KAS. As well as some USI mods, KAS, KIS and Community Tech Tree.

 

Edited by Trigonaut

Share this post


Link to post
Share on other sites

Well, then I don't know. Check GameData/ModuleManager.ConfigCache looking for ExMallet and ExSurveyStake. They should both have TechRequired = advConstruction and category = Utility.

Share this post


Link to post
Share on other sites

Yeah, the configs are right. I just did a clean install with nothing else except the latest KIS, and the survey stakes and mallet still don't exist. Has nothing like this ever happened before?

Edited by Trigonaut

Share this post


Link to post
Share on other sites

You have ModuleManager installed too, right? (not sure it would matter for that, though). Also, they will not be in the KIS EVA items tab, but should be in the EL Items tab (and Utility tab).

I did however, find one bug: the mallet was not being disabled when it should be (one of my installs does not have KIS but the mallet was not being disabled while the survey stake and survey station were).

Did KIS change how MM sees it? (dll name, I think) [edit] nope, just checked: I have the latest version.

Edited by taniwha

Share this post


Link to post
Share on other sites

Hi @taniwha! I'm having an issue with EPL and time warping, so I did a few tests and this is what happens:

  1. I start the Rocket Parts production form a workshop (I tried also with workshops from different mods, always same results).
  2. I start to build something and make sure I'm producing more Rocket Parts than I'm using.
  3. I go to the Tracking Station, warp a few days ahead and come back to the vessel.
  4. Rocket Parts are full, but my build looks like has been paused for most of the time.

It looks like the Rocket Parts production isn't simulated when I'm not focussing the vessel, so the building process uses all Rocket Parts available and then pauses, until I focus back the vessel, the Rocket Parts production simulation "catches up" but the building process stays days behind.

Is this an EPL issue or just how KSP simulates things in background? Is there a way to force the simulation while not focussing a vessel?

Share this post


Link to post
Share on other sites

BigJammy: Do not go to the tracking station to time warp when you have an active EL build.  The launchpad's UI must remain active for the build to proceed.  Even so much as closing the launchpad UI will have the same effect as hitting the "Pause Build" button.  Remain focused on your base and leave the launchpad UI open while timewarping.  Doing so should correct your problem.

Share this post


Link to post
Share on other sites
6 hours ago, taniwha said:

You have ModuleManager installed too, right? (not sure it would matter for that, though). Also, they will not be in the KIS EVA items tab, but should be in the EL Items tab (and Utility tab).

I did however, find one bug: the mallet was not being disabled when it should be (one of my installs does not have KIS but the mallet was not being disabled while the survey stake and survey station were).

Did KIS change how MM sees it? (dll name, I think) [edit] nope, just checked: I have the latest version.

Yeah, I have MM 2.7.5 since it's bundled with KIS. Also, I looked around and found that the part.cfg for the mallet and survey stake has TechRequired = unresearchable   category = none. That was the way they downloaded, but I changed to advConstruction and Utility, and they still didn't show up. They aren't in any editor categories, and when I search 'survey' all I get is the survey station.

Share this post


Link to post
Share on other sites
2 hours ago, cgwhite4 said:

BigJammy: Do not go to the tracking station to time warp when you have an active EL build.  The launchpad's UI must remain active for the build to proceed.  Even so much as closing the launchpad UI will have the same effect as hitting the "Pause Build" button.  Remain focused on your base and leave the launchpad UI open while timewarping.  Doing so should correct your problem.

I thought this was the case, but I was hoping there was a way to avoid it since it means I can't build things simultaneously on different bases. Guess I'll have to rethink my plans.

Share this post


Link to post
Share on other sites
3 hours ago, cgwhite4 said:

Do not go to the tracking station to time warp when you have an active EL build.  The launchpad's UI must remain active for the build to proceed.

This hasn't been true for over two years: EL builds work quite well in the background (part of your problems with them building too fast). Though there have been problems with converters and pads fighting it out.

 

3 hours ago, BigJammy said:

It looks like the Rocket Parts production isn't simulated when I'm not focussing the vessel, so the building process uses all Rocket Parts available and then pauses, until I focus back the vessel, the Rocket Parts production simulation "catches up" but the building process stays days behind.

Odd, I thought I fixed that over a year ago :/. As a work around, have a larger stockpile of rocket parts and visit your vessel moderately often. The problem is when in catch-up mode, the pad grabs all the resources it can, exhausts the stored up KerbalHours and then the converters run, though I thought I fixed it so the pad and converters would properly interleave their catch-up cycles.

4 hours ago, BigJammy said:

Is this an EPL issue or just how KSP simulates things in background? Is there a way to force the simulation while not focussing a vessel?

This is mostly likely an EL issue. KSP doesn't really simulate anything other than orbits and commnet in the background.

1 person likes this

Share this post


Link to post
Share on other sites

Oops, I must have missed something in a set of old patch notes.  Good to know.  Sorry about that.

Share this post


Link to post
Share on other sites
2 hours ago, taniwha said:

Odd, I thought I fixed that over a year ago :/. As a work around, have a larger stockpile of rocket parts and visit your vessel moderately often. The problem is when in catch-up mode, the pad grabs all the resources it can, exhausts the stored up KerbalHours and then the converters run, though I thought I fixed it so the pad and converters would properly interleave their catch-up cycles.

I did a couple more tests and yes, it looks like having a larger stockpile of rocket parts would help. It seems like the building keeps going based on how many rocket parts I can have at most and then it pauses until I focus again the vessel, as if it finishes whatever amount of rocket parts can be stocked and then stops because the game is not producing parts while I'm not flying the vessel.

Share this post


Link to post
Share on other sites

Hi,

I don't know if this has been suggested before, but can this mod work with the larger docking ports in the near future construciton mod?

If not who can add it? them or you :)  (or can I hack things here to make it work?)

Thanks

Share this post


Link to post
Share on other sites
45 minutes ago, bunjatec said:

Hi,

I don't know if this has been suggested before, but can this mod work with the larger docking ports in the near future construciton mod?

If not who can add it? them or you :)  (or can I hack things here to make it work?)

Thanks

In what way?  You can build pretty much any saved craft.

Share this post


Link to post
Share on other sites

Had to add the following to DockingPorts.cfg to turn these 3 types of docking port into launchpads.. otherwise they have no UI capability. 

@PART[truss-octo-docking-25]
{
    MODULE
    {
        name = ExLaunchPad
        SpawnHeightOffset = 0.4274363
    }
}

@PART[truss-circular-docking-01]
{
    MODULE
    {
        name = ExLaunchPad
        SpawnHeightOffset = 0.122
    }
}

@PART[truss-spinal-docking-01]
{
    MODULE
    {
        name = ExLaunchPad
        SpawnHeightOffset = 0.103
    }
}
 

I've not had time to test spinal truss version, but the other 2 work.. I've taken offset values from the node positions in the part files.

Should work well for building _massive_ orbital structures..

 

my quesiton is, should this be in the EL mod or the Near future construciton mod?

Share this post


Link to post
Share on other sites

Is there a way to build rockets without kerbals? I'm trying to send a small robotic asteroid miner out to Dres and have it start constructing a base before the kerbals arrive.

Share this post


Link to post
Share on other sites

Recycle Bin has no controlling UI (turning it off or on). What could I be missing that can cause this?

 

ps 1. I just copied the GameData directory from the release. Not sure if the Source is needed.

Edited by pp3d

Share this post


Link to post
Share on other sites

How much time does it take to build a vessel?

It doesen't seem to be working on me.

Share this post


Link to post
Share on other sites

@pp3d do not install from github: that is source-only. The correct download link is in the OP.

@Nailed it! that depends very much on what workshops you have in your vessels, and the number and quality of the kerbals in those workshops (note: every command pod, and the stock habitable parts are all low-grade workshops). There are links in the OP that should help you with the kerbal factor (by kerbas ad astra)

Share this post


Link to post
Share on other sites

I apologize if this has been answered already, but is it possible to mine metal from asteroids? If so, do I need to do anything different than grapple to the asteroid with a Klaw and then deploy/activate the augers?

Share this post


Link to post
Share on other sites

It's planned, but I haven't had time to sort things out.

Share this post


Link to post
Share on other sites

Lessons learn't from playing around with KIS, KAS and Extraplanetary Launchpads:

The dynamite actually works.

Do not play with dynamite.

It's going to explode your ship.

(it would have been nice to have that warning before I tested it)

Activated dynamite, but it didn't explode. Thought it was fine and the dynamite didn't actually work. So I went back to trying to get the survey stake to work with building and such. Placed the survey stake down and boom went the dynamite. Jebediah survived. The ship did not. So with the dynamite jeb is responsible for the murder of the 5 kerbals onboard that ship.

The dead kerbals returned a few seconds later(with time warp). The kerbals remind me more and more about Kenny from SOuth Park. Dies over and over, but keeps comming back

Share this post


Link to post
Share on other sites

Posted (edited)

Honestly I really love this mod however the only draw back are the terribly looking parts which to me look extremely out of date to KSP but thats it. However they may of changed and i might be stupid. This point is mainly directed at the workshop however as a mod as a whole. It's very impressive. :) 

Edited by spence
Better Response

Share this post


Link to post
Share on other sites

NOTE: This is a double-release post (both 5.7.0 and 5.7.1).

I have released version 5.7.0 of Extraplanetary Launchpads.

Changes from 5.6.0:

  • Change Metal to ScrapMetal for recycling. This  means that bases and stations now require a smelter to make full use of recycled vessels (ie, beyond their carried resources).
  • More GetExportedTypes cleanup
  • Re-implement building subassemblies (sorry, no thumbnails).
  • Resurrect mission flag selection.
  • Remember the last craft built. Handy for pumping out satellites.
  • Disable the select craft button when selecting (avoids spawning the browser multiple times).
  • Thermal data added to EL's resources.
  • Mallet MM patch (for KIS) tweaked.
  • Much documentation work.

For those who do not like the change from Metal to ScrapMetal, reverse this patch:

--- a/GameData/ExtraplanetaryLaunchpads/Resources/Recipes.cfg
+++ b/GameData/ExtraplanetaryLaunchpads/Resources/Recipes.cfg
@@ -22,8 +22,8 @@ EL_TransferRecipe {
 EL_RecycleRecipe {
        name = RocketParts
        Resources {
-               Metal = 8
-               loss = 2
+               ScrapMetal = 9
+               loss = 1
        }
 }
 

However, this was intended back when I introduced recipes, except I forgot to do it.

Oops... so hot on its heels I was still writing this post... version 5.7.1:

  • Plug the NRE hole when highlighting a survey station.

Turned out I'd never made the actual change, only talked about it.

3 people like this

Share this post


Link to post
Share on other sites

Hmm, it would, possibly help a little if the link on the op lead to the download instead of to the message annoucing the update :)

 

Hmm, it would, possibly help if I clicked on the download link and not the release notes link :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now