Badsector

Members
  • Content Count

    345
  • Joined

  • Last visited

Community Reputation

161 Excellent

2 Followers

About Badsector

  • Rank
    Third Class Citizen

Recent Profile Visitors

3,999 profile views
  1. Not officially but after 1 year the issue still here, you can use the bug tracker or move your complains vs private division but the fact is that the joystick don't work in linux.
  2. Yes, starting from 1.4.0 joystick don't work in linux.
  3. Please help with informations about your system https://bugs.kerbalspaceprogram.com/issues/17984 for solve this issue. Thanks
  4. Probably it work, but i don't know if it have some issues with KSP 1.4, i'm waiting for a stable release for update the mod.
  5. CPU overheat ? Check CPU temperature with the game running and if that is the problem clean or change the fan.
  6. The problem is not that KSP forget the axis, axis are recognised and stored perfectly in setting.cfg, the problem is that KSP don't use them. I have already updated the issue, and i'm waiting for some news from squad
  7. Some news, following @luke-lukem advice i have set SDL_GAMECONTROLLERCONFIG variable, you can find a database with mappings for your device at https://github.com/gabomdq/SDL_GameControllerDB and after you can check with gamepadtool application if all work fine, now the joystick is found and the setting accept keybinding but don't store gamepad axis and probably is related at that old issue Now i'm going to update the issue on the bugtracker, if you can try that solution can be useful for solving this annoying bug
  8. Same here, if squad is able to fix the problem ok otherwise 1.3.1 is fine for me. @luke-lukem thanks for the info.
  9. I have open a bug if you have others information please send yours log or settings Regards Luca
  10. I have try others solutions like add "SDL_JOYSTICK_DEVICE=/dev/input/js0" to /etc/environment but nothing After checking the player log i don't find "Using libudev for joystick management" in 1.4 If someone can confirm the same issue i open a bug
  11. The joystick is correctly installed and work fine in KSP 1.3.1 Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 005 Device 002: ID 0079:0006 DragonRise Inc. PC TWIN SHOCK Gamepad Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 003: ID 04f2:0841 Chicony Electronics Co., Ltd HP Multimedia Keyboard Bus 003 Device 002: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub But in configuration the gamepad don't work like it is not installed Edit Bug Report
  12. Idk if i'm able to explain it better , but if you have 2 dummy over axis X-Y of the gimbal and you want to move your flap over Y you need to link it with the dummy on X, you have only to find the right position for place your dummy objects versus the center of the flap. Edit Other solution is have the flaps with the same name of the gimbal and have a fixed dummy with FXModuleLookAtConstraint that lock the axis you don't need to move, but i don't know of it work
  13. if is only aesthetic you can use FXModuleLookAtConstraint with 2 or 4 dummy empty over the same axis of the gimbal, on this way you can use 1 modulegimbal for move all 4 flaps over only 1 axis
  14. I have had the same problem, the 2 thrusttransform need to be child of 1 or 2 gimbal object and after you can add 2 modulegimbal to 2 different gimbal objects or add 1 modulegimbal to 2 different objects with the same name
  15. First IVA i have ever made please be gentle Still a work in progress, after i update the package